Working in Autodesk Maya

The Autodesk® Maya® working environment has evolved to accommodate the individual artist
as well as a team of artists working in a production pipeline. The interface presents tools, con-
trols, and data in an organized fashion to allow you to bring your fantastic creations to life easily.

Understanding the way Maya organizes data about the objects, animations, textures,
lights, dynamics, and all the other elements contained within the 3D environment of a scene
is essential to understanding how the interface is organized. Maya uses what’s known as the
Dependency Graph to keep track of the various packets of data, called nodes, and how they
affect each other. Any single element of a Maya scene consists of multiple nodes connected in a
web, and each one of these nodes is dependent on another. The Maya interface consists of edit-
ing windows that allow you to connect these nodes in an intuitive way and edit the information
contained within each node.

There is usually more than one way to accomplish a task in Maya. As you grow comfortable
with the interface, you'll discover which editing windows best suit your working style.

This chapter is a brief overview of what professionals need to understand when working in
Maya. You'll learn what types of nodes you'll be working with and how they can be created and
edited in Maya. You'll also learn how to work with projects and scene data as well as the various
windows, panels, and controls that make up the interface. This will help you, whether you are
working alone or as part of a team of artists.

This chapter is about working with nodes, but it is not meant to be a comprehensive guide
to each and every control in Maya. You will find that information in the Maya documentation.
If you've never used Maya before, I strongly encourage you to read the Maya documentation as
well as Introducing Autodesk Maya 2015, by Dariush Derakhshani (Sybex, 2014).

In this chapter, you will learn to:

¢ Understand transform and shape nodes

¢ Create a project

Creating and Editing Nodes

A Maya scene is a system of interconnected nodes that are packets of data. The data within a
node tells the software what exists within the world of a Maya scene. The nodes are the building
blocks that you, as the artist, put together to create the 3D scene and animation that will finally
be rendered for the world to see. So if you can think of the objects in your scene, their motion,
and their appearance as nodes, think of the Maya interface as the tools and controls you use

to connect those nodes. The relationship between these nodes is organized by the Dependency
Graph (DG), which describes the hierarchical relationship between connected nodes. The inter-
face provides many ways to view the graph, and these methods are described in this chapter.
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Any given workflow in Maya is much like a route on a city map. There are usually many
ways to get to your destination, and some of them make more sense than others depending on
where you're going. In Maya, the best workflow depends on what you're trying to achieve, and
there is typically more than one possible ideal workflow.

There are many types of nodes in Maya that serve any number of different functions. All
the nodes in Maya are considered DG nodes. Let’s say you have a simple cube and you sub-
divide it once, thus quadrupling the number of faces that make up the cube. The information
concerning how the cube has been subdivided is contained within a DG node that is connected
to the cube node.

A special type of DG node is the directed acyclic graph (DAG) node. These nodes are made of
two specific types of connected nodes: transform and shape. The arrangement of DAG nodes
consists of a hierarchy in which the shape node is a child of the transform node. Most of the
objects you work with in the Maya viewport, such as surface geometry (cubes, spheres, planes,
and so on), are DAG nodes.

To understand the difference between the transform and shape node types, think of a trans-
form node as describing where an object is located and a shape node as describing what an
object is.

The simple polygon cube in Figure 1.1 consists of six flat squares attached at the edges to
form a box. Each side of the cube is subdivided twice, creating four polygons per side. That
basically describes what the object is, and the description of the object would be contained in
the shape node. This simple polygon cube may be 4.174018 centimeters above the grid, rotated
35 degrees on the x-axis, and scaled four times its original size based on the cube’s local x- and
y-axes and six times its original size in the cube’s local z-axis. That description would be in the
transform node.

FIGURE 1.1

A shape node
describes the shape
of an object and
how it has been
constructed; a
transform node
describes where the
object is located in
the scene.
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Maya has a number of workspaces that enable you to visualize and work with the nodes and
their connections. The following sections describe how these workspaces work together when
building a node network in a Maya scene.

Using the Hypergraph

The Hypergraph is a visual representation of the nodes and their connections in Maya. A com-
plex scene can look like an intricate web of these connections. When you need to know how a
network of nodes is connected, the Hypergraph gives you the most detailed view. There are two
ways to view the Hypergraph:

¢ The hierarchy view shows the relationships between nodes as a tree structure.
& The connections view shows how the nodes are connected as a web.

You can have more than one Hypergraph window open at the same time, but you are still
looking at the same scene with the same nodes and connections.
This short exercise gives you a sense of how you would typically use the Hypergraph:

1. Create a new Maya scene.
2. Create a polygon cube by choosing Create > Polygon Primitives > Cube.

3. You will be prompted to draw a polygon on the grid by dragging on the grid (see
Figure 1.2). Drag a square on the grid, release the cursor, and then drag upward on the
square to turn it into a three-dimensional cube. Release the mouse button to complete
the cube. At this point, feel free to make your own decisions about the size and position
of the cube on the grid.

FIGURE 1.2

Maya prompts you
to draw the base of
the cube on the grid
in the scene.

4. Select the cube in the viewport, and choose Window > Hypergraph: Hierarchy to open
the Hypergraph in hierarchy mode. You'll see a yellow rectangle on a black field labeled
pCubel. The rectangle turns gray when deselected.

5. Move the mouse over the rectangle labeled pCube and then right-click. Choose Rename
from the pop-up window. Rename the cube myCube.

3
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INTERACTIVE CREATION

By default Maya creates objects using the Interactive Creation method, which allows you to draw on
the canvas as you create your geometry. To turn this feature off, choose Create > Polygon Primitives,
and deselect the Interactive Creation option at the bottom of the menu. This feature is turned off
for all the projects in this book to ensure precise placement of primitive objects.

While the Interactive Creation mode is on, you can deselect the Exit On Completion method; this
means that each time you draw on the grid, you will continue to create cubes until you switch to
another tool.

6. Select myCube and, from the Hypergraph menu, choose Graph > Input And Output
Connections. This switches the view to the connections view just as if you had origi-
nally opened the Hypergraph by choosing Window > Hypergraph: Connections. It’s
the same Hypergraph, but the view mode has changed, allowing you to see more
of the scene.

When you graph the input and output connections, you see the connected nodes that make
up an object and how the object appears in the scene. In the current view, you should see the
myCube node next to a stack of connected nodes labeled polyCubel, myCubeShape, and ini-
tialShadingGroup, as shown in Figure 1.3. (The nodes may also be arranged in a line; the actual
position of the nodes in the Hypergraph does not affect the nodes themselves.)

FIGURE 1.3

The node network
appears in the
Hypergraph. This
shape node (myC-
ubeShape) is con-
nected to two other
nodes, whereas the
transform node
(myCube) appears
off to the side.
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NAVIGATING THE HYPERGRAPH

You can navigate the Hypergraph by using the same hot-key combination you use in the viewport:
Alt+MMB-drag/Option+MMB-drag pans through the Hypergraph workspace, and Alt+RMB-drag/
Option+RMB-drag zooms in and out. (MMB means clicking with the middle mouse button, and RMB
means clicking with the right mouse button.) Selecting a node and pressing the f hot key focuses the
view on the currently selected node. It is also possible to zoom in using the scroll wheel on your mouse.

The myCube node is the transform node. The myCubeShape node is the shape node. In the
Hypergraph, the shape and transform nodes are depicted as unconnected; however, there is
an implied connection, as you'll see later. This is demonstrated when you rename the myCube
node; the shape node is renamed as well.

In Maya, the construction history feature stores a record of the changes used to create a par-
ticular node. The polyCubel node is the construction history node for the myCubeShape node.
When you first create a piece of geometry, you can set options to the number of subdivisions,
spans, width, height, depth, and many other features that are stored as a record in this history
node. Additional history nodes are added as you make changes to the node. You can go back
and change these settings as long as the history node still exists. Deleting a history node makes
all the previous changes to the node permanent (however, deleting history is undoable). Use the
following steps to guide you through the process of modifying history nodes:

1. Keep the Hypergraph open, but select the cube in the viewport.
2. Change the menu set in the upper left of the main interface to Polygons.

3. Press the 5 key on the keyboard to switch to shaded mode. Choose Mesh > Smooth. The
cube will be subdivided and smoothed in the viewport.

In the Hypergraph you'll see a new polySmoothFacel node between the polyCubel node
and the myCubeShape node (see Figure 1.4). This new node is part of the history of the cube.

FIGURE 1.4
Performing a
smooth operation
on the cube when
construction his-
tory is activated
causes a new polyS-
moothFacel node
to be inserted into
the node network.

4. Select the polySmoothFacel node, and delete it by pressing the Backspace key on the key-
board. The cube will return to its unsmoothed state.

5
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FIGURE 1.5

The attributes of
myCube’s trans-
form node have
been keyframed.
The keyframe
nodes appear in the

Hypergraph.

5. Select the transform node (myCube), and press the s hot key. This creates a keyframe on
all the channels of the transform node. A keyframe stores the current attribute values at
a particular time on the timeline. Animation is created by interpolating between key-
framed values.

You'll see a new node icon appear for each keyframed channel with a connection to the
transform node (see Figure 1.5).
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6. Hold the cursor over any line that connects one node to another. A label appears describ-
ing the output and input attributes indicated by the connection line.

WORKING WITH HISTORY

Over the course of a modeling session, the history for any given object can become quite long and
complex. This can slow down performance. It’s a good idea to delete history periodically on an
object by selecting the object and choosing Edit > Delete By Type > History. You can also choose
to delete the history of all the objects in the scene at once by choosing Edit > Delete All By Type
> History. Once you start animating a scene using deformers and joints, you can use the Delete
By Type > Non-Deformer History option, which will remove the construction history nodes while
preserving connections to animation nodes such as deformers.

You can turn off the history globally by clicking the Construction History toggle switch on the
status line, as shown here:

Wl rstruction hiskory anfoff e
§ ——1 rd
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FIGURE 1.6

display modes,
starting with loca-
torl in default,
nurbsSpherel in
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Connecting Nodes with the Node Editor

Connections between nodes can be added, deleted, or changed using the Hypergraph and
the Connection Editor. Introduced in Maya 2013, the Node Editor combines the features of the
Hypergraph, Hypershade, and Connection Editor into a single graphical interface. Maya 2015
brings numerous changes and enhancements.

When you open the Node Editor you are presented with an empty, grid-lined space. To view
a selected node, you must choose the type of connections you wish to graph: input, output, or
both. After establishing a graph, you can add additional nodes by choosing the icon with three
nodes and a red plus symbol from the Node Editor toolbar.

Every node has a series of ports for connecting attributes between nodes. By default, the
nodes are shown in Simple mode, meaning none of their attributes or other ports are shown.
In Simple mode, you can click on the dot on either side of the node to access a pop-up menu
for a node’s input or output connections. When unconnected, the superport is white. After
connecting, the port takes on the color of the connected attribute. You do not always have to
use the superport and subsequent pop-up menu to make connections. You can expose the
lesser ports by changing the nodes’ display from their simple, default display to Connected,
exposing the connected attributes, or to Full mode. Click the icon in the lower-right corner of
each node to change its display. You can also press 1, 2, or 3 on the keyboard, with the node
selected, to change its mode. To change all of the nodes” modes at once, use the Edit menu at
the top left of the Node Editor. The Full mode allows you to see all of the connectable ports
(see Figure 1.6).
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Like with all editors in Maya, you can customize the colors of the Node Editor using the
Windows > Settings/Preferences > Color Settings window. The Attribute Type rollout under the
Node Editor rollout allows you to change the color of the various types of connections.
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The following steps walk you through the basic uses of the Node Editor and how to make
connections:

1. Start a new Maya scene.

2. Create a locator in the scene by choosing Create > Locator. A simple cross appears at
the center of the grid in the viewport. This locator is a simple nonrendering null that
indicates a point in space. Locators are handy tools that can be used for a wide variety of
things in Maya.

3. Press the w hot key to switch to the Move tool; select the locator at the center of the grid,
and move it out of the way.

4. Press the g hot key to create another locator. The g hot key repeats the last action you per-
formed, in this case the creation of the locator.

5. Create a NURBS sphere in the viewport by choosing Create > NURBS Primitives >
Sphere. If you have Interactive Creation selected, you'll be prompted to drag on the grid
in the viewport to create the sphere; otherwise, the sphere will be created at the center of
the grid based on its default settings.

6. Move the sphere away from the center of the grid so that you can clearly see both locators
and the sphere.

7. Use the Select tool (hot key = q) to drag a selection marquee around all three objects.

8. Open the Node Editor by choosing Window > Node Editor. A grid is drawn in the work-
space. The grid can be toggled on or off by choosing the grid-visibility button (circled in
Figure 1.7) from the Node Editor’s toolbar. Choose the Input and Output Connections
button, also circled in Figure 1.7, to graph your selection.

FIGURE 1.7
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At the bottom of the screen are the two transform nodes for locatorl and locator2. loca-
torShapel and locatorShape2 are the shape nodes for the locators. nurbsSpherel is the
transform node for the NURBS sphere. And nurbsSphereShapel is the shape node for the
sphere; it’s connected to makeNurbSpherel, which is the history node, and to initialSha-
dingGroup. The initialShadingGroup node is the default shading group that is applied
to all geometry; without this node, the geometry can’t be shaded or rendered. When you
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apply a new shader to an object, the connection to initialShadingGroup is replaced with
a connection to the new shader. A shader is a node that determines how a surface appears
in Maya, as well as how it reacts to virtual lights.

9. In the Node Editor, use Alt+RMB to zoom in and out. Notice how the name bar that sits
on top of each node scales with the camera, enabling you to view long names regardless
of your camera view.

10. Select the locatorl, locator2, and nurbsSpherel transform nodes, and drag them away
from the other nodes so that you can work on them in their own space. To keep your
graph neat, you can use snap to grid to align your nodes with the grid.

11. Click the white superport on the right side of the locatorl node. This is the output.

12. From the pop-up menu, choose Translate > Translate. A yellow wire extends from the
translate node (see Figure 1.8). The wire can be connected to a white port on another node.

FIGURE 1.8

Use the wire to
connect the output
of one node to the
input of another.

Incatorl

locator2
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13. Connect the yellow wire to the left side of the nurbsSpherel node by clicking on its white
superport and choosing Translate from the pop-up menu. You can connect the yellow
wire to either side of a node. The connection will be the same. A green wire shows the
finished connection.

You can also choose Other from the pop-up menu. Doing so brings up the Input
Selection window. The window lists the attributes of the node. Any of the attributes that
have a plus sign next to them can be expanded to reveal nested attributes. For instance,
find the Translate attribute and expand it by clicking the plus sign. (The term translate in
Maya refers to an object’s position. When you use the Move tool to change the position
of an object in 3D space, you are “translating” the object.) You'll see that Translate has
Translate X, Translate Y, and Translate Z. This means that you can choose either to select
the Translate attribute, which will automatically use all three nested attributes as the
input connection, or to expand Translate and choose one or more of the nested Translate
X, Y, or Z attributes as the input connection. In some situations, a connection becomes
unavailable (grayed out), indicating that the connection between the two attributes can-
not be made, usually because the connection is not appropriate for the selected attributes
(see Figure 1.9).
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FIGURE 1.9 [Wirouescicion SN
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window specifies
which attributes
can be connected
between nodes.
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In the viewport, switch to wireframe mode if you are not already in it. You can do this by
pressing 4 on the keyboard or by clicking the wireframe icon on the icon bar at the top of
the viewport window; the wireframe icon is the wireframe cube.

In the viewport, you'll notice that the sphere has snapped to the same position as the
locator. Select the sphere, and try to move it using the Move tool (hot key = w). The sphere
is locked to the locator, so it cannot be moved. Select the locator, and try to move it; the
sphere moves with the locator. The output of the locator’s Translate attributes is the input
for the sphere’s Translate.

INCOMING CONNECTIONS

In wireframe view, an object will be highlighted in purple if it has an incoming connection from
the selected object.

16.

17.

Click on the nurbsSpherel node and press 3 to display the node’s attributes in full.
Click the plus sign next to Rotate to expand the Rotate rollout. Repeat the procedure for
locator2.

Click on the right-side port or output for RotateX on nurbsSpherel.
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18. Drag the yellow wire to the left side (the input side) of locator2 and connect it to RotateY.
The yellow wire turns cyan to match the color of its port of origin and the connection is
made. The difference in color indicates rotational values as opposed to numeric values,
like those used by the translate and scale attributes.

19. In the viewport, select the sphere and switch to the Rotate tool (hot key = e).

20. Drag up and down on the red circle of the tool to rotate the sphere around its x-axis. The
locator rotates around its y-axis.

USING THE NODE EDITOR TO MAKE SIMPLE CONNECTIONS

The Node Editor is perfect for making one-to-one relationships between attributes on two nodes. In
other words, the value of the output connection needs to equal exactly the value of the input con-
nection. You can also create nodes from inside the editor by using the RMB and subsequent marking
menu.

The Node Editor can get cluttered quickly. To combat a messy graph, you can pin your nodes
to their current position and size regardless of regraphing. The pushpin icon in the upper-left
quadrant of the node (top-right corner on Mac) allows you to toggle the pinning feature. You can
also select Options > Pin All Nodes By Default or RMB-click in the Node Editor to access the
option through the marking menu.

It is also possible to reduce the number of attributes displayed in each node to help simplify
your view. To activate Edit Custom Attribute List, RMB-click on a port of a node you wish to
customize. In edit mode, the node is divided by a yellow bar. The attributes above the yellow bar
are the ones that display. Those below the yellow bar are hidden. You can click on an attribute to
hide or unhide it. Attributes can also be rearranged by MMB-dragging to a new location within
the node. To accept your changes, RMB-click on the node’s graphic and deselect Edit Custom
Attribute List. You can then press 4 to see your edited node. To revert the node to its original set-
tings, RMB-click on any attribute in edit mode and choose Revert from the context menu.

Experiment with making connections between the various attributes with the Node Editor.
You can break a connection by selecting and dragging the arrow along the wire into empty
space. Notice the changes in the port colors when making or breaking connections.

Creating Node Hierarchies in the Outliner

The Outliner shows a hierarchical list of the nodes in the scene in a form similar to the outline
of a book. It is another way to view the transform and shape nodes in a scene and a way to cre-
ate hierarchical relationships between nodes through parenting. The Outliner does not show
the connections between nodes like the Hypergraph does; rather, it shows the hierarchy of the
nodes in the scene. To see how this works, try the following exercise:

1. OpenminiGun_v01l.ma from the Chapterl/scenes directory at the book’s web page
(www.sybex.com/go/masteringmaya2015). The scene consists of a minigun model in
three parts.

2. Open the Outliner by choosing Window > Outliner.
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OUTLINER LAYOUT PRESETS

The Outliner can be opened as a separate panel or, like many of the panels in Maya, it can be opened
in a viewport. A popular window arrangement is to split the viewports into two views, with the left
view set to the Outliner and the right view set to the perspective view. You can open this arrange-
ment by going to the menu bar in a viewport window and choosing Panels > Saved Layouts > Persp/
Outliner. You can also click the third layout button on the left side of the interface just below the
toolbox (as shown here).

et 1
nz PerspfOutliner
k) X

3. At the top of the Outliner is a menu bar. In the Display menu, make sure DAG Objects
Only is selected and Shapes is deselected (see Figure 1.10).

FIGURE 1.10

The Display menu
at the top of the
Outliner

In the Outliner, you'll see three nodes listed—gunBarrels, housing, and mount—in addi-
tion to the four default cameras and several set nodes (don't worry about the set nodes).
These are the three transform nodes for the pieces of the minigun. Select each node, and
you’ll see the corresponding part highlighted in the perspective view. At the moment,
each piece is completely separate and unconnected.

4. Select the housing node, and switch to the Rotate tool (hot key = e).

5. Rotate the objects; nothing else is affected. Try translating housing using the Move tool
(hot key = w); again, nothing else is affected.
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6. Use Undo (hot key = Ctrl/Cmd+z) a few times until the housing node returns to its origi-
nal location and orientation.

7. In the Outliner, select the gunBarrels object. Then Ctrl/Cmd+click the housing object,
and choose Edit > Parent (hot key = p) from the main Maya menu at the top.

Parenting one object to another means that you have made one transform node the child
of the second. When an object is a child node, it inherits its position, rotation, scale, and
visibility from the parent node. When you have multiple objects selected, the last object
selected becomes the parent. In the Outliner, you'll notice that the housing node has a
plus sign beside it and the gunBarrels node is not visible. The plus sign indicates that the
node has a child node.

8. Click the plus sign next to the housing node to expand this two-node hierarchy. The gun-
Barrels node is now visible as the child of the housing node.

9. Select the housing node, and try rotating and translating it. The gunBarrels node follows
the rotation and translation of the housing node (see Figure 1.11).

FIGURE 1.11
When the gunBar-
rels node is made a
child of the housing
object, it inherits
changes made to
the housing object’s
transform node.

Unlike the situation presented in the “Connecting Nodes with the Node Editor” section
earlier in this chapter, the rotation and translation of the gunBarrels object are not locked
to the rotation and translation of the housing node; rather, as a child, its rotation, transla-
tion, scale, and visibility are all relative to that of its parent.

10. Select the gunBarrels node, and try rotating and translating the object; then rotate and
translate the housing node. You'll see the gun barrels maintain their position relative to
the housing node. You could create an animation in which the gun barrels rotate on their
own z-axis to spin around while firing, at the same time the housing node is animated,
rotating on all three axes in order to aim.

11. Press Undo a few times (hot key = Ctrl/Cmd+z) until both the housing and gunBarrels
objects are back to their original positions.

12. In the Outliner, select the housing node, and MMB-drag it on top of the mount node. This
is a way to parent objects quickly in the Outliner.

13
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13.

Click the plus signs next to the mount and housing nodes in the Outliner to expand the
hierarchy. The lines indicate the organization of the hierarchy; the gunBarrels node is
parented to the housing node, which is parented to the mount node.

SHIFT+CLICK TO EXPAND THE HIERARCHY

You can expand an entire hierarchy with one click in the Outliner. Just Shift+click the plus sign
for the hierarchy you want to expand.

14.

15.

16.
17.

18.

19.

Select the mount node, and choose Edit > Duplicate (hot key = Ctrl/Cmd+d). This makes
a copy of the entire hierarchy. The duplicated mount node is named mount1.

Select the mountl node, and switch to the Move tool (hot key = w). Pull on the tool’s red
arrow to move the duplicate along the x-axis about two units.

Select the mount node, and then Ctrl/Cmd+click the mountl node in the Outliner.

Choose Edit > Group (hot key = Ctrl/Cmd+g) to group these two nodes under a single
parent node.

A group node is a transform node that has no shape node. It’s just a location in space used
to organize a hierarchy. Like a parent node, its children inherit its rotation, translation,
scale, and visibility.

Select the groupl node, and Shift+click the plus sign next to it in the Outliner to expand
the group and all its children.

Double-click the label for the groupl node in the Outliner to rename it; rename the
group guns.

RENAMING NODES

You'll notice that the duplicate mount node has been renamed mount1 automatically. Nodes on the
same level of the hierarchy can’t have the same name. The child nodes do have the same name, and
this is usually a bad idea. It can confuse Maya when more complex connections are made between
nodes. Whenever you encounter this situation, you should take the time to rename the child nodes
so that everything in the scene has a unique name.

20. Select the mountl node in the guns hierarchy, and choose Modify > Prefix Hierarchy

Names.

21.

22.

In the pop-up window, type right_. This renames the top node and all its children so that
“right_” precedes the name. Do the same with the other mount node, but change the pre-
fix to left_.

Select the guns group, and choose Modify > Center Pivot. This places the pivot at the
center of the group. Try rotating the guns group, and you’ll see both guns rotate together
(see Figure 1.12).
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FIGURE 1.12
The guns group
isrotated as a
single unit.

Each member of the hierarchy can have its own animation, so both gun barrels can rotate
around their z-axes as they fire, the two housing nodes could be animated to aim in different
directions, and the two guns could rotate as one unit, all at the same time. The entire group can
be parented to another node that is part of a vehicle.

Displaying Options in the Outliner

There are several options in the Outliner for displaying nodes and their hierarchical arrange-
ments. You can see that the default perspective, top, side, and front cameras are visible as nodes
at the top of the Outliner. Also, a number of sets, such as the defaultLightSet, appear at the
bottom of the Outliner. These sets are mainly used for organization of data by Maya and are
usually not directly edited or altered.

1. In the Display menu of the Outliner, select the Shapes option to display the shape nodes
of the objects. The shape nodes appear parented to their respective transform node. You
can select either the transform node or the shape node in the Outliner to select the object.

ACCESSING OUTLINER OPTIONS

You can right-click in the Outliner to access the Outliner’s display options quickly, rather than use
the menu at the top of the Outliner.

2. In the Display menu, activate the visibility of attributes by selecting the Attributes
(Channels) option.

Each node now has an expandable list of attributes. Most of the time you may want this
option off because it clutters the Outliner and there are other ways to get to these attri-
butes. Ultimately, how you use these options is up to you.
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3.

FIGURE 1.13
The Outliner can
display shape
nodes as well

as other types
of nodes in the
scene.

Turn off the Attributes display, and turn off the DAG Objects Only option. This allows
you to see all the nodes in the scene in the Outliner list, as opposed to just the DAG nodes.

DAG stands for “directed acyclic graph,” and DAG objects are those that have both a shape
and a transform node. It’s not crucial to understand exactly what directed acyclic graph
means as long as you understand that it is an arrangement in which a shape node is par-
ented to a transform node. When you turn off DAG Objects Only in the Outliner, you'll see
all the nodes in the Maya scene appear. Many of these are default utility nodes required

to make Maya function, such as the layerManager node or the dynController]l node. Many
other nodes appear when you create a new node or connection. An example of this is a
keyframe or an expression node.

When you turn off DAG Objects Only, the list can get quite long. To find a node quickly, type the
node’s name in the field at the very top of the Outliner. This hides all nodes except the named
node. Clearing the field restores the visibility of all nodes in the Outliner (see Figure 1.13).
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Additional viewing options are available in the Show menu, which contains options for
displaying only nodes of a certain type. Throughout this book, the Outliner will be used
extensively, so you'll have lots of practice working with this panel.

4. In the Display menu of the Outliner, turn the DAG Objects Only option back on. Save the
scene as minGun_v02.ma.

To see a finished version of the scene, open miniGun_v@2.ma from the chapterl\scenes
directory on the book’s web page.

SEARCHING FEATURES IN THE OUTLINER

A complex scene in Maya can easily have hundreds of nodes. Just one character often has associated
geometry, dozens of animation controls, joints, textures, and so on. Add another character to the
scene with its own set of node networks, and the Outliner can become very cluttered very quickly.
Establishing an organized naming system for the nodes in your scenes has many benefits, one of
which is that you can use the search feature in the Outliner to filter what is displayed, thus making
it easy to access the nodes you need. Take the time to name your nodes in such a way as to make
searching easy. The following illustrates how the search feature can be used in a complex scene.

Let’s say you have a scene with two complex characters, one named Larry and the other named Cecil.
Both characters have similar rigs that use NURBS curves to control their animation rigs, and both
have geometry, joints, shaders, and so on. When naming the nodes associated with each character,
you make sure that all Larry nodes start with the name “larry.” So, Larry’s skin geometry might
be named larry_SKIN_GEO, whereas his clothes would use names like larry_PANTS_GEO. Using
capital letters in this case is purely a personal preference; the important thing is that the name of
each node starts with larry_. Cecil would use the same convention; his skin geometry would be
cecil_SKIN_GEO, and his pants would be cecil_PANTS_GEQ. You end the names using GEO so
that you know that this is a geometry node.

The controls for the animation rig use names like larry_LEFT_HAND_wrist_CTRL1, larry_
SPINE_CTRL1, and larry_NECK_CTRL1. You get the idea. You can see that each of these nodes
belongs to Larry, nodes for the left side of the body are clearly identified, the associated body part
is identified, and they end with the letters CTRL. The same goes for Cecil.

Now here’s where this type of organization, or something similar, is helpful in the Outliner. At
the top of the Outliner is a blank field. To filter the nodes listed in the Outliner, you need to type
some text and either precede or follow the text with an asterisk (*). The asterisk tells Maya to
show all nodes that use the text before or after the asterisk in the name. So if you want to see all
nodes associated with Larry, type larry*. If you want to see all the control nodes for both Cecil
and Larry, type *CTRL*. In this case, there may be text before and after the CTRL letters, so use
an asterisk before and after CTRL. If you want to see the controls associated with Cecil’s hands,
type cecil*HAND*, and so on.

The following images show variations on how to search through the Outliner with this method. If
nothing appears in the Outliner when you type some text, check to see whether the asterisk is in
the right place. To find one specific node, type its full name without the asterisk.

continues
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right of the interface
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The Channel Box

The term channel is, for the most part, interchangeable with attribute. You can think of a chan-
nel as a container that holds the attribute’s value. The Channel Box is an editor that lists a node’s
attributes for quick access. The Channel Box displays the node’s attributes, which are most fre-
quently keyframed for animation.

The Channel Box is located on the right side of the screen when the view mode at the end of
the status bar is set to show the Channel Box/Layer Editor (see Figure 1.14).

toggles the visibility
of the Channel Box/
Layer Editor.

Two tabs on the very right side of the screen allow you to switch quickly between the
Channel Box and the Attribute Editor, as shown in Figure 1.15. (The Attribute Editor is dis-
cussed in detail later in this chapter.) These tabs are visible when both the Attribute Editor
icon and the Channel Box icon are activated on the status bar in the upper-right corner of the
interface.

This exercise gives a quick tour of how to work in the Channel Box:

1. Create a new scene in Maya, and create a NURBS sphere on the grid (Create >
NURBS Primitives > Sphere). You'll be prompted to draw the sphere on the grid if the
Interactive Creation mode is on; if not, the sphere will appear at the center of the grid.
Either option is fine.
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FIGURE 1.15
The two tabs on
the right side of
the screen allow
you to switch
quickly between
the Channel
Box and the
Attribute Editor. guns

2. Make sure that the Channel Box is visible on the right side of the screen. To do this,
click the icon at the farthest right of the status bar (shown earlier in Figure 1.14). This is

a toggle to display the Channel Box. Click it until the Channel Box appears, as shown in
Figure 1.16.

FIGURE 1.16
The Channel
Box displays the
channels for
the currently
selected object.
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3.

FIGURE 1.17
You can quickly
“zero out”

the Translate
and Rotate
channels by
Shift+clicking
their fields and
entering 0.

10.

The Channel Box will list the currently selected object. Select the sphere, and you'll see
nurbsSpherel appear. The list below it shows the attributes for the nurbsSpherel’s trans-
form node.

The lower half of the Channel Box lists the connections to this node. You'll see the name
of the associated shape node under SHAPES, and below this a section for the inputs. In
this case, the input is the history node, named makeNurbSpherel, which contains the
original settings used to create the sphere. If you delete history on the sphere, these attri-
butes will no longer be accessible.

In the upper section of the Channel Box, under nurbsSpherel, try selecting the fields and
inputting different values for Translate, Scale, and Rotate. The sphere updates its position,
size, and orientation.

. In the Visibility channel, select the word On in the field, and type 0. The sphere disap-

pears. Input the value 1, and it reappears. Visibility is a Boolean, meaning it is either on or
off, 1 or 0.

. Select the Translate X field so that it is highlighted. Shift+click the Rotate Z value, and all

the values in between are also selected.

Type 0 in the Translate X field while they are selected, and press the Enter key. Doing so
sets all the Translate and Rotate values to the same value, places the sphere at the center
of the grid, and returns it to its original orientation (see Figure 1.17).

nurbsSpherel

SHAPES
nurbsSphereShapel

INPUTS
makeNurbSphere 1

. In the makeNurbSphere section under INPUTS, highlight the Start Sweep channel. Enter

a value of 90, and the sphere opens up. If this is hard to see, switch to shaded mode by
pressing 5 on the keyboard. You're altering the construction history of the sphere so that
it is no longer a closed surface.

Select the word Sections so that it is highlighted in blue. MMB-drag back and forth in the
viewport. Doing so creates a virtual slider so that you can change the value of the field
interactively instead of numerically. This should work for all the channels (at least, most
of the time).

Set the timeline to frame 1 by clicking on the far left of the time slider where it is labeled
1, and press the s hot key. You'll see all the channels turn orange, indicating that they
have been keyframed. The s hot key keyframes all the available channels.
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FIGURE 1.18

Right-click the

selected chan-

nels, and choose
Key Selected to

keyframe just
those specific
channels.

16.

CREATING AND EDITING NODES

Move the timeline to frame 24, and change some settings both on the transform node (the
upper half of the Channel Box) and under makeNurbSpherel in the INPUTS section.

Press the s hot key again to set another key. Play the animation, and you'll see the sphere
update based on the keyframed changes.

If the animation seems to play too quickly, you need to change the preferences so that
playback matches the frame speed of the animation. To do so, choose Windows >
Settings/Preferences > Preferences. In the Preferences window, choose Time Slider on the
left column and set PlayBack Speed to Real-Time [24 FPS].

The s hot key keyframes everything, even those channels you may not need to keyframe.
You can use the Channel Box to keyframe specific channels.

Rewind the timeline, and choose Edit > Keys > Delete Keys to remove all the keyframes
on the sphere.

Highlight Translate X and Shift+click Translate Z so that the translation channels are all
selected.

Right-click these values, and choose Key Selected (see Figure 1.18).

Move to frame 24, and enter different values in the Translate fields.

17. Shift+click the Translate fields in the Channel Box, right-click, and choose Key Selected.

This places a keyframe on just the selected channels—often a cleaner and more efficient
way to work because you're placing keyframes only on the channels you need to animate
and not on every keyable channel, which is what happens when you use the s hot key.
Now try playing the animation.

BE THRIFTY WITH KEYFRAMES

Creating extra, unnecessary keys leads to a lot of problems, especially when you start to refine the
animation on the Graph Editor (discussed in Chapter 2, “Introduction to Animation.” Keyframes
also can increase the scene size (the amount of storage space the scene uses on disk). Be cheap with
your keyframes, and use the Key Selected feature to keyframe only the channels you need. Avoid
using the s hot key to create keys on everything.

21
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18. To remove keys, you can highlight the channels, right-click, and choose Break
Connections. This removes any inputs to those channels. The values for the current key-
frame will remain in the channels.

The channels are color-coded to show what kind of input drives the channel:
¢ Pinkindicates a keyframe.
¢ Purple indicates an expression.

& Yellow indicates a connection (as in a connection from another node or channel, made in
the Connection Editor or Node Editor).

Brown indicates a muted channel.

Gray means the channel is locked.

LOCKING AND MUTING CHANNELS

You can mute a channel by right-clicking it and choosing Mute Selected from the context menu.
When you mute a channel, the keyframes on that channel are temporarily disabled; as long as
the channel is muted, the animation will not update. This is useful when you want to disable the
keyframes in a channel so that you can focus on other aspects of the animation. Locking a channel
is another option available when you right-click selected channels in the Channel Box. A locked
channel prevents you from adding keyframes to a channel regardless of whether it has been ani-
mated. Creating animation is examined further in Chapter 2.

The Channel Box will be explored throughout the book and used frequently, particularly in
the chapters concerning animation.

The Attribute Editor

The Attribute Editor is a tabbed panel that gives detailed information and access to a node’s
attributes. The tabs at the top of the editor allow you to move between the attributes of all the
upstream (input) and downstream (output) connected nodes. This exercise gives a brief tour of
how to use the Attribute Editor:

1. Create a new scene in Maya. Create a polygon cube on the grid (Create > Polygon
Primitives > Cube).

2. Select the cube, and open its Attribute Editor. There are several ways to do this:

¢ Right-click and hold the right mouse button over the cube, and choose pCubel from
the marking menu.

Select the cube, and choose Window > Attribute Editor.

Click the Show/Hide Attribute Editor icon in the upper right of the Maya interface
(Figure 1.19).



FIGURE 1.19
The Show/Hide
Attribute Editor
icon resides in Show/Hide Attribute Editor
the upper-right
corner of the
Maya interface.

the selected object or node.
© nelp

Displays or hides the Attribute Editor which ists properties for
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¢ DPress Ctrl+a on the keyboard. This toggles between Channel Box and Attribute Editor

if they’re docked.

3. With the Attribute Editor open, choose the pCubel tab at the top (Figure 1.20). The panel
that opens contains the attributes for the cube’s transform node, much like the upper sec-
tion of the Channel Box described in the previous section. It also contains options for set-

ting limits on the transform attributes.

FIGURE 1.20

Attribute Editor

The Attribute

Editor contains

tabs that allow ’cububz. ===

you to move

through the con- B PoiteL

nected nodes of
a network. ¥ Transform Auributes

Translate 0.000

Rotate  (0.000

Scale 1.000

Shear | 0.000

Many of the settings can be accessed through the Attribute Editor’s rollout panels. These

are collapsible sections of grouped settings.

4. In the Attribute Editor, on the pCubel tab, click the triangle next to mental ray. This
reveals mental ray—specific settings related to the cube. Note that there are subsections

under mental ray that are also collapsible.

5. Choose the pCubeShapel tab at the top of the Attribute Editor. This tab contains settings
related to the shape node. For example, expand the Render Stats section and you'll see a
list of settings that control how the shape will appear in a render.

-2}

history on the cube, this tab will no longer appear.

N

Channel Box (Figure 1.21).

List Selected Focus Atributes Show Help

initialShadingGroup 4]

0.000
0.000
1.000
0.000
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0.000
1.000
0.000

Focus
Presets
wv | Hide

J01p3 Jake | xog puuRyD)
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. Choose the polyCubel tab, and you'll see the construction history settings. If you delete

Expand the Poly Cube History rollout. If you right-click any of the fields, you get a menu
that offers options such as expressions, key setting, or locking, much like the fields in the

23
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FIGURE 1.21 Artribute Editor
Right—clicking List Selected Focus Armributes Show Help
an attribute field
reveals a menu
with options for
animating the
attribute value.
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8. In the Subdivisions Width field, highlight the text and type =. Doing so lets Maya know
that you want to add an expression to the field.

CUSTOMIZING THE ATTRIBUTE EDITOR

There are several ways to customize the Attribute Editor. The menu displayed by right-clicking on
any field contains the Hide Attribute Control option. Choosing this removes the attribute from
view. To display it, choose Show > Show Attributes, and then choose the hidden attribute you
want to show. For greater control, you can create an XML-based template file. Maya automatically
reads XML files placed in the scripts\AETemplates folder of your Maya install directory. You
can then choose the template from the Attribute Editor’'s menu Show > Set Current View or Show
> Set Global View.

9. Complete the expression by typing 9*2 after the equals sign (see Figure 1.22); then press
the Enter key. Doing so adds an expression to this attribute that makes the Subdivisions
Width value equal to 18. Note that the field turns purple and the slider can no longer be
moved.

FIGURE 1.22
You can enter
simple math-
ematical expres-
sions directly
into a field in the
Attribute Editor.

Subdivisions Width | =9+2|

Subdivisions Helght 1

Subdivisions Depth 1
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Note that a new tab called expressionl is added to the top of the Attribute Editor; this is a
new expression node that is now part of the cube’s node network.

If the number of connected nodes is too large to fit within the tab listing at the top, you can
use the two arrow buttons to the right of the tabs to move back and forth between the tab list-
ings. Likewise, if not all connections are visible, you can use the Go To Input and Go To Output
Connection buttons to the right of the field indicating the node name.

The Notes field at the bottom is useful for typing your own notes if you need to keep track of
particular settings or leave a message for yourself or other users (see Figure 1.23). You can col-
lapse this section by dragging the bar above it downward, thus making more room for the other
settings in the Attribute Editor.

FIGURE 1.23
Messages can be
entered in the
Notes section at
the bottom of the
Attribute Editor.

LOAD ATTRIBUTES

You can use the Load Attributes button at the bottom of the Attribute Editor if the attribute display
needs to be refreshed. Maya automatically updates the editor when new attributes are added, but
occasionally it misses an update and needs to be refreshed.

The Attribute Editor is the workhorse panel of Maya. Throughout this book we will use it
constantly. Make sure you are comfortable with the core concepts of how to switch between
node settings using the tabs as well as how to change the available values.

Working with Shader Nodes in the Hypershade

The Hypershade, as the name suggests, is similar in function to the Hypergraph. It gives a visual
display of how nodes in a Maya scene are connected. The Hypershade is mostly concerned with
shaders—nodes used to define the color and material properties of renderable objects in a scene.
These include materials (also known as shaders), textures, lights, cameras, and shading utili-

ties. However, it is not unusual to use the Hypershade Work Area to make connections between

other types of nodes as well. In this exercise, you'll use the Hypershade to connect several types
of nodes.

1. Create a new scene in Maya. Create a NURBS cone on the grid. You'll be prompted to
draw the cone on the grid if Interactive Creation mode is on; if it is not, the cone will
appear at the center of the grid. Either option is fine.

2. Switch to smooth-shaded mode by pressing 6 on the keyboard, or click the Smooth Shade
All and Textured icons on the viewport’s menu bar (see Figure 1.24).
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FIGURE 1.24

The Maya viewport
menu bar allows
you to choose
between shading
modes by toggling
buttons.

Panels

3. Open Hypershade by choosing Window > Rendering Editors > Hypershade.

The Hypershade Editor is made up of several frames. On the left side is a list and a visual
menu of the nodes you can create in Hypershade. The list is divided into sections for the
Maya nodes, mental ray nodes, and a customizable list for your own favorites at the very
top. Clicking a category in the list filters the node-creation buttons to the right of the list,
which helps to cut down on the amount of time you need to hunt for specific nodes. To
add a node to the Favorites list, MMB-drag the node button from the right on top of the
Favorites menu. You can also search through the nodes by typing in the field at the very
top of the list. For example, typing mia in this field filters the node creation buttons so
that all the mia (mental images architectural) nodes are displayed (see Figure 1.25).

FIGURE 1.25

The text field at the top
of the Create tab allows
you to filter the list of
buttons. MMB-dragging
a button on top of

the Favorites section
adds the node to the
Favorites.

The right side of the Hypershade contains a visual display of the nodes in the scene at the
top and the Work Area at the bottom (see Figure 1.26). The upper section is organized by
tabs named Materials, Textures, Utilities, Rendering, Lights, Cameras, Shading Groups,
Bake Sets, Projects, and Asset Nodes. If you want to access all the file textures used in the
scene, you can choose the Textures tab to see them listed with preview icons.

4. On the left side of the Hypershade, click Surface in the list of Maya nodes. Click the Blinn
button to create a new Blinn material.
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You can see the new blinnl material listed on the Materials tab; it also appears in the

Work Area.

FIGURE 1.26
The Hypershade orga-
nizes render nodes and

Materizls

offers a workspace for
constructing render node
networks. This image
shows an example of a
shader network graphed
in the Work Area.
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HYPERSHADE TABS

If tabs appear to be missing, you can revert to the default tab layout by choosing Tabs > Revert
To Default Tabs, as shown here. This clears the current tabs and replaces them with the default
Materials, Textures, Utilities, Rendering, Lights, Cameras, and other default tabs. You can use
the Tabs menu to create your own custom tabs and determine which tabs you want visible and in

what order.

Graph

Current Tab

Options
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DEFAULT SCENE MATERIALS

All Maya scenes start with three materials already created: lambert1, particleCloudl, and shad-
erGlowl. The lambert] material is the default material applied to all newly created geometry, the
particleCloudl1 material is a special material reserved for particle-cloud objects, and the shader-
Glow1 node sets the glow options for all shaders in the scene.

5. Select the blinnl material in the Work Area and, from the menu at the top of the
Hypershade, choose Graph > Input And Output Connections. This displays all the
upstream and downstream nodes connected to blinnl. Upstream nodes are nodes that
plug into a node and affect its attributes; downstream nodes are ones that are affected by
the node.

The blinn1SG node is a downstream node known as a shader group, connected to blinn1.
All materials have a shader group node connected to them. This node is a required part
of the network that defines how the shader is applied to a surface, and it is often used
when creating complex mental ray shader networks and overrides (see Figure 1.27).

FIGURE 1.27
Shaders all have
shading group nodes
attached, which
define how the shader
is applied to the
geometry.

blinnlsG

6. In the viewport, select the cone. You can apply the blinnl material to the cone in three
ways:

¢ MMB-drag the material icon from the Hypershade on top of the cone in the viewport
window.

¢ Select the cone, right-click the blinn1 node in the Hypershade, and choose Assign
Material To Selection (see Figure 1.28).

¢ Right-click the surface in the viewport, and choose Assign New Shader to create a
new shader, or choose Assign Existing Material to assign a shader you've already
created.

7. In the Work Area of the Hypershade, select the blinnl node. This opens the Attribute
Editor for the Blinn shader if it’s not open already. This is where you can adjust the set-
tings that define the look of the material.
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FIGURE 1.28
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USE THE SHELF BUTTONS TO CREATE A NEW SHADER

You can assign a new material to a surface using the buttons in the rendering shelf at the top of the
Maya interface (shown here). If you select an object and click one of these buttons, a new shader
is created and assigned to selected objects. If no objects are selected, it just creates a new shader,
which you’ll find on the Materials tab of the Hypershade.

Animatian v 5 Rendering Pa
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s Pansls Blinn Material: Assign a nevs Blinn materlal to the active objects

8. In the Attribute Editor for the blinn1 node, rename the material coneShader by typing in
the field at the top of the editor.

9. Click the checkered box to the right of the Color slider. This opens the Create Render
Node window (see Figure 1.29).

10. Select 2D Textures from the list on the left, and click the Grid button on the right side of
the panel to create a grid texture; this is applied to the color channel of the cone, and it is
visible on the cone in the viewport when textured and smooth-shaded mode is on (hot
key = 6) (see Figure 1.30).

11. Select coneShader in the Work Area of Hypershade, and right-click its icon. Choose
Graph Network. You'll see that the coneShader node now has the gridl texture node as
well as the place2dTexturel node attached (see Figure 1.31).

12. Click the place2dTexturel node in the Work Area, and its attributes will be displayed in
the Attribute Editor.



30 |CHAPTER1 WORKINGINAUTODESK MAYA

13. Type 0.5 in the first field next to Coverage and press Enter. This reduces the coverage of
the grid texture in U space by one-half.

FIGURE 1.29 ate Render lode
Click the checkered i
box next to the
Color slider to open
the Create Render
Node window.
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FIGURE 1.30
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FIGURE 1.31
Applying the grid
texture to the color
channel of the
coneShader adds
two new nodes to
the shader network.
Graph the input and
output connections
to see these nodes in
the Hypershade.
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NURBS UV TEXTURE COORDINATES

NURBS surfaces have their U and V texture coordinates based on the parameterization of the
surface, unlike polygon meshes, which require defined UV coordinates. You can use the attributes
in the place2dTexturel node to position textures on NURBS surfaces.

14. Select the gridl node in the Work Area of the Hypershade to open its settings in the

Attribute Editor.

15. Expand the Color Balance rollout, and click the color swatch next to Default Color. This

opens the Color History. Set the color to red.

DEFAULT COLOR

The default color of the texture is the color “behind” the grid texture. Any part of the surface
that is not covered by the grid (based on the settings in the place2dTexturel node) will use the

default color.

16. In the left panel of the Hypershade, select 2D Textures in the Maya list, and click the
Ramp button to create a ramp node. At the moment, it is not connected to any part of
the coneShader network. This is another way to create render nodes in the Hypershade.

NAVIGATING THE HYPERSHADE WORK AREA

You can zoom in or out while in the Work Area of the Hypershade by holding down the Alt button
while RMB-dragging; likewise, you can pan by holding the Alt button down while MMB-dragging.

31
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17. Select the gridl texture to open its settings in the Attribute Editor.

18. In the Work Area of the Hypershade, MMB-drag the ramp texture from the Work Area all
the way to the color swatch next to the Filler Color in the grid’s Attribute Editor. Hold the
MMB while dragging; otherwise, you'll select the ramp texture, and the Attribute Editor
will no longer display the gridl texture attributes (see Figure 1.32). If the Connection
Editor pops up as a result of dragging, you can just click Close.

FIGURE 1.32

A texture node

can be MMB-
dragged from the
Hypershade into an
attribute slot in the
Attribute Editor.

19. Select the coneShader node in the Work Area of the Hypershade, and choose Graph >
Input And Output Connections from the Hypershade menu. In the Work Area, you can
see that the ramp texture is connected to the gridl texture. The gridl texture is connected
to the coneShader, and the shader is connected to the blinn1SG node (see Figure 1.33).

FIGURE 1.33

The coneShader
network has grown
with the addition of
new nodes.
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GRAPHING SHADER NETWORKS

You can graph the shader network at any time to refresh the view of the connected nodes in the
Work Area. Just right-click the node you want to graph and choose Graph Network, or click
the Input And Output Connections button at the top of the Hypershade (shown here). More options
for displaying the network are available in the Graph menu at the top of the Hypershade.

Tabs Graph  Windo

AR T

Iriput and output connections T

20. Select the blinn1SG node, and graph its input and output connections. The cone’s shape
node appears (if the Bottom Caps option was on in the Creation options for the NURBS
cone, you'll see a second shape node for the cone’s bottom cap surface). The blinn1SG
node is also connected to the render partition and the light linker, which defines the
lights used to light the cone (see Figure 1.34).

FIGURE 1.34

The shape nodes for
the cone are included
in the graph when
the input and output
connections of the
blinn1SG node are
graphed.

The Hypershade is a powerful and easy-to-use editor. You can build complex networks of
nodes quickly, just like rearranging building blocks. You can see how nodes are connected by
holding the mouse pointer over the lines that connect the nodes.

The previous sections of this chapter revealed to you the many ways Maya nodes can be
displayed, connected, and edited in a Maya scene. Make sure that you are comfortable with
the basics of working with the editors described. You will rely on them heavily throughout the
book, and by working through the various exercises, you will gain proficiency in using them.
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Creating Maya Projects

Organization is the key to creating a successful animation. Whether you are working by your-
self or with others in a production pipeline, you'll want to know where to find every file related
to a particular project, whether it’s a scene file, a texture map, an image sequence, or a particle
disk cache. To help you organize all the files you use to create an animation, Maya offers you the
option of easily creating a Maya project, which is simply a directory with subfolders where each
file type related to your scenes can be stored.

Creating a New Project

Creating a new project is simple. Projects can be created on your computer’s primary hard
drive, a secondary drive, or a network drive. The scene files used for each chapter in this book
are stored in their own project directories at www.sybex.com/go/masteringmaya2015. Maya
uses a default project directory when one has not been specified. This is located in your My
Documents\maya\projects folder in Windows. As an example, you'll create a project directory
structure for the examples used in this chapter.

1. Start a new Maya scene. You'll note that an empty scene is created when you start Maya.
2. Choose File > Project Window.

3. The Project Window dialog box opens. Click the New button to the right of the
Current Project field. In the Current Project field, type Mastering_Maya_Chaptero1
(see Figure 1.35).

FIGURE 1.35

The Project Window
dialog box lets you
set the location of

a new project direc-
tory and determine
its directory struc-
ture on your hard
drive.

¥ Primary Proj
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4. To the right of the Location field, click the folder icon to browse your computer. The Select
Location window opens and lets you determine where on your computer or network you
want the project to be stored, or you can simply type the path to the directory. The project
folder can be a subfolder of another folder if you like.

In the Primary Project Locations section, you'll see a large number of labeled fields. The
labels indicate the various types of files a Maya scene may or may not use. The fields indi-
cate the path to the subdirectory where these types of files will be located.

When you click the New button as mentioned in step 3, Maya automatically fills in all the
fields (see the right side of Figure 1.36).
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The fields contain the name of the subdirectory relative to the project file. So when you
choose to use the default settings, all Maya scene files (files with the .mb or .ma file exten-
sion) will be stored in a folder labeled Scenes. The path to that folder will be, in this
example, Mastering_Maya_Chapter0l\Scenes.

EDITING DEFAULT FILE LOCATIONS

If you decide you want to store the scene files in a different directory, you can type the path to that
directory in the field or click the folder icon to the right of the field to set a different folder path.

5. Click Accept. Maya will take a few moments to create the project directory and all sub-
folders on the specified drive.

6. Use your computer’s file browser to locate the new project; then expand the folder, and
you’ll see all the subfolders.
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Editing and Changing Projects

You may not need to use every folder Maya creates for you, or you may decide to change where
Maya looks for elements such as file textures. If youre working on a number of projects, you
may need to switch the current project. All of these options are available in the Maya File menu.

1. To edit the current project, choose File > Project Window. The Project Window dialog box
opens with all the paths to the project subdirectories. You can type a new directory path
in any one of these fields or click the folder icon to browse your computer’s directory.
Then click the Accept button. If a folder does not already exist, Maya will create it for you.

RELINKING FILES AFTER CHANGING PROJECT SETTINGS

If you edit the project, Maya will look in the newly specified folders from this point on, but files
used prior to editing the project will not be copied or moved. You’ll need to move these files using
the computer’s file browser if you want Maya to find them easily after editing the project.

2. To switch projects, you can choose File > Set Project or choose a project listed in the
Recent Projects menu.

When working on a project with a number of other animators, you can choose to share the
same project, which is a bit risky, or each animator can create their own project directory struc-
ture within a shared folder. The latter approach is a little safer because it prevents two people
from having the same project open or overwriting each other’s work. Later in this book, you'll
learn how multiple animators can share parts of the scene using file references.

It is possible to work on a scene file outside the current project. This happens usually when
you forget to set the project using the File > Set Project option. Make a habit of setting the cur-
rent project each time you start to work on a scene; otherwise, linked files such as textures,
dynamic caches, and file references can become broken, causing the scene to behave unpredict-
ably (which is a nice way of saying that the scene will fall apart and possibly crash Maya).

While working with the project files for this book, you’ll want to copy the entire project to
your local drive and then use the Project Window dialog box to choose the corresponding chap-
ter project directory as the current project. This way, all the linked files in the scenes should
behave correctly and the exercises will function.

OVERRIDING PROJECT SETTINGS

You can choose to override a project setting for an individual scene element. For instance, by
default Maya looks to the sourceimages directory for file textures. However, when you create a
file texture node, you can use the Browse button to reference a file anywhere on your machine or
the network. This is usually not a great idea; it defeats the purpose of organizing the files in the
first place and can easily lead to broken links between the scene and the texture file. It’s a better
idea to move all file textures used in the scene to the sourceimages directory or whatever direc-
tory is specified in your project settings.
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The Bottom Line

Understand transform and shape nodes. DAG nodes have both a transform node and a
shape node. The transform node tells where an object is located; the shape node describes
how it is made. Nodes can be parented to each other to form a hierarchy.

Master It Arrange the nodes in the miniGun_v03.ma file in a hierarchical structure so
that the barrels of the guns can rotate on their z-axis, the guns can be aimed indepen-
dently, and the guns rotate with the turret.

Create a project. Creating a project directory structure keeps Maya scene files and con-
nected external files organized to ensure the animation project is efficient.

Master It Create a new project named Test, but make sure the project has only the
scene, source images, and data subfolders.






