Chapter 1

IntroducinMNTS Editor

In This Chapter
Understanding the GIANTS Editor interface
Opening 3D objects and scenes in the editor
Moving around within a 3D scene in GIANTS Editor

Moving, rotating, and scaling objects

A Il modding for Farming Simulator starts and ends
with GIANTS Editor. If you want to make a quick
change to a map or a vehicle, you can open its file and
edit attributes in GIANTS Editor. If you've created a full
mod from scratch, you pull all the pieces together and
prepare them for inclusion in the game in GIANTS Editor.
Think of GIANTS Editor as your modding dashboard.

You don’t need to do a lot in order start working with
GIANTS Editor; it ships with Farming Simulator. So if
you've been playing the game, you're good to go with the
editor; you just need to install it. You can find the install
file in the sdk folder wherever you've installed Farming
Simulator on your hard drive. (On a Windows computer,
it’s usually something like C: \Program Files (x86)\
Farming Simulator 2015.) Of course, going to the
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GIANTS Developer Network website (http://gdn.
giants-software.com) and checking for updates is
still a good idea. That way you can be sure you get the
latest features and bug fixes. Updated versions of the
editor are free to download after you've registered on the
site (which is also free).

This chapter serves as your jumping-off point into the
world of creating mods for Farming Simulator by making
sure you have firm footing when it comes to using GIANTS
Editor. Regardless of how simple or complex your mod
may be, it needs to come through GIANTS Editor, so this
chapter is relevant, no matter your general modding
experience.

Knowing the Editor’s Parts

When you first launch GIANTS Editor, you'll see a Getting
Started splash window that provides you with a hotkey
reference and a set of buttons that links you to a number of
useful resources to help quickly get you on the road to mod-
ding. You can toggle whether this window appears every
time you launch it by clicking the Show at startup check-
box in the window’s lower-left corner. These resources
are certainly valuable, but you also have this book, so you
can comfortably close this window for the time being. You
can always bring it back from the Help menu in the editor
(Help=>Getting Started . . .).

After you move past the splash window and actually

get into the editor, you may think it looks rather stark,
consisting of a set of mostly empty panels. Not to worry,
though, those panels will fill up pretty quickly. Figure 1-1
shows GIANTS Editor with the default interface and a
scene already loaded.



MBER
\‘&
&

Chapter 1: Introducing GIANTS Editor 7 ’

(S5
)

Figure 1-1: The GIANTS Editor default interface.

You can see four main panels when you first load GIANTS
Editor:

+* Scenegraph: You can find the Scenegraph on the
far left of the editor window. The Scenegraph gives
you a hierarchical view of the 3D scene, including all
models, lights, and cameras. Think of it as an outline
for your mod. In complex scenes, the Scenegraph
panel is incredibly useful for selecting the object
you're interested in editing.

v+~ 3D Viewport: The 3D Viewport is the large panel at
the center of the editor window and is where the
majority of your work takes place. Here you can
select and manipulate objects in your mod; the 3D
Viewport also provides a decent preview of what
you can expect your mod to look like after you load
it into Farming Simulator.

v~ Attributes: The Attributes panel on the far right of
the editor window can show different settings and
parameters, depending on the object you currently
have selected. At the very least, any object you
select will have Transform attributes for controlling
how that object is positioned and oriented in 3D
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space. From there, depending on what the object is
and what it does, it may have a wide variety of poten-
tial other subtabs available in the attributes panel.
For example, in Figure 1-1, the selected building in
that scene has a separate tab labeled LOD, for level
of detail.

v Scripting: The Scripting panel is across the bottom
of the editor window. This panel gives you a log and
basic feedback on what’s been done in your scene,
such as loading external textures. It can also give
you warnings if you have missing assets or if you've
formatted something incorrectly in your mod. When
things go pear-shaped in your mod, the Scripting
panel is your best friend for troubleshooting what
happened. And, of course, you can use the Scripting
panel to type commands and make large automated
changes to objects in your scene. Chapter 12 discusses
scripting in greater depth.

With the exception of the 3D Viewport, you can move
around any panel in the GIANTS Editor interface by click-
ing and dragging the panel’s header bar. Doing so allows
you to place the panel in another location or leave it as its
own floating window. Being able to customize your inter-
face is especially useful if you're working on a computer
with multiple monitors. You can keep the 3D Viewport as
big as possible on one monitor and move the other panels
to your other monitor. Also, you can close any panel by
clicking the little X on the right of the panel’s header. You
can bring back any closed panels from the Window menu.

Loading Assets

The file format that GIANTS Engine uses is the I3D format.
I3D is an eXtensible Mark-up Language (XML) file format.
That means, in part, that you can open it with a plain text
editor and make changes to it. Chapters 6 and 11 discuss
I3D and XML more.
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For the purposes of this chapter, you just need to know
that an I3D file encapsulates or references all the necessary
data for a 3D asset in GIANTS Engine. That also means [3D
files are what you load and modify from GIANTS Editor for
your Farming Simulator mod. This section explains how to
open full maps as well as individual assets that may appear
on a map.

Opening an existing map

The easiest asset to open in GIANTS Editor is the default
map that comes with Farming Simulator. Go to File=>Open
in GIANTS Editor and navigate to the maps folder within
the folder where you've installed Farming Simulator (typi-
cally C:\Program Files (x86)\Farming Simulator
2015\data\maps) and choose the file named map01.i3d.
You should see the familiar original map in the 3D Viewport
after it finishes loading. Figure 1-2 shows the default Farming
Simulator map loaded in GIANTS Editor.

=3 11D

Figure 1-2: The default Farming Simulator map (map01 . 13d) opened
within GIANTS Editor.

Do not save or overwrite the default Farming Simulator
map, especially if you've made any changes to the file. At
the very least, doing so may change the default behavior of
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the game. At worst, it may cause the game not to load and
force you to reinstall it. Although Chapter 2 covers export-
ing the original map for modifications, right now your main
focus should be on loading the map in GIANTS Editor and
poking around to familiarize yourself with the interface.

Using this same basic method you can open any map
scene. If you have any map mods installed, you can try
opening up the map scenes from them as well.

Previewing objects

A Farming Simulator map is really a compilation of dif-
ferent 3D assets, including props, terrain, buildings, and
so on. Suppose you’re not interested in working with a
full map, and you only want to have a look at one of the
objects that appears on the map. You don’t have to open
the map in GIANTS Editor and hide everything except
what you want to see.

You just need to follow the same basic steps for opening a
map in GIANTS Editor. Find the I3D file for the object and
open it from the editor. Figure 1-3 shows a mailbox from
the default Farming Simulator map loaded in GIANTS
Editor.
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Figure 1-3: A mailbox object opened in GIANTS Editor.
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When you first load an object in the editor, you may
notice that the object may be really small in the 3D
Viewport or out of view entirely. Fortunately, you can
easily fix it with the following steps:

1. If you can see the object in the 3D Viewport, you
can select it by clicking on it.

If it’s too small to select that way or if it’s not visible
in the 3D Viewport at all, you can click on the object’s
name in the Scenegraph panel and select it that way.

2. With the object selected, you can frame the 3D
Viewport on it using the F hotkey.

Doing so brings the object into view. However more
than likely, the view will be too close to see the entire
object. Using the scroll wheel on your mouse, you
can back away from the object in the 3D Viewport
and make it more visible. For more ways to navigate
the 3D Viewport, refer to the next section.

You may also notice that your object appears really dark.
Most objects don’t emit light, so most object I3D files
don’t include any light in the scene, which can make pre-
viewing an object difficult.

To see the object clearly, you may want to add a light
using the Ctrl+L hotkey combination. You can also add a
light from the Create menu (Create=>Light).

If you're viewing objects from the Farming Simulator data
folder, do not save those object files, especially if you've
made modifications like adding a light. Doing so affects
how the object appears in the game.

Navigating in 3D Space

Being able to move around in the 3D Viewport to see the
map or object from different angles is also important. You
can move around by using the mouse and the Alt key on
your keyboard.
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Having a three-button mouse when working with 3D
software is really in your best interest. These programs
have a tendency to use as many buttons on your com-
puter as they can get. Fortunately, most modern desktop
computers come with three-button mice. (Note: You can
find the third button on most of these mice by pressing
down on the mouse’s scroll wheel.) If you have a laptop,
though, the built-in trackpad doesn’t often have a middle
mouse button. In that case, | highly recommend that you
purchase a proper mouse.

Navigating a 3D scene consists of three main types of
movement:

v Orbiting: The view from the 3D Viewport rotates
around a fixed location. In GIANTS Editor, you orbit
the view by holding Alt while clicking and dragging
your left mouse button.

v+~ Panning: The view from the 3D Viewport always
faces the same direction, but it moves horizontally
and vertically. Imagine that you're stepping side-to-
side or squatting and standing while always looking
the same direction. You pan in GIANTS Editor by
holding Alt while clicking and dragging your middle
mouse button.

v Zooming: The view from the 3D Viewport gets closer
or farther away from a point in 3D space. A quick way
to do this is with your mouse’s scroll wheel. However,
scrolling to zoom snaps in fixed increments. If you
want more fine-grained control, hold Alt while click-
ing and dragging your right mouse button. Zooming
this way is much smoother.

Using Framed Rotate

You can use another option for navigating in the 3D
Viewport: Framed Rotate specifically relates to orbiting in
the 3D Viewport. You can use the F hotkey to frame the 3D
Viewport on the selected object. When you orbit the view
with Framed Rotate enabled (Viewr>Framed Rotate), you
orbit around the last framed location, no matter how far
away you pan from it.



Chapter 1: Introducing GIANTS Editor 7 7

&NBER Framed Rotate is great when you want to focus your atten-
tion on a single specific object. However, if you want to
navigate a large scene like a map, having Framed Rotate
enabled can make things difficult and unpredictable. When
Framed Rotate is disabled, you can move about the 3D
Viewport more freely. In fact, it feels a lot more like you're
rotating the view camera while holding it rather than
orbiting around a fixed point somewhere else in 3D space.

L

Choosing camera views

All 13D files have at least one camera object in them. The
default camera is named persp, for perspective. However,
some I3D files may have multiple cameras in the scene.
These cameras are typically part of vehicle objects so the
player has more than one option while driving. Of course, if
you're interested in making a vehicle mod (or tweaking the
camera angles in an existing vehicle), you need to see from
the perspective of those cameras within GIANTS Editor.

<P You can change the current active camera from the View
menu (View=>Camera). This submenu has a list of every
available camera in the I3D file. Clicking a camera’s name
in the menu automatically changes the 3D Viewport to
see from that camera’s perspective. Figure 1-4 shows the
expanded View menu with the Camera submenu on a
vehicle with two cameras.

r6.0.0 - G/
[Wiew| Window Help

Camera outdoorCamera

¥ | Framed Rotate © 05 indoorCamera

Wireframe
Shaded

1_attacherlointBach
2_attacherlointBach

Figure 1-4: You can choose from two camera objects
in this vehicle file.
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Be careful about navigating in the 3D Viewport after
changing to one of these vehicle cameras. By doing so,
you're actually changing the position and orientation of
the camera itself. For that reason, when opening a vehicle
I3D file in GIANTS Editor, it’s a good idea to add an addi-
tional camera to the scene to be your work camera. That
way you don’t mess up any of the vehicle’s cameras. Of
course, if you opened this file from Farming Simulator’s
data folder, you shouldn’t be saving over it anyway. But
creating a work camera is still a good practice to get into,
just in case.

Transforming Objects

The real fun begins with modifying and changing things.
Adjusting the location, rotation, or scale of an object
in 3D space is called transforming the object. In GIANTS
Editor, the easiest way to transform any active object is
with the transform gizmo in the 3D Viewport. As shown
in Figure 1-5, the transform gizmo looks like a 3D-axis
surrounded by circles.

/
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Figure 1-5: The transform gizmo allows you
to move and rotate the active object.
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The following sections examine the different ways that
you can transform objects in GIANTS Editor.

Translating, rotating, and scaling

The transform gizmo gives you control over two types of
transformations:

v Translation: Otherwise known as moving your object
or changing its location. Use the gizmo to translate
your active object by left-clicking and dragging one
of the arrows on the gizmo’s 3D axis.

+ Rotation: To rotate your active object with the gizmo,
left-click and drag along one of its three circles.

Another way that you can transform an active object is
to scale or adjust its size. Unfortunately, the transform
gizmo doesn’t provide the facilities for adjusting scale.
Instead, you need to make scaling adjustments from
the Transform tab of the Attributes panel, as shown in
Figure 1-6.

The translate, rotate, and scale fields take up the bulk

of the space in the Transform tab of the Attributes panel.
These text fields give you much more precise control
over the location, orientation, and size of your active
object. The following list gives additional information
about each of these fields:

v Translate X/Y/Z: These values are measured in
meters from the scene’s origin (Om, Om, Om). Knowing
the units here is especially important when putting an
object on a map in a game. It can be pretty disorient-
ing if you expect a part of a building to be 1cm off the
ground, but it ends up floating 1m above the ground.

v Rotate X/Y/Z: These values are measured in degrees
relative to the object’s original rotation, which
should be (0°, 0°, 0°).
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Figure 1-6: The Transform tab of the Attributes panel
is available for any objectin an I3D file.

v Scale X/Y/Z: These values are multiplied by the
object’s original scale, which should be (1, 1, 1). So
if you set the scale values to (0.5, 0.5, 0.5), then it
will be half of its original size. There isn’'t any way
to lock the three scale values together, so if you
want your object to be scaled uniformly, you need to
double-check these values and make sure they’re all
the same.
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In GIANTS Engine, the 3D environment is in a y-up world.
That is, if you look at the 3D axis, the y-axis points up
and down in the world, between the ground and the sky.
Think of the plane defined by the x- and z-axis as the
ground at sea level. The x-axis points east/west while the
z-axis points north/south.

Selecting objects

You can also select multiple objects at once. The method
that you use varies slightly depending on whether you're
in the 3D Viewport or the Scenegraph.

v+~ 3D Viewport: You can add to the current selection
set by Shift+left-clicking multiple objects. There is
no way to remove an object from the current selec-
tion set, so if you select something incorrectly and
you want to stay in the 3D Viewport, you'll need to
redo your selection.

» Scenegraph: The Scenegraph is much better suited
for multiple selection. You can toggle whether an
object is part of the current selection set by Ctrl+left-
clicking its name. Furthermore, if you click one
object’s name and Shift+left-click another name else-
where on the tree, all of the objects between those
two are also selected.

Regardless of how you make your multiple selection, the
first object you select has a green wireframe whereas

all additional selected objects have white wireframes.
The green object is the active object, and its properties
are the only ones editable from the Attributes panel.
Furthermore, transformations with the transform gizmo
in the 3D Viewport also only affect the active object. If
you want to manipulate multiple objects at the same time,
you need to make a new Transform Group and add those
objects to it. Check out Chapter 2 for more information.
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