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Chapter  1

Working with 
Ranges
In Excel, a range is a collection of two or more cells that you work 
with as a group rather than separately. This enables you to fill the 
range with values, move or copy the range, sort the range data, and 
insert and delete ranges. You learn these and other range techniques 
in this chapter.
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Select a Rectangular Range
1 	Position the mouse ( ) over 

the first cell you want to 
include in the range.

2 	Click and drag the  over the 
cells that you want to include 
in the range.

A 	Excel selects the cells.

3 	Release the mouse button.

Select a Range of Individual 
Cells
1 	Click in the first cell that you 

want to include in the range.

2 	Hold down  and click in each 
of the other cells that you want 
to include in the range.

B 	Each time you click in a cell, 
Excel adds it to the range.

3 	Release .

Select a Range

Select a Range

To work with a range in Excel, you must first select the cells that you want to include in the range. 
After you select the range, you can fill it with data, move it to another part of the worksheet, 

format the cells, and perform the other range‐related tasks that you learn about in this chapter.

You can select a range as a rectangular group of cells, as a collection of individual cells, or as an 
entire row or column.
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Select an Entire Row
1 	Position the mouse ( ) over the 

header of the row you want to 
select (  changes to ).

2 	Click the row header.

C 	Excel selects the entire row.

	 To select multiple rows, click and 
drag across the row headers or 
hold down  and click each 
row header.

Select an Entire Column
1 	Position the mouse ( ) over the 

header of the column you want 
to select (  changes to ).

2 	Click the column header.

D 	Excel selects the entire column.

	 To select multiple columns, click 
and drag across the column 
headers, or hold down  and 
click each column header.

TIPS
Are there keyboard techniques I can use to 
select a range?
Yes. To select a rectangular range, navigate to the 
first cell that you want to include in the range, 
hold down , and then press  or  to extend 
the selection. To select an entire row, navigate to 
any cell in the row and press  +  . 
To select an entire column, navigate to any cell in 
the column and then press  +  .

Is there an easy way to select every cell in the 
worksheet?
Yes. There are two methods you can use. Either press 

 +  , or click the Select All button ( ) in the 
upper‐left  
corner of the 
worksheet ( A ).



6

9781119074731-ch01.indd  6� July 20, 2015 11:40 PM

4 	Release the mouse button.

A 	Excel fills the range with the 
initial cell value.

Fill a Vertical or Horizontal 
Range
1 	In the first cell of the range you 

want to work with, enter the data 
you want to fill.

2 	Position the mouse ( ) over the 
bottom‐right corner of the cell 
(  changes to ).

3 	Click and drag  down to fill a 
vertical range or across to fill  
a horizontal range.

Fill a Range with the Same Data

Fill a Range with the Same Data

If you need to fill a range with the same data, you can save time by getting Excel to fill the range 
for you. The AutoFill feature makes it easy to fill a vertical or horizontal range with the same 

value, but you can also fill any selected range. This method is much faster than manually entering 
the same data in each cell.

See the previous section, “Select a Range,” to learn how to select a range of cells.



7

Chapter

1Working with Ranges

9781119074731-ch01.indd  7� July 20, 2015 11:40 PM

Fill a Selected Range
1 	Select the range you want to fill.

2 	Type the text, number, or other 
data.

3 	Press  +  .

TIP
How do I fill a vertical or horizontal range without also copying the formatting of the original cell?
	 Follow these steps:

1 	Perform steps 1 to 4 to fill the data.

A 	Excel displays the AutoFill Options smart tag ( ).

2 	Click the AutoFill Options .

3 	Click Fill Without Formatting.

	 Excel removes the original cell’s formatting from 
the copied cells.

B 	Excel fills the range with the 
value you typed.
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Fill a Range with a Series of Values

AutoFill a Series of Numeric, 
Date, or Alphanumeric Values
1 	Click in the first cell and type the 

first value in the series.

2 	Click in an adjacent cell and type 
the second value in the series.

3 	Select the two cells.

4 	Position the mouse ( ) over the 
bottom‐right corner of the 
second cell (  changes to ).

5 	Click and drag  down to fill a 
vertical range or across to fill a 
horizontal range.

A 	As you drag through each cell, 
Excel displays the series value 
that it will add to the cell.

6 	Release the mouse button.

B 	Excel fills the range with a series 
that continues the pattern of the 
initial two cell values.

Fill a Range with a Series of Values

If you need to fill a range with a series of values, you can save time by using the AutoFill feature 
to create the series for you. AutoFill can fill a series of numeric values such as 5, 10, 15, 20, and 

so on; a series of date values such as January 1, 2016, January 2, 2016, and so on; or a series of 
alphanumeric values such as Chapter 1, Chapter 2, Chapter 3, and so on.

You can also create your own series with a custom step value, which determines the numeric 
difference between each item in the series.
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Fill a Custom Series  
of Values
1 	Click in the first cell and type 

the first value in the series.

2 	Select the range you want to 
fill, including the initial value.

3 	Click the Home tab.

4 	Click Fill ( ).

5 	Click Series.

	 The Series dialog box appears.

6 	In the Type group, select the  
type of series you want to fill  
(  changes to ).

7 	If you selected Date in  
step 6, select an option  
in the Date unit group  
(  changes to ).

8 	In the Step value text box, 
type the value you want to use.

9 	Click OK.

C 	Excel fills the range with the 
series you created.

TIP
Can I create my own AutoFill series?
Yes. You can create a custom list, which is a series 
of text values. When you add the first value in your 
custom list, you can then use AutoFill to fill a 
range with the rest of the series. Follow these 
steps:

1 	Click the File tab.

2 	Click Options.

	 The Excel Options dialog box appears.

3 	Click Advanced.

4 	Scroll down to the General section and then 
click Edit Custom Lists.

	 The Custom Lists dialog box appears.

5 	Click NEW LIST.

6 	In the List entries box, type each item in your 
list, and press  after each item.

7 	Click Add.

8 	Click OK to return to the Excel Options dialog box.

9 	Click OK.
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Flash Fill a Range

Flash Fill a Range with 
Extracted Data
1 	Make sure the column of original 

data has a heading.

2 	Type a heading for the column of 
extracted data.

3 	Type the first value you want in 
the new column.

4 	Begin typing the second value.

A 	Excel recognizes the pattern and 
displays suggestions for the rest 
of the column.

5 	Press .

B 	Excel flash fills the column with 
the extracted data.

Flash Fill a Range

You can save time and effort by using the Flash Fill feature in Excel to automatically fill a range of 
data based on a sample pattern that you provide.

Although there are many ways to use Flash Fill, the two most common are flash filling a range with 
extracted data and flash filling a range with formatted data. For example, if you have a column of 
full names, you might want to create a new column that includes just the first names extracted from 
the original column. Similarly, if you have a column of phone numbers in the form 1234567890, you 
might want a new column that formats the numbers as (123) 456‐7890.
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Flash Fill a Range with 
Formatted Data
1 	Make sure the column of original 

data has a heading.

2 	Type a heading for the new 
column of formatted data.

3 	Type the first value you want in 
the new column.

4 	Begin typing the second value.

C 	Excel recognizes the pattern and 
displays suggestions for the rest 
of the column.

5 	Press .

D 	Excel flash fills the column with 
the formatted data.

TIPS
Why do I not see the automatic Flash Fill suggestions when 
I type the sample data?
For Flash Fill’s automatic suggestions to appear, you must have 
headings at the top of both the column of original data and 
the column you are using for the filled data. Also, the flash fill 
column must be adjacent to the original column and the 
sample entries you make in the fill column must occur one 
after the other. Finally, note that Flash Fill’s automatic 
suggestions usually only work with text data, not numeric data.

Can I still use Flash Fill even though I 
do not see the automatic suggestions?
Yes, you can still invoke Flash Fill on any 
range by running the Ribbon command. 
In the fill range, type the first value, 
then select that value and the rest of the 
fill range. Click the Data tab and then 
click Flash Fill ( ). Excel flash fills the 
selected range.
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Move a Range
1 	Select the range you want to 

move.

2 	Position the mouse ( ) over  
any outside border of the range 
(  changes to ).

3 	Click and drag the range to the 
new location (  changes to ).

A 	Excel displays an outline of the 
range.

B 	Excel displays the address of the 
new location.

4 	Release the mouse button.

C 	Excel moves the range to the new 
location.

Move or Copy a Range

Move or Copy a Range

If your worksheet is not set up the way you want, you can restructure or reorganize the worksheet 
by moving an existing range to a different part of the sheet.

You can also make a copy of a range, which is a useful technique if you require a duplicate of the 
range elsewhere, or if you require a range that is similar to an existing range. In the latter case, 
after you copy the range, you can then edit the copied version of the data as needed.
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Copy a Range
1 	Select the range you want to copy.

2 	Press and hold .

3 	Position the mouse ( ) over any 
outside border of the range  
(  changes to ).

4 	Click and drag the range to the 
location where you want the copy 
to appear.

D 	Excel displays an outline of the 
range.

E 	Excel displays the address of the 
new location.

5 	Release the mouse button.

6 	Release .

F 	Excel creates a copy of the range 
in the new location.

TIPS
Can I move or copy a range to another 
worksheet?
Yes. Click and drag the range as described in 
this section. Remember to hold down  if you 
are copying the range. Press and hold  and 
then drag the mouse pointer over the tab of the 
sheet you want to use as the destination. Excel 
displays the worksheet. Release  and then 
drop the range on the worksheet.

Can I move or copy a range to another workbook?
Yes. If you can see the other workbook on‐screen, click 
and drag the range as described in this section, and 
then drop it on the other workbook. Remember to hold 
down  if you are copying the range. Otherwise, 
select the range, click the Home tab, click Cut ( ) to 
move the range or Copy ( ) to copy it, switch to the 
other workbook, select the cell where you want the 
range to appear, click Home, and then click Paste ( ).
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Insert a Row or Column

Insert a Row or Column

You can insert a row or column into your existing worksheet data to accommodate more 
information. The easiest way to add more information to a worksheet is to add it to the right 

or at the bottom of your existing data. However, you will often find that the new information you 
need to add fits naturally within the existing data. In such cases, you first need to insert a new row 
or column in your worksheet at the place where you want the new data to appear, and then add the 
new information in the blank row or column.

Insert a Row
1 	Click any cell in the row below 

where you want to insert the 
new row.

2 	Click the Home tab.

3 	Click the Insert .

4 	Click Insert Sheet Rows.

A 	Excel inserts the new row.

B 	The rows below the new row are 
shifted down.

5 	Click the Insert Options smart 
tag ( ).

6 	Select a formatting option for the 
new row (  changes to ).
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TIP
Can I insert more than one row or column at a time?
Yes. You can insert as many new rows or columns as you need. First, select the same number of rows or 
columns that you want to insert. (See the “Select a Range” section earlier in this chapter to learn how to 
select rows and columns.) For example, if you want to insert four rows, select four existing rows. For rows, 
be sure to select existing rows below where you want the new rows inserted and then follow steps 2 to 4 in 
the “Insert a Row” subsection. For columns, be sure to select existing columns to the right of where you 
want to insert the new columns and then follow steps 2 to 4 in the “Insert a Column” subsection.

Insert a Column
1 	Click any cell in the row to the 

right of where you want to insert 
the new column.

2 	Click the Home tab.

3 	Click the Insert .

4 	Click Insert Sheet Columns.

C 	Excel inserts the new column.

D 	The columns to the right of the 
new column are shifted to the 
right.

5 	Click the Insert Options smart  
tag ( ).

6 	Select a formatting option for the 
new column (  changes to ).
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Insert a Cell or Range

Insert a Cell or Range

If you need to add data to an existing range, you can insert a single cell or a range of cells within 
that range. When you insert a cell or range, Excel shifts the existing data to accommodate the 

new cells.

Although it is often easiest to create room for new data within a range by inserting an entire row 
or column, as explained in the previous section, “Insert a Row or Column,” this causes problems 
for some types of worksheet layouts. (See the first tip to learn more.) You can work around such 
problems by inserting just a cell or range.

1 	Select the cell or range where 
you want the inserted cell or 
range to appear.

2 	Click the Home tab.

3 	Click the Insert .

4 	Click Insert Cells.

Note: You can also press  
 +   +  .
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	 The Insert dialog box appears.

5 	Select the option that 
corresponds to how you want 
Excel to shift the existing cells  
to accommodate your new cells 
(  changes to ).

Note: In most cases, if you selected 
a horizontal range, you should click 
the Shift cells down option; if you 
selected a vertical range, you should 
click the Shift cells right option.

6 	Click OK.

A 	Excel inserts the cell or range.

B 	The existing data is shifted down 
(in this case) or to the right.

7 	Click the Insert Options smart 
tag ( ).

8 	Select a formatting option for the 
new row (  changes to ).

TIPS
Under what circumstances would I insert a cell 
or range instead of inserting an entire row or 
column?
In most cases, it is better to insert a cell or 
range when you have other data either to the left 
or right of the existing range, or above or below 
the range. For example, if you have data to the 
left or right of the existing range, inserting an 
entire row would create a gap in the other data.

How do I know which cells to select to get my 
inserted cell or range in the correct position?
The easiest way to do this is to select the existing cell 
or range that is exactly where you want the new cell 
or range to appear. For example, if you want the new 
range to be A5:B5 as shown in this section’s example, 
you first select the existing A5:B5 range. When you 
insert the new range, Excel shifts the existing cells 
(down in this case) to accommodate it.
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Delete Data from a Range

Delete Data from a Range

If your worksheet has a range that contains data you no longer need, you can delete that data. 
This helps to reduce worksheet clutter and makes your worksheet easier to read.

Note that deleting cell data does not adjust the structure of your worksheet in any way. That is, after 
you delete the cell data, the rest of your worksheet data remains intact and in the same place that it 
was before the data deletion. If you want to delete cells and not just the data within the cells, see 
the following section, “Delete a Range.”

Delete Range Data
1 	Select the range that 

contains the data you want 
to delete.

2 	Click the Home tab.

3 	Click Clear ( ).

4 	Click Clear Contents.

A 	If you want to delete the 
range data and its 
formatting, click Clear All 
instead.
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B 	Excel removes the range data.

Undo Range Data Deletion
1 	Click the Undo .

2 	Click Clear.

Note: If the data deletion was the most recent 
action you performed, you can undo it by pressing 

 +   or by clicking Undo ( ).

C 	Excel restores the data to the range.

TIPS
Are there faster ways to delete the data 
from a range?
Yes. Probably the fastest method is to select 
the range and then press . You can 
also select the range, right‐click any part of 
the range, and then click Clear Contents.

Is it possible to delete a cell’s numeric formatting?
Yes. Select the range with the formatting that you want to 
remove, click Home, click , and then click Clear Formats. 
Excel removes all the formatting from the selected range.  
If you prefer to delete only the numeric formatting, click 
Home, click the Number Format , and then click General.
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Delete a Range

Delete a Range

If your worksheet contains a range that you no longer need, you can delete that range. Note that 
this is not the same as deleting the data within a cell or range, as described in the previous 

section, “Delete Data from a Range.” When you delete a range, Excel deletes not just the data within 
the range, but also the range of cells. Excel then shifts the remaining worksheet data to replace the 
deleted range. Excel displays a dialog box that enables you to choose whether the data is shifted up 
or to the left.

1 	Select the range that you want to 
delete.

2 	Click the Home tab.

3  Click the Delete .

4 	Click Delete Cells.
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	 The Delete dialog box appears.

5 	Select the option that 
corresponds to how you want 
Excel to shift the remaining cells 
after it deletes the range  
(  changes to ).

Note: In most cases, if you have data 
below the selected range, you should 
click the Shift cells up option; if you 
have data to the right of the selected 
range, you should click the Shift 
cells left option.

6 	Click OK.

A 	Excel deletes the range and shifts 
the remaining data.

TIPS
Are there faster ways to delete a range?
Yes. Probably the fastest method is to 
select the range and then press  +  . 
You can also select the range, right‐click 
any part of the range, and then click 
Delete. Both methods display the Delete 
dialog box.

How do I delete a row or column?
To delete a row, select any cell in the row, click the Home 
tab, click the Delete , and then click Delete Sheet Rows. 
To delete a column, select any cell in the column, click the 
Home tab, click the Delete , and then click Delete Sheet 
Columns. Note, too, that you can delete multiple rows or 
columns by selecting at least one cell in each row or column.
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Hide a Row or Column

Hide a Row or Column

If you do not need to see or work with a row or column temporarily, you can make your worksheet 
easier to read and to navigate by hiding the row or column. Hiding a row or column is also useful 

if you are showing someone a worksheet that contains private or sensitive data that you do not want 
the person to see.

Hiding a row or column does not affect other parts of your worksheet. In particular, formulas that 
use or rely on data in the hidden rows and columns still display the same results.

Hide a Row
1 	Click in any cell in the row you 

want to hide.

2 	Click the Home tab.

3 	Click Format.

4 	Click Hide & Unhide.

5 	Click Hide Rows.

Note: You can also hide a row by 
pressing  +  .

A 	Excel removes the row from the 
worksheet display.

B 	Excel displays a double‐line 
border between the surrounding 
row headers to indicate that a 
hidden row lies between them.

	 Another way to hide a row is to 
move the mouse ( ) over the 
bottom edge of the row heading 
(  changes to ), and then 
click and drag the edge up until 
the height displays 0.
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Hide a Column
1 	Click in any cell in the column 

you want to hide.

2 	Click the Home tab.

3 	Click Format.

4 	Click Hide & Unhide.

5 	Click Hide Columns.

Note: You can also hide a column by 
pressing  +  .

TIP
How do I display a hidden row or column?
To display a hidden row, select the row above and the row below the hidden row, click Home, click Format, 
click Hide & Unhide, and then click Unhide Rows. Alternatively, move the mouse ( ) between the 
headings of the selected rows (  changes to ) and then double‐click. To unhide row 1, right‐click the 
top edge of the row 2 header and then click Unhide.

To display a hidden column, select the column to the left and the column to the right of the hidden 
column, click Home, click Format, click Hide & Unhide, and then click Unhide Columns. Alternatively, 
move the  between the headings of the selected columns (  changes to ) and then double‐click. To 
unhide column A, right‐click the left edge of the column B header and then click Unhide.

C 	Excel removes the column from 
the worksheet display.

D 	Excel displays a slightly thicker 
heading border between the 
surrounding columns to indicate 
that a hidden column lies 
between them.

	 Another way to hide a column is 
to move the mouse ( ) over the 
right edge of the column heading 
(  changes to ), and then 
click and drag the edge left until 
the width displays 0.
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Freeze Rows or Columns

Freeze Rows or Columns

You can keep your column labels in view as you scroll the worksheet by freezing the row or rows 
that contain the labels. This makes it easier to review and add data to the worksheet because you 

can always see the column labels.

If your worksheet also includes row labels, you can keep those labels in view as you horizontally 
scroll the worksheet by freezing the column or columns that contain the labels.

Freeze Rows
1 	Scroll the worksheet so that the 

row or rows that you want to 
freeze are visible.

2 	Select the cell in column A that 
is one row below the last row you 
want to freeze.

	 For example, if you want to 
freeze row 1, select cell A2.

3 	Click the View tab.

4 	Click Freeze Panes.

5 	Click Freeze Panes.

	 Excel freezes the rows.
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TIPS
Are there easier methods I can use to freeze just the top row 
or the first column?
Yes. To freeze just the top row, click View, click Freeze Panes, and 
then click Freeze Top Row. To freeze just the first column, click 
View, click Freeze Panes, and then click Freeze First Column. 
Note that in both cases you do not need to select a cell in advance.

How do I unfreeze a row or column?
If you no longer require a row or 
column to be frozen, you can 
unfreeze it by clicking View, clicking 
Freeze Panes, and then clicking 
Unfreeze Panes.

Freeze Columns
1 	Scroll the worksheet so that the 

column or columns that you 
want to freeze are visible.

2 	Select the cell in row 1 that is 
one row to the right of the last 
column you want to freeze.

	 For example, if you want to 
freeze column A, select cell B1.

3 	Click the View tab.

4 	Click Freeze Panes.

5 	Click Freeze Panes.

	 Excel freezes the columns.
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Merge Two or More Cells

Merge Two or More Cells

You can create a single large cell by merging two or more cells. For example, it is common to 
merge several cells in the top row to use as a worksheet title.

Another common reason for merging cells is to create a label that applies to multiple columns of 
data. For example, if you have three columns labeled January, February, and March, you could select 
the three cells in the row above these labels, merge them, and then use the merged cell to add the 
label First Quarter.

1 	Select the cells that you 
want to merge.

2 	Click the Home tab.

3 	Click the Merge & Center .

4 	Click Merge Cells.
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A 	Excel merges the selected cells 
into a single cell.

5 	Type your text in the merged cell.

TIP
How do I center text across multiple columns?
This is a useful technique for your worksheet titles or headings. You can center a title across the entire 
worksheet, or you can center a heading across the columns that it refers to. Follow steps 1 to 3 and then 
click Merge & Center. Excel creates the merged cell and formats the cell with the Center alignment option. 
Any text you enter into the merged cell appears centered within the cell.
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Transpose Rows and Columns

Transpose Rows and Columns

You can use the Transpose command in Excel to easily turn a row of data into a column of data, or 
a column of data into a row of data.

The Transpose command is useful when you enter data into a row (or column) or receive a worksheet 
from another person that has data in a row (or column), and you decide the data would be better 
presented as a column (or row). You can also transpose rows and columns together in a single 
command, which is handy when you need to restructure a worksheet.

1 	Select the range that includes 
the data you want to transpose.

2 	Click the Home tab.

3 	Click Copy ( ).
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TIPS
How do I know which cells to select?
The range you select before copying depends on what 
you want to transpose. If you want to transpose a 
single horizontal or vertical range of cells, then 
select just that range. If you want to transpose a 
horizontal range of cells and a vertical range of cells 
at the same time, select the range that includes all 
the cells, as shown in this section’s example.

Can I transpose range values as well as range 
labels?
Yes. The Transpose command works with text, 
numbers, dates, formulas, and any other data that 
you can add to a cell. So if you have a rectangular 
region of data that includes row labels, column 
labels, and cell values within each row and column, 
you can select the entire range and transpose it.

4 	Click where you want the 
transposed range to appear.

5 	Click the Paste .

6 	Click Transpose ( ).

A 	Excel transposes the data and 
then pastes it to the worksheet.
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Select Data
1 	Tap the first cell you want to 

select.

2 	Tap and hold the lower‐right 
selector, and then slide down 
and/or to the right to extend the 
selection.

3 	Tap and hold the upper‐left 
selector, and then slide up and/
or to the left to extend the 
selection.

Enter and Edit Data
1 	Double‐tap the cell you want to 

use to enter or edit data.

Select and Enter Data Using Touch Gestures

Select and Enter Data Using Touch Gestures

If you will also be working with the Excel app on a touchscreen device, such as an iPad or Surface, 
you need to know how to use touch gestures to select, enter, and edit data. Although you can 

attach external keyboards to these devices, most of the time you might not have access to a physical 
keyboard. In such cases, you need to use touch gestures — tapping, sliding, and so on — to 
manipulate the data that you see on the Excel screen.
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	 The Excel app opens the Formula 
bar for editing and displays the 
on‐screen keyboard.

2 	Using the on‐screen keyboard, 
add or edit the cell data.

Note: To position the cursor within 
the Formula bar, tap and hold inside 
the Formula bar, then slide left or 
right.

A 	Tap Abc or 123 to toggle the 
keyboard between letters and 
numbers.

3 	To confirm the cell entry or edit, 
tap OK ( ).

B 	If you do not want to accept  
the changes to the cell, tap 
Cancel ( ).

TIPS
Is there an easier way to enter a long list of items in a 
column or a row of cells?
Yes. Rather than tapping OK ( ) after each entry, tap 
123 to display the numeric keyboard, and then tap an arrow 
key. The active cell moves in the direction of the arrow or 
to the cell you tapped, and Excel leaves the Formula bar 
open for editing.

Is there an easier way to enter several 
items randomly in a worksheet?
Yes. Instead of tapping OK ( ) after 
each entry, tap the next cell you want to 
use. The active cell moves to the cell you 
tapped, and Excel leaves the Formula bar 
open for editing.


