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Getting Started 
with Power BI
Power BI enables you to create visual analytics from data, allowing you 
to understand even complex data structures and effectively communicate 
insights gained. You need neither special mathematical skills nor 
programming experience to understand and acquire Power BI skills.
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What Is Power BI?

Power BI is a data‐visualization app that enables you to analyze data without technical expertise 
or programming knowledge. BI is a standard abbreviation for business intelligence. Instead of 

needing to type in complex data queries, you can create your queries by clicking and dragging items 
in Power BI’s graphical interface. This ease of use allows you to quickly find insights in your data 
and to share them with others.

You do not have to know from the start what you are looking for or how you want to present the results. 
Rather, Power BI takes you on a journey through your data and helps you discover relationships you did 
not expect to exist through visual analysis. This approach is fundamentally different from other tools, 
whose use requires that you already know at the beginning of your analysis which data you want to 
present in which form.

Power Query, an Essential Part of Power BI
Power BI also offers complex techniques of data cleansing, data modeling, and data preparation with Power 
Query. Power Query is a data transformation and data preparation engine. Power Query has a graphical user 
interface for retrieving data from sources and a Power Query editor for applying transformations. You can 
use Power Query to perform ETL processing on data. Extract, Transform, Load, or ETL, is a process that 
unifies data from multiple, possibly differently structured, data sources.

Power BI’s Vast Variety of Data Sources
Power BI Desktop enables you to connect to a wide variety of data sources. You can use data stored in Excel 
workbooks or in text files in the comma‐separated values format, CSV. You can use data from databases such 
as Access or SQL Server. You can access data in data cubes, which are multidimensional arrays containing 
values. You can also connect to data warehouses, clusters of computers running the Apache Hadoop 
computing framework, or various cloud services such as Google Analytics.

After connecting to the appropriate data source, you interact with the Power BI user interface to query the 
data with a few mouse clicks and display the results in various charts and maps. You can then arrange these 
visualizations into dashboards to put them into meaningful context.

When communicating key insights, you have a variety of options depending on the product you use, from 
sharing interactive dashboards to embedding them in web pages. Power BI facilitates both the presentation 
of insights from data and the communication process, that is, data storytelling and interactive dashboards, 
without requiring any programming skills.

Data Analysis and Excel
Data analysis and visualization have always been an important topic in the professional environment and a 
fundamental tool for business decision‐making. In this environment, Microsoft Excel quickly became popular and 
established itself as one of the most important tools for data analysis. However, with the exponential growth of 
data in the world, often referred to as big data, and the growth of the culture of analytics and data science, 
Excel is reaching its limits and is being replaced by more efficient tools for data analysis such as Power BI.



5

CHAPTER

1Getting Started with Power BI

1.indd  5	 Trim size: 7.375 in × 9.25 in� March 21, 2023 2:16 PM

Power BI, the Big Leap from Excel
Year after year, companies are focusing more on data and how to get value from it in order to sell more products, 
attract more customers, and increase the efficiency of the process. In this scenario, a tool that handles a large 
amount of data and is able to analyze data quickly and easily to present information clearly to businesses 
becomes essential. To address this need, Microsoft has developed Power BI, a visualization tool that is capable 
of handling large and complex amounts of data while changing the way you deal with charts or visualizing data.

Excel has excellent features and allows the user to work easily and effectively to analyze data. Excel is the 
most widespread spreadsheet tool, where it can indisputably show its full power. With the introduction of 
Pivot Tables in Excel in 1994 and Power Query functions in Excel 2010, Excel gained functions for editing 
and analyzing data in tables up to 1 million rows. Nevertheless, Excel’s strength remains the calculation of 
complex formulas more than the processing of large amounts of data. Excel also brings good functionalities 
for analysis and good graphical visualizations. Ultimately, even with smaller data sets, Power BI offers better 
performance, more comprehensive analytics and visualizations, and the ability to share dashboards or apps 
across the enterprise for a “one‐stop solution.” In these cases, Power BI proves to be extremely useful with 
advantages over Excel, making data analysis more agile and efficient.

With a wide range of graphics and widgets, a good ability to handle big data, integration with different 
platforms and ease of use, and centralization of different data sources, Power BI is proving to be 
increasingly popular, both among experienced Excel users and beginners new to the world of data.

How This Book Guides You into Power BI
This book is designed to provide you with a step‐by‐step introduction to creating visual analytics, enabling 
you to understand even complex data structures and effectively communicate insights gained. Therefore, 
this book is of interest to a variety of audiences, such as people who have access to and want to understand 
data, executives who make decisions based on data, analysts and developers who create visualizations and 
dashboards, and aspiring data scientists.

You need neither special mathematical skills nor programming experience to understand this book and develop 
skill in using Power BI effectively. The book is suitable for beginners and for users who want to approach the 
topic of data visualization and analysis in a practical way, without extensive theoretical treatises.
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Microsoft groups various software products and services for data analysis under the umbrella name 
Power BI. For this book’s purposes, the three key Power BI components are Power BI Desktop, 

the Power BI cloud service, and the Power BI Report Server.

Power BI Desktop is a desktop application that you use to create analyses and reports from data 
sources. You can then make these analyses and reports available to consumers via either the Power 
BI cloud service or the Power BI Report Server — or indeed both. This section explains how the 
different Power BI components and licensing models interact with reports.

Understanding the Different Components of  
Power BI

Power BI Desktop
Power BI Desktop is a free application for Windows 
that is popular among analysts and business users. 
On the one hand, Power BI Desktop allows you to 
connect to local files, such as Excel and CSV, and 
save report files locally. On the other hand, Power 
BI Desktop allows you to connect to many external 
data sources and store them on your own report 
server or the Power BI cloud service. The focus of 
this book is Power BI Desktop, which allows you to 
quickly create advanced analytics and reports and 
gain data‐driven insights.

Power BI Pro
Power BI Pro is a user‐based license for the Power 
BI service that lets you share reports and analytics 
with other users. You can use collaborative 
functions and integrate a role and rights concept. 
You can also embed published reports in other 
applications such as Microsoft SharePoint, Microsoft 
Teams, or other Microsoft Power Platform 
applications. At the time of this writing, the Pro 
license cost $9.99 per user per month; see powerbi. 
microsoft.com/en‐us/pricing for current pricing. 
Power BI Pro is already included in the Microsoft 
365 Enterprise E5 subscription plan.

Power BI Premium
Power BI is a platform for data analysis and is used by 
small companies as well as large, publicly traded 
corporations. Power BI Premium is used to provide 

Power BI Embedded
With Power BI Embedded, you can integrate 
reports and analyses on your website and make 
them available to your customers without them 
having to log in to the Power BI service. Power BI 
Embedded uses a different licensing model: Your 
company pays for Power BI capacity that you make 
available for your customers to use, rather than 
customers needing to have their own Power BI 
accounts.

Power BI Report Server
The Power BI Report Server is a server platform on 
which you can publish and view reports in the 
same way as Power BI Premium. However, this is 
not a cloud platform but a so‐called “on‐premise” 
solution that you can integrate into your own 
network.

Power BI Mobile
Power BI Mobile is an application for iOS and 
Android smartphones and tablets and Windows 
devices that lets you access your data and the 
Power BI service on the go.

company‐wide visualizations and dashboards, which 
can also be operated in the web browser and can also 
be embedded in the company intranet. As of this 
writing, Microsoft offers a free 30‐day trial for Power 
BI Premium; go to powerbi.microsoft.com/en‐us/
power‐bi‐premium and click Try Power BI for free.
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Power BI is part of Microsoft’s Power Platform, a set of tools for creating data‐driven solutions to 
business needs. In addition to Power BI, Power Platform includes the Power Apps development 

environment, the Power Automate framework, the Power Virtual Agents tool for creating chatbots, 
and the Power Pages tool for building business‐oriented websites quickly.

Understanding Power BI as Part  
of the Power Platform

Power Apps
Power Apps is a development environment with little or no code, where you can develop your own applications 
to solve various business challenges. For example, you could develop a Power App that accesses a SharePoint 
list for data display and data entry. You could then deploy that app to your organization’s iPhones, iPads, and 
Android devices.

Power Automate
Power Automate is a framework that allows end users to create “flows” that automate organizational 
processes. For example, you might develop a flow that automatically sends an email notification to 
supervisors when an employee submits a particular electronic form.

Power Virtual Agents
Power Virtual Agents is a no‐code tool that lets you create chatbots to communicate with customers and 
employees.

Using the Power Platform
Each of these components — Power Apps, Power Automate, and Power Virtual Agents — can be used by 
Power BI to provide insights that drive your work forward. What follows are some examples of how each 
component might work with Power BI.

For example, in Power Apps, you could set up an application that allows an inspector to take notes in the 
field and upload that data to a SQL Server database. A Power BI report could also connect to that SQL Server 
database, retrieve the information uploaded by the Power App, and update the report based on the new data 
added by the multiple inspectors in the field using the Power App.

As another example, consider virtual agents, which are software programs that provide customer service to 
humans and mimic a customer service representative. With virtual agents, large amounts of data are collected 
as end users interact with your chatbots. All of this data is collected and stored, which means Power BI can 
generate reports on it. This creates an end‐to‐end reporting solution that allows your business to get textual 
insights into what your customers really want from your business.
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Install Power BI Desktop

You can install Power BI Desktop in only a few minutes and begin creating visual data analytics. 
Before you start installing Power BI Desktop, make sure that your computer meets the necessary 

system requirements; see the tip for details.

The requirements of Power BI Desktop on your system are comparable to other Microsoft Office 
applications. However, how much data you connect and how many visualizations you display at the 
same time also play a major role. For complex analyses and large amounts of data, you will get a 
more comfortable experience with a powerful processor and more memory.

Install Power BI Desktop

	A	 If Microsoft Store ( ) appears on the 
taskbar, click Microsoft Store ( ) and 
go to step 4.

1	 In Windows, click Start ( ).

The Start menu opens.

2	 Type store.

The search results appear.

3	 Click Microsoft Store ( ).

The Microsoft Store app opens.

4	 Click Search ( ).

The Search field becomes active.

5	 Type power bi desktop.

The search results appear.

6	 Click Power BI Desktop ( ).
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When the download and installation is 
complete, the Open button appears.

	C	 You can click Open to open Power BI 
Desktop directly from the Microsoft 
Store app.

8	 Click Close ( ).

The Microsoft Store app closes.

	B	 Power BI Desktop begins downloading 
and installing on your computer.

The product page for Power BI Desktop 
appears.

Note: To determine whether Power BI Desktop 
will run on your computer, scroll down to the 
System Requirements section on the product 
page and look for the message This product 
should work on your device. See the tip for 
more information on system requirements.

7	 Click Get.

TIP
What are the system requirements for Power BI Desktop?
To run Power BI Desktop, you need a PC running Windows 10 version 14393.0 or later, such as Windows 11, 
with at least 2 GB of disk space free. Microsoft recommends a Windows 10 PC with a minimum of 2 GB of 
RAM, but for reasonable performance, 4 GB is a realistic minimum, and 8 GB or more will give better 
performance. Windows 11 requires at least 4 GB of RAM; for good performance, treat 8 GB as a realistic 
minimum, and get 16 GB or more if possible.
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2	 Start typing power bi desktop.

The Start menu displays search results 
as you type.

3	 Click Power BI Desktop ( ).

After you have successfully installed Power BI Desktop, as described in the previous section, you 
can launch the app from the Windows Start menu. If you want to launch Power BI Desktop more 

quickly in the future, you can pin Power BI Desktop to your Start menu, making it always appear 
there. For even faster launching without opening the Start menu, you can pin Power BI Desktop to 
the taskbar.

This section shows Windows 11. If your computer has Windows 10, the Start menu is located in the 
lower‐left corner of the screen by default.

Start and Pin Power BI Desktop

Start Power BI Desktop
1	 Click Start ( ).

The Start menu opens.

	A	 If Power BI Desktop ( ) appears in the 
Recommended section, click Power BI 
Desktop ( ) and go to step 4.

Start and Pin Power BI Desktop
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Pin Power BI Desktop
1	 Click Start ( ).

The Start menu opens.

2	 Right‐click Power BI Desktop ( ).

3	 To pin Power BI Desktop to the Start menu, 
click Pin to Start ( ).

4	 To pin Power BI Desktop to the taskbar, 
click Pin to taskbar ( ).

After pinning the Power BI Desktop icon to 
the Start menu or the taskbar, you can start 
Power BI Desktop quickly by clicking the 
icon on the Start menu or the taskbar.

Power BI Desktop opens.

	B	 The Power BI Desktop splash screen 
appears.

	C	 The right pane contains links you can 
click to display various types of 
information about Power BI.

4	 Click Get Started.

The splash screen closes.

You can now start using Power BI 
Desktop.

TIP
Is Power BI available for the Mac or Linux?
As of this writing, Power BI Desktop is available only for Windows, so Mac users and Linux users cannot 
install and use Power BI Desktop natively. On either macOS or Linux, you can install virtual‐machine 
software, such as Parallels Desktop for macOS, from www.parallels.com, or the free VirtualBox for either 
macOS or Linux, from www.virtualbox.org. Install Windows on the virtual machine, and then install Power BI 
Desktop. Another approach is to use a cloud PC, such as Microsoft’s Windows 365 Cloud PC service, which you 
can access from macOS, Linux, Windows, iOS and iPadOS, Android, and most other current operating systems.



12

1.indd  12	 Trim size: 7.375 in × 9.25 in� March 21, 2023 2:16 PM

Like many of Microsoft’s professional apps, Power BI Desktop has a ribbon‐driven interface rather 
than menus. If you are familiar with Microsoft apps such as Word or Excel, the Power BI Desktop 

ribbon will look familiar; if not, you can quickly master how to use it.

Below the ribbon is the Canvas, the area on which you create visualizations. To the left of the Canvas 
is the View bar; to the right of the Canvas are the Filters pane, the Visualizations pane, and the 
Fields pane, which you can collapse and expand as needed. At the bottom of the Power BI Desktop 
window is the status bar.

Explore the Power BI Workspace

A	 �Quick Access 
Toolbar
The Quick Access 
toolbar provides easy 
access to the Save, 
Undo, and Redo 
commands.

B	 Ribbon
The ribbon is the 
primary interface 
element for giving 
commands. The 
ribbon contains six 
fixed tabs: File, 
Home, Insert, 
Modeling, View, and 
Help. Other tabs, 
such as the Format 
tab and the Data/
Drill tab, are context 
sensitive and appear 
only when you have selected an object with which such a tab is associated.
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C	 View Bar
The View bar, on the left side of the Power BI Desktop window, enables you to switch between three 
views: Report, Data, and Model. By default, Report view is selected.

D	 Canvas
The Canvas is the area on which you create and manipulate your visualizations.

E	 Filters Pane
In the Filters pane, you can filter data fields to limit the analysis to the relevant data range. You can 
control whether the filtering applies to a single visualization, a single page, or all pages of your file. 
You can expand the Filters pane, the Visualizations pane, and the Fields pane by clicking Expand ( ), 
and you can collapse them by clicking Collapse ( ).

F	 Visualizations Pane
In the Visualizations pane, you can create a new data visualization, change the chart type of an existing 
visualization, and adjust the formatting. A series of icons shows you the available visualization types 
and helps to quickly select the desired chart. Here, also depending on the selected visualization, you can 
assign data fields or calculation results to the visualizations and add visual features such as tool tips, 
drill‐through references, and additional analyses. You can also load various other powerful visualizations 
from the Microsoft Store.

G	 Fields Pane
The Fields pane gives you an overview of which data fields and calculations are available in your source. 
A sum sign, Σ, in front of a field name indicates a field that Power BI has evaluated as being suitable for 
summation or aggregation.

H	 Tab Bar
The tab bar below the Canvas enables you to create new pages and navigate from one to another. Click 
Add ( ) to add a page. Click a page’s tab to display that page. When there are more pages than can 
appear on the tab bar, click Go to Start ( ) or Go to End ( ) to scroll the displayed tabs left or right.

I	 Status Bar
The status bar, at the bottom of the Power BI Desktop window, displays current information, such as  
the page number and the number of pages, and contains the zoom slider, the Zoom Menu button 
(such as  ), and the Fit to Page button ( ).
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The Power BI Desktop ribbon contains six fixed tabs: File, Home, Insert, Modeling, View, and Help, 
looking from left to right. This section gives you an overview of these six tabs.

Power BI Desktop also has context‐sensitive tabs, which appear when you have selected an object for 
which the tabs are relevant. For example, when you select a visual, the Format tab appears, giving 
you access to controls for configuring interactions with the visual and arranging it on the canvas.

Explore the Power BI Workspace (continued)

The Files Tab and Backstage View
Clicking the File tab at the left end of the ribbon opens Backstage 
view, which gives you access to commands for creating, saving, and 
managing documents. For example, you can click New (A) to open a 
new Power BI Desktop window, click Save (B) to save the active 
report, click Get Data (C) to display the Get Data commands, or 
click Options and settings (D) to configure Power BI Desktop.

The Home Tab
The Home tab contains 
seven groups of controls. 
The Clipboard group 
enables you to use the Cut, Copy, Paste, and Format Painter commands. The Data group allows you to create 
connections to data sources. The Queries group lets you transform data and refresh your existing queries. 
From the Insert group, you can insert visuals and text boxes. The Calculations group enables you to create 
new measures, or calculations. The Sensitivity group allows you to apply sensitivity labels to reports. The 
Share group lets you upload the report to the Power BI service.
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The Insert Tab
The Insert tab contains six 
groups. The Pages group 
enables you to add new 
pages to the report. The Visuals group provides controls for adding visuals to the report. The AI Visuals group lets 
you add elements such as a Q&A section and a decomposition tree. The Power Platform group helps you add 
Power Apps to the report; see the section “Understanding Power BI as Part of the Power Platform,” earlier in this 
chapter, for more about Power Apps. The Elements group lets you insert text boxes, buttons, shapes, and images. 
The Sparklines group allows you to add sparklines, miniature charts that illustrate a single data series.

The Modeling Tab
The Modeling tab 
contains six groups. The 
Relationship group 
contains the Manage 
Relationships button, which you click to open the Manage Relationships dialog box, where you configure 
the relationships between different tables you are using. The Calculations group enables you to create new 
measures, columns, and tables. The Page Refresh group allows you to configure the frequency at which 
Power BI Desktop checks your data sources for changes. The What If group lets you add new parameters to 
your report. The Security group provides controls for managing security roles for other users and for viewing 
your report from another user’s point of view. The Q&A group enables you to configure a Q&A section, set its 
language, and import and export linguistic schemas.

The View Tab
The View tab contains 
five groups. From the 
Themes group, you can 
apply a preset visual theme to the report. The Scale to Fit group lets you choose whether to view the report 
at its actual size, fit it to a page, or fit it to the window width. The Page Options group enables you to add 
gridlines, control whether objects snap to the grid, and lock objects to prevent movement. The Show Panes 
group allows you to control which panes appear in the report window.

The Help Tab
The Help tab contains 
four groups. The Info 
group contains only the 
About button, which you 
can click to display information about Power BI Desktop and your current session. The Help group gives you 
access to specific help resources. The Community group provides links to community support and external 
tools. The Resources group lets you access examples and Power BI consulting services.


