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Chapter 01
Getting Started

Autodesk® Inventor® has a context-sensitive user interface that provides you with the tools 
relevant to the tasks being performed. A comprehensive online help and tutorial system 
provides you with information to help you learn the application. This chapter introduces the 
tools and interface options that you use on a constant basis.

This chapter also introduces fundamental of parametric part design concepts that enable you 
to capture design intent and build intelligence into your designs.

Objectives

After completing this chapter, you will be able to:

• Identify the main user interface components that are common to all Autodesk 
Inventor design environments and describe how to access different tools.

• View all aspects of your design by efficiently navigating around in  
2D and 3D space.

• Describe the characteristics and benefits of a parametric part model.
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Lesson 01 | Autodesk Inventor User Interface

This lesson describes the application interface. You are introduced to the different file types  
(part, assembly, presentation, and drawing) you work with as you create and document your 
designs, and you examine the common user interface elements and view management tools in 
these environments.

As with all computer applications, the User Interface (UI) is what you use to interact with the 
program. While the Autodesk Inventor UI shares many common themes and elements with other 
Microsoft Windows applications, it also has some unique elements and functionalities that may be 
new to you, even as an experienced CAD user.

In the following illustration, the Autodesk Inventor User Interface is shown.

Objectives

After completing this lesson, you will be able to:

• Describe the multiple environments within Autodesk Inventor.

• Describe what project files are used for.

• Describe the types of files Autodesk Inventor creates and the kinds of information they store.

• Identify the major components of the Autodesk Inventor user interface.

• Identify the browser and panel bar in the assembly, part, presentation, and 
drawing environments.

• Identify and access various types of online help and tutorial resources.
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Assembly files: IAM files reference part files and are referenced by drawing files.

Part files: IPT files are referenced by assembly files and drawing files.

Drawing files: DWG files reference assembly files and part files.

Inventor Drawing files: IDW files are interchangeable with DWG files in Inventor and 
reference assembly and part files.

Using Template Files

Template files serve as the basis for all new files that you create. When you begin a file from a 
template file, you can control default settings such as units, snap spacing, and default tolerances  
in the new file.

The application offers template files for each type of file. Template files are categorized into two 
main groups: English for English units (inches and feet), and Metric for metric units (millimeters 
and meters).

About Multiple Environments

In order to provide the greatest design flexibility and reuse, each part, assembly, and drawing is 
stored in a separate file. Each part file is a stand-alone entity that can be used in different assembly 
files and drawing files. When you make a change to a part, the change is evident in each assembly 
or drawing that references that part. Assembly files can be referenced by other assembly files, 
presentation files, and drawing files. IDW and DWG files are now interchangeable. Depending 
on your workflow and need for use in downstream applications, you can create your production 
drawings with either file format.

The basic file references that exist in a typical 3D design are represented in the  
following illustration.
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The New File dialog box has three tabs: Default, English, and Metric. The Default tab presents 
templates based on the default unit that you select during installation, while the English and 
Metric tabs present template files in their respective units.

Part Modeling Environment

In the part modeling environment:

• You create and edit 3D part models.

• The interface adjusts automatically to present tools for your current task, for example, tools for 
sketching or tools to create 3D features.

The following illustration shows the user interface in the part modeling environment.
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Assembly Modeling Environment

In the assembly modeling environment:

• You build and edit 3D assembly models. The components displayed in the system are references 
to external parts and subassemblies.

• You use assembly specific tools to position and build relationships between components.

• A common set of viewing tools is available.

The following illustration shows the user interface in the assembly modeling environment.

Presentation Environment

In the presentation environment:

• You create exploded assembly views.

• You can record an animation of an exploded view to help document your assembly.

• The presentation file references an existing assembly.

• A common set of viewing tools is available.
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The following illustration shows the user interface in the presentation environment.

Drawing Environment

In the drawing environment:

• You create 2D drawings of parts and assemblies.

• A drawing file references one or more parts, assemblies, or presentation files. Changes to the 
part or assembly model update the associated drawing views and annotations.

The following illustration shows the user interface in the drawing environment.
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About Project Files

As you create designs in Autodesk Inventor, file dependencies are created between files of 
different types. For example, when you create a 3D assembly, a file dependency between the 
assembly and its part models is created. As your designs grow in complexity, these dependencies 
can become more complicated. Autodesk Inventor utilizes project files to locate the required files 
as they are needed. As a result of using the information contained in the project file, when you 
open that 3D assembly, Autodesk Inventor can locate the 3D part files and display them properly.

In the context of an introduction to the Autodesk Inventor user interface, all that is important to 
realize is that you must have an active project before you create any files. This is why the project 
file is listed in the New File dialog box. Autodesk Inventor installs several sample project files, but 
the default project is initially active.
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Inventor File Types

To maximize performance, Autodesk Inventor uses different file types for each type of file. 
Assembly files are stored in a different type of file than the parts that are used to create them. 2D 
drawing information can be stored in either the IDW file type that is unique to Autodesk Inventor, 
or the DWG format that is native to AutoCAD® and is an accepted industry standard.

In the following illustration, the New File dialog box illustrates the different types of files that you 
can create with Autodesk Inventor.

Part Files

Part files (*.ipt) represent the foundation of all designs using Autodesk Inventor. You use 
the part file to describe the individual parts that make up an assembly.
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Assembly Files

Assembly (*.iam) files consist of multiple part files assembled in a single file to represent 
your assembly. You use assembly constraints to constrain all the parts to each other. The 
assembly file contains references to all of its component files.

Presentation Files

You use presentation files (*.ipn) to create exploded views of the assembly. It is also 
possible to animate the exploded views to simulate how the assembly should be put 
together or taken apart.
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Drawing Files

You use drawing files (*.idw) to create the necessary 2D documentation of your design. 
Drawing files include dimensions, annotations, and views required for manufacturing.  
When you use a drawing file to create 2D views of an existing 3D model, the views are 
associative to the 3D model, and changes in model geometry are reflected in the drawing 
automatically. You can also use drawing files to create simple 2D drawings in much the 
same way that you use other 2D drawing programs.

Inventor drawing files can also be stored in the standard DWG format. If you use this 
format for your 2D drawings, they can be opened and saved in AutoCAD. This is a very 
useful option for users who must share their design data with others who use AutoCAD.
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Navigation Bar

Browser

3D Indicator

Graphics Window

Application Menu

Quick Access Toolbar

Ribbon

Ribbon Tabs

ViewCube

User Interface

All environments share a common layout for tabs on a single toolbar across the top of the 
application window called the ribbon. The ribbon contains tools and commands for specific tasks 
on separate tabs. Each environment, assembly, part, or drawing for example, displays tabs and 
tools specific to that environment. As you change tasks within a single environment, the ribbon 
adjusts to present the appropriate tabs and tools.

The following illustration shows the major components of the Autodesk Inventor user interface. 
The ribbon and tabs are displayed at the top of the application window.
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Interface Structure

Autodesk Inventor uses a standard structure common in all Microsoft Windows applications. The 
structure is context-sensitive based on the environment and mode you are using.

As you are learning the application more thoroughly, you should take the time to familiarize 
yourself with the different options that are displayed on the ribbon in different work environments.

The following illustration shows the Assemble tab in the assembly modeling environment.

The following illustration shows the Model tab in the part modeling environment.

The following illustration shows the Place Views tab in the drawing environment.
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Quick Access Toolbar

By default, a single Inventor standard toolbar is displayed in all environments and is called the 
Quick Access toolbar. When you change between environments, the Quick Access toolbar updates 
to present valid tools for the environment. The toolbar contains tools for file handling, settings, 
view manipulation, and model or document appearance.

A section of the Quick Access toolbar is displayed in the following illustration. It is organized  
into groups based on functionality. This area of the toolbar displays tools for standard file and 
modeling operations.

Selection filters

Color List

Design Doctor

Standard file management tools

Undo and Redo

Environment navigation

Update document
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Context-Sensitive Tools

As you switch between environments or between tasks in a single environment, Autodesk  
Inventor displays the appropriate tools and information for the current task. The ribbon 
automatically presents tabs and tools for the current task. The browser displays information  
on the active environment.

The ribbon is your primary interface for accessing the tools available while you design. The 
context-sensitive design presents the relevant tools based on the current context of your 
design session. For example, when you switch from assembly modeling to part modeling, the 
ribbon switches automatically to display the correct tabs and tools for the context where  
you work.

The browser is one of the main interface components. It is context-sensitive with the 
environment you use. For example, when you work on an assembly you use the browser to 
present information specific to the assembly environment. While you use the part modeling 
environment, the browser displays information that is relevant to part modeling.

Model Tab

When you are in the part modeling environment, the Model tab is displayed while you create and 
edit part models. You use these tools to create parametric features on the part.
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Sketch Tab

You use the Sketch tab in the modeling environment to create 2D parametric sketches, dimensions, 
and constraints. You use the same set of tools on the Assemble tab when creating a sketch in the 
assembly environment.

Part Modeling Browser

The browser displays all features you use to create the part. The features are listed in the order 
in which they are created. The browser also displays the Origin folder at the top of the list which 
contains the default X, Y, and Z planes, axes, and center point.
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Assembly Modeling Environment

When you are in the assembly modeling environment, the browser displays all the parts you use 
in the assembly. It also lists the Origin folder containing the default X, Y, and Z planes, axes, and 
center point of the assembly.

If applied, nested under each part, you see the assembly constraints. If you select an assembly 
constraint, an edit box is displayed at the bottom of the browser, enabling you to edit the offset or 
angle value for the constraint.

Tip  In the assembly environment, you can use the Modeling View option in the Assembly 
View drop-down list to display the part features nested under the parts instead of the 
assembly constraints. This is useful when performing part modeling functions in the 
context of the assembly.
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Tip  You can also choose to display tool icons without text by right-clicking anywhere on 
the ribbon and then clicking Ribbon Appearance → Text Off.

Design Accelerator

Clicking on the ribbon, Design tab displays the Design Accelerator tools.

In the following illustration, the Assemble tab is shown in the default Normal mode. In Normal 
mode, the tool icons and names are displayed.

Presentation Tab

When you are in the presentation environment, you use the Presentation tab to create 
presentation views and tweaks, and to animate geometry in the presentation environment.
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Presentation Browser

The browser displays the presentation views you create followed by the tweaks you use for the 
explosion. When you expand each tweak, you see the parts included in that tweak. You can also 
switch the browser mode from Tweak View to Sequence View or Assembly View.

Drawing Environment

In the drawing environment, the browser displays the Drawing Resources folder containing sheet 
formats, borders, title blocks, and sketched symbols. It also displays each sheet in the drawing 
along with the views you create for each.
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You use the Place Views tab in the drawing environment to create drawing views on the sheet.

Keyboard Shortcuts

You can use keyboard shortcuts to access and begin tools and commands. For example, you can 
enter P for Place Component, or N for Create Component. Entering the keyboard shortcut is the 
same as clicking the tool on the tabs. When you hover the mouse over a tool on the ribbon, the 
tooltip will expand to reveal information about the tool. The keyboard shortcut (1) will be listed as 
shown in the following illustration.

You use the Annotate tab in the drawing environment to add reference dimensions and other 
annotation objects.

Note:  Access Shortcut Keys List You can access a complete list of the default shortcut 
keys from the Help menu. In the Info Center, click the arrow next to the Help icon > 
Shortcut/Alias Quick Reference.
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Condensed Ribbon

As you become more familiar with the tools in each environment, you can condense the ribbon by 
choosing to display tool icons without text. To switch, right-click anywhere on the ribbon and click 
Ribbon Appearance > Text Off. Clear the check mark to display icon text. In this mode, tools are 
displayed with icons only resulting in more area for the browser and graphics windows.

Alternative Ribbon and Browser Positions

In addition to the default positions, you can alter the location of the ribbon or browser by clicking 
and dragging the horizontal bars near the top of the element, or the title area when the element is 
floating. Both the ribbon and browser can be placed in a docked position on the left or right side of 
the screen, or in a floating position anywhere in the graphics window.
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Online Help and Tutorials

Autodesk Inventor offers several types of online help, tutorial references, and other resources to 
assist in building your skill level. Standard Help files, context-sensitive how-to presentations, Show 
Me animations, and tutorials are available.

Setting Your User Type

The initial Help screen enables you to specify the user type that most closely matches your 
situation. The topics that are most relevant to the user type that you select are presented first 
on the initial help screen. By default, the option to Show Help on startup is enabled. This causes 
the Inventor Help system to launch each time you start Inventor and create a new file or open an 
existing file.

To access the Inventor Help System, press F1 or click Help menu > Help Topics.
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Help for AutoCAD Users

AutoCAD users can use the Help topics designed specifically for them as they make the transition 
to Autodesk Inventor.

Shortcut/Alias Quick Reference

The Shortcut/Alias Quick Reference shows all of the default Shortcut/Alias keys along with the 
command names they execute.

Click Help menu > Shortcut/Alias Quick Reference to access the reference.

Help for Returning and New Users

Returning and new users can find links to Help information that is most relevant for them.
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Show Me Animations

The Show Me animations present topic-specific information in animated presentations.

To access the Show Me animations, on the Info Center, click Help > Help Topics and select the 
Show Me Animations link. In the Show Me Animations dialog box, navigate to the topic of choice 
and the animation begins automatically.

Tutorials

There are several tutorials available that cover a range of topics from Level 1 to Level 3. Click the 
tabs along the top of the page to view the tutorials for each level. On each tab, panels display 
tutorial titles and descriptions. From the main list of tutorials, select the topic of interest. The 
tutorials present step- by-step information on performing tasks in Autodesk Inventor.

You access these tutorials by clicking Help menu > Learning Tools > Tutorials, or by clicking  
Try It Tutorials on the main Help screen.
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In the following illustration, the Introduction to the Ribbon Interface page of the Autodesk 
Inventor tutorial is displayed.



25Exercise | Explore the Autodesk Inventor User Interface

Exercise | Explore the Autodesk Inventor User Interface

In this exercise, you explore the Autodesk Inventor user interface for assembly, part modeling, and 
drawing environments.

The completed exercise

Completing the Exercise:  To complete the exercise, follow the steps in this book or 
in the onscreen exercise. In the onscreen list of chapters 
and exercises, click Chapter 1: Getting Started. Click 
Exercise: Explore the Autodesk Inventor User Interface.
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Exercise Setup

Before you can complete the exercises for the Learning Autodesk Inventor 2010 course, you must 
activate the Learning Autodesk Inventor 2010 project file.

1 Start Autodesk Inventor. If Autodesk Inventor is already running, close all files.

2 Click Get Started tab > Launch panel > Projects.

• If Learning Autodesk Inventor 2010 is displayed in the project list, double-click to 
make it active. A check mark appears next to the active project.

• If Learning Autodesk Inventor 2010 is not in the list, click Browse.
• Navigate to the installation folder of your student dataset files. By default, this 

location is C:\Autodesk Learning\Inventor2010\Learning.
• Double-click Learning Autodesk Inventor 2010.ipj. A check mark appears next to the 

active project.
• Click Done.

3 End of exercise setup. Continue to the exercise.

Explore the Autodesk Inventor User Interface

1 Open Mating Press View.iam.

2 Because this is an assembly file, notice the specific assembly modeling tools on the ribbon. In 
the browser, notice the appearance of both assembly files (1) and part files (2). When assembly 
files are referenced in other assemblies, they are commonly referred to as subassemblies.
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4 To activate a part in the context of the assembly:

• In the browser, collapse the Base_Plate:1 subassembly node.
• Double-click the Top_Component:1 part instance.
• Notice the change in appearance in the browser, graphics window, and ribbon. In 

the browser, the area listing inactive components and subassemblies has a gray 
background. The ribbon changes to display tools specific to part modeling, and in the 
graphics window, all inactive components become transparent leaving only the active 
part opaque in color.

5 To return to the assembly, on the ribbon, click Return.  
Note: You could also double-click the assembly in the browser to return. 

3 In the browser, expand the Base_Plate:1 subassembly to view its referenced parts (1) and 
assembly constraints (2).
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6 To open a part in its own window:

• In the browser, right-click the Top_Component:1 part. Click Open. The part opens in a 
separate window and any changes made to the part are reflected in the assembly.

• Notice how the part color is different than it appears in the assembly. This occurs 
because a part can be assigned a different color style in the context of the assembly.

7 To activate the sketch environment:

• In the browser, expand the Extrusion1 part feature.
• Double-click Sketch1.

The browser background color changes to indicate the active sketch, the part features are 
rolled-back, and the graphics window displays the sketch geometry.

8 To exit the sketch, on the ribbon, click Finish Sketch

9 Close the part file and return to the assembly. If you are prompted to save changes, click No.

10 To open an Inventor drawing file:

• On the Quick Access toolbar, click Open.
• In the Open dialog box, select m_Mating-Press-Drawing.idw and click Open.
• The ribbon updates to show drawing related tasks and tools.
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11 In the browser, expand the Drawing Resources node and View1: Mating Press View.iam node 
to reveal the nested resources, views, and assembly references.

12 To explore the Help System resources:

• Press F1.
• If you are an experienced AutoCAD user, click the option for Users Transitioning from 

AutoCAD and explore the Help resources that are tailored for these users.
• If you are new to Inventor and do not have AutoCAD experience, click the option for 

Returning / New Inventor Users and explore the Help resources that are tailored for  
these users.

13 Close the Help windows.

14 Close all files. Do not save.
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Lesson 02 | View Manipulation

This lesson describes the use of the various view manipulation tools in the modeling and 
drawing environments.

You view all aspects of your 3D geometry by navigating around in 3D space. The view manipulation 
tools enable you to quickly perform these tasks in a manner that is intuitive and efficient.

In the following illustration, a constrained orbit is used to rotate the assembly and change the view 
orientation. The ViewCube, in the upper right corner of the graphics window, is shown with the 
compass displayed. The ViewCube rotates with the model and aids in the orientation of the model.

Objectives

After completing this lesson, you will be able to:

• Identify the tools that are available in the graphics window.

• Explain the behavior of the Free Orbit and Constrained Orbit tools.

• Explain the ViewCube options and how to access them.

• Describe how the ViewCube can be used to view part and assembly models and how to 
customize its appearance and behavior options.

• Explain the steps to define and restore the home view.

• Describe how to use various tools to restore previous views.
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About the Graphics Window

Your 3D part and assembly models, presentations, and drawings are displayed in the graphics 
window. Many tools are available to manipulate the view and appearance of your model in the 
graphics window.

Viewing Tools

View manipulation is a key 2D drawing and 3D modeling skill. You are often required to view 
different areas of a design, and changing your view can help you visualize solutions for the current 
task. Many of the view manipulation tools are common to all environments.



32 Chapter 01 | Getting Started   

The following illustration shows the view manipulation tools that are available on the  
Navigation bar.

Navigation Bar Orbit OptionsZoom Options

ViewCube

SteeringWheel

Pan

View Face

Zoom All

Free Orbit
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Icon View Tool Description

ViewCube In the 3D environment the ViewCube tool displays as a 
default in the graphics window, enabling you to reorient 
your view of the model. In the 2D environment the 
ViewCube enables the definition of view orientations 
for a drawing view.

Free Orbit Enables you to freely rotate the view of your model  
on screen.

Constrained 
Orbit

Constrained Orbit enables you to rotate around the 
vertical axis of a model in a manner similar to the 
rotation of a turntable.

SteeringWheel The SteeringWheel tool is designed to be a common 
tool for multiple Autodesk products. The SteeringWheel 
tool was implemented to provide many different levels 
and types of control over model and  
drawing navigation.

You have different view manipulation tools available to you depending on how you want to change 
where you are viewing and to what magnification. To efficiently change your view to see exactly 
what you want or need to see, you need to know what view manipulation tools are available to you 
and how to use them.

Tip:  You can use the mouse to accomplish most pan and zoom tasks.

• Roll the mouse wheel to zoom at the cursor location. 
• Click and drag the mouse wheel to pan. 
• SHIFT+click and drag the mouse wheel to free orbit. 
• Double-click the mouse wheel to zoom all.
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Toggle the section views which graphically slice portions of an assembly so that you can 
visualize other features.

Toggle between Orthographic and Perspective display modes.

Toggle between Shaded, Shaded with Hidden Edge and Wireframe displays.

Toggle between No Shadow, Ground Shadow, and X-Ray Shadow display modes.

In an assembly file, toggle between Transparency On and Transparency Off display modes.

Select a color/material to assign to a component.

Display Modes

This area of the toolbar displays appearance-related tools for controlling the appearance of your 
model. Select a render style from the list to change the color and texture of your model.

3D Indicator

While using the assembly, part modeling, and presentation environments, the 3D Indicator is 
displayed in the lower-left area of the graphics window. The Indicator displays your current view 
orientation in relation to the X, Y, and Z axes of the coordinate system.

• Red: X-axis

• Green: Y-axis

• Blue: Z-axis

The 3D Indicator is positioned below and to the left of the assembly in this illustration.
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Orbit Tools

You have two options to rotate the views of models and assemblies. The Free Orbit tool is used 
to rotate the model freely in screen space, while the Constrained Orbit tool is used to rotate the 
model about axes in model space.

In the following illustration, the functionality of the Constrained Orbit tool is compared to that of 
a globe. As you rotate a globe about the north-south axis, the angle at which you view the globe 
does not change. The Constrained Orbit tool is similar in behavior.

Access

Free Orbit

Navigation Bar: Free Orbit

Ribbon: View tab > Navigate panel

Access 

Constrained Orbit

Navigation Bar: Constrained Orbit

Ribbon: View tab > Navigate panel
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Free Orbit

The Free Orbit tool enables you to dynamically change your view of the model. It is important to 
remember that the model does not move, you change your viewing position with the Rotate tool.

The following illustration outlines the rotation modes available. The cursor provides feedback on 
the rotation mode available. You click and drag to rotate the view and you can set the center of 
rotation by clicking a location on the model.

Click and drag here to rotate the view about all axes.

Click and drag here to rotate the view about a vertical axis.

Click and drag here to rotate the view about a horizontal axis.

Click and drag here to rotate the view about an axis normal to the screen.

Position and click here to exit.
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Axis Orbiting with Free Orbit

The illustrations below display the behavior of the Free Orbit tool. When the model view is orbited 
using the horizontal cross hairs, the model rotates about an imaginary vertical axis based on the 
view. The model does not stay in the same view orientation. When the view is orbited without 
the use of the cross hairs, the rotation is about the center of the graphics area, or the center as 
assigned by the SteeringWheel.

In the following example, using the Free Orbit enables you to view the top and bottom of the 
assembly as it is orbited.

Axis Orbiting with Constrained Orbit

The Constrained Orbit tool places the axis of rotation on the vertical axis of the part or assembly. 
This functionality enables users to orbit around the vertical axis of their models as they would on  
a turntable.

In the following illustrations, the Constrained Orbit tool is started. The orbit starts from the right 
horizontal cross hair. As the assembly is orbited, you can see the sides of the assembly, but your 
view orientation remains the same.



38 Chapter 01 | Getting Started   

About the ViewCube

The ViewCube tool displays by default in the graphics window. The ViewCube enables you to  
be more efficient because it is accessible at all times, and provides intuitive access to multiple  
view orientations.

In the following illustration, the front view of the assembly is restored by clicking Front on the 
ViewCube.

Definition of the ViewCube

The ViewCube is a view manipulation tool that enables you to efficiently and intuitively change 
the viewing angle of your parts and assemblies. The ViewCube uses faces, edges, and corners as 
selection options to define viewing angles.
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ViewCube Example

In the following illustration, the view of the monitor arm assembly is changed from the current 
isometric view (1) to an angle view between the top and front views (3). The new view orientation 
was obtained by selecting the ViewCube edge (2) between the Top and Front panels on the 
ViewCube.

Using the ViewCube

You can access the ViewCube tools by selecting the face, edge, or corner of the ViewCube. Each 
face, edge, and corner of the ViewCube represents a different view orientation that corresponds to 
the model. The model rotates to the selected view orientation when the ViewCube is clicked.

In the following illustration, the ViewCube is used to reorient the view of the assembly.
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Access

ViewCube

Navigation Bar: ViewCube

Ribbon: View tab > Windows panel > Toggle Visibility of the 
User Interface Elements > ViewCube

Access

ViewCube Options

Ribbon: Tools tab > Application Options > ViewCube > Options
Shortcut: Right-click the ViewCube > Options

Introduction to ViewCube Options

The ViewCube is displayed in the upper right corner of the graphics area of a new window by 
default. However, there are many options associated with the ViewCube that enable you to control 
both its appearance and behavior.
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ViewCube Display Options

The following options control the display and appearance of the ViewCube.

Use this option to display the ViewCube. To hide the ViewCube, clear the check mark in the 
box next to the Show the ViewCube on Window Create option. When a check is in the box for 
the ViewCube option, you can choose to display the ViewCube in all 3D views or only in the 
current view window.

Use this option to place the ViewCube in a corner of the graphics area. Options include: Top 
Right, Bottom Right, Top Left, and Bottom Left. The default location is Top Right.

Use this option to set the ViewCube size. Options include: Small, Normal, or Large. The 
default setting is Normal.

Use this option to control the ViewCube opacity. When the cursor is near the ViewCube, 
the ViewCube is fully opaque. When the cursor is away from the ViewCube, the opacity of 
ViewCube is reduced. Options include: 0%, 25%, 50%, 75%, and 100%. The default setting  
is 50%.
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ViewCube Behavior Options

The following options control the behavior of the ViewCube.

Use this option to snap the ViewCube to a common view position when dragging the 
ViewCube through different view orientations.

When selecting a new view orientation using the ViewCube, use this option to fit the new 
view to the screen.

Use this option to create smooth transitions from the current view to the selected view.

Use this option to apply additional calculations for view orientation.

Use this option to set the default orientation of the ViewCube.

Use this option to display a compass with the ViewCube.
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Procedure: Using the ViewCube to View Models

The following steps describe using the ViewCube to change the view orientation of your models 
and assemblies.

1 Select the panel on the ViewCube to change the view orientation.

2 Select the arrow to rotate the view orientation.

3 Select a corner to change the view orientation to an isometric view of the panel view. In this 
example, the Bottom view is shown.

4 An isometric view based on the Bottom view is displayed.
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Procedure: Using the ViewCube to Orient Drawing Views

The following steps describe using the ViewCube to set the view orientation of your models and 
assemblies for drawing views.

1 Start the Base View tool. Click Place Views tab > Create panel > Base View.

2 Select to change the view orientation.

3 Select the desired ViewCube face.

4 If necessary, rotate the model orientation.
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5 Accept the changes and place the view. 

Procedure: Resetting the Current View as Front

The following steps describe resetting the current view orientation to the Front view.

1 Select the panel on the ViewCube to change the view orientation.

2 Right-click the ViewCube, click Set Current View as Front.

3 The ViewCube updates the orientation of the current view to Front.
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Using Home View

Using the Home View tool, you can manipulate your model to any orientation, then specify that 
view as the home view. In addition to being able to quickly return to that view, the home view is 
also the view that is shown each time you open the file.

In the following illustrations, the view orientation of the assembly is restored to the home view 
when the Home View glyph next to the ViewCube is clicked.

Orthographic View Home View

Access

Home View

The Home View glyph displays as you move your cursor to the ViewCube.

Tip:  In all modeling environments, you can quickly return to the home view using either of 
the following methods.

• Right-click in the graphics window background. 
• Click Home View. Press the F6 function key.
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Home View Options

The following options control the model display when you use the Home View tool.

Use to define the direction of the view and the zoom magnification.

Use to define the direction of the view and automatically assign the zoom magnification as 
view all.

Procedure: Setting the Home View

The following steps describe how to set any view orientation to the home view.

1 Use any view manipulation tools to orient the model.
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2 With the model in the desired orientation, right-click anywhere in the ViewCube. Click Set 
Current View as Home, and select Fixed Distance or Fit to View.

3 With the model in a different orientation, click the Home View glyph.

4 The view orientation returns to the specified home view.
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Restoring Your Views

As you manipulate the views in the graphics window, there will be times when you need to return 
to a previous view to reevaluate your design or to make additional edits. The Previous View tool, 
and the Rewind option of the SteeringWheels view manipulation tool, enable you to restore 
previous views. The Previous View tool enables you to return to the view previous to your current 
view, while the Rewind tool enables you to return directly to one of the previously defined views.

In the following illustration, the Rewind tool displays a filmstrip of previously visited views. As you 
move your mouse over the previews, the main view updates to reflect the view being selected on 
the filmstrip.

Access

SteeringWheel

Navigation Bar: SteeringWheel

Ribbon: View tab > Navigate panel
Shortcut: CTRL + W
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Access

Previous View

Ribbon: View tab > Navigate panel

Shortcut: Right-click anywhere in the graphics window, click Previous View
Shortcut: F5

Procedure: Restoring Views

The following steps describe the two main methods for restoring previous views.

1 To return to your previous view: 

• Press F5. Each time that you press F5, you return to the view that was previous to the 
current view.

2 To return directly to a previous view that was active several views prior to your current view:

• Press CTRL+W to activate the SteeringWheel.
• Click Rewind.
• Drag the cursor through the slideshow ribbon that is displayed. When the desired 

view is reached, release the mouse button.
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Exercise | Manipulate Your Model Views

In this exercise, you use the ViewCube and Home View tools to navigate through and restore 
different view orientations.

Completing the Exercise:  To complete the exercise, follow the steps in this book or 
in the onscreen exercise. In the onscreen list of chapters 
and exercises, click Chapter 1: Getting Started. Click 
Exercise: Manipulate Your Model Views.

1 Open 3D Navigation.ipt.

2 To switch to an isometric view, click the top left corner of the ViewCube.

The completed Exercise
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3 To view the current top view, on the ViewCube, click Top.

Your view is displayed as shown.
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4 To rotate the view:

• On the ViewCube, click and hold Top.
• Drag the cursor toward the upper left corner of the ViewCube until the model is 

oriented as shown.

5 To return the view orientation to the original Home view:

• Move the cursor to the ViewCube.
• When the house image is displayed (1), click the image.
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8 To redefine the Home view to the current view:

• Right-click the ViewCube.
• Click Set Current View as Home > Fixed Distance.

7 To view the model in an isometric view, click the upper left corner of the ViewCube. 

6 To redefine the current view as the Front view:

• Move the cursor to the ViewCube.
• Right-click the cube. Click Set Current View as Front.
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9 To edit the options of the ViewCube:

• Right-click the ViewCube. Click Options.
• In the ViewCube Options dialog box, under Document Settings, place a check in the 

box next to the Show the Compass Below the ViewCube option.
• Click OK.

10 To orbit the model:

• Click View tab > Navigate panel > Free Orbit.
• Click the right quadrant line and drag the cursor to the left until you can see the 

bottom view of the computer housing.
• Right-click anywhere in the graphics window. Click Done.
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13 To turn off the display of the ViewCube:

• Click View tab > Windows panel > Toggle Visibility drop-down > ViewCube.
• Click the option again to turn the ViewCube on.

14 To return to your previous view:

• Press F5.
• Your previous view is restored.
• Press F5 again to return the view previous to the current view.

11 On the ViewCube, click Home View.

12 To constrain orbit the model:

• Start the Constrained Orbit tool.
• Click the right quadrant line and drag the cursor to the left.
• Right-click anywhere in the graphics window. Click Done. 

Notice that the orbit pivots about the axis.
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15 To rewind to a specific view:

• Press CTRL+W to activate the SteeringWheel.
• Click Rewind and hold down the cursor.
• Drag your cursor over the views filmstrip and release the mouse button over the 

specific view you want to restore.
• Continue to use the Rewind tool to restore other views.

16 Close the SteeringWheel tool.

17 Close all files. Do not save.



58 Chapter 01 | Getting Started   

Lesson 03 | Designing Parametric Parts

This lesson describes the characteristics of parametric part models and the overall process of 
 their creation.

Familiarity with the basic characteristics of parametric models simplifies the process of learning 
and applying the tools to create such models.

A parametric part model is shown with dimensions displayed in the following illustration.

Objectives

After completing this lesson, you will be able to:

• Describe the characteristics of a parametric part model.

• Identify guidelines for capturing design intent.

• State the general workflow for creating parametric part models.

• State the characteristics of the ribbon and browser when in the part environment.

• Create a basic parametric part.
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About Parametric Part Models

You can create and edit 3D geometry using parametrics. Parametrics use geometric and 
dimensional constraints to precisely control the shape and size of a 3D model.

A typical parametric part is shown in the following illustration, consisting of both 2D sketch 
geometry with dimensional constraints and the resulting 3D solid geometry.

Parametric Part Models

A parametric model is a 3D model that is controlled and driven by geometric relationships and 
dimensional values. You typically create parametric models from a combination of 2D sketches and 
3D features. With a parametric part model, you can change a value of a feature and the part model 
is adjusted according to that value and any existing geometric constraints.

Sketched Features

Sketched features are features that add or remove material and are typically based on a 2D closed 
loop sketch. The sketch can be composed of lines, circles, and arcs.

Sketched features are shown in the following illustrations. After the sketch is used by a feature, it is 
considered consumed by the feature and is displayed nested below that feature in the browser.
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Placed Features

While sketched features start from a sketch, placed features have an internally defined shape 
for adding or removing material. You need to determine only where and at what size the feature 
should be created. Holes and fillets are two commonly used placed features.

Placed features are shown in the following illustration by the Fillet4 and Chamfer2 highlights.

Base Features

The first feature that you create is typically a sketched feature. This first feature is also referred 
to as the base feature. All subsequent features either add material to or remove material from the 
part model.

Extrusion1 represents the base feature of the part in the following illustration.

Base sketch and base feature
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Progression of a Parametric Model

A parametric model progresses through the stages of its creation in the following illustrations. The 
model is transformed after the size of the base feature is increased upon inclusion of sketched and 
placed features.

Initial sketch is created

Secondary sketch is added

Fillets (placed features) are added

Base feature is created

Secondary feature is created 
from secondary sketch

Length is changed in initial sketch, 
causing part to update
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Capturing Design Intent

Regardless of the type of design that you are creating, you should always aim to capture the intent 
of the design as early in the process as possible. It is common for a design to change as a result 
of inherent design problems or future revisions. The ability to capture design intent makes these 
potential changes much easier to implement.

Design intent has been captured in the following illustration by using a simple formula (2) to 
calculate the outside diameter of the part based on the inside diameter (1).

About Capturing Design Intent

When you capture your design intent, you add intelligence to your design. This intelligence can 
exist in several different forms. It can reside in a simple geometric constraint that forces two lines 
to be parallel or two circles to be concentric. Intelligence can also reside in dimensional constraints 
that force a feature’s dimension to remain constant or enable the dimension to change based on a 
built-in formula.

Just as each part design is unique, so is the design intent for each part. Capturing this intent  
is a process in which you match the design intent with a feature or capability that makes it  
possible to create the design in the most efficient way while enabling you the maximum flexibility 
in making changes.

Different examples of design intent are shown in the following illustration being captured at the 
earliest stage of the design. The toolbars show constraint symbols (glyphs).
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Toolbars displaying geometric constraints applied to the geometry. Each icon illustrates a 
specific type of geometric constraint that has been applied to the sketch, and as a result 
captures a portion of the design intent. For example, the right-most icon on the top toolbar 
indicates a tangent constraint between the top horizontal line and the arc on the right side  
of the sketch.

Coincident constraints are displayed by a yellow dot at the coincident point between 
two segments.

Dimensional constraints applied to the geometry. These types of constraints capture design 
intent by defining the size of objects in the sketch.

Guidelines for Capturing Design Intent

Consider the following guidelines when you begin a new part design. Each of the following points 
indicates an area in which design intent can be captured.

• Identify geometric relationships. For example, a feature’s length may be directly related to its 
width, or the width or length of another feature.

• Identify areas of the design that may be prone to change as a result of design problems  
or revisions.

• Identify areas of symmetry or areas where features are duplicated or patterned.

Once you have identified the potential ways to capture your design intent, you can then match that 
intent with a specific Inventor tool or capability.
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Example of a Part Design Capturing Design Intent

A simple parametric design of a plastic indexer is shown in the following illustrations. Each one 
reflects how a specific guideline of the design intent is captured and implemented into the design 
with a parametric feature.

Capturing Geometric Relationships in Design Intent

Design intent for the indexer part dictates that the outside diameter should be equal to twice the 
inside diameter in the following illustration. The design intent has been captured with the use of a 
simple formula in the dimension parameter.

Inside diameter of the indexer part.

Outside diameter is determined by a formula equal to twice the inside diameter.

Capturing Design Intent for Features That Are Prone to Change

Design intent has been captured to allow for potential design changes in the following illustration. 
As the thickness of the part changes, so does the depth of the slots. This result is achieved by 
setting the depth parameter for the slot to All, ensuring the slot always extrudes completely 
through the part.
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Capturing Symmetry in Design Intent

Design intent for symmetry has been captured in the part design in the following illustration by 
using a parametric pattern feature. By capturing the design intent in this manner, you can easily 
change the number or angled spacing of slots by editing the feature.

Original slot feature.

Circular pattern being created to duplicate the slot feature in a precise and easily  
editable manner.

With a 3 mm part height, slot depth cuts though the entire part.

With a change in part height from 3 mm to 6 mm, the slot depth continues to cut through the 
entire part.
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Process: Creating a Parametric Part

The following steps provide an overview of the process for creating a parametric part.

1 Create the initial sketch profile.

Creating Parametric Part Models

The overall process for creating parametric part models is very flexible. With this flexibility,  
you can concentrate on your design, design intent, and essential design features instead of  
being limited by a rigid modeling process.

In the following illustration, what begins as a simple circle is transformed into a fully  
parametric model.



67Lesson 03 | Designing Parametric Parts

Part Design Considerations

When creating a parametric part model, try to determine the basic building blocks of the part; that 
is, how the part can be designed and built in stages. Also determine which aspects of the model 
are the critical aspects of the part. You create those aspects first in the order of their importance 
and relationship.

4 Continue to develop the design by creating additional sketched and placed features.

2 Capture the design intent by applying constraints and dimensions.

3 Use the part feature tools to create the base feature.
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Part Design Workflow

The following steps represent the overall workflow for creating parts.

• Use one of the part templates provided to create a new part.

• All new parts you create have a blank sketch automatically placed. Create the profile of your 
geometry on the initial sketch.

• Use sketched features such as Extrude and Revolve to create your base feature.

• Create additional sketched and placed features as required to generate the necessary  
3D geometry.

Part Design Environment

When you are editing a part file and the part environment is active, the ribbon and browser are 
displayed with the tools and information relevant to this environment.

The part design environment is shown in the following illustration.

Part Features on Ribbon Model Tab: Displays part modeling tools while in part 
modeling mode.

Browser: Displays the feature history for the part or assembly
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Model Tab

The Model tab is displayed when you are editing a part model. You use these tools to create 
sketched and placed features on the part.

Browser

When you use the browser in the part design environment, it displays the Origin folder containing 
the default X, Y, and Z planes, axes, and center point. It also lists all features you use to create the 
part. Features are listed in the order in which they are created.
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Exercise | Create a Parametric Part

In this exercise, you create a simple bracket by extruding the predefined sketch. You then edit the 
part by changing some of the parameters and add a fillet feature.

The completed exercise

Completing the Exercise:  To complete the exercise, follow the steps in this book or 
in the onscreen exercise. In the onscreen list of chapters 
and exercises, click Chapter 1: Getting Started. Click 
Exercise: Create a Parametric Part.
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2 Click Model tab > Create panel > Extrude.

• For Distance, enter 25 mm.
• Click OK.

1 Open Create-Parametric-Part.ipt. The initial sketch profile has been created and constrained.
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4 In the browser, double-click Sketch1.

• Double-click the 25 mm horizontal dimension.
• In the Edit Dimension dialog box, enter 35.
• Press ENTER.
• On the Sketch tab, click Finish Sketch.  

The part is updated to reflect the new dimension value.

3 In the browser, expand the Extrusion feature.

• The initial sketch is consumed by the 3D extrusion feature.
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5 In the browser, right-click the Extrusion1 feature. Click Edit Feature.

• For Distance, enter 40 mm.
• Click OK.  

The parametric part updates to reflect the new parameter value.
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6 Click Model tab > Modify panel > Fillet.

• In the graphics window, select the inside edge.
• For Radius, enter 5 mm.
• Click OK. The fillet feature is updated.

7 Close all files. Do not save.



75Chapter Summary

Chapter Summary

By using the context-sensitive user interface and the tools that are available, you can quickly create 
basic parametric geometry. This chapter introduced you to the Autodesk Inventor user interface 
and concepts supporting parametric part design and capturing design intent.

Having completed this chapter, you can:

• Identify the main user interface components that are common to all Autodesk Inventor 
design environments and describe how to access different tools.

• View all aspects of your design by efficiently navigating around in 2D and 3D space.

• Describe the characteristics and benefits of a parametric part model.


