Chapter 1

The Basics of Illustrator CS
Adobe Illustrator CS is a versatile program that can be used to create detailed illustrations both for print and the Web. Illustrator includes industry-standard drawing tools that are often used to create digital artwork such as company logos, product packaging, and cartoon characters. Because drawing in Illustrator is quite different from drawing in real life, these tools can be a little difficult for a beginner to master at first. After introducing the basic principles of vector illustration, this chapter will help you get started by covering the Illustrator interface and its tools in detail.
The Illustrator Interface

This chapter provides a general overview of the main features of Illustrator CS. The Illustrator interface can seem a little daunting at first with its mix of menus, toolboxes, and palettes; this chapter will introduce you to the various screen elements through detailed explanations and simple examples.

Vector and Bitmap Images

All computer graphics are either vector or bitmap. Vector images are created using strokes and fills that are defined using mathematical equations. Points are joined to create lines and lines are joined to create objects. Because vector images are defined using mathematical equations, vector images have small file sizes and maintain their resolution or quality even when magnified. The downside to vector images is that they cannot be made to look very realistic.

Bitmap images, on the other hand, are recorded using individual pixels. The higher the image resolution, the more pixels are used to record the image; this creates sharper looking images. The opposite is true for images with lower resolutions; these often appear blurry or poorly detailed. Bitmap images are used for realistic images such as photographs and scans. When you magnify a bitmap, the image loses sharpness. If magnified sufficiently, the pixels that make up the image become discernable.
Illustrator is a vector-based graphics program. Therefore, all text and shapes created in Illustrator are vector images. Vector images can be converted to bitmap images through a process called rasterization, but doing so will greatly reduce your ability to edit your graphics using Illustrator.

**Converting Vector Images into Bitmap Images in Illustrator CS**

The [Object] - [Rasterize] command can be used to turn vector images into bitmap images. However, bitmap images cannot be converted to vector images.

1. Select the vector image, then choose [Object] - [Rasterize].

2. When the Rasterize dialog box appears, enter the appropriate settings and click [OK].

3. The vector image will be converted into a bitmap image.
When you first open Illustrator CS, you will see the welcome screen. The welcome screen contains options that make it easy for you to get started in Illustrator whether you are a new user, an upgrader, or are just looking to create a new document. Let’s have a look at the options available in the welcome screen.

**What’s New in Illustrator:**
Click this to find out about the program’s new features at the Adobe Web site.

**Tutorials:** You can click on this to access the Help menu.
Cool Extras: Clicking Cool Extras brings up a PDF document with information on templates, brushes, fonts, colors, and gradients. Sample files that demonstrate what Illustrator can do are also available.

New Document, New from Template, or Open Document: Clicking New Document, New from Template, or Open Document opens the respective command’s dialog box. Enter the desired settings or navigate in the dialog box to create or open a new document in the document window.

Illustrator CS Interface

Almost all of the commands for drawing or editing artwork in Illustrator can be found in the work space—the menu bar at the top, the toolbox on the left, and the floating palettes on the right. In the center of the document window is the work area, where you’ll create and edit your graphics.
**A Menu Bar:** Clicking on a menu item opens a drop-down menu which contains a list of commands and submenus.

**B Toolbox:** The toolbox contains the tools that you will use to work with images.

**C Work Area:** The work space for your drawing.

**D Status Bar:** Displays information on the active document.

**E Palettes:** The palettes contain preset options and various commands for modifying an image. Some of the palettes also display information on an active image or the current task.

**Menu Bar**

The menu bar contains a multitude of commands for performing a wide variety of tasks in Illustrator. Some of these commands are only found in the menu bar while others can also be accessed through keyboard shortcuts, palettes, the toolbox, or status bar. Clicking on a menu item opens a drop-down menu which contains commands and submenus. In the drop-down menu, you will also find the keyboard shortcuts for accessing commonly used commands. Let’s take a quick look at the type of commands found in each menu.
**File Menu:** The commands found in the File menu are basic functions that you will need in order to work in Illustrator. These commands cover areas related to creating, printing, and saving documents, importing and exporting files, adjusting document settings and exiting Illustrator.

**Edit Menu:** The Edit menu contains commands that help you edit an image or change the way you work in Illustrator. Commands related to image-editing include the undo and redo commands, the copy and paste commands and text-editing commands such as the Find and Replace command. You can also tailor your Illustrator environment using the Presets commands or the Color Settings, Keyboard Shortcuts or Preferences commands.

**Object Menu:** The Object menu contains object-related functions. A number of these functions such as the Blend command can also be accessed through the toolbox or the palettes. Some of the commonly used object commands involve changing the object’s shape (Transform), position (Arrange), appearance (Expand) and how you work with objects (Group).

**Type Menu:** The Type menu contains commands for adjusting text properties such as font type, font size, type orientation, punctuation and style.

**Select Menu:** The Select menu lets you choose the fastest and easiest way to select one or more objects. It may come as a surprise to you but there are many ways to select an object. For example, you can choose one of the Same commands to select objects with the same characteristics.

**Filter Menu:** The Filter Menu contains commands that change an image completely to create a different style. The Artistic filters, for example, make an image appear to have been painted or created in the selected artistic style. Chapter 5 covers the topic of filters in more detail.

**Effect Menu:** Effects, like filters, change an image completely to create a different style. The key difference between effects and filters is that an effect can be edited after you apply it while a filter cannot be changed. See Chapter 10 for more information on effects.

**View Menu:** The View menu lets you change the view of the artboard, decide whether elements such as rulers will be shown and determine how objects are represented in the artboard.

**Window Menu:** In the Window menu is a list of all the palettes in Illustrator, a check mark beside a palette name indicates that the palette is opened. If there is no check mark, the palette is closed. To open or close a palette, you can check or uncheck the palette name in the Window menu. When working with more than one file in Illustrator, you can also use the Cascade or Tile commands in the Window menu to change the view of the files and switch from one file to another easily.

**Help:** The Help menu contains copyright information on the program and support material and resources that will help you get started in Illustrator.

**Toolbox**
The toolbox, which sits at the top-left of the Illustrator window, contains many different tools for drawing and editing artwork in Illustrator. All of these tools are represented by icons corresponding to their functions, and you can activate a tool by clicking it or by typing its keyboard shortcut.

When you point at a tool in the toolbox, a tool tip showing the tool’s name and its keyboard shortcut will appear. Double-clicking a tool will show the tool’s options in a dialog box.
Placing the cursor over the Direct Selection tool reveals the name and the shortcut key for the tool.

If a tool icon shows a triangle at the bottom-right side (▲), it means that other similar tools have been grouped together with the tool. To see the hidden tools, click and hold down the mouse on the tool. Clicking on the vertical bar at the end of a group of tools will display the group in a floating window outside the toolbox. Pressing the close button (□) will close the floating window. Holding down the [Alt] key as you click on a group of tools will toggle between the tools in the group.

In this section, let’s take a quick look at all the tools in the toolbox (these tools will be covered in greater depth later in the book). The default shortcut key(s) for each of these tools is indicated in the brackets beside the tool name. You can change the shortcut by selecting [Edit] - [Keyboard Shortcuts] from the main menu.
### Selection Tools

- **Selection Tool [V]**: This tool is used to select an entire object.

- **Direct Selection Tool [A]**: The Direct Selection tool selects object paths or anchors. You will learn about paths and anchors in Chapter 2.

- **Group Selection Tool**: This tool selects a single object from a set of grouped objects. Double-click once to select the entire group.

- **Magic Wand Tool [Y]**: The Magic Wand tool selects objects with the same color.

- **Lasso Tool [L]**: Use the Lasso tool to create freeform selections.

### Path Tools

- **Pen Tool [P]**: The Pen tool creates vector lines, curves, and objects. This tool is used frequently.
• **Add Anchor Point Tool** [+ ] < >: This tool adds anchor points to an object or path to change the shape of the object.

• **Delete Anchor Point Tool** [- ] < >: This tool deletes anchor points from objects or paths.

• **Convert Anchor Point Tool** [Shift]-[C] < >: The Convert Anchor Point tool is used to control direction lines or to turn linear paths into curves (and vice versa).

**Line Tools**

• **Line Segment Tool** [ \ ] < >: The Line Segment tool creates straight lines.

• **Arc Tool** < >: This tool creates arcs.

• **Spiral Tool** < >: The Spiral tool draws spirals.
- **Rectangular Grid Tool**: This tool creates rectangular grids.

- **Polar Grid Tool**: The Polar Grid tool creates circular grids.

- **Paintbrush Tool [B]**: This tool is used to add brush strokes.

- **Transform Tools**
  - **Rotate Tool [R]**: Use the Rotate tool to rotate objects.
  - **Reflect Tool [O]**: The Reflect tool creates a vertical or horizontal reflection of the object.
  - **Scale Tool [S]**: This tool changes the size of an object.
• **Shear Tool**: Use the Shear tool to adjust the slant of an object.

• **Reshape Tool**: When an anchor point is selected using the Reshape tool, the surrounding path segments are “bound” to that point; clicking-and-dragging the anchor point will reshape the selected area of the object.

• **Warp Tools**
  - **Warp Tool [Shift]-[R]**: The Warp tool distorts the shape of an object.
  - **Twirl Tool**: This tool twirls an object.
  - **Pucker Tool**: The Pucker tool pulls an object inward.
  - **Bloat Tool**: Use the Bloat tool to swell an object outward.
- **Scallop Tool**: The Scallop tool creates rounded ridges along a path.

- **Crystallize Tool**: The Crystallize tool creates spikes along a path.

- **Wrinkle Tool**: The Wrinkle tool crinkles object lines.

**Symbol Tools**

- **Symbol Sprayer Tool**: This tool sprays the selected symbol onto the work area.

- **Symbol Shifter Tool**: The Symbol Shifter tool moves symbols gradually in the direction that you drag the tool.

- **Symbol Scruncher Tool**: The Symbol Scruncher tool is used to pull in or spread out symbols.
- **Symbol Sizer Tool**: The Symbol Sizer tool is used to increase or decrease the size of symbols.

- **Symbol Spinner Tool**: The Symbol Spinner tool rotates symbols.

- **Symbol Stainer Tool**: The Symbol Stainer tool uses the selected fill color to change the color of symbols without altering their overall brightness.

- **Symbol Screener Tool**: The Symbol Screener tool makes symbols transparent.

- **Symbol Styler Tool**: This tool alters the stylistic traits of symbols.

- **Mesh Tool**: The Mesh tool adds criss-crossed paths to an enclosed area to create a mesh of paths. Meshes can be used to create highly detailed fills that convey realistic light and shadow effects.
Color and Measurement Tools

- **Eyedropper Tool** [I]: Click an object with the Eyedropper tool to copy its color and stroke settings to the Color and Stroke palettes. If another object is selected when you click an object with the Eyedropper tool, its fill and stroke properties will be modified to match the clicked object.

- **Paint Bucket Tool** [K]: Use the Paint Bucket tool to fill an object with the selected color.

- **Measure Tool** : This tool measures the position, angle, and distance of objects.

Slice Tools

- **Slice Tool** [Shift]-[K]: Use the Slice tool to slice images into smaller segments for the Web.

- **Slice Selection Tool** : The Slice Selection tool selects image slices.

Move Tools

- **Hand Tool** [H]: Use the Hand tool to drag your view of the work area. The Hand tool is very useful for quickly shifting your focus to another area of your image.
• **Page Tool** [ ]: The Page tool moves the printable area on the page.

### Fill and Stroke Colors
- **Fill Color Swatch** [X] [ ]: Shows the selected fill color, which is used for coloring an area enclosed by paths. Double-click on the swatch to open the Color Picker dialog box and select a new fill color.
- **Stroke Color Swatch** [X] [ ]: Shows the selected stroke color, which is used for coloring paths. Double-click on the swatch to open the Color Picker dialog box and select a new stroke color.
- **Swap Fill and Stroke Colors** (Shift)-[X] [ ]: Swaps the fill and stroke colors.
- **Default Fill and Stroke Colors** [D] [ ]: Sets the fill color to white and the stroke color to black.
- **Color** [<] [ ]: Changes the fill color to the last selected solid color in the Color palette.
- **Gradient** [>] [ ]: Changes the fill color to the last selected gradient in the Gradient palette.
- **None** [/] [ ]: Removes either the fill or stroke color – whichever is selected.

### Screen Modes
- **Standard Screen Mode** [F] [ ]: Displays the image in the default window view, which includes the menu bar, title bar, and scroll bars.
- **Full Screen Mode with Menu Bar** [F] [ ]: Displays the image without a title bar or scroll bars.
- **Full Screen Mode** [F] [ ]: Displays the image without the menu bar, title bar, or scroll bars.

### Zoom Tool [Z] [ ]: The Zoom tool is used to zoom in or out of an image.

### Cropping Tools
- **Scissors Tool** [C] [ ]: This tool cuts an object straight across between two selected points on the path.
Auto Tools

- **Blend Tool [W]**: Use the Blend tool to create intermediate shapes between two objects.

- **Auto Trace Tool**: The Auto Trace tool traces a bitmap image to create paths.

Gradient Tool [G]**: The Gradient tool is used to adjust the direction of a gradient.

Graph Tools

- **Column Graph Tool [J]**: Use the Column Graph tool to create a column graph.

- **Stacked Column Graph Tool**: The Stacked Column Graph tool creates a stacked column graph.
• **Bar Graph Tool**: The Bar Graph tool creates a horizontal bar graph.

• **Stacked Bar Graph Tool**: Use the Stacked Bar Graph tool to create a horizontal stacked bar graph.

• **Line Graph Tool**: This tool creates a connected line graph.

• **Area Graph Tool**: The Area Graph tool creates an area graph.

• **Scatter Graph Tool**: A scatter graph can be created with the Scatter Graph tool.

• **Pie Graph Tool**: The Pie Graph tool creates a pie graph.
Free Transform Tool [E]: Use the Free Transform tool to create a bounding box around an object. The bounding box can be used to scale, rotate, reflect, shear, or distort the object.

Freeform Line Tools

- Pencil Tool [N]: Use the Pencil tool to draw freeform lines.
- Smooth Tool: This tool smoothes lines.
- Erase Tool: The Erase tool erases object anchor points or lines.

Shape Tools

- Rectangle Tool [M]: The Rectangle tool creates rectangular shapes.

• Radar Graph Tool: You can create a radar graph with the Radar Graph tool.
• **Rounded Rectangle Tool**: This tool makes rectangles with rounded edges.

• **Ellipse Tool**: The Ellipse tool draws circles and ellipses.

• **Polygon Tool**: The Polygon tool draws polygons.

• **Star Tool**: This tool creates stars.

• **Flare Tool**: The Flare tool adds a lens flare.

**Type Tools**

• **Type Tool**: The Type tool is used to enter characters. Click and drag the Type tool to create a text field, then type in the text. Alternatively, simply click on the work area to add text without a bounding box.
• **Area Type Tool**: This tool adds text inside a closed area.

• **Path Type Tool**: The Path Type tool enters text on a path.

• **Vertical Type Tool**: This tool is used to enter vertical text.

• **Vertical Area Type Tool**: This tool enters vertical text inside a closed area.

• **Vertical Path Type Tool**: The Vertical Path Type tool enters vertical text along a path.

Adobe Illustrator Icon: Opens up the main Illustrator page on the Adobe Web site.
Work Area

The work area in Illustrator is divided into five sections. These sections indicate the printable and unprintable areas and the boundaries of the page.

A **Imageable Area**: The area inside the innermost dotted lines is the printable area.

B **Nonimageable Area**: The area between the sets of two dotted lines is the unprintable margin of the page.

C **Edge of Page**: The edge of the paper.

D **Artboard**: This is the entire area that can contain printable artwork; it is determined by the dimensions you specify when creating your document.

E **Scratch Area**: This is the area outside the artboard. You may work in this area, but the drawings in this area will not be printed.

---

**Defining Page Areas**

The page size, and therefore the boundaries of the page, are determined by the printer’s default settings. The document size, as well as the printing and non-printing areas of the page, can be changed by selecting [File] - [Document]. If you don’t see the dotted and solid lines as shown in the figure above, see the “Showing or Hiding the Artboard and Page Tiling” note below.

---

**Showing or Hiding the Artboard and Page Tiling**

If you do not see the solid or dotted lines demarcating the artboard window, you can turn on the lines by selecting [View] - [Show Artboard] or [View] - [Show Page Tiling]. To hide the lines, select [View] - [Hide Artboard] or [View] - [Hide Page Tiling].

If the second set of dotted lines indicating the edge of the page is not showing, it is probably because the artboard’s boundary (represented by solid lines) is overlying the page boundary (represented by dotted lines). The artboard, by default, is the same size as the page, but the size of the artboard can be changed. You will be able to see the second set of dotted lines if the artboard and the page are of different sizes. To change the size of the artboard, select [File] - [Document Setup] from the menu bar.
Status Bar
The status bar contains the Zoom pop-up menu and the Status pop-up menu. These menus pop up when you click on their respective arrow icons () in the status bar. Using the Zoom pop-up menu, you can zoom in or out of an image very easily.

The Status pop-up menu lets you select the kind of information on the active document that you want displayed. When the default Current Tool option is selected, the Status menu displays the name of the currently selected tool. The tool name displayed changes when you switch to another tool. Other options in the Status pop-up menu include Date and Time, which shows you the current date and time; Number of Undos, which displays the number of undos and redos that have been applied; and the Document Color Profile, which indicates the color mode of the document. You will learn more about color modes later in this chapter.

Easter Eggs
In some programs, there are functions that are left deliberately undocumented so that users can be pleasantly surprised when they discover them by accident. These hidden functions, known as easter eggs, are often quirky and fun and not essential for using the software. One example of an easter egg is found in Illustrator’s status bar. Holding down the [Alt] key and clicking on the arrow icon next to the Status pop-up menu reveals options that are not documented in the Adobe Help function.

Easter eggs range from the quirky (Eyes) to the bizarre (Mordy’s Home Number).
Using Palettes

In Illustrator, as with many other programs, some functions are grouped into palettes and these palettes are displayed on the right-hand side of the work space. The purposes and uses of the palettes vary rather widely. Some palettes display information on an image or the current task, some contain commands for modifying an image, and others contain preset options such as styles and color swatches.

This section will briefly introduce you to all the palettes in Illustrator and show you how to manage them. Do note that this section provides only an overview, and more information on each of the palettes can be found in later chapters.

Showing or Hiding Palettes

When you first launch Illustrator, you will see the default palettes on the right-hand side. These are the palettes that are used most often. Illustrator contains more palettes than is possible to show on screen, so you’ll need to decide which are most important to your work. You can see the complete list of palettes available in Illustrator by selecting the Window menu. By checking or unchecking a palette name in the Window menu, you can hide or show a palette on the screen.

The list of palettes starts from [Actions] and ends at [Symbol Libraries]. A check mark indicates palettes that are currently shown in the window.
Another way to hide a palette is to click on the close button ( ☑️ ) on the top-right corner of the palette. You can also minimize or maximize palettes. Click on the minimize button ( ▼️ ) to show only the palette’s tab and the maximize button ( ▲️ ) to show the entire palette.

A Minimized Palette

A Maximized Palette

**Hiding the Toolbox and All Palettes**

The toolbox, when combined with numerous palettes, can clutter up the work space and make it hard to review your work without distraction. A quick way to hide all this clutter is to press the [Tab] key once. Pressing the [Tab] key again will show all the palettes and the toolbox. To hide only the palettes and not the toolbox, press [Shift]-[Tab] instead. Pressing [Shift]-[Tab] again will show all the palettes.

**Showing or Hiding Palette Options**

Every palette has its own pop-up menu which is opened by clicking the triangle icon ( ▽️ ) at the top-right corner of the palette. On some of these menus, you can select [Hide Options] to hide some of the options on the palette. Selecting [Show Options] reveals all the palette options again.

Selecting [Hide Options] from the Pop-Up Menu.

After selecting [Hide Options], all options except the color spectrum bar will be hidden.
Moving, Grouping, or Separating Palettes

Because it is not possible to show all of the palettes at any one time, similar palettes are grouped into one window to save space. In a group containing multiple palettes, only the options for the selected palette are shown. To view a palette hidden in the group, click on the palette’s tab to bring it up.

You can also move individual palettes and palette groups to other positions on the screen. To move a palette, click and drag the palette’s tab to another position on the work space to create a standalone palette. Alternatively, drag it inside another palette group to pair the palette up with the group.

You can also drag a palette to the bottom of another palette to dock it there; doing so will tether the palettes to one another. To move an entire palette group, just click and drag the palette’s title bar to the new position.
Palette Descriptions

Every palette has a different role and function. In this section, let’s take a closer look at each of the different palettes and see how they are used.

Actions Palette

The Actions palette can be used to record and apply actions (e.g., automated scripts) for frequently repeated tasks. (If you’re familiar with Microsoft Word, this is similar to the [Tools] - [Macro] command.) While recording commands to create actions, each step will appear beneath the name you’ve selected for your action. These steps can be applied separately or consecutively. You can also use the Actions palette to edit, delete, organize, and export recorded actions.

Align Palette

This palette is used to align and distribute objects. You can align selected objects along the vertical or horizontal axis. You can also choose to align objects using their edges or anchor points as reference. The designs of the align and distribute icons in the palette are suggestive of their respective functions. Note that to use the Align palette you must select more than one object.

Appearance Palette

This palette shows the appearance attributes of the selected object, including the fill and stroke properties, and the effects applied to the object using the Effect menu. You can use this palette to duplicate, edit, and delete attributes. A set of appearance attributes can be saved as a new style in the Styles palette.

Attributes Palette

The Attributes palette contains a mishmash of options. First, it can be used to set overprinting for the fill or stroke color of an object. The overprinting option affects the color of overlapping areas when printed; when overprinting is not selected, the color of the top object knocks out the color of the bottom object. So a yellow object will appear yellow even if it overlaps a blue object. Conversely, when overprinting is selected, the overlapping areas will turn out green.

The Attributes palette can also be used to make the center point of an object visible or invisible. There are also options for selecting whether overlapping areas from the same path will be filled with color or treated as “outside” the object and left empty. Using the Attributes palette, an object can also be set to link to a Web address.
Brushes Palette
The Brushes palette contains a wide range of brush styles that can be used with the Paintbrush tool ( ) or applied to any existing path in an image. Using the Brushes palette, you can customize and add new brush styles or load Illustrator’s collection of brushes from the brush library. To load a brush library, click the triangle button ( ) at the top-right side of the palette and select [Open Brush Library].

Character Palette
The Character palette sets the character properties of text. You can open this palette by selecting [Window] - [Type] - [Character].

Character Styles Palette
This palette is used to save the settings entered in the Character palette as a character style. You can click a saved style to apply it to selected text. You can open this palette by selecting [Window] - [Type] - [Character Style].

Color Palette
The Color palette allows you to apply fill and stroke colors to a selected object. You can also use the palette’s pop-up menu to specify different color modes (e.g., RGB or CMYK).

Document Info Palette
The Document Info palette shows information on the active document. The information is grouped into different categories and these categories are shown in the pop-up menu. The categories are Document, Object, Graph Style, Brush, Spot Color Object, Patter Object, Gradient Object, Font, Linked Image, Embedded Image, and Font. You can choose [Save] to save the information as a text file.

Flattener Preview Palette
The Flattener Preview palette allows you to preview your artwork as a flattened image. Areas that will be affected by the flattening process are highlighted.
Glyphs Palette

Glyphs are special characters or symbols that are not found in the alphabet. Every font has its own set of glyphs and you can view and insert a glyph by double-clicking on it in the Glyphs palette. The fonts—Webdings, Windings, Windings 2, and Windings 3—contain some of the more commonly used glyphs. You can open this palette by selecting [Window] - [Type] - [Glyphs].

Gradient Palette

This Gradient palette is used to apply and edit color gradients. You can choose the gradient type, color, angle, and position.

Graphic Styles Palette

The Graphic Styles palette contains a list of styles that can be applied to objects and paths. To choose from more styles, select [Open Graphic Styles Library] from the palette’s pop-up menu to access Illustrator’s collection of graphic styles.

Info Palette

The Info palette indicates the position of the cursor on the page. The position is shown in X and Y coordinates and these values change as the cursor moves. The Info palette also contains information on the current object or task, such as angle and dimension data. The palette automatically pops up when the Ruler tool ( ) is used to measure an object.

Layers Palette

Artwork in Illustrator can be created using one layer or many overlapping layers. You can think of layers as transparent sheets on which objects are drawn. The stacked sheets combine to form a single image when viewed from above. Layers are created and manipulated using the Layers palette, which displays the content of each layer (using thumbnails) as well as the order in which the layers appear in the “stack.” You will learn more about layers in Chapter 5.

Links Palette

This palette is used to manage bitmap images added with the [File] - [Place] command.
**Magic Wand Palette**

The Magic Wand palette is used for setting the Tolerance value for the Magic Wand tool. A high Tolerance value selects a large color area, while a low value allows for less color deviation and usually results in a smaller selection.

**Navigator Palette**

This palette is used to zoom in and out of a document. You can also drag the red box to specify the part of the document that you want to look at.

**OpenType Palette**

OpenType is a font file format with two primary characteristics—OpenType fonts are compatible across Windows and Macintosh operating systems, and these fonts support a wider range of glyphs and characters than other type formats. You can tell that a font is in the OpenType format if the font name has the word “Pro” at the end. With an OpenType font selected in the Character palette, you can use the OpenType palette to modify the style of the characters. You can open this palette by selecting [Window] - [Type] - [OpenType].

**Paragraph Palette**

The Paragraph palette sets the spacing and indentation of paragraphs. You can open this palette by selecting [Window] - [Type] - [Paragraph].

**Paragraph Styles Palette**

Settings entered in the Paragraph palette can be saved as a paragraph style in the Paragraph Style palette. Clicking on a saved style applies the style to the document. You can open this palette by selecting [Window] - [Type] - [Paragraph Styles].

**Pathfinder Palette**

The Pathfinder palette creates new paths based on overlapping objects or paths. For example, the paths for two objects can be combined to form a single object, or two objects can be divided according to the intersections of their paths. Fill colors can also be removed or changed depending on the options selected in the Pathfinder palette.
The Basics of Illustrator CS

Chapter 1

**Stroke Palette**

The Stroke palette can be used to change the weight and style of an object’s stroke line. Style options include choosing a design for a stroke’s starting point, corners, and end points, and setting the length of the dashes and gaps for a dashed line.

---

**SVG Interactivity Palette**

This palette is used for adding interactivity to an image that will be placed on the Web. You can add an event to an object so that when a user performs the event, an action is triggered. For example, clicking on an object opens a link in a new window.

---

**Swatches Palette**

The Swatches palette provides an easy way to select and apply commonly used colors, gradients, and patterns. Select [Open Swatch Library] from the palette’s pop-up menu to load more swatches into Illustrator. Some interesting swatch libraries include the Skin Tones, Metals, and Earth Tones libraries. You can also mix your own color and save it as a color swatch.

---

**Symbols Palette**

The Symbols palette contains symbol objects that can be used in your document. Using symbols greatly reduces the size of your file and makes it easy to edit repetitive objects in your artwork. When an object is turned into a symbol, Illustrator saves only one copy of the object. Other instances of the object are linked to the symbol, and therefore do not increase the file size of your image. You can place symbols in the work area using the Symbol Sprayer tool. The other symbol tools, such as the Symbol Stainer tool, can be used to edit symbols once they’re placed in the work area of your image.

---

**Tabs Palette**

The Tabs palette is used to display and set tabs. Text can be set to align to the left, right, or center of a tab. You can open this palette by selecting [Window] - [Type] - [Tabs].

---

**Transform Palette**

This palette is used to move, scale, rotate, and slant selected objects. It also displays the coordinates and dimensions of selected objects.
**Transparency Palette**

This palette is used to change the opacity of objects and determine how objects will blend in overlapping areas.

**Variables Palette**

The Variables palette is used to create and manage the variables in a template. Designers often use standard templates (without variables) if they need to create numerous images that share similar designs or layouts. Working with a template is easy and it’s rather like filling out forms. But if you need to create a large number of designs from a template, say 100 Web banner designs, the process of filling out data on a template a hundred times is still tedious. A more efficient method is to use variables to define which objects on the template are dynamic (changeable). By using variables, you can automate the process of filling out the template with a set of data.

---

**Basic Illustrator Commands**

In this section, you will learn more about the tools, menu commands, and palettes needed to perform basic tasks in Illustrator CS. These commands represent the building blocks for working with graphics in the program.

**Changing the View**

It is important to be able to move around the screen when you are working in Illustrator, and you can use many methods to change the screen view.

**Zoom Tool**

You can click or drag the Zoom tool (🔍) to magnify part of the image. If you hold down the [Alt] key while clicking with the Zoom tool, you will zoom out of the area. While working with other tools, you can temporarily access the Zoom tool by pressing [Ctrl]-[Spacebar] to zoom out or [Ctrl]-[Alt]-[Spacebar] to zoom in. Double-clicking on the Zoom tool (🔍) sets the image magnification value to 100%.
Hand Tool
You can use the Hand tool to click and drag your view of the work area. This allows you to focus on a specific part of your image. Double-clicking the Hand tool ( ) or pressing [Ctrl]-[0] automatically maximizes your image within the document window.

View Menu
Another way to change the screen view is to use the View menu, which contains several commands for altering your document view—Zoom In, Zoom Out, Fit in Window, and Actual Size.

Navigator Palette
Move the red box in the Navigator palette to move your view around the artboard. To zoom in or out from an image, click the Zoom Out ( ) or Zoom In ( ) button, or drag the triangle icon below the slider ( ). You can also specify the zoom value directly in the text box in the bottom-left corner.

Status Bar
Type a magnification value in the Zoom pop-up menu in the status bar ( ) or click on the arrow icon ( ) to select a preset zoom value.

<< tip
Saving the View
If you've found a view that works for an image, you can save the view by selecting [View] - [New View]. When the New View dialog box appears, enter a name and click [OK]. To apply the view, look for the name of the view at the bottom of the View menu. This view will only be shown for the file with which it was saved.

Selecting Objects
Before you can move, color, or apply effects to objects, you must select them first. Objects are selected using selection tools found in the toolbox or by using menu commands.

Selection Tools
You can use the Selection tool ( ), Direct Selection tool ( ), Group Selection tool ( ), Lasso tool ( ), and the Magic Wand tool ( ) to select part or all of an object. The selection tools are covered extensively in Chapter 2.
Select Menu

The Select menu contains options for making selections.

<table>
<thead>
<tr>
<th>Select</th>
<th>Filter</th>
<th>Effect</th>
<th>View</th>
<th>Win</th>
</tr>
</thead>
<tbody>
<tr>
<td>All</td>
<td>A</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Deselect</td>
<td>B</td>
<td>Shift+Ctrl+A</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Reselect</td>
<td>C</td>
<td>Ctrl+E</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Inverse</td>
<td>D</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Next Object Above</td>
<td>E</td>
<td>Alt+Ctrl+[</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Next Object Below</td>
<td>F</td>
<td>Alt+Ctrl[-</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Same</td>
<td>G</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Object</td>
<td>H</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save Selection...</td>
<td>I</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Edit Selection...</td>
<td>J</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

A All: Selects all objects in the image.

B Deselect: Deselects the current selection.

C Reselect: Repeats the last selection command used.

D Inverse: Deselects the current selection and selects the previously unselected areas.

Choosing [Select] - [Inverse] deselects the yellow star (the current selection) and selects all the other stars.

E Next Object Above: Selects the object above the selected object.

F Next Object Below: Selects the object below the selected object.

G Same: The Same submenu contains options for selecting objects with the same attributes.

H Object: Use the Object submenu to select similar types of objects.
Manipulating Objects

The Edit and Object menus contain options for manipulating objects. In this section, you will learn to copy and paste objects using the Edit menu, and to group, ungroup, and lock objects using the Object menu.

Edit Menu

A Cut, Copy, and Paste: Because you will cut, copy, or paste objects frequently when using Illustrator, it helps to remember the keyboard shortcuts for these actions. Press [Ctrl]-[X] to cut, [Ctrl]-[C] to copy, and [Ctrl]-[V] to paste.

B Paste in Front and Paste in Back: The Paste in Front and Paste in Back commands let you paste an object on top of or behind other objects in your drawing.

<< note

Paste in Front and Paste in Back

The Paste in Front and Paste in Back commands can be used to make accurate drawings and create variations of an object, as shown in the following examples:

▲Select [Edit] - [Copy] to copy the oval.
▲Change the color and shape of the oval.
▲Select [Edit] - [Paste in Front] to paste the original copy in front.

▲Select [Edit] - [Copy] to copy the fish.
▲Change the color and size of the fish.
▲Select [Edit] - [Paste in Back] to paste the original copy behind the fish.
Locking Layers in the Layers Palette

The Layers palette can be used to lock layers. In the Layers palette, clicking in the Toggles Lock box of a layer will lock the layer. The lock icon (.ValidationError) will appear when the layer is locked. Clicking on the icon will unlock the layer and the icon will disappear.

Creating New Documents

The first few pages of this chapter dealt with using the welcome screen, including how the welcome screen can be used to create a new document. In this section, let’s look at other ways of creating new documents. For example, you can open a new document or use an existing template to create a new document.

A new document in Illustrator consists of a single page that you use to draw artwork. An Illustrator document cannot have more than one page.
Using the New Command

You can create a new document at any time by selecting [File] - [New] or by pressing the shortcut keys, [Ctrl]-[N]. When the New Document dialog box appears, enter your desired settings and click [OK].

![New Document dialog box]

**A** Name: Enter a name for the new document.

**B** Size: Sets the size of the new document.

**C** Units: Determines the unit of measurement for width and height.

**D** Color Mode: Choose the color mode of the new document—CMYK for printing and RGB for Web images.

**E** Orientation: Choose a portrait (Portrait) or landscape (Landscape) orientation for the document.

**F** Width and Height: Specifies the document size using width and height dimensions. If dimensions are entered manually, “Custom” will appear in the Size drop-down menu.

Using Templates

Templates are preset documents, and there is a wide variety of templates to choose from in Illustrator. There are blank templates for doing artwork in odd sizes, such as CD disc labels and business cards, and thematic templates such as designs for restaurant menus and postcards. In order to make a new document using a template, do the following:

1. Select [File] - [New from Template] to open the New from Template dialog box.

2. Double-click on a folder and navigate to a template. Click [New].
3. Edit or draw in the template to create your artwork.

Saving Documents

The File menu contains a number of commands for saving documents. The save commands can be used to create a file that is compatible with Illustrator CS, while the [File] - [Export] command can be used to create a file that is compatible with previous versions of Illustrator. Let’s have a look at these commands.

Using the Save and Save As commands

1. Click on [File] - [Save As] to open the Save As dialog box. Enter a file name, choose a file format, navigate to the desired save location, and then click [Save].

2. An Options dialog box will appear. In this case, choosing the Illustrator file format (*.ai) opens the Illustrator Options dialog box. Enter your desired settings and then click [OK]. More often than not, the default settings are used. See the note after this section for more information on the Illustrator Options dialog box.

3. The file will be saved with the name you entered in the Save As dialog box. Notice that the document title has been changed to the new name. Moving forward, you’ll be able to save your progress to the file using the [File] - [Save] command.
Other Save Commands

- **Save a Copy**: Saves a copy of the file while the current document remains active.
- **Save as Template**: Use this command to save a file you created as a template.
- **Save for Web**: Saves an image as a graphic for the Web.
- **Save for Microsoft Office**: Saves the document in PNG format for use in Microsoft Office.

Using the Export Command

The [File] - [Export] command can be used for saving files in a variety of file formats, including file formats for the Web and Microsoft Office. The advantage of using the Export command as opposed to using the save commands is that the Export command lets you adjust a variety of options before saving.

Depending on the file format chosen, options include resolution, opacity, and background color. Another advantage of using the [File] - [Export] command is that the command can be used to create a file that is compatible with previous versions of Illustrator.
Common File Formats
Illustrator supports a wide variety of file formats, and the following is a list of the more commonly used ones:

Adobe Illustrator (*.AI)
This is the basic Illustrator file format. It is advisable to work in this file format and only choose to save in another file format (if you wish) when the file is final. This is because you can only be certain that every aspect of your image is saved if you use the native Illustrator format.

Illustrator Legacy (*.AI)
This option saves the file in a format compatible with previous Illustrator versions. Some of the effects used in Illustrator CS are not supported by older versions; such effects will automatically be rasterized when saved in the Illustrator legacy format. This process will limit your ability to edit your image.

Illustrator EPS (*.EPS)
The EPS (Encapsulated PostScript) format is used for transferring image files across applications and platforms. For example, files created in Illustrator are saved in this format so that they can be imported into page layout programs. Although this format can be used to save paths, it does not save alpha channels.

Photoshop (*.PSD)
The PSD option exports the image as a Photoshop file while preserving layers. Photoshop is an image-editing program commonly used for creating and editing artwork, including photographs.

Macromedia Flash (*.SWF)
Flash is a program used for creating animated graphics that can include sound. Flash movies are popular on the Web and you can use Illustrator to create images for these animations. Saving a file in the Macromedia Flash format converts the layers in Illustrator into Flash frames.

BMP (*.BMP, *.RLE, *.DIB)
This is the native image file format for the Windows operating system. Bitmap formats support 24-bit color, but because they are not compressed, their file size is relatively large.

Adobe PDF (*.PDF, *.PDP)
The Photoshop PDF (Portable Document Format) format was created for compatibility with Adobe Acrobat. It ensures that documents appear the same regardless of the operating system in which they are opened.

CompuServe GIF (*.GIF)
The GIF (Graphic Interchange Format) format was developed as a compressed file format to reduce the size of image files sent over networks. It has since become a Web standard. The format supports
animations, offers good compression without losing quality, and can be used to save transparent frames. The primary drawback to GIF images is that they can only contain up to 256 colors (8 bit).

**JPEG (*.JPG, *.JPEG *.JPE)**

The JPEG (Joint Photographic Expert Group) format is a compressed file format used on the Internet for photographic or continuous-color images. This file format supports progressive viewing of images (i.e., the image will begin to appear before it’s completely downloaded) and can display up to 24 bits of color. Users can configure the compression rate to reduce file size. However, higher compression rates result in lower image quality.

**PICT (*.PCT, *.PICT)**

The PICT file format was created for use on Macintosh computers. RGB images saved as PICT files can be saved at a depths between 16 and 32 bits.

**PNG (*.PNG)**

The PNG (Portable Network Graphic) format can be used to create transparent images for the Web in 8-bit or 24-bit color depth. PNG offers compression without a loss of quality but can result in larger file sizes compared with JPEGs. Because it is a relatively new file format, its use can cause problems with browser compatibility.

**TGA (*.TGA, *.VDA, *.ICB, *.VST)**

The TGA (Targa) format was developed by Truevision for their Targa and Vista video boards. This format can be used on both PCs and Macs and supports 24-bit color, as well as 32-bit Web color.

**TIFF (*.TIF, *.TIFF)**

The TIFF (Tagged Image File Format) format, like EPS, was developed for compatibility with editing programs. It can be used across different types of computers and most graphic software programs. The LZW compression option doesn’t reduce quality and preserves channels. Compared with EPS files, TIFFs are faster and smaller. TIFF also supports ZIP compression and preserves transparent frames.

---

**Basic Color Concepts**

Before you start using Illustrator or any other graphics program, you need to grasp some basic concepts related to the use of color in graphics software. In this section, you will learn about color models and color modes.

**Understanding Color Models and Color Modes**

Color models and color modes affect the range of colors displayed on computer screens and printed files. Because colors appear differently on different computers and printers, it’s important to put some thought into how you set up color in your images—to ensure maximum consistency.
**Color Models**

Color models refer to a system of describing color. There are five color models in Illustrator—RGB, CMYK, Web Safe RGB, Grayscale, and HSB. To select a color model, click on the triangle button (▲) in the Color palette and choose a color model from the palette menu.

**Color Modes**

Color modes determine how an image will be output to a printer, and there are two color modes available in Illustrator—RGB and CMYK. You can choose the color mode when you create a new document or change it anytime using the [File] - [Document Color Mode] command.

As a rule, it is not advisable to switch back and forth between different color models or color modes because each color model and color mode has its own unique color range. This means that some of the colors you use may get turned into other colors when you switch between color models or modes, and the more often you switch, the more often your color scheme will be skewed.

**RGB Color Model and Color Mode**

The RGB color model describes the colors created by mixing red, blue, and green. This is the color system used by computer monitors and televisions. The three primary colors—red, green, and blue—create 16,800,000 colors when combined. You should use this color mode when creating or editing images on a computer. Note that mixing all three primary colors creates white light.

**CMYK Color Model and Color Mode**

The CMYK color model is used to describe the colors created by mixing cyan, magenta, yellow, and black inks. Note that mixing all four colors creates black. In real life (on a printing press), mixing all four colors is likely to create a dark grayish color because of the impurities in the dye, so avoid overblending the four component colors. This color model is primarily used for printing.
Web Safe RGB Model

This color model is derived from the RGB mode and includes colors that can be used safely on the Web. When the Web Safe RGB model is selected, each of the RGB colors in the Color palette uses 16-bit colors between the 00 and FF color values. The RGB color range is limited to ensure that colors appear consistently on any of the computers that might visit your Web page.

Grayscale Color Model

The Grayscale color model describes 256 shades of gray. In this mode, 0 represents black, 255 represents white, and all figures between 1 and 254 display increasingly dark shades of gray.

HSB Color Model

The HSB color model describes color using hue, brightness, and saturation values.

- **Hue**: Represents a spectrum of colors that differ only in color—not in brightness or saturation.

- **Brightness**: Represents the brightness or darkness of a color.

- **Saturation**: Determines the strength or intensity of the color.

Editing Stroke and Fill Attributes

Drawn objects are made up of a stroke (the line made by the object’s path) and a fill (the area inside the path). The color of a stroke or fill can be changed either in the toolbox or by using the Swatches or Color palettes. The thickness and style of a stroke can be adjusted in the Stroke palette.

Changing Stroke and Fill Colors

When a file is first opened or created, Illustrator will set the fill color to white and the stroke color to black by default. If you don’t want to use any color, click the None icon (☐) in the toolbox or the Color and Swatches palettes.
**Using the Toolbox**

You can change the fill or stroke colors by double-clicking the Fill or Stroke color boxes in the toolbox to open the Color Picker and select a new color.

**Using the Color or Swatches Palette**

Before you change a fill or stroke color, you will need to select the Fill or Stroke color box in the toolbox or Color palette. Pressing the [X] key toggles between the Fill and Stroke color boxes.

**Color Palette**

The RGB color sliders in the Color palette can be adjusted to blend a color. You can also type in the color values directly or click on a color in the color spectrum. Clicking on the triangle icon (▲) opens the Color palette’s pop-up menu, from which you can change the default RGB color mode to Grayscale, HSB, CMYK, or Web Safe RGB.

- **Fill Color**: Click to activate the fill color, then blend the color in the Color palette. Double-clicking it opens the Color Picker, which contains additional color options.
- **Stroke Color**: Click to activate the stroke color, then blend the color in the Color palette.
- **None**: Click to select no color.
- **Color Spectrum bar**: Click on this to select a color instantly.
- **Color Sliders**: Use the color sliders to alter the component color values.
- **White/Black**: Click to choose white or black.
- **Palette Menu**: Contains options for changing the color mode.
Swatches Palette
You can select preset colors, gradients, and patterns from the Swatches palette; these can be used for both fills and strokes. Using the Swatches palette, you can select process colors, global process colors, nonglobal process colors, and spot colors. Choosing [Open Swatch Library] from the palette’s pop-up menu allows you to add more swatch libraries.

You can save a color you mixed to the Swatches palette by clicking the New Swatch icon ( ). If you create or modify a swatch library, you can save it by selecting [Save Swatch Library] from the pop-up menu. Saved swatch libraries can be accessed by selecting [Open Swatch Library].

A Process Colors: Process colors are mixed by combining one or more of these four colors: cyan (C), magenta (M), yellow (Y), and black (K). These colors represent the inks used in commercial printing, so this color system (CMYK) is suitable for print documents but not for Web images, which use the RGB (red, green, blue) color system.

B Gradients: Gradients can only be used as fills. Gradients are created using the Gradient and Color palettes.

C Global Process Colors: When you edit a global process color swatch, all objects using that color are updated. This way, you don’t have to change the color for each of the objects separately.

D Spot Colors: A spot color is a matched or exact color that is not created by mixing cyan, magenta, yellow, and black inks. A spot color is a premixed ink that you specify using a color matching system such as PANTONE. Unlike process colors, which can deviate from printer to printer, you can tell exactly how a spot color will look when printed by referring to a color book from PANTONE (or whichever color system you’re using). When you update a Spot Color swatch, all objects using the color will be updated.

E Show All Swatches: Show all swatches.

F Show Color Swatches: Show only color swatches.

G Show Gradient Swatches: Show only gradient swatches.

H Show Pattern Swatches: Show only pattern swatches.

I New Swatch: Make a new swatch.

J Delete Swatch: Delete the selected swatch.

K Patterns: Repeating patterns can be applied to both fill and stroke colors. To create a pattern swatch, create the pattern on the page and then drag it into the Swatches palette.
Changing Stroke Thickness and Style

The Stroke palette is used to adjust an object’s stroke thickness and style.

1. To apply a swatch color to an object, select the areas in the object to be changed and click on the desired swatch in the Swatches palette. In this example, the hat, scarf, and sack of the Santa piggy are selected and then the Global Red swatch in the Swatches palette is clicked to apply the color.

2. Double-clicking on a swatch opens the Swatch Options dialog box. In this case, we’ve double-clicked on the Global Red swatch to open the Swatch Options dialog box.

3. The new color is automatically applied to the areas containing the Global Red swatch.

Using the Swatches Palette

To apply a swatch color to an object, select the areas in the object to be changed and click on the desired swatch in the Swatches palette. In this example, the hat, scarf, and sack of the Santa piggy are selected and then the Global Red swatch in the Swatches palette is clicked to apply the color.

Double-clicking on a swatch opens the Swatch Options dialog box. In this case, we’ve double-clicked on the Global Red swatch to open the Swatch Options dialog box.

The new color is automatically applied to the areas containing the Global Red swatch.

**Changing Stroke Thickness and Style**

The Stroke palette is used to adjust an object’s stroke thickness and style.

- **Weight**: Adjusts the stroke thickness.
- **Miter**: Sets the limit for when the stroke corners change from pointed corners to squared-off corners. For example, at the default miter limit of 4, a corner squares off when the length of the corner is 4 times the stroke thickness. A Miter value of 1 squares off all the corners.
**Dashed Line:** Checking this option lets you create a dashed line by entering values for up to three dash and gap lengths.

**Dash:** Sets the length of a dash.

**Gap:** Adjusts the spacing between dashes. When using Butt Caps ( ), the gap starts at the end. When using Round Caps ( ) or Square Caps ( ), the gap starts at the center of the dashed line and extends to the end.

![Using the Same Dash Value of 10 Points and Gap Value of 23 Points on a Line with Butt Caps (Left) and a Line with Round Caps (Right)](image)

**Join:** Select one of the corner styles—Miter Join ( ), Round Join ( ), or Bevel Join ( ).

![From Left to Right: Miter Join, Round Join, and Bevel Join](image)

**Cap:** Select a style for the end point—Butt Cap ( ), Round Cap ( ), and Projecting Cap ( ).

![From Left to Right: Butt Cap, Round Cap, and Projecting Cap](image)

<< note

**Undo**

You can use [Edit] - [Undo] to undo one or more previous steps. [Edit] - [Redo] reverses a previous Undo command.

<< note

**Eyedropper Tool and Paint Bucket Tool**

The Eyedropper tool and the Paint Bucket tool can be used to copy the attributes of an object and apply them to another object. The Eyedropper tool affects all the paint attributes of an object. Double-click on the tool to access its dialog box and adjust the scope of the tool.

![Use the Eyedropper tool to create a color sample. Click the Paintbrush tool on another object to apply the color.](image)
In the CS version of Illustrator, moving, scrolling, printing, and file saving are all much faster. Working across multiple artboards is also much speedier. In addition to these improvements, the following new features have been added.

**3D Effects**

Among all of the new features in Illustrator CS, the flashiest one has got to be the 3D effect option. The 3D submenu, which is found under the Effect menu, contains the Extrude and Bevel, Revolve, and Rotate commands. Using the Extrude and Bevel and Revolve commands, two-dimensional vector objects can be turned into three-dimensional objects. The Rotate command rotates two- and three-dimensional objects in three-dimensional space.

**New Type Options**

One of the best improvements in Illustrator CS applies to typography. Let’s look at the new typography features one by one:

**Type On a Path Submenu**

There are more options now for positioning type on a path. The [Type] - [Type on a Path] submenu contains five preset alignment settings for placing type on a path. These preset alignment settings—named Rainbow, Skew, 3D Ribbon, Stair Step, and Gravity—are also found in the Type on a Path Options dialog box. The Type on a Path Options dialog box also contains options for adjusting spacing and alignment.
Font Menu

The newly improved font menu displays a font name in the font face itself, making it much faster and easier to select your desired font.

<table>
<thead>
<tr>
<th>Font Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arial</td>
</tr>
<tr>
<td>Arial Black</td>
</tr>
<tr>
<td>Arial Narrow</td>
</tr>
<tr>
<td>ITCA New Baskerville</td>
</tr>
<tr>
<td>Baskerville Modern Std.</td>
</tr>
<tr>
<td>Bookman</td>
</tr>
<tr>
<td>Bookman Old Style</td>
</tr>
<tr>
<td>Brush Script Std Medium</td>
</tr>
<tr>
<td>Century</td>
</tr>
<tr>
<td>Century Gothic</td>
</tr>
<tr>
<td>Century Old Style Std.</td>
</tr>
<tr>
<td>Chaparral Pro</td>
</tr>
<tr>
<td>CHARLEMAINE STD</td>
</tr>
<tr>
<td>COMIC SANS</td>
</tr>
<tr>
<td>Comic Sans Italic</td>
</tr>
<tr>
<td>Courier</td>
</tr>
</tbody>
</table>

Every-line Composer Command

The new Every-line Composer command is found in the Paragraph palette’s pop-up menu. When the command is selected, it automatically evens out the spacing between words and letters, and determines how best to break lines in a paragraph to minimize the use of hyphenation and maintain consistent line lengths.

The Single-line Composer command, which is not new to Illustrator CS, performs the same function as the Every-line Composer command, but does it line by line, rather than to the entire type area. Both of these commands work with the area type tools and the type on a path tools.

Optical Kerning and Optical Margin Alignment

Both the Optical Kerning and Optical Margin Alignment commands are new and are used for adjusting spacing. The Optical Kerning command, which is found in the Character palette, automatically modifies the space between characters (i.e., kerning). In previous Illustrator versions, kerning had to be adjusted manually when the built-in kerning for character pairs in a given font did not create satisfactory results. To activate Optical Kerning, go to the [Set the kerning between two characters] option in the Character palette and select Optical.
OpenType Font Support

With Illustrator CS, there is now support for the OpenType font format. OpenType fonts are compatible across Windows and Macintosh operating systems and they support a wider range of glyphs and characters. In addition, some OpenType fonts contain ligatures that can be activated in Illustrator to replace certain characters. Ligatures are character combinations that are designed as a single unit. For example, “1/2” can be turned into “½” when the Fractions option is selected in the OpenType palette.

Another new kerning feature is the [Type] - [Optical Margin Alignment] command. The Optical Margin Alignment command is used for keeping the left and right margins of a text area aligned by changing the position of punctuation and characters at the edge.
Paragraph Styles and Character Styles Palettes

Commonly used paragraph and character settings can be saved in the Paragraph Styles and Character Styles palettes, respectively. These two new palettes make it possible to maintain a consistent style throughout your artwork when editing characters, lines, or entire paragraphs.

Glyphs Palette

Earlier in this chapter, you learned that glyphs are special characters or symbols that are not found in the alphabet. Every font has its own set of glyphs, and with Illustrator CS you can now view and insert a glyph simply by double-clicking on it in the Glyphs palette.

Tab Leaders

Tab leaders are the dots and patterns that appear when the [Tab] key is hit. Tab leaders are created and edited in the Tabs palette. You can open this palette by selecting [Window] - [Type] - [Tabs].

Improved Row and Column Features

After text has been entered into a text area, the text area can be split and the text distributed quickly into rows and columns. With the text area selected, choose [Type] - [Area Type Options] to open the Area Type Options dialog box and split the text area into rows and columns.

▲ Insert the number of rows and columns needed and click [OK] (left); the text will be distributed into two columns.
**Scribble Effect**

The Scribble effect (the name says it all) creates artwork that looks scribbled. The casual, hand-drawn style is great for creating friendly, inviting designs. The command is found at [Effect] - [Stylize] - [Scribble].

**Enhanced Adobe PDF Support**

PDF is the native file format for the Adobe Acrobat program. PDF files are widely used because they are compatible across many platforms and the Acrobat Reader program used for reading PDF files can be downloaded for free. In Illustrator CS, support for Adobe PDF has been enhanced to include compatibility with the Adobe Acrobat 6.0 program and the Adobe PDF 1.5 file format. This feature is useful for sharing artwork with clients or friends who lack the Illustrator program. Other new improvements include support for layers, printer marks and bleeds, and more security options.

**Expanded Print Capabilities**

The user interface for sending artwork to print has been streamlined to make the process smoother and faster. The Page Setup and Separations Setup dialog boxes have been removed and their functions consolidated into the Print dialog box. Using the Print dialog box, frequently used print settings can be saved as print presets which can be loaded when needed.

**Integration with Microsoft Office**

The Save for Microsoft Office command can be used to save an Illustrator file so that the artwork can be opened in Microsoft Office applications such as Powerpoint, Excel, and Word. Files saved using this command work on both Windows and Macintosh operating systems.
Templates

There are more than 200 different design templates in Illustrator CS. Templates are a great source of inspiration and can help you get started on a new project. All the elements in a template can be altered to create unique images. For example, if you need to create a CD label, you can use one of the CD templates just to get the CD label’s dimensions right. The design of the CD can then be changed to suit your personal style.

Templates are opened as new files. Making changes to and saving these new files will not affect the original template in any way.

You can also save your own designs as templates, especially when working on a large project for which you need to maintain a consistent design.

A template saved by using the [File] - [Save As Template] command.