
The Maya Interface

The Maya interface can be a bit intimidating, and it’s not fair to expect

yourself to pick it right up and remember where everything is. As you will see throughout

this book, the best way to learn Maya is to put it to task, and you can use this chapter as a

reference to the interface and the many windows and functions you will find yourself

using in your work.

Try not to rush it, and don’t be overly concerned with customizing the keys and using

shelves or the hotbox for now; just access your commands and functions through the menus.

Of course there are a few exceptions to this, as we’ll see in Chapter 2, “Quick Start: Creat-

ing an Animation in Maya 8.5,” but for the most part it is highly recommended that you

familiarize yourself with where everything roughly should be through the menu system.

This chapter is a look at how to access functions and a fairly complete rundown of the

often-used windows in Maya to get you familiar with their workings. Without further ado,

let’s get to the interface that makes Maya what it is.

■ The interface

■ Getting around

■ Scene windows

■ Window layouts

■ The hotbox

■ Menus and shelves

■ The Outliner and the Hypergraph

■ The Channel Box and the Attribute Editor

■ The Timeline

■ The Command line, the Feedback line, and the Script Editor

■ Customizing the interface
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The Interface
You can perform almost every task in Maya in more than one way. The most common

way to access functions and tools is through the menu. In addition to menus, you can

access functions through icons in the shelf, through hot keys, through marking menus,

and through the hotbox. This is one of the charms of Maya and helps make it one of the

most powerful CG creation tools on the market. Its adaptability to individual work flows

makes it an essential tool for artists. This can be a double-edged sword for beginners

though, since they often find themselves overwhelmed as to where to go or how to pro-

ceed. You will see all these options throughout the book and a rundown of them in this

chapter. We recommend you familiarize yourself with the menus first and then get into

the productivity-enhancing shortcuts.

If you are already experienced with other CG software and find it easy to get around in

Maya, you can just use this chapter as a reference to come back to when you’re already

steeped in your scene. Artists who used other packages say that Maya’s work flow and inter-

face are important to learn because they can offer a faster, more efficient way of working.

If you’re new to Maya and have not had a chance to set any defaults for yourself, reset

the interface to the default settings to make sure everything lines up between your work

and the exercises in this book. Choose Window ➔ Settings/Preferences ➔ Preferences. In

the Preferences window, choose Edit ➔ Restore Default Settings. This should restore set-

tings to their original state. Be careful not to reset someone else’s settings, though, if you

are on a multiuser computer.

Let’s take a look at what elements make up the default Maya screen, which is shown in

Figure 1.1.

The reason we specifically mentioned the default Maya screen is that Maya has a highly

customizable interface that you can tailor to the way you like to work. As you become

experienced with Maya, you will begin customizing the interface for yourself easily. As an

inexperienced user, it’s best to leave everything at the default to have a level playing field.

In addition, for those systems that have multiple displays, Maya fully supports using a

secondary display as long as your video card is capable. Keep in mind that both displays

should be set to the same resolution and refresh rate for best OpenGL performance.

Experienced users should focus on the section “Customizing the Interface” later in

this chapter.

The Nickel Tour
Let’s take a look at the interface and identify the parts of the UI.

Running across the top of the screen (see Figure 1.1) are the main menu bar, the Status

line, and the shelf. These provide access to the many functions in Maya. Running vertically

to the left of the screen is the Tool Box, giving you fast access to common tools to manipulate

your objects. Across the screen are the Channel Box/Layer Editor and sometimes the

Attribute Editor. (The Attribute Editor is not displayed in Figure 1.1.) This part of the 
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screen gives you access to information on the objects in your scene and allows you to

manipulate and organize them as well.

Running horizontally at the bottom of the screen are the Time Slider and the Range

Slider. These give you access to various functions and feedback from Maya itself.

In the middle of all these elements is the workspace, which hosts your view panels (or

scene windows) and their own scene menus. These panels are known as views or viewports

in some other 3D packages. You can change the options for each panel through its scene

menus, from changing its view to changing how objects are displayed. Essentially, these

panels are where you create and manipulate your 3D scenes. Figure 1.1 shows the panels

with a grid displayed. This grid represents the ground axis of your 3D space and is useful

for orienting yourself, especially in the perspective views.

Workspace 

Title bar 

Layer Editor 

Channel Box 

Help line 

Command line 

Range Slider 

Time Slider 

Tool Box 

View Compass Scene menu bar 

Shelves 

Status line 

Main menu bar
Figure 1.1

The Maya 8.5 
interface
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The Workspace
When you first launch Maya, you will be presented with a full-screen perspective view, as

shown in Figure 1.2. This view is essentially the view from a camera and shows real-world

depth through the simulation of perspective. You use this window to see your scene in

three dimensions. You can also move around a perspective view in real time to get a sense

of proportion and depth.

Press the spacebar while in the panel to switch from the full-screen perspective to the

four-panel layout originally shown in Figure 1.1. The four-panel layout shows the per-

spective view as well as three orthographic views (top, front, and side), each from a differ-

ent side. Pressing the spacebar again returns your active view panel to full-screen mode.

Orthographic views are usually used for modeling and scene layout, because they con-

vey exact dimensions and size relationships better than perspective views, as shown in

Figure 1.3. Even though the cubes in this scene are all the same size, the perspective view

displays the cubes farther away as being smaller than those closer to you. Orthographic

views display proper proportions so you can see the four cubes identical in size and shape

as well as their position in the scene.

Figure 1.2

The full 
perspective view
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You can use any of the six presets in the Tool Box on the left side of the screen to adjust

the panel layouts of your screen. You can also go through the main menu to make adjust-

ments by choosing Window ➔ Saved Layouts. Furthermore, you can change any panel’s

view by choosing another panel name from the Panels menu (this menu is found just

above any panel), shown in Figure 1.4. You can choose any modeling view, orthographic

or perspective, or another window to best suit your work flow. Last, you can change the

size of any of the panels by clicking and dragging the separating borders between the

panels.

The panels display a grid that you can use to align objects

and for a general sense of placement and position. You can

adjust the size and availability of the grids by choosing Dis-

play ➔ Grid ❒. The grid is made of actual units of measure

that you can adjust. Choose Window ➔ Settings/Prefer-

ences ➔ Preferences to open the Preferences dialog box, and

in the Settings section make your adjustments.

Figure 1.3

The four-panel 
layout
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You can change
your panel view
through the scene
menus in each of the
panel views.
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Getting Around
What’s the use of all these views and UI elements if you can’t get around? Just as with

every other program on a computer, you will be using the keyboard and mouse to interact

with Maya, although perhaps more in tandem with each other. Maya relies on the Alt key

a great deal for the navigation in its work windows. Also, Maya requires the use of a three-

button mouse, even with a Macintosh system. On a Macintosh, the Option key doubles as

the Alt key. You use one of the mouse buttons in conjunction with the Alt key to move in

your scene.

The Mouse Controls

The left mouse button (LM) is the primary selection key in Maya and is the most often

used, obviously. But as far as getting around in a scene, when used with the Alt key, the

LM button tumbles or orbits around your scene in perspective (camera) panels. The right

mouse button (RM) activates shortcut menus, as it does in many software programs, and

also Maya’s system of marking menus, which are similar to shortcut menus. (For more on

marking menus, stayed tuned to this chapter.) The RM button also allows you to dolly

into or out of your scene. Dollying moves the camera closer to or farther from your sub-

ject in the scene. It is not accurate to call this type of move a zoom, though it often is,

because a zoom changes the focal length of the lens of the camera as opposed to physically

moving it in relation to the subject. Finally, the middle mouse button (MM) used with the

Alt key allows you to pan around the scene, as well as acting as a virtual slider. You will see

an example of a virtual slider later when we discuss the Channel Box.

Also note that if your mouse has a clickable middle wheel, you can use the wheel itself

to dolly into or out of a Maya scene simply by rolling it up or down. This move is the same

as an Alt+RM move. You may have to set up your mouse functions (through the mouse

driver itself) for the mouse wheel to behave as a mouse’s middle button when pressed.

View Compass

The View Compass, shown in Figure 1.5, lets you switch your view in the active panel. A

panel, of course, is one of the working views in Maya; the workspace is shown through

the panels in Maya’s UI. By clicking one of the compass’s axes, represented by the cyan,

red, green, and blue cones, you can quickly change the active view to an orthographic view.

Clicking the cyan cube at the heart of the View Compass returns you to your perspective view.

The Main Menu Bar
Starting with the menu bar, shown in Figure 1.6, you’ll find a few of the familiar menu

choices you’ve come to expect in many applications, such as File, Edit, and Help.

Figure 1.6

The main menu bar

6 ■ chapter 1: The Maya Interface

Figure 1.5

The View Compass

28453c01.qxd  2/26/07  3:57 PM  Page 6



C A M E R A  M O V E M E N T  T E R M I N O L O G Y

Every kind of camera move has a different name. The following lists the type of camera

moves you have and what each one means:

• Rotate (Tumble) view means to rotate the (perspective) camera; hold down the Alt key

and the left mouse button, and then drag in the perspective window to rotate the view.

This action physically moves the camera around the subject and can be effective only in

a perspective view panel.

• Move view means to move any camera; hold down the Alt key and the middle mouse

button, and then drag in any scene window. This will move the camera horizontally or

vertically in the scene, effectively panning the view.

• Dolly view means to scale—commonly called a zoom—any camera; hold down the Alt

key and the right mouse button (you can also hold down both the LM and MM), and

then drag in any scene window to zoom (or scale) the view in or out.

This setup allows a straightforward Alt key plus mouse button mapping of left=rotate,

middle=pan, and right=zoom.

In Maya, your exact menu choices depend on your current menu set. By switching

menu sets, you change your menu choices and the set’s corresponding toolset. It may seem

strange at first, but it makes the best sense to divide the menu headings into what kind of

task you are involved in. The menu sets in Maya Complete are Animation, Polygons, Sur-

faces, Dynamics, and Rendering; Maya Unlimited adds the Classic Cloth, nCloth, and

Maya Live menu sets to those four. The menu sets are available through the Status line,

which is discussed in the next section.

The first six items in the main menu are constant, no matter what menu set you are in:

File, Edit, Modify, Create, Display, and Window. The last menu, Help, is also constantly

displayed. Their functions are as follows:

File Contains file operations, from saving and opening to optimizing scene size and

export/import.

Edit Gives you access to the commands you use to edit characteristics of the scene, such

as, for example, deleting and duplicating objects or undoing and redoing actions.

Modify Lets you edit the characteristics of objects in the scene, such as moving or scaling

them or changing their pivot points.

Create Lets you make new objects, such as primitive geometries, curves, cameras, and so on.

Display Contains commands for adjusting elements of the GUI (graphical user interface)

in Maya as well as objects in the scene, allowing you to toggle, or switch on and off, the

display of certain elements as well as components of objects, such as vertices, hulls, pivots,

and so on.
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Window Gives you access to the many windows you will come to rely on, such as the

Attribute Editor, Outliner, Graph Editor, and Hypergraph. The Window menu is broken

down into submenus according to function, such as rendering editors and animation editors.

Help Gives you access to the extensive Maya help documentation in HTML format.

You’ll notice two different icons to the right of some menu items: arrows and boxes

(called option boxes). Clicking an arrow opens a submenu that contains more specific

commands. Clicking an option box (❒) opens a dialog box in which you can set the

options for that particular tool.

Tear-Off Menus

At the top of every menu is a double line. Clicking the double line allows you to tear off

the menu and place it as a toolbox anywhere on your screen (or screens if you have dual

displays enabled). These tear-off menus are also called floating menus. Creating a tear-off

menu makes accessing menu commands easier, especially when you need to use the same

command repeatedly. Let’s say, for example, that you need to create multiple polygonal

spheres. You can tear off the Create ➔ Polygonal Primitives menu and place it at the edge

of your screen. You can then click the Sphere command as many times as you need with-

out opening the dual-layered menu every time.

The Status Line
The Status line (see Figure 1.7) contains some important icons.

The first item in the Status line is the menu set drop-down menu. Selecting a particular

menu set changes the menu headings in the main menu bar as we discussed earlier. You 

Click here and drag to tear off menu.

8 ■ chapter 1: The Maya Interface

28453c01.qxd  2/26/07  3:57 PM  Page 8



will notice immediately after the menu set drop-down menu, and intermittently through-

out the Status line, black vertical line breaks with either a box or an arrow in the middle.

Clicking a break opens or closes sections of the Status line.

Scene File Icons

The first section of tool icons in the Status line deals with file operations:

I C O N N A M E D E S C R I P T I O N

New Scene Creates a new, blank scene file

Open Scene Displays a window in which you can find and open any
scene file you’ve saved

Save Scene Displays a window in which you can specify a filename and
location to save a new scene or, if the current scene has
already been saved and named, save it to that location

Selection Modes

The second section is the Selection Mode field. This drop-down menu lets you use presets

for selection masks. Selection masks give you the opportunity to choose one kind of object

but not another. You can, therefore, select all the particles in the scene and none of the

polygon models. This is useful when you have a heavy scene and you need to select some

objects and not others. By choosing the type of objects you want to be able to select, you

can speed up your work flow in large scene files. The menu selections here give you a few

presets to optimize the selection modes for your convenience according to your current

work flow (for example, select only deformers in a scene, or select from just the dynamic

objects such as particles).

Presets are fine and good, but you might prefer to use the individual selection mask

icons farther down the Status line to gain more control—you can turn on and off whether

you can select individual object types such as particles, NURBS, polygons, and so on. We

will cover these in just a moment.

The next group of icons in the Status line lets you click into three distinct selection modes.

Maya is based on object hierarchy, in which components make up objects that can make

up larger objects and so on. You will see this in action in the next chapter in the Quick

Start exercise. Selection modes let you choose different levels of an object’s hierarchy. For

example, using a selection mode, you can choose an entire group of objects, only one of

the objects in a group, or just the points on the surface or the poly faces that make up an

object. The primary selection modes are object mode and component mode:

Figure 1.7

The Status line
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I C O N N A M E D E S C R I P T I O N

Hierarchy Mode Lets you select groups of objects or parts of a group

Object Mode Lets you select objects such as geometry, cameras, lights,
and so on

Component Mode Lets you select an object’s components, such as vertices,
faces, or the control vertices (CVs) of NURBS surfaces

For example, if you have grouped several objects together, being in hierarchy mode

and clicking any of the member objects selects the entire group of objects. Being in object

mode selects just the object you click. To toggle between object and component modes,

press the F8 key, the default hot key.

Individual Selection Masks

The next set of icons between the section breaks deals with individual selection masks,

which give you control over which objects or components you want to select. Exactly which

icons are displayed here depends on the selection mode you’re currently in. If you have

many objects in your scene and you are having difficulty selecting a certain type of object

with your cursor, you can use these filters to single out the object(s):

I C O N N A M E D E S C R I P T I O N

Set Object Selection Mask Turns on or off all selection icons

Select By Handles Allows selection of object handles

Select By Joints Allows selection of joints

Select By Curve Allows selection of curves

Select By Surfaces Allows selection of surfaces

Select By Deformations Allows selection of lattices and other deformers

Select By Dynamics Allows selection of particles and dynamic objects

Select By Rendering Allows selection of rendering nodes and objects
such as lights and cameras

Select By Miscellaneous Allows selection of miscellaneous objects such as
locators and dimensions

Lock Selection Keeps selected objects locked in as selected

Highlight Selection Mode Turns off the automatic display of components
when selecting in selection mode

You can get a quick preview of what each icon is called by rolling your mouse pointer

over and hovering on each icon to see a pop-up tooltip that gives the icon name and

describes its function. As a matter of fact, this is a great way to get to know Maya’s UI—

in addition to reading every word of this chapter, of course.
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Snapping Functions or Snaps

The “magnet icons” are called snaps. Snaps let you snap or lock your cursor or object to

specific points in the scene. You can snap to other objects, to CVs or vertices, and to grid

intersections and more by toggling these icons. You can also enable some snaps by holding

down their respective hot keys. While the respective key is pressed, your manipulator cur-

sor will turn from a square to a circle.

I C O N N A M E H O T  K E Y D E S C R I P T I O N

Snap To Grids x Lets you snap objects to inter
sections of the view’s grid.

Snap To Curves Lets you snap objects along a
curve.

Snap To Points v Lets you snap objects to object
points such as CVs or vertices.

Snap To View Planes Lets you snap objects to view
planes.

This has nothing to do with snap-
ping. It lets you create objects such
as curves directly on a surface.

Input and Output Connections

The two icons to the right of all the filters list the input and output connections of an

object, and the third icon toggles on/off construction history. Objects in Maya can con-

nect with each other for any variety of purposes, from animation to rendering. When an

object is influenced by any attributes of another object or node in Maya, that object has an

input connection. When a node’s own attribute(s) is influencing another object, that node

has an output connection. Now these icons aren’t used that often in a typical work flow, but

it’s good to know what they are nonetheless. You will see much more work with input and

output connections throughout this book, especially when rigging scenes for animation or

creating shaders.

This third icon is for toggling on and off construction history. Construction history

keeps track of the nodes and attributes that help make up an object, making it easier to

edit those objects that have history.

I C O N N A M E D E S C R I P T I O N

Input Connections Lets you select and edit all the input connections for the
selected object. That is, you can select and edit any object
that directly influences the selected object.

Output Connections Lets you select and edit the output connections or any
objects the selection affects.

Construction History Toggles on/off the construction history.

Make The Selected
Object Live

the interface ■ 11

28453c01.qxd  2/26/07  3:57 PM  Page 11



Render Controls

The next three icons give you access to render controls:

I C O N N A M E D E S C R I P T I O N

Render Current View Renders the active viewport at the current frame.

IPR Render Current View Renders the active view at the current frame into
Interactive Photorealistic Rendering (IPR). You can
change certain shading and texturing settings and
view real-time updates in the IPR window.

Render Settings Opens a window that gives you access to all the ren-
dering switches such as resolution, file type, frame
range, and so on.

Input Box

New to Maya 8.5, the Input Box allows you to quickly transform, rename, or select objects

and components. By clicking the arrow icon to the left of the input fields, you can choose

the following operations:

I C O N N A M E D E S C R I P T I O N

Absolute Transform Translates an object or component in a speci-
fied axis in reference to their original creation
position.

Relative Transform Translates an object or component in a speci-
fied axis in reference to their current position.

Rename Edits the name of the currently selected
object.

Select By Name Selects objects by their name. You can use
the asterisk and text to select all objects with
specified prefixes or suffixes.

The Channel Box/Layer Editor

The last part of the Status line deals with the area defined as the Channel Box/Layer Editor.

These icons toggle through three available views in the area on the right side of the screen.

Clicking the first button displays the Attribute Editor on the right part of the screen, with

which you can edit Maya’s object attributes. Clicking the second turns on a window called

Tool Options on the right part of the screen, giving you access to options for the currently

active tool. Clicking the last icon restores the Channel Box/Layer Editor, showing you the

most commonly animated attributes of an active object as well as the display and render

layers in your scene.
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I C O N N A M E D E S C R I P T I O N

Show/Hide Attribute Editor Displays the Attribute Editor in this area

Show/Hide Tool Settings Displays the current tool’s settings

Show/Hide Channel Box/Layer Editor Displays the Channel Box and Layer Editor

The Shelf
The shelf, shown in Figure 1.8, is an area where you keep icons for tools. The icons are

separated into tabs that define the functions for the tool icons in the shelf. Select the

appropriate tab in the shelf for what you’re doing to access an array of common tool icons

for that work flow. You can populate a Custom tab with the tools you find most useful for

your own work flow.

To customize the shelf so that your favorite tools are immediately accessible, click the

Menu icon ( ) to open a menu to edit the shelf. To simply add a menu item to the shelf,

press Ctrl+Alt+Shift while selecting the command from any main menu (for Mac

users, press F+Option+Shift). That tool’s icon will then appear on the current shelf.

To get rid of a shelf item, MMB drag the icon to the Trash icon to the right of the shelf.

You can create multiple shelves, stack them on top of each other, and access them by

clicking the Shelf Tab icon ( ) above the Menu icon to the left of the shelf. As with the

icons on the Status line, moving your mouse pointer over an icon in the shelf displays a

tooltip that gives you the name and a description of that icon.

It’s a good rule of thumb to know where the tools in the shelf are found in the menu,

so if you are just starting out in Maya, try using the menus first before getting used to the

shelf. It may be a bit more work, but it will give you a better understanding of how Maya is

laid out.

The Tool Box
The Tool Box, shown in Figure 1.9, displays the most commonly used tools: Select, Lasso

Select, Translate (or Move), Rotate, Scale, Universal Manipulator, Soft Modification, and

Show Manipulator. These tools are most often accessed with hot keys. By default the lay-

out is simple. The most-used tools—Select, Move, Rotate, and Scale—are mapped to the

keys Q, W, E, and R, as shown in the following list. (Keep in mind that Maya’s hot keys are

case sensitive, which means that all commands in this book should be read as lowercase,

even though they may be printed as uppercase. When an uppercase hot key is needed, it is

referred to in this book as Shift+key.)
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I C O N N A M E H O T  K E Y D E S C R I P T I O N

Select q Lets you select objects

Lasso Select Allows for a free-form selection using a
lasso marquee

Paint Selection Tool Allows you to select components by
painting over them with a brush (new 
to Maya 8)

Translate (Move) w Moves selection

Rotate e Rotates selection

Scale r Scales selection

Universal Manipulator Allows for translation, rotation, and scale
within one tool

Soft Modification Allows you to modify an area with a
gradual drop-off of its effect

Show Manipulator Displays an object’s specific manipulators

Current Tool Display t Shows the currently selected tool
(shown as blank)

In addition to these common tools, the Tool Box contains icons for several choices of

screen layouts to let you change your interface quickly. This is convenient because differ-

ent scenes and work flows can call for different view modes. Experiment with the layouts

by clicking any of the six presets in the Tool Box.

The Channel Box
The area running vertically on the right side of the screen is usually for the Channel 

Box with the Layer Editor immediately below it. The Channel Box is a key element in

Maya. It lists the commonly animated attributes of a selected object and lets you quickly

adjust attributes and add animation and expressions without having to open the Attribute

Editor (which is the window that lists all the attributes of an object; more on this later

in this chapter). In addition, you can easily see input connections on an object’s attrib-

utes through color coding. This way you can tell if an object is animated, constrained

to another object, has an expression controlling it, is dynamic, or so on. Figure 1.10

shows the Channel Box with the Layer Editor just below it. The selected object shown

in the Channel Box here is a polygon sphere with several connection types displayed as

different colors.
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Attribute Display in the Channel Box

The following list shows the colors and their connections for the attributes in the

Channel Box:

I N P U T  C O N N E C T I O N C O L O R D E S C R I P T I O N

Keyframed Orange A keyframe is set for the attribute at some point in
the Timeline.

Yellow This attribute shares the same value as another
attribute on another object or has dynamic forces
affecting it.

Expression Control Purple A written expression controls the value of this
attribute.

Constraint Blue The attribute’s value is constrained to the value of
an attribute of another object.

Locked Gray You cannot change the value without first unlock-
ing the attribute.

Muted Animation Brown There is animation on the attribute, but it is currently
muted so it will not play back until it is unmuted.

Green The value of this attribute is blended with the value
of another attribute.

Nonkeyable Light Gray This attribute cannot be animated.

Editing Attribute Values in the Channel Box

When an object is selected, its name appears at the top of the Channel Box. You can click

the name and type a new name to rename the selected object. The channels (keyable attrib-

utes) for that object are listed vertically below with the attribute name to the left and the

attribute value to the right in text boxes. You can click in the text box to change the value

through the keyboard. You can also use a virtual slider in Maya by clicking a channel’s

name in the Channel Box and using the MM in a view panel to drag left or right to decrease

or increase the value of the selected channel.

If you RM click an attribute name in the Channel Box, you will see a context menu 

that gives you access to several common commands, such as keyframing or locking and

unlocking the selected channel or channels. You can animate any channel here by RM

clicking the attribute name and choosing Key Selected from the shortcut menu. RM click-

ing the value itself displays a shortcut menu from which you can cut and paste values.

Another useful shortcut menu command is Break Connections, which removes any

connections for the selected attributes and returns the value to a normal white color in the

Channel Box. For example, if you have keyframes on the Rotate X channel of an object (with

the text box shown in orange), clicking Rotate X in the Channel Box and right-clicking and

choosing Break Connections from the shortcut menu deletes the keyframes and returns the

text box to white. You will see more of this usage later in this book and as you learn how to

animate in Maya.

Blended (with another
attribute)

Connected (to another
attribute) or is dynamic
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Below the channel values in Figure 1.10 (shown in the previous section), you can see

the headings SHAPES and INPUTS. These correspond to the connections the selected

polygon sphere already has. In this case, under SHAPES we see the selected pSphereShape1

and the pShpere1_scaleConstraint1 nodes. These nodes have inputs to the selected

sphere and help define the object in Maya. In short, nodes in Maya are groups of attrib-

utes that define an object, its location, shape, and so on. There is animation and an expres-

sion on this sphere as well, shown under the INPUTS heading. Clicking the node names

here gives you access to their own attributes so that you can quickly make adjustments to

the selected object and its connected nodes.

Changing the Channel Box/Layer Editor View

Although it’s typical to display the Channel Box and the Layer Editor all the time, you can

replace this panel with one of two other windows—the Attribute Editor or the Tool Set-

tings window—by clicking one of the three icons in the upper-right corner, shown in

Figure 1.10. This gives you quick access to the three windows you may find most useful

to have on screen.

Some find it inconvenient to have the Attribute Editor and Tool Settings windows

open in this area. That’s why it’s wise to set Maya to open these tools in their own separate

windows. To do this, choose Window ➔ Settings/Preferences ➔ Preferences. The Prefer-

ences window (Figure 1.11) is opened. Under the Interface category (on the left side of

the window), set the settings Open Attribute Editor and Open Tool Settings both to In

Separate Window.

Figure 1.11

The Preferences 
window
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You can switch between the Channel Box and the Layer Editor by toggling one of the

icons in the upper-left corner. (See Figure 1.10.) The following list shows the icons that

switch the views in this area of the UI:

I C O N N A M E

Show The Channel Box

Show The Layer Editor

Show The Channel Box And The Layer Editor

You can resize this area by clicking either of the double arrow buttons at the bottom of

the panel below the Layer Editor, which we will look at next.

The Layer Editor
Immediately under the Channel Box is the Layer Editor. This layout with the Channel Box

and Layer Editor together is opportune for most scenes since it gives you immediate access

to the layering of a scene as well as the channels of a selected object or

objects. The Layer Editor has a twofold purpose: displaying layers and

rendering layers.

Display Layers

The first and immediately useful aspect of the Layer Editor is display

layers. You can create display layers and assign objects to them to

organize your scene. With objects on organized layers, you can quickly

turn selections on and off by just toggling the View icon in the Layer

Editor next to the appropriate layer name. Figure 1.12 shows just the

Layer Editor with several layers already added

to the scene.

To create a new layer, click the Create New

Layer icon ( ). To add items to a layer,

choose Layers ➔ Membership. You can also

select the objects for your layer and then

choose Options ➔ Add New Objects To 

Current Layer to automatically place those objects in the current layer. You can also use

the layers to select groups of objects by choosing Layers ➔ Select Objects In Selected Layers.

To change the name and color of a layer, simply double-click the layer to open the Edit

Layer dialog box.
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Render Layers

Like display layers, render layers control what objects are on which layers so that you can

separate your renders into different layers or passes. Rendering in layers is powerful for

later editing in a compositing package such as After Effects or Shake because it gives you

ultimate control over the objects in your scene and how best to color correct or even place

them. To see the render layers in your scene, click the Render Radio button to toggle away

from the display layers. Creating and adjusting render layers is the same as display layers.

We will cover rendering in layers in detail in Chapter 14.

The Time Slider/Range Slider
Horizontally across the bottom of the screen are the Time Slider and the Range Slider,

shown in Figure 1.13. The Time Slider displays the range of frames currently in your ani-

mation. The gray bar on the Time Slider is known as the Current Time Indicator, which

you can click and drag back and forth in a scrubbing motion to move through time in

your sequence. Clicking the Time Slider will also position the slider to whatever frame you

clicked, allowing you to jump around in your Timeline.

The text box to the right of the Time Slider displays the current frame. You can also use

it to enter the frame you want to access. Immediately next to the current time readout is a

set of VCR or DVD playback controls that you can use to play your animation.

Below the Time Slider is the Range Slider, which you can use to adjust the range of

animation playback shown in your Time Slider. The text boxes on either side of this

slider give you readouts for the start and end frames of the scene and of the range

selected to display in the Time Slider. You can adjust this range by either typing in the 

text boxes or lengthening or shortening the slider with the handles on either end of the

Range Slider bar.

When you change the range, you change only the viewable frame range of the scene;

you don’t adjust any of the animation. This just makes longer animations easier to read

and deal with. Adjusting actual animation timing and lengthening or shortening anima-

tions are accomplished differently (see Chapters 8 and 10).

Range bar handles

Playback controls

Scene start frame

Range start frame Range end frame

Scene end frame Auto Keyframe

Character Set Selection menu

Animation Preferences

Current frameScrub bar
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To the right of the Range Slider are the Character Set Selection menu (which deals with the

automation of character-animated objects), the Auto Keyframe button (which sets a key-

frame automatically when an animated value is changed), and the Animation Preferences

button. Clicking this button opens the Preferences window shown earlier in Figure 1.11.

The Command Line/Help Line
Maya is based on Maya Embedded Language (MEL), and all its functions and commands

invoke an appropriate MEL command. MEL is a user-accessible programming language

and is mostly what allows Maya to be as resourceful and flexible as it is.

You can write your own commands or scripts in MEL, entering them into either the

Command line or a window called the Script Editor. Use the Command line (see Figure 1.14)

to enter single MEL commands directly from the keyboard in the white text box portion

of the bar. The Command line also displays command feedback and messages from the

program in the gray portion of the bar. Try entering the following into this box: sphere.

A new sphere should pop up in your Maya panels. You’ve created a basic sphere using the

MEL command. To delete it, click it to select it and then press Delete.

Clicking the icon at the end of the Command line opens the Script Editor window, in

which you can enter more complicated MEL commands and scripts.

Below the Command line is the Help line. When you hover your mouse pointer over

an icon, the Help line tells you what it is. This is a terrific way to learn the UI. The Help

line also prompts you for the next step in a particular function or the next required input

for a task’s completion. It’s a great way to understand how some tools work when you’re

not really sure about the next step in a command, such as which object to select or which

key to press to execute the command. You’ll be surprised at how much you’ll learn about

tool functions by reading the prompts displayed here.

Working in View Panels
Let’s get a quick taste for working in the view panels. Create a NURBS sphere by choosing

Create ➔ NURBS Primitives ➔ Sphere and then clicking in any viewport. (With Maya 8,

Script Editor buttonCommand line

Help line

Command feedback
Figure 1.14

The Command line
and the Help line

working in view panels ■ 19

28453c01.qxd  2/26/07  3:57 PM  Page 19



primitives are typically created by choosing a primitive from the Create menu and then

click-dragging in the interface.) A sphere will appear in your panels and will be selected,

as shown in Figure 1.15. Notice its primary attributes in the Channel Box.

Now, press 2 and you will see the wireframe mesh become denser, as in the middle

frame of Figure 1.15. Press 3 and the mesh becomes even denser (bottom frame). You can

view all NURBS objects in three levels of display, such as this sphere. Pressing 1, 2, or 3

toggles between detail levels for any selected NURBS object. NURBS, as you will see in

further detail in Chapter 4, are types of surfaces in Maya that can adjust detail level at any

time to become more or less defined as needed. As such, the 1, 2, and 3 toggles only work

on NURBS objects.

When working in the 3D views, you can view your 3D objects in wireframe mode,

where you can see through each polygon (as in Figure 1.15), or in shaded mode, where

objects are solid-looking (see Figure 1.16). Wireframe gives you the best performance 

on your computer’s graphics system when working in a large scene, as well as the

chance to see through the wireframe of one object to another object for position or

comparison’s sake.

Within shaded mode, you have a few display options to help you in your work. You can

choose to display the wireframe mesh on top of a shade view to help you better model and

manipulate the objects. To turn on wireframe shaded view while in shaded view, in the

Scene menu, choose Shading ➔ Wireframe On Shaded. Figure 1.17 shows a sphere and

cube with wireframe on shaded view enabled. Also, you can make your objects shaded but

yet semitransparent in the panel so you can see through them but still get a sense of volume.

For X-Ray view, choose Shading ➔ X-Ray. Figure 1.18 shows X-Ray as well as wireframe on

shaded modes enabled. You will see under the Shading menu that you can change your view

to flat shaded (which is faster than smooth shaded but still shaded), bounding box (which

merely displays the extent of the objects in the view and is the fastest view), or even points

(which shows just the points of the objects in the panel).

When you increase the display feedback of your view panels, such as using shaded mode or

textured mode, you increase the work your system and your graphics card have to do. This is

not a concern until your scenes get larger and heavier, but if you notice that your computer is

not responding as fast as you’d like with a scene, try decreasing the visual feedback of your

scene to wireframe view or turning display layers on and off as needed.
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Figure 1.16

Shaded NURBS display smoothness.

Figure 1.15

NURBS display smoothness.
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Figure 1.18

X-Ray view allows
you to see through
an object while still

seeing it shaded and
in this case with

wireframe on
shaded as well.

Figure 1.17

Wireframe on
shaded view gives

you a good view to
model on your

shaded objects.
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Shaded, Textured, and Lighted Modes
You can select from varying degrees of shading detail, going as far as seeing your objects with

textures and lighting detail. You can cycle through the levels of detail by pressing 4, 5, 6,

and 7. Wireframe mode is 4, shaded mode is 5, texture shaded mode is 6, and lighted mode

is 7. Lighted mode will only work if you are already in mode 5 or 6. While in mode 6, press-

ing 7 will give you a lighted and textured mode. These modes give you a basic idea of lighting

and/or texture detail.

Texture shaded mode (6) displays the actual image textures that have been applied to

the object as long as Hardware Texturing is already enabled. (In the view panel, choose

Shading ➔ Hardware Texturing and make sure it is checked on.) Lighted mode (7) is a

hardware preview of the object or objects as they are lit in the scene. Its accuracy depends

on your graphics hardware. Here’s a summary:

K E Y F U N C T I O N

4 Toggles into wireframe mode

5 Toggles into shaded mode

6 Toggles into textured mode

7 Toggles into lighted mode

It is handy to toggle between modes 4 and 5 to get a good feel for the weight and shape

of your objects. Furthermore, lighted mode (mode 7) is useful for spotting proper light-

ing direction and object highlights when you first begin lighting a scene. It helps to see

the direction of lights within your scene without rendering frames all the time. The num-

ber of lights you see in the modeling window depends on your computer’s graphics and

overall capabilities.

You can display a higher-textured view of your models by enabling High Quality Ren-

dering view. In your view panel, choose Renderer ➔ High Quality Rendering. This will give

you a good idea of the texturing and lighting in your scene but at the expense of speed.

Display Shortcuts
In the view panel’s View menu, you will find two handy UI features, Frame All (hot key A)

and Frame Selection (hot key F), and a third slightly homely cousin, Look At Selection.

Frame All animates the camera or orthogonal views in or out to see all the objects in a

scene. Frame Selection animates the camera view to focus on the selected object or the

center of selected objects. Look At Selection snaps the selected object into the middle of

your view without moving in close to it.

If you find yourself wondering why pressing a hot key isn’t working, Caps Lock may be

enabled. Some hot keys have multiple meanings for the lower- and uppercase of the same

letter, so check the Caps Lock key.
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The Manipulators
Manipulators are on-screen handles that you use to manipulate the selected object in true

form. Figure 1.19 shows the four distinct and most common manipulators for all objects in

Maya: Move, Rotate, Scale, and Universal Manipulator. You use the handles on the manip-

ulators to adjust your objects in real time in any of the axes, as we discuss later in this sec-

tion. Some tools or objects have special manipulators that allow you to interactively adjust

certain attributes particular to the tool or object, such as the cone angle of a spotlight.

You can access the manipulators using either the icons from the Tool Box or the fol-

lowing hot keys:

K E Y F U N C T I O N

W Activates the Move tool

E Activates the Rotate tool

R Activates the Scale tool

Q Deselects any translation tool to hide its manipulator and reverts to the Select tool

The default hot keys let you easily select your transformation tools (Move, Rotate, Scale)

since they rest on the left side of the keyboard. You can, of course, change these key layouts

as you see fit. We’ll discuss how to customize the interface at the end of this

chapter.

Each of the manipulators has a handle for a particular axis, designated

by its color. Red is for the X axis, green is for the Y axis, and blue is for the Z

axis. A cyan colored axis allows for free movement in both axes of the active

panel view. When you select a particular handle, it turns yellow. You can

then only transform (move, scale, or rotate) the object in that axis.

As shown in the first panel of Figure 1.19, the Move tool (a.k.a. the

translate tool) displays arrows for the axis of movement. You can grab any

one of the handles (axis arrow lines) to move the selected object in just the

translation axis. The Rotate tool (shown in the second panel) displays cir-

cles around the object’s pivot point that act as axis handles. You drag on

one of the circles to rotate the selected object in just the rotation axis. The

Scale tool (shown in the third panel) displays handles with colored cubes,

which, when dragged, scale the object in the scale axis.

The Universal Manipulator is shown in the fourth panel of Figure 1.19

and acts in place of all three tools. You can select the arrows to move the

object with the Universal Manipulator just like with the Move tool. Select

any of the curved arrows in the middle of the box edges of the manipulator

to rotate the object in the Universal Manipulator’s axis. Finally, selecting

and dragging the cyan boxes in the corners of the manipulator box lets

you scale the sphere. If you hold down the Ctrl key as you drag, you can

scale the sphere in just one axis.

24 ■ chapter 1: The Maya Interface

Figure 1.19

Manipulators let you
control your object’s

position, rotation,
and scale with ease.

28453c01.qxd  2/26/07  3:57 PM  Page 24



The Universal Manipulator interactively shows you the movement, rotation, or scale as

you manipulate your object. As you move an object, the Universal Manipulator shows you

the coordinates. Likewise, rotating with the Universal Manipulator displays the degree of

change. Last, scale values in dark gray on the three outside edges of the manipulator box

are displayed as you scale the sphere with the Universal Manipulator.

Now these four tools offer you two different ways to move, rotate,

or scale your objects. However, the next tool down in the Tool Box is

a bit different. The Soft Modification tool allows you to select an area

on your surface or model and adjust the surface. The adjustments

gradually taper off away from the initial place of selection to “soft

modify” an area of the model.

For instance, create a NURBS plane by choosing Create ➔ NURBS

Primitives ➔ Plane  ❒. This opens the options for creating a plane. Set

both the U Patches and V Patches sliders to 10 and click/drag your

mouse cursor to create a plane on the grid.

Select the Scale tool and scale the plane up to about the size of the grid. Then, select the

Soft Modification tool ( ) from the Tool Box and click the plane, somewhere just off the

middle. This will create an S and a special manipulator to allow you to move, rotate, or

scale this soft selection.

It is much easier to use the default hot keys defined for these transformation tools than to

select them from the Tool Box. If the keys aren’t working, make sure Caps Lock is off. You

must use the lowercase keys.
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Grab the cone handle and drag it up to move the soft selection up. Notice the plane lifts

up in that area only, gradually falling off as if you were picking up a napkin.

The cube handle on the Soft Modification tool scales the soft selection, and dragging on

the circle rotates it. Simply select another transformation tool to exit the Soft Modification

tool. You can always go back and select the S on the surface to edit the selection or even

keyframe it for animation. You can place as many soft selections as you need on a surface.

Tip: To scale the manipulator handles to make them more noticeable or less obtrusive,

press the plus key (+) to increase a manipulator’s size or press the minus key (–) to

decrease it.

The Hotbox
The hotbox (see Figure 1.20) gives you convenient access to all menu commands in Maya.

It is a quick way to get to the menu selections without accessing the menu bar itself. This is

useful if you want to turn off the menu bar and other UI elements to give you the maxi-

mum screen space for your scene. To open the hotbox, simply hold down the spacebar in

an active view panel. You can then select menu options with the mouse.

All the menu commands that are available from the main menu bar are available

through the hotbox. You can display some or all of the menu headings to give you quick

access to whatever commands and features you use most. The hotbox is separated into five

distinct zones, delineated by short black diagonal lines: North, East, West, South, and 
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Center. To adjust the hotbox to your liking, press and hold the spacebar and click Hotbox

Controls to the right of the Center zone. From here you can select to display some or all of

the menu headings.

Activating the hotbox and clicking a zone with the mouse displays a set of shortcut

menu commands called marking menus, discussed in the next section.

Marking Menus
In addition to menu selections, the hotbox has marking menus in each of the five zones.

Using marking menus is yet another way to quickly access the commands you use the

most. The marking menus are classified as follows:

Z O N E M A R K I N G  M E N U

North Zone Selects the display layout, similar to the display layout buttons in the Tool Box.

East Zone Toggles the visibility of UI elements such as the Help line or Status line. You can
quickly toggle the display of several UI elements to maximize your screen space.

South Zone Changes the current view panel to an information panel window such as the
Outliner or Hypershade windows.

West Zone Activates Selection Masks, as if using the Selection Mask icons in the Status line
discussed earlier in the chapter. You can use a marking menu like this to quickly
set your selection to vertices without needing to access the Status line, for example.

Center Zone Sets the view panel to any of the modeling or perspective windows in your scene.

Center zone

North zone

South zone

East zoneWest zone

Figure 1.20

The hotbox 
and its zones
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As you become more familiar with Maya, your use of the hotbox and the marking

menus will greatly increase your productivity. If you are just starting out, it’s advisable to

begin with accessing the menus and commands such as selection sets through the Status

line and main menu bar until you are familiar with where everything is. It is easy when

you’re a beginner to get lost in all the options you have when selecting some tools and

work flows, so it’s best to start with the plain and simple and work your way up to the

faster work flows such as marking menus.

Menu Sets
As we discussed earlier, menu sets are organized according to function. The menu sets are

Animation, Polygons, Surfaces, Dynamics, and Rendering, all of which are available in

Maya Complete and Maya Unlimited. However, with Maya Unlimited, you are given

access to the Classic Cloth, nCloth, and Maya Live menu sets as well. Each menu set gives

you access to the commands associated with its broader function set. The Polygons menu

set, for example, displays in the main menu bar all the menu headers that correspond to

polygon modeling functions.

The menu sets drop-down (shown in Figure 1.21) is the first thing on the Status line.

Changing between menu sets is simpler if you use the default hot keys shown here:

K E Y F U N C T I O N

F2 Animation menu set

F3 Polygons menu set

F4 Surfaces menu set

F5 Dynamics menu set

F6 Rendering menu set

Customizing Menu Sets

New to Maya 8, you can customize menu sets by opening the Menu Set Editor and choos-

ing the Customize option in the menu sets drop-down. The Menu Set Editor (Figure 1.22)

allows you to modify existing menu sets or to create your own. To make your own menu set,

select the New Menu Set button and enter a name for your set. To add menus to your set,

scroll through the available menus on the right, highlight the ones you wish to add, right-

click and select Add to Menu Set.

This wraps up the interactive parts of Maya’s UI. You will find all this information a bit

much at first, but as soon as you begin using Maya, you will find it becomes second nature

quickly. You might want to skip ahead to the next chapter to begin working a simple scene

in Maya to apply what you’ve learned here and then come back for a description of the

windows you will be using, or you can stick around and get your feet wet on the most

commonly used Maya windows in the next section.
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The Main Maya Windows
Maya has a few important windows in which you will be working frequently. The follow-

ing sections introduce the location and function of each window, tell you when you will

come across them, and describe how to use them.

The Attribute Editor Window
As you’ve already seen to some extent, every object is defined by a series of attributes, all

placed in nodes. You can edit some of these attributes in the Channel Box as you have

seen, but to see all the attributes available for a selected object, you will need the Attribute

Editor, which is possibly the most important window in Maya. Through this window

you can change an object’s attributes, set keyframes, connect to other attributes, attach

expressions, or simply view their values.

Create an object in Maya. Choose Create ➔ NURBS Primitives ➔ Sphere and then click

anywhere in the scene view to put a NURBS sphere in your scene.

With the sphere still selected, open the Attribute Editor by choosing Window ➔ Attribute

Editor or by pressing the default hot key Ctrl+A.

You will see that the Channel Box displays the commonly used attributes for the sphere

but that the Attribute Editor shows an entire collection of attributes. Figure 1.23 shows the

sphere and its attributes. The attributes in the Channel Box and Attribute Editor are the same.

If you move or otherwise transform the sphere, the values are consistent in both displays.

Connected Nodes

Notice the tabs running across the top of the Attribute Editor. These tabs correspond to

the object’s node structure. Each tab displays the attributes of another tab that is in some

way connected to the sphere that is currently selected. You can easily adjust any of the

settings for any node that is linked to the selected object by just selecting its tab in the 

Figure 1.22

You can create your
own menu sets or
edit existing ones.
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Attribute Editor. For example, if you click the nurbsSphere1 tab, you will see the DAG

node attributes. A DAG node is the placement, or transforms node, of the object. This

node tells the object where it is and what its rotation and scale is. Click the nurbsSphere-

Shape1 tab to see the shape node of the sphere. The shape node contains the attributes that

define the shape of the object. Click the makeNurbsSphere1 tab to access to the creation

node of the sphere.

The creation node displays attributes for how the object was made. For example, try

changing the value for the Start Sweep attribute. This will change the sweep of the sphere,

effectively slicing a chunk out of it, so it looks like a cut-open, hollow orange, as shown here.

Figure 1.23

The Attribute Editor
and Channel Box

display the values
for the selected

sphere.
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What’s more, you can animate almost any of the attributes in any of these nodes

(Attribute Editor tabs). All you need to do is RM click the attribute in the Attribute Editor

and choose Set Key from the shortcut menu . This sets a keyframe for that attribute at the

current frame, just like RM clicking in the Channel Box.

Notes

At the bottom of the Attribute Editor is a Notes area where you can type and record com-

ments that stay with the object’s Attribute Editor window. Simply drag the separator bar

as shown to create more or less space in the Notes section; this area is

handy for remembering how certain things are set up or to pass secret

notes about your boss around the studio.

Multiple Selections

The Attribute Editor can display only one object at a time. If you have

multiple objects selected, you can toggle through them through the

Attribute Editor’s menu by choosing Selected and then choosing the

object from the menu.

The Outliner
The Outliner and Hypergraph (covered next) use two different

approaches to the same end: organization. Maya is based on node

structure, meaning every object in Maya is represented by a node. A

node is a collection of attributes that define how the object looks, to

make a long story short. Some nodes interconnect to form more com-

plex objects or to give you the best control over their shape or behavior.

As you grow your scene, you will create more and more nodes, and

you will need a way to organize your objects. Furthermore, you can

group objects and place objects into hierarchies. By creating groups,

you can control objects as a single unit in which all the members of the group move,

rotate, and scale as one. Additionally, with parenting, you place one object (the child)

under the influence of another object (the parent) to control the objects together.

With a parent-child hierarchy, the child can move independently under the parents as

well as inherit the movements of the parent. The child node inherits the transforms (move-

ments) of all the parents above it and moves (or rotates or scales) however the parents

move, but it can move on its own as well. Imagine, if you will, a ball bouncing on a cart.

If your sphere does not have a makeNurbsSphere1 tab in the Attribute Editor, check to make

sure the Construction History button in the Status line is toggled on. Without it, the sphere is

created without history, so its creation node is deleted right after the sphere is made.
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The cart rolls along while the ball bounces on top. The ball is a child of the cart and moves

along with the cart as it rolls along, but the ball has its own movement on the cart as it

bounces up and down. Creating good hierarchies is the backbone of animation in Maya

and is covered throughout this book.

Both windows display the objects in your scene and allow you to make hierarchy (or

grouping) decisions, as well as more intricate connections between attributes. The Out-

liner displays your scene objects as an outline, and the Hypergraph uses a flowchart lay-

out that gives you more finite control. You access the Outliner by choosing Window ➔

Outliner.

The Outliner (see Figure 1.24) displays all the objects in your scene as an outline. You

can select any object in a scene by simply clicking its name.

You can reorganize objects listed in the Outliner by MMB dragging an object to a new

location in the window. By default, objects are listed in order of creation in the scene. You

have easy control over organization in your scene:

• You can select objects in your scene by selecting them in the Outliner.

• To rename a node, double-click its Outliner entry, and type the new name.

• To relocate an object’s entry in the Outliner to another location in the Outliner, 

MM drag the node’s entry and place it in-between two other node entries.

• To parent one object under another, MM drag the node onto the new parent.

• To pull an object out of a group, MM drag the node to a different location in the 

Outliner.

You can separate the Outliner into two independent scrolling displays, which is useful

when you have a large scene with a long Outliner list of nodes. The separator bar is located

at the bottom of the Outliner window; simply click it and drag it up or down for a second

Outliner display area. This is also useful when you need to parent one node at the bottom

of the list onto another node toward the top of the list.

The Hypergraph
Using a flowchart or graph view, the Hypergraph (see Figure 1.25) also displays all the objects

in your scene. The Hypergraph, however, is a more detailed view of your nodes and how

they connect with each other. You can easily parent objects to each other through this win-

dow by MM dragging the node to be parented onto the node you wish to be the parent, just

as in the Outliner. And since you can have several objects in your scene (indeed hundreds

or more), you will need to move around in the Hypergraph. Navigating the Hypergraph is

the same as navigating in any modeling panel using the familiar Alt key and mouse combi-

nations for tracking and zooming. You access the Hypergraph by choosing Window ➔

Hypergraph:Hierarchy Or Hypergraph:Connections.
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Connections and the Hypergraph

You can edit connections of attributes between nodes graphically to set up some rather

complex relationships, though this is not immediately evident when you first open the

window. Create a NURBS sphere and cone in a scene, place them side by side, and open

the Hypergraph window.

In Figure 1.26, you see the simple scene in the Hypergraph’s main node view. The

Hypergraph shows nodes for the four panel views (persp, top, front, side) as well as the

NURBS sphere (nurbsSphere1) and the NURBS cone (nurbsCone1). Select them both in

the Hypergraph, and then click the Input And Output Selections icon (see to Figure 1.25

for its location). This connections view shows you all the nodes that interact with the

selected node(s). In this case, as shown in Figure 1.27, you see our object’s DAG nodes

(nurbsSphere1 and nurbsCone1) and their shape nodes (nurbsSphereShape1 and nurbs-

ConeShape1) and creation nodes (makeNurbSphere1 and makeNurbCone1) as well as the

default gray shader they are assigned to upon creation (initialShadingGroup). For more

on hierarchies, see Chapter 2.

The lines connecting the nodes represent connections, with the arrows displaying

which node is feeding the other. Here, the creation nodes feed the shape nodes. The DAG

nodes are displayed separately on the left. In the example in Figure 1.27, the nurbsCone1

Toggle Freeform/
Automatic Layout 

Modes

Input and Output Selections

Object Nodes

Frame All

Frame Selection

Frame Hierarchy

Scene Hierarchy

Frame Branch

Create Bookmark

Bookmark Editor

Figure 1.25

The Hypergraph dis-
plays your objects in
a flowchart format.
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node is connected into the nurbsSphere1 node. The line represents a connection made in

this example to lock their rotations together. You will get more practice on this in Chapter

8, but for now, as an exercise in how the Hypergraph works, we’ll show you how to make

this connection yourself, to match Figure 1.27.

In this connections display, if you MM drag one node on top of another, Maya presents

an option to connect attributes between the nodes. The node you drag will connect into

the node you drag it to. In this case, MM drag nurbsSphere1 onto nurbsCone1. A pop-up

menu appears, as shown in Figure 1.28.

Figure 1.28

Connecting 
attributes in the

Hypergraph

Figure 1.27

Detailed connec-
tions are displayed

and edited in the
Hypergraph display.

Figure 1.26

A scene in the
Hypergraph
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Select Other from the menu to open a new window called the Connection Editor,

shown here and explained later in this chapter. In the Connection Editor, scroll down and

select Rotate on both sides of the window.

This action connects the rotations of the sphere to the cone. Select the cone and rotate

it in the perspective view. You will see the sphere rotating as well. In the Hypergraph,

move your mouse over any of the connecting lines to display the attributes that are con-

nected, as shown here.

The connecting lines are also color coded. A green line, as in our example, represents a

vector connection. A vector connection is a connection of three attributes (or channels),

such as RotateX, RotateY, and RotateZ. A single channel

connection is made with a blue line.

Notice now that you can no longer rotate the sphere

directly if you select the sphere and try to rotate it in

your scene. The sphere’s rotations are locked to the cone

until you sever the connections either through the Chan-

nel Box (RM click the attribute in the Channel Box and

choose Break Connection) or through the Hypergraph. To disconnect in the Hypergraph,

click the green connecting line and press Delete.

To see additional connections between nodes, such as expressions and deformers,

choose Options ➔ Display and select the type of connection you want to see.

To return to the regular node view at any time when you are editing connections in the

Hypergraph, simply click the Scene Hierarchy icon.
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Changing Layout

Using the icons across the top of the window, called out in Figure 1.25 earlier in this chap-

ter, you can change your view quickly. For example, if you select an object in the perspec-

tive panel but can’t find it in the Hypergraph view, just click the Frame Selection icon. If

you prefer a vertical layout similar to the Outliner (shown in Figure 1.29), in the Hyper-

graph menu choose Options ➔ Orientation ➔ Vertical.

The nodes in the Hypergraph are lined up by default. If you would like a free-form dis-

play so that you can move your nodes however you wish (instead of horizontally or verti-

cally), click the Toggle Freeform/Automatic Layout Modes icon shown in Figure 1.25.

You can also import an image as the Hypergraph background in free-form mode to place

nodes on parts of an image. Just toggle View ➔ Show Background Image and select your

image by selecting View ➔ Set Background Image. This is handy for making character rigs

when you want to place the appropriate character nodes on the character’s parts for mak-

ing selections and reference faster.

Bookmarks

Another convenience of the Hypergraph is the use of bookmarks. When you frame a cer-

tain selection of nodes in the window, you can bookmark the view to return to it later easily.

To bookmark a Hypergraph view, choose Bookmarks ➔ Create Bookmark, or click the

Create Bookmark icon called out in Figure 1.25 earlier in this chapter. You can then just

select the view from the Bookmark menu at a later time.

Traversal Depth

To help better organize complex connection hierarchies, you can specify a traversal depth

when viewing input and output connections in the Hypergraph. You can set the depth by

using the icons and text field in the toolbar, as shown in Figure 30. By default, the depth

is set to infinity (–1). The lower the traversal depth, the more pruned the hierarchy will

appear.

Containers

New to Maya 8.5, containers let you organize nodes within the dependency graph, allow-

ing you to simplify your layout by grouping nodes together. Container nodes differentiate

themselves from other nodes by their thick outline, as seen in Figure 1.31.

To create a container, select the nodes in the Hypergraph that you wish to add, and

choose Edit ➔ Create Container. To look inside a container, simply double-click on 

the container node. To add a node to a container, Alt+Shift+drag the node on top of the

container node. Likewise, to remove a node from a container, Alt+Shift+drag the node

outside of the container. Nodes within a container do not change their hierarchy or con-

nections; they simply act as organizational groupings.
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The Connection Editor
You can use the Connection Editor (choose Win-

dow ➔ General Editors ➔ Connection Editor; see

Figure 1.32) to connect attributes between almost

any two objects, as you have just seen in the discus-

sion on the Hypergraph. The connection we made

there attached the rotations of a sphere to that of a

cone. Simple enough, but we can make connections far more complex. For example, the

height of a cube in the Y axis can control the amount of red in a sphere’s rendered color.

You will see how to make complex animations and relationships later in this book, in

Chapter 8, when you begin to rig a scene for animation.

Figure 1.30

Traversal depth
prunes a displayed
connection hierarchy.
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Creating and Editing Connections

The Connection Editor is separated into two vertical panes. Each pane represents one of

two objects in the connection. By selecting an object and clicking the Reload Left button,

you can load into the Connection Editor’s left column all the attributes of the selected

objects. By selecting a second object and clicking Reload Right, you can load the attributes

of the second object. As you saw earlier, clicking attributes in both columns creates a

direct relationship between the two objects’ attributes.

When you want to edit connections on attributes or channels already connected, sim-

ply click one object’s attribute to show you what channel it is connected to on the other

object. Maya will highlight the other connected channel when you select the first object’s

attributes in one of the panes. To disconnect a connection through the Connection Editor,

click the channel and simply click the other object’s highlighted channel(s).

Connections are the cornerstone of animation and a significant reason for animation

being so open ended in Maya. You can create any kind of relationship between almost any

attributes of almost any object to create highly complex, interconnected animations.

Filtering the Display of Connections

Since there can be so many attributes and connections even between just two objects, you

can filter the view in the Connection Editor to show or hide attribute types entirely. You

can access view filters through the window’s menu bar. Choose Left Display or Right Dis-

play menu headings to toggle the connections you want to display.

Figure 1.32

The Connection 
Editor
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C H A N N E L  F I L T E R S D E S C R I P T I O N

Readable Displays all the attributes of an object, regardless of whether they
can be keyframed

Outputs Only Shows attributes that can only be connected to other nodes

Inputs Only Presents attributes that can only be connected into

Non-Keyable Displays attributes that you cannot create connections with or for

Connected Only Shows attributes that already have connections

Hidden Displays hidden attributes for that node

The Multilister
As the Outliner and Hypergraph list the objects in the scene, the Multilister and Hyper-

shade (see the next section) windows list the render nodes of your scene—textures, lights,

cameras, and so on. In Maya terminology, adding textures and such to objects is called

shading (called surfacing in Lightwave-speak, for example). And as with the Outliner and

Hypergraph, these windows approach presenting the shaders of your scenes differently to

accommodate the best of options in your work flow. You will have a small taste of shading

in the next chapter.

The Multilister (accessed through Window ➔ Rendering Editors ➔ Multilister; see

Figure 1.33) lays out not just the shaders of your scene, but also lights, cameras, and the

shaders’ textures, in a table format. All the shaders in the scene are displayed under their

respective tabs in this window and are represented by named thumbnail icons.

Thumbnail size

Shader thumbnails

Tabs

Shading Group tool

Select tool

Pin/Unpin Appearance
of New Nodes

Display options

Figure 1.33

The Multilister
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Double-clicking any of the names under the thumbnails lets you change the name of

the shader or render node. Clicking the thumbnails themselves selects the shader for use,

and double-clicking the thumbnail (and not the name) opens its Attribute Editor.

The Multilister is in two panels. Both panels let you select what type of shading/render

node is displayed. By default, the top panel displays all the shaders in the scene in the Gen-

eral tab—with materials, lights, and camera nodes under their respective tabs. The bottom

panel is typically used to display texture nodes that are in use or are already connected to

shaders.

You can add or edit tabs to filter just the nodes you need to work on. For example, if

you would like to view only the type(s) of nodes you want, pay a visit to the Display ➔

Tabs menu. There you can create new tabs with special filters using the Create Filtered

command from that menu.

Many of the commands accessible through the menu system are also available through

shortcut menus when you RM click the shaders in the Multilister panes. To assign a shader,

for example, select your object in Maya, click your desired shader to select it, and then RM

click and choose Edit ➔ Assign from the shortcut menu.

You can customize the look of the Multilister by clicking the option display icons of

the thumbnail size icons running down the left side of the window, shown in Figure 1.33.

Each thumbnail has a small arrow in the lower-right corner. Clicking this arrow expands

on that shader’s network of connection nodes, if you have textures or images attached.

The Multilister is good for fast shader management and assignment if you are connect-

ing and editing attribute connections, even more so than the Hypergraph. It does, how-

ever, lack the brawn of the Hypershade to get into serious shader network management.

The Hypershade
The Hypershade is accessed through Window ➔ Rendering Editors ➔ Hypershade (see

Figure 1.34) and displays the shaders and textures in your scene in a graphical flowchart

layout similar to the Hypergraph window. You connect and disconnect render node

attributes through the Hypershade to create shader networks from the simple to the

intricately complex. The Hypershade window has three main areas: the Create/Bins

panel, the render node display, and the work area. The three icons in the upper right let

you switch views.

The Create/Bins Panel

The Create/Bins panel on the left is divided into two tabs: Create and Bins. Selecting the

Create tab displays the icons to create several render nodes from materials such as Lam-

bert and Blinn to procedural textures such as ramps and fractal noise. To create a node,
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simply click its icon in the Create panel and it will appear in the node display and work

area for immediate editing. The Create icons are separated into types of render nodes,

from surfaces to utility nodes. You will have plenty of exposure to these nodes and how

to best edit them in Chapter 12.

The bar at the top of this pane lets you select the kind of node you want to create; you

can switch between Maya shading nodes and mental ray nodes. Since mental ray is a fully

integrated plug-in, you will need to make sure it is loaded before you see the mental ray

option in this panel. We’ll discuss plug-ins later in this chapter in the section “Customiz-

ing the Interface.”

Sort In Reverse
Order

Show Top Tabs Only

Show Bottom Tabs Only

Show Top And Bottom Tabs

Render node display

Work area

View As Icons

View As List

Icon Size

Sort By Name

Sort By Type

Sort By Time

Figure 1.34

The Hypershade
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The Bins tab lets you store sets of shaders in bins to manage them better, especially if

you have a heavy scene to work in. You use the icons at the top of the Bins tab to organize

your shaders. If you hover the mouse pointer over the icons, Maya will show you a pop-up

description for each.

The Render Node Display Area

After you create render nodes, they appear in the display area as thumbnail icons. Clicking

a render node’s icon selects that node for use, and double-clicking it opens the Attribute

Editor. If you want to edit a shading network, MM drag the thumbnail icon to the work

area below. Navigating in this area of the Hypershade, as well as the work area, is similar

to navigating the Hypergraph and work windows in that you use the Alt key and mouse

controls. The Hypershade zooms in levels as opposed to the smooth zooms in a work

panel, though it still uses the Alt+RM. And although you cannot freely pan around this

window, you can use Alt+MM to scroll up and down when you have enough shaders to

fill the panel. The bottom panel, the work area, however, reacts much the same as a nor-

mal view panel with the panning and zooming moves.

The Work Area

The work area is a free-form workspace where you connect render node attributes to form

shading networks for your scene. This is by far the easiest place to create and edit complex

shaders, because it gives you a clear flowchart of the network, much like the Hypergraph

view of object nodes. To work on a shading node from the node display panel, just MM

drag it down into the work area.

The most efficient way to work with shaders is to use marking menus in the Hyper-

shade window panels. RM click a shading icon to display a marking menu. This marking

menu lets you assign the shader to the current selection of objects, select objects that have

that shader already assigned to them, or to graph the network. Graphing the network of a

shader gives you a display similar to the Hypergraph’s connection display. Also like the

Hypergraph, Maya 8.5 introduces containers to the

work area, helping you to group nodes together.

See the Hypergraph section on containers for

details on how to create and modify container nodes.

Figure 1.35 shows how you can edit the connections

between shading nodes graphically.

As you saw with the Hypergraph earlier in this

chapter, the connections between nodes is handled

with color-coded lines and arrows. In this example,

a Phong material has connections coming in from a

fractal node, a ramp node, and a bump map with a

leather node.
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Using the Hypershade

Open the Hypershade and create a Phong shader by clicking the Phong icon in the Create

Maya Nodes panel. Double-click the Phong’s thumbnail to open the Attribute Editor (Fig-

ure 1.36). In the Attribute Editor, if you click the color swatch next to the Color (or other

attribute) of the shader, you can change the color of the material. To map a texture (such

as a procedural texture—that is, a texture that is created entirely in Maya) or an image file

to a color or other attribute, click the map icon (the checkered button) to the right of that

attribute. For this example, click the map icon next to the Color attribute. The Create

Render Node window opens (Figure 1.37). Click the Ramp icon to create a ramp node for

the color of this Phong material. If you open your Attribute Editor, you’ll notice a green

line connecting a new ramp node to the Phong material.

As with the Hypergraph, you can mouse over the connecting lines to see which attrib-

utes are connected. You can also select the connection lines and press Delete to disconnect

those connections.

Figure 1.37

The Create Render Node window

Figure 1.36

A Phong shader
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The Graph Editor
Maya’s Graph Editor (choose Window ➔ Animation Editors ➔ Graph Editor) is a truly

powerful editing tool for the animator (see Figure 1.38).

Since 3D data is stored digitally as vector information, every movement that is set in

Maya generates a graph of value vs. time. The Graph Editor provides direct access to the

curves generated by your animation to let you fine-tune and edit, even create, your anima-

tion in this window.

The left panel of the Graph Editor is much like the Outliner and displays the selected

objects and their hierarchy along with a listing of their animated channels or attributes. By

default, all of an object’s keyframed channels display as colored curves in the display to the

right of the list, with red, green, and blue for the X, Y, and Z axes, respectively. Selecting

an object or an object’s channel in the list, you isolate only those curves you want to see on

the right.

The Graph Editor displays these animation curves as value vs. time, with value running

vertically and time horizontally. Keyframes are represented as points on the curves that

can be freely moved to adjust timing and/or value. This is where most animators spend

their time animating.

Denormalize

Keyframe

Open Dope
Sheet

Open Trax Editor

Select curve
cycle types

Move Nearest Picked Key tool

Insert Keys tool

Add Keys tool

Lattice Deform Keys

Time text box

Value text box

Frame All Center View
Select a

Curve to
Buffer

Swap
Buffer
Curve

Frame Playback Range

Tangent Types Tangent Behavior

Time Snap

Value Snap

Normalize

Figure 1.38

The Graph Editor
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To move a keyframe in the Graph Editor, click to select (or drag a marquee around the

keys to select them) and MM drag the keys as needed. You can also select the entire curve

or curves and move them with the MM as well. Using the snap icons shown in Figure 1.38,

you can snap your keyframes to whole numbers in time or value. This is useful for snap-

ping keys to whole frames.

Navigation in the Graph Editor is the same as the Alt+mouse combinations you are

familiar with by now. You can pan and zoom in this window with Alt+MM and Alt+RM

respectively.

You can adjust the Graph Editor’s curve display with Normalize or Denormalize func-

tions. For example, when you have a translate X curve with vertical values from 1 to 3, and

a Rotate Y curve with values from 1 to 360 degrees, seeing the detail of the curves in rela-

tion to each other is difficult since you would need to zoom out in the Graph Editor to see

values as high as 360. Figure 1.39 shows an animation in which the curves’ values stretch

up high. In Figure 1.40 we have normalized the curve view so that the full range of values

fits between –1 and 1 in the Curve Editor, giving you the opportunity to compare timings

between curves with very different value ranges. To normalize the view, click the Normal-

ize icon shown in Figure 1.38. To return to your regular view, click Denormalize.

Figure 1.40

Normalizing the
view makes it easier
to compare timings.

Figure 1.39

Different value
ranges can make it
difficult to compare
timings in animation
curves.
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Keep in mind that normalizing does not change the animation in the scene. It only

allows you to see all the curves and their relative motions. Normalizing your view is par-

ticularly helpful in busy scenes when you want to adjust both the smallest scale of values

alongside the largest scale of values without having to constantly zoom in and out of the

Graph Editor to see the appropriate curves.

You will get hands-on experience with the Graph Editor in Chapter 7 of this book.

The Script Editor
You access the Script Editor (see Figure 1.41) by clicking the icon in the bottom-right

corner of the screen at the end of the Command line or by choosing Window ➔ General

Editors ➔ Script Editor. Since almost everything in Maya is built on MEL, every command

you initiate generates some sort of MEL script or MEL argument. A history of these com-

mands is available in the Script Editor.

You can use this window when you need to reference a command that was issued or an

argument or a comment that was displayed in the Help line but was too long to read on

one line.

Of course, this window is also useful in scripting or creating macros of MEL commands

to execute compound actions. When you want to create a custom procedure, you can copy

and paste MEL from this window to form macros. As a matter of fact, the Script Editor is

great to use to learn how to script in the first place. By reading the command feedback and

the MEL commands issued whenever you execute a button or tool, you will start to pick

up on how MEL works. Maya 8.5 introduces support for Python commands. Python sup-

port and other new Script Editor features are discussed in Chapter 16.

Figure 1.41

The Script Editor
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The window is in two halves. The top half is the Script Editor’s feedback history, and

the bottom half is its Command line, where new MEL commands can be issued. By high-

lighting text in the upper window, you can copy and paste the command back into the

Command line. Once you have some commands that are working for you, you can add

them to the shelf by highlighting the text and choosing File ➔ Save Script To Shelf.

Using the Script Editor is also a good way to check on error messages that are too long

to fully view in the Command line’s feedback box. If you see an error message pop up and

something goes wrong, open the Script Editor to see what sort of error(s) have scrolled by.

Customizing the Interface
You’ve probably noticed that we’ve run into the same tools more than once as we’ve gone

through the aspects of the user interface so far. Simply put, for everything you need to do

in Maya, there are not only a few ways to do so, but at least a couple of ways to access the

tools to do so.

Most of Maya’s commands and tools can be found in at least two places. This may be

confusing at first, but you’ll discover that in the long run it is most advantageous. It allows

for the greatest flexibility in individual work flow and in part accounts for Maya’s being

easily customized.

Once you are confident with your Maya know-how, you’ll develop your own ideas

about how to use all the other user interface methods to customize your work flow. You’ll

want to return to this section when you’re ready to do some serious customization.

User Preferences
To customize Maya, you use the Preferences window (choose Window ➔ Settings/Prefer-

ences), as shown in Figure 1.42.

The Preferences window is separated into categories that define aspects of the program.

• Interface options to change the main user interface:

• UI Elements lets you change which parts of the UI are displayed. You’ve seen in

this chapter how you can access these preferences through marking menus, but

you also have access here.

• Help lets you specify whether you want tooltip pop-up windows when you

mouse over icons or buttons, as well as how you view the HTML documentation

that comes with Maya.

• Display options to specify how objects are displayed in the workspace.
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• Settings lets you change the default values of several tools and their general operation.

An essential aspect of this category is the Working Units section under the Settings

category itself. These options set the working parameters of your scene, including the

frame rate. It’s important to set the time units and frame rate properly. Some impor-

tant subsections are as follows:

• Files/Projects initially specifies where Maya looks for your projects and files.

Maya keeps things organized as projects. This setting allows you to specify 

where Maya always goes first when you try setting a project or loading/saving 

a scene.

• Timeline sets your playback rate for the scene. Keep in mind this is not the same

as setting the scene’s frame rate, but merely adjusts how fast Maya will attempt to

playback your animation in the view panels.

• Undo sets the size of the undo queue. It is a good idea to set this to Infinite, which

will give you the opportunity to undo almost all your actions in any working ses-

sion in case something does not work out quite as planned. This will not use up

that much more memory, so it’s quite worth it.

• Selection allows you to specify the order of preferred selection. Maya has a selec-

tion queue that marks some objects as more selectable than others. If you mar-

quee select a bunch of objects of different types in the scene, Maya will select the

more important object types instead of the others. This is where you set your

preference of what is selected over another object.

Figure 1.42

The Preferences 
window
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• Modules specifies which modules are loaded by default whenever you start Maya. By

default, both Dynamics and Paint Effects are loaded. This is not the same as loading

plug-ins such as fur and mental ray, which are accessed through the Plugin Manager

(covered later in this chapter).

• Applications lets you set the path of applications that are commonly used in conjunc-

tion with Maya. This makes work flow much faster, allowing you to launch an appli-

cation such as Photoshop to edit a texture map from within Maya itself.

Colors
You can change just about any of the UI and object display colors in Maya by choosing

Window ➔ Settings/Preferences ➔ Color Settings to open the Colors window, as shown in

Figure 1.43. You can click the color swatch to change the colors or use the slider to toggle

through common preset colors.

For example, to change the background color of the 3D view panels, click the 3D View

heading and select your color. The Active and Inactive tabs give you access to colors of

objects that are currently selected (or active) or not selected (inactive).

As you will see throughout exercises in this book, organizing your scene elements using

groups with different display colors is different from using the Colors window. These

changes affect all scenes and UI elements for the particular user in Maya and are used to

customize the display for your convenience, not for scene management or organization.

You will be using display layers and the like for organizing.

Shelves
Choose Window ➔ Settings/Preferences ➔ Shelf Editor to manage your shelves (see 

Figure 1.44). You can create or delete shelves or manage the items on the shelf with 

this function.

Figure 1.44

The Shelves window

Figure 1.43

Adjusting the colors of your UI elements, 
windows, and scene objects is easy.
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You can easily add any menu item or Toolbox item to your shelf:

• To add an item from the Toolbox, simply MMB drag its icon from the Toolbox into

the appropriate shelf.

• To add an item from a menu to the shelf, hold down Ctrl+Shift+Alt while selecting

the item from the menu.

• To add an item (a MEL command) from the Script Editor, highlight the text of the

MEL command in the Script Editor, and MMB drag it onto the shelf. A MEL icon will

be created that will run the command when you click it.

• To remove an item from a Shelf, MMB drag its icon to the Trash icon at the end of

the shelf, or choose Window ➔ Settings/Preferences ➔ Shelf Editor.

Hot Keys
Hot keys are keyboard shortcuts that can access almost any Maya tool or command. You

have already encountered quite a few so far in our exploration of the interface. You can

create even more through the Hotkey Editor, shown in Figure 1.45.

Figure 1.45

The Hotkey Editor
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Through this monolith of a window, you can set virtually any key combination to be

used as a shortcut to virtually any command in Maya. Since so many tools already have

hot keys assigned by default, it is important to get to know them first before you decide

to start changing things around to suit how you work. If you are coming to Maya from

another 3D package, you can set up your hot keys to resemble your old work flow.

Every menu command is represented by menu categories on the left, and the right side

allows you to view the current hot key or to assign a new hot key to the selected command.

Ctrl and Alt key combinations can be used with any letter keys on the keyboard. Keep in

mind that Maya is case sensitive, meaning it differentiates between upper- and lowercase

letters. For example, one of our personal hot keys is Ctrl+h to hide a selected object from

view, and Ctrl+shift+H is to unhide it.

When you are ready to start setting your own hot keys, query your intended hot key

with the Query button to find out if it is assigned to a command that suits that hot key

better.

The lower section of this window displays the MEL command that the menu command

invokes. It also allows you to type your own MEL commands, name them as new com-

mands, categorize them with the other commands, and assign hot keys to them.

Marking Menus
Customizing your marking menus can give a huge boost to your work flow. You might

want more modeling tools at your fingertips than general UI controls such as the defaults.

You can customize the marking menus by choosing Window ➔ Settings/Preferences ➔

Marking Menu Editor. Figure 1.46 shows the Marking Menu Editor window.

Figure 1.46

The Marking Menu
Editor window
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The marking menu is divided into zones. Select the zone you want to customize in the

top panel and click Edit Marking Menu, as shown in Figure 1.47.

To change a marking menu entry, drag its icon or menu item directly onto the location

where you want it to appear in the marking menu for the current zone.

The Plugin Manager
The Plugin Manager, accessed by choosing Window ➔ Settings/Preferences ➔ Plug-in

Manager, lets you load and unload plug-ins for Maya. For example, mental ray for Maya

is a plug-in that must be loaded to have mental ray rendering in your scenes.

You load a plug-in by clicking the Loaded button. To unload, simply uncheck

the box. If you want the plug-in to always load on Maya startup, check the

Auto Load box. You can load third-party plug-ins by clicking the Browse but-

ton at the bottom of the window. Most third-party plug-ins provide instruc-

tions for installing them properly.

Summary
Once you have wrapped your head around how the challenging Maya inter-

face works at its defaults, you will applaud the ability to change it to make it

work best for you.

This chapter gave you an overview of all the major components of Maya’s

UI and major windows and will be useful as a reference whenever you need a

quick brush-up on how something works or is loaded. We explored the inter-

face, navigation, scene windows, and window layouts before looking at the

hotbox, menus, and shelves. You should also have a good idea of how to use

the Outliner and Hypergraph as well as the Channel Box and Attribute Editor.

We also explored the Timeline, Command line, Feedback line, and Script Edi-

tor before discussing the interface customization options available.
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Editing the North Zone of our marking
menus
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