Chapter 2

Virtual Filmmaking with
Autodesk Maya Cameras

Maya is a visual effects studio designed with the art of filmmaking in mind. Maya’s virtual cam-
era replicates real-world cameras as much as possible, while at the same time offering enough
flexibility in the settings to allow for a wide variety of creative uses. This chapter introduces the
core concepts of how to work with Maya'’s virtual cameras.

Although the technical aspects of using Maya’s cameras are not difficult to learn, mastering
the art of virtual cinematography can take years of practice. As with all filmmaking, the story
is told through the camera. The camera is used to manipulate the elements of the scene, letting
viewers know what they need to focus on and how they should feel about what is going on in
the scene.

Working with Maya’s cameras should never be an afterthought. In fact, when you start to
build a scene that you intend to render, configuring the cameras should be one of your first con-
cerns. That is why this chapter appears early in this book. From the moment you frame the first
shot in the animation, you assume the role of director. The lessons in this chapter are designed
to make you feel comfortable with the technical aspects of configuring your cameras as well as
give you some creative examples that demonstrate the effect your camera setup has on how the
viewer will perceive the scene.

In this chapter, you will learn to:

Determine the image size and film speed of the camera
Create and animate cameras

Create custom camera rigs

Use depth of field and motion blur

Create orthographic and stereoscopic cameras

* & o o

Use the Camera Sequencer

Determining the Image Size and Film Speed of the Camera

When starting a new project in Maya, you should first determine the final size of the rendered
image or image sequence as well as the film speed (frames per second). These settings will
affect every aspect of the project, including texture size, model tessellation, render time, how
the shots are framed, and so on. You should raise this concern as soon as possible and make
sure every member of the team—from the producer to the art director to the compositor to the
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editor—is aware of the final output of the animation. This includes the image size, the resolu-
tion, the frames per second, and any image cropping that may occur after rendering. Nothing is
worse than having to redo a render or even an animation because of a miscommunication con-
cerning details such as resolution settings or frames per second.

TAKING OVER A PROJECT

If you inherit a shot or a project from another animator, double-check that the resolution and cam-
era settings are correct before proceeding. Never assume that the animation is set up properly. It’s
always possible that something has changed between the time the project started and the moment
you took over someone else’s scene files.

Setting the Size and Resolution of the Image

The settings for the image size and resolution are located in the Render Settings window under
the Image Size rollout on the Common tab (shown in Figure 2.1). When you start a new scene,
visit this section first to make sure these settings are what you need.

FIGURE 2.1
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Image size refers to the number of pixels on the horizontal axis by the number of pixels on the
vertical axis. So, a setting of 640 by 480 means 640 pixels wide by 480 pixels tall.

Resolution refers to how many pixels fit within an inch (or centimeter, depending on the set-
ting). Generally you’ll use a resolution of 72 pixels per inch when rendering for animations
displayed on computer screens, television screens, and film. Print resolution is much higher,
usually between 300 and 600 pixels per inch.

You can create any settings you'd like for the image size and resolution, or you can use one of
the Maya Image Size presets. The list of presets is divided so that common film and video pre-
sets are at the top of the list and common print settings are at the bottom of the list. In addition
to the presets there are fields that allow you to change the size and resolution units.

ADJUSTING SI1ZE FOR RENDER TEST PREVIEWS

1f you need to create test renders at a smaller size, you can change the size of just the images you
see in the Render Preview window by choosing a setting from the Render > Test Resolution menu
in the Rendering menu set. This option affects images only when they’re displayed in the Render
Preview window; it does not change the final output settings. When you render your final anima-
tion using a batch render, your images will use the size settings specified on the Common tab of
the Render Settings window.

Resolution is expressed in a number of ways in Maya:

Image Aspect Ratio The ratio of width over height. An image that is 720 by 540 has a ratio
of 1.333.

Pixel Aspect Ratio The ratio of the actual pixel size. Computer monitors use square pixels:
the height of the pixel is 1, and the width of the pixel is 1; thus, the pixel aspect ratio is 1.
Standard video images use nonsquare pixels that are 1 pixel high by 1.1 pixel wide, giving
them a pixel aspect ratio of 0.9.

Device Aspect Ratio The image aspect ratio multiplied by the pixel aspect ratio. For a video
image that is 720 by 486 (1.48) using nonsquare pixels (0.9), this would be 1.48 X 0.9 = 1.333.

Film Aspect Ratio The film aspect ratio is found in the Attribute Editor for the selected
camera. For a typical 35mm video image, this would be 0.816 - 0.612 = 1.333.

VIEWING NONSQUARE PIXELS ON A COMPUTER MONITOR

Viewing nonsquare pixels on a computer monitor makes the image look squished. Typically you
would test render your animation using a pixel aspect ratio of 1.0 with an image size of 720 by 54o0.
When you are ready for final output, you can switch your resolution to a standard video resolution
using a pixel aspect ratio of 0.9 and an image size of 720 by 486. You can use the CCIR 601/Quantel
NTSC preset under the Image Size rollout in the Render Settings.
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Setting the Film Speed

The film speed (also known as transport speed) is specified in frames per second. You can find
this setting in the Maya Preferences window (Window > Settings/Preferences > Preferences).
Under the Categories column on the left side of the window, choose Settings. In the Working
Units area, use the Time drop-down list to specify the frames per second of the scene. You can
change this setting after you've started animating, but it’s a good idea to set it at the start of a
project to avoid confusion or mistakes. When changing this setting on a scene that already has
keyframed animation, you can choose to keep the keyframes at their current frame numbers
or have Maya adjust the keyframe position automatically based on the new time setting (see
Figure 2.2).
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Creating and Animating Cameras

When you add a camera to a scene, you should think about how the shot will be composed and
whether the camera will be animated. The composition of a shot affects the mood and tells the
viewer which elements visible within the frame are most important to the story. The camera set-
tings allow you to fine-tune the composition of the shot by controlling what is visible within the
frame and how it appears.

Most of the attributes of a camera can be animated, allowing you to set the mood of a scene
and create special camera effects. Three types of cameras offer different animation controls.
These are the one-, two-, and three-node cameras. The controls available for each camera type
are suited for different styles of camera movement. This section covers how to create different
camera types for a scene and how to establish and animate the settings.
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ANIMATICS

An animaticis a filmindustry term referring to a rough animation designed to help plan a shot, like
amoving storyboard. Typically models in an animatic are very low resolution and untextured with
simple lighting. Animatics are used to plan out both computer-generated (CG) and live-action shots.
Camera work, timing, and the composition of elements within the frame are the most important
aspects of an animatic.

Creating a Camera

Every new Maya scene has four preset cameras by default. These are the front, side, top, and
perspective (persp) cameras. You can render using any of these cameras; however, their main
purpose is to navigate and view the 3D environment shown in the viewport. It’s always a good
idea to create new cameras in the scene for the purpose of rendering the animation. By keeping
navigation and rendering cameras separately, you can avoid confusion when rendering.

1. Open the chase_v01.ma scene from the chapter2/scenes folder on the DVD. You'll find
that a simple animatic of a car racing down a track has been created.

2. Create a new camera (Create > Cameras » Camera). Open the Outliner, and select the
new cameral node. Double-click its transform node in the Outliner, and rename it shot-
Cam1 (see Figure 2.3).
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3. In the Display tab of the Layer Editor, turn off the visibility of all the layers except the
street layer to hide the unnecessary geometry in the scene.

4. Select shotCam1 in the Outliner, and press the f hot key to focus on this camera in the
viewport.
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DISPLAY LAYERS

You can find display layers below the Channel Box/Layer Editor on the right side of the screen.
Clicking the V button toggles the visibility of the layer.

Anin

The icon for the camera looks like a movie camera. It has a transform node and a shape
node. The camera attributes are located on the shape node.

5. To move the camera up from the center of the grid to the level of the street, set the
Translate X, Y, and Z channels to 1.382, 4.138, and -3.45 in the Channel Box. Press f
again to focus the view on the camera that should now be above the street.

6. In the toolbox, click the Show Manipulator tool (the bottom icon in the toolbox). If you
zoom out in the viewport, you'll see the camera has a second positional icon; this manipu-
lator can be used to aim the camera (see Figure 2.4). Grab the aim handle of the manipula-
tor, and position it on the street so the camera is looking up the road (toward the beginning
of the track where the car starts).

ugf:::;vg FIGURE 2.4
The Show Manipu-
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7. In the Viewport panel menu, choose Panels » Look Through Selected (or Panels >
Perspective » shotCam1). This will switch the view to shotCam1.
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You can use the icons at the top of the Viewport panel to quickly access common view-
port settings (see Figure 2.5). The first group of icons on the left side is directly related
to camera display options. Starting from the left, these are the actions associated with
each icon:

Select Camera Selects the transform node of the current viewing camera.
Camera Attributes Opens the Attribute Editor for the current viewing camera.

Bookmark Stores a bookmark for the current camera position. To move the camera to a

bookmarked position, choose View > Bookmarks, and choose the bookmark from the list.

FIGURE 2.5
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CAMERA BOOKMARKS

You can name your stored bookmarks and create a shelf button for each using the Bookmark Editor
(View » Bookmarks > Edit Bookmarks).

Image Plane Creates an image plane for the current camera. Chapter 3, “Modeling I,”
discusses image planes.

2D Pan/Zoom Toggles between the current view and the 2D Pan/Zoom view for the
current viewing camera. This is a feature that was introduced in Maya version 2011. For
more information, see the “2D Pan/Zoom Tool” sidebar.

Grid Turns the Grid display on or off.
Film Gate Turns the Film Gate display on or off.
Resolution Gate Turns the Resolution Gate display on or off.

Gate Mask Turns the shaded Gate Mask display on or off when either the Resolution
Gate or Film Gate display is activated.

Field Chart Turns the Field Chart display on or off.
Safe Action Turns the Safe Action display on or off.
Safe Title Turns the Safe Title display on or off.
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2D PAN/ZOOM TOOL

The 2D Pan/Zoom tool allows you to pan or zoom around the view of the current viewing camera
without changing its position or rotation. This tool is designed to help you if you are working on a
scene in which you are matching the animation of a model to footage projected on an image plane
very closely. To do this, you may need to zoom in or move the view to get a better look without
disturbing the actual position of the camera. To do this, follow these steps:

1. Switch to the camera that is viewing the scene and the footage on the image plane.

2. Fromthe panel menu, choose View » Camera Tools » 2D Pan/Zoom Tool » Options. The options
should open in the Tool Settings. In the options you can switch between 2D Pan and 2D Zoom
modes.

3. Dragaround in the viewport window to pan or zoom.

4. To toggle back to the actual camera view, use the 2D Pan/Zoom button in the panel menu bar
or use the \ hot key.

In the Attribute Editor for the camera’s shape node, you can enable rendering for the 2D Pan/Zoom
view if needed under the Display Options rollout panel.

8. In the Display tab of the Layer Editor, turn on the visibility of the buildings layer so the
buildings are visible. Tumble around in the viewport (LMB-drag while holding down the
Alt key) so you can see part of the large building to the left of the street.

9. In the panel view, turn on the Resolution Gate display. Click the Camera Attributes icon
to open the Attribute Editor for shotCam1.

The image size of this scene is set to 1280 by 720, which is the HD 720 preset. You can
see the image resolution at the top of the screen when the Resolution Gate is activated.
Working with the Resolution Gate on is extremely helpful when you're establishing the
composition of your shots (Figure 2.6).

FIGURE 2.6 1280 % 720
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DISPLAY SETTINGS

You can find these same settings in the Attribute Editor for the camera’s shape node under the
Display Options rollout. You can use these settings to change the opacity or the color of the gate
mask: Turn on both the Resolution and Film Gate displays at the same time, and change the Overscan
setting, which changes the amount of space between the gate and the edge of the viewport.
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When you create a new camera to render the scene, you need to add it to the list of
renderable cameras in Render Settings. You can render the scene using more than one
camera.

10. Scroll down in the Attribute Editor for shotCam1, and expand the Output Settings roll-
out. Make sure the Renderable option is selected.

11. Open the Render Settings window. In the Renderable Cameras area, you'll see both the
shotCaml and persp cameras listed (see Figure 2.7). Remove the perspective camera from
the list of renderable cameras by clicking the Trash Can to the right of the listing.

To change the renderable camera, choose a different camera from the list. To add another
camera, choose Add Renderable Camera at the bottom of the list. The list shows all avail-
able cameras in the scene.
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FIGURE 2.7
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Setting Camera Attributes

At the top of the Attribute Editor for the camera’s shape node, you'll find the basic settings for
the camera available in the Camera Attributes rollout panel.

Single-Node Camera A single-node camera is just a plain camera like the perspective cam-
era. You can change its rotation and translation by setting these channels in the Channel Box,
by using the Move and Rotate tools, or by tumbling and tracking while looking through the
camera.

Two-Node Camera A two-node camera is a camera that has a separate aim control. The
Camera and Aim control are contained within a group. When you switch to this type of cam-
era (or create this type of camera using the Create > Cameras menu), the rotation of the cam-
era is controlled by the position of the aim node, which is simply a locator. It works much like
the Show Manipulators tool except that the locator itself has a transform node. This makes it
easy to visualize where the camera is looking in the scene and makes animation easier. You
can keyframe the position of the aim locator and the position of the camera separately and
easily edit their animation curves on the Graph Editor.

Three-Node Camera A three-node camera is created when you choose Camera, Aim, and
Up from the Controls menu. This adds a third locator, which is used to control the camera’s
rotation around the z-axis. These controls and alternative arrangements will be explored later
in the “Creating Custom Camera Rigs” section.
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MOVING THE CAMERA

You translate and rotate a camera using the standard transform tools. This is done when you are
viewing the camera from another camera. When you are looking through a camera, you can use the
same hot keys you use while moving around the perspective camera:

Alt+LMB = Tumble; also known as rotating the camera.
Alt+MMB = Track; this is the same as moving the camera on the x- and y-axes.

Alt+RMB = Dolly; this is the same as moving the camera on the z-axis. Also known as pushing
the camera.

You can find additional camera movement controls in the panel’s View menu; just choose View >
Camera Tools, and pick one of the tools from the list.

Lighting nderer Panels
BHE 9 G oy

1280 x 720

By default, each change in position that results from tumbling, tracking, or dollying a camera view
is not undoable. You can change this default by activating the Undoable Movements option in the
Movement Options rollout panel of the camera’s Attribute Editor; however, this may add a lot to
the Undo queue. Alternatively, you can use the bracket hot keys, [ and ], to move between previous
views. Bookmarks are also a good way to store camera views. It’s also common to set a keyframe
on a camera’s Translation and Rotation settings as a way of storing the position. The keyframe can
be used as part of an animation or deleted if it’s not needed in the final animation.

When working with two- or three-node cameras, resist the temptation to move or keyframe
the position of the group node that contains both the camera and the aim locator. Instead,
expand the group in the Outliner, and keyframe the camera and aim nodes separately. This
will keep the animation simple and help avoid confusion when editing the animation. If you
need to move the whole rig over a large distance, Shift+click both the camera and the aim
locator, and move them together. Moving the group node separately is asking for trouble.
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CAMERA TWIST

The Camera and Aim type of rig has a twist attribute on the group node above the camera and aim
nodes. The group node is labeled Camerai_group and can be selected in the Outliner. Twist controls
the Z rotation of the camera much like the Up control on the three-node camera. This is the only
control on the group node that you may want to adjust or keyframe.

For most situations, a two-node camera is a good choice since you can easily manipulate
the aim node to accurately point the camera at specific scene elements, yet at the same time,
it doesn’t have additional nodes like the three-node camera, which can get in the way. In this
example, you'll use a two-node camera to create an establishing shot for the car chase scene.
The focal length of the camera has a big impact on the mood of the scene. Adjusting the focal
length can exaggerate the perspective of the scene, creating more drama.

1. Select shotCam1, and open its Attribute Editor to the shotCam1Shapel tab. In the
Controls drop-down list, you have the option of switching to a camera with an aim node

or to a camera with an Aim and an Up control. Set the camera to Camera And
Aim (Figure 2.8).

2. Expand the shotCam1_group node that now appears in the Outliner, and select the shot-
Cam_aim node.
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3. In the Channel Box, set its Translate X, Y, and Z settings to -0.155, 4.206, -2.884. (The cam-
era’s node should still have its X, Y, and Z Translate settings at 1.382, 4138, and -3.45.)

4. In the Display Layer menu, turn on the visibility of the car layer. Set the current frame to
60 so that the car is in view of the camera.

5. In the Attribute Editor for shotCam1, adjust the Angle Of View slider. Decreasing this
setting flattens the perspective in the image and zooms in on the scene; increasing this
setting exaggerates the perspective and zooms out.
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anEEgTTWE 6. With the camera still selected, switch to the Channel Box, and find the Focal Length set-
ting under the shotCamShapel node.

7. Highlight the Focal Length channel label, and MMB-drag left and right in the viewport
window. Set Focal Length to 20 (see Figure 2.9).

FIGURE 2.9
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Adjusting the focal length of the camera has a similar effect on the camera as changing the
angle of view; however, it is inversely related to the angle of view. Increasing the focal length
zooms in on the scene, and decreasing it zooms out. The two settings are connected; they can’t
be set independently of each other.

In a real camera as you adjust the focal length, you are essentially repositioning the lens in
the camera so that the distance between the lens and the film gate (where the sensor is exposed
to light) is increased or decreased. As you increase the focal length, objects appear larger in
frame. The camera zooms in on the subject. The viewable area also decreases—this is the angle
of view. As you decrease the focal length, you move the lens back toward the film gate, increas-
ing the viewable area in the scene and making objects in the frame appear smaller. Youre essen-
tially zooming out (see Figure 2.10).

By default, Maya cameras have a focal length of 35. Roughly speaking, the human eye has a
focal length of about 50. A setting of 20 is a good way to increase drama in an action scene by
exaggerating the perspective. Higher settings can flatten out the view, which creates a differ-
ent type of mood; by reducing perspective distortion, you can make the elements of a scene feel
very large and distant.

FIGURE 2.10
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RENDERING A PORTRAIT

When you want to render a close-up of a character, a short focal length can distort the features of
your character’s face. To achieve the best results, you want to push the camera back in the scene
and then zoom in. This flattens the depth of the scene and creates a more accurate portrayal of the
character. Try these steps:

1. In the Render Settings, create an image size suitable for a portrait—try something like
990 x 1220.

2. Create a new camera, and turn on the Resolution Gate display so that you can properly frame
the face.

3. Setthe camera to a focal length of 50, dolly the camera back (Alt+RMB), and frame the face.

900 x 1200

SHAPES
renderCamShape

Render Anim

Help

A good portrait should be slightly off-center. Divide the frame horizontally into thirds, and posi-
tion the eyes at about the place where the top and middle thirds meet. You can always experiment
with different camera positions relative to the subject to see how it affects the emotional impact of
the image. Unless you want to create a very confrontational image, try not to put the subject dead
center in the frame. When rendering characters for a portfolio, this author finds this setup creates
a visually pleasing way to show off my work, which is not surprising since these techniques have
been developed by portrait artists over the past few centuries.

Limiting the Range of Renderable Objects with Clipping Planes
cafl Clipping planes are used to determine the range of renderable objects in a scene. Objects that lie
OBJECTIVE outside the clipping planes are not visible or renderable in the current camera. Clipping planes can
affect the quality of the rendered image; if the ratio between the near clipping plane and the far
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clipping plane is too large, image quality can suffer (if the near clipping plane is 0.1, the far clip-
ping plane should be no more than 20,000). Keep the far image plane just slightly beyond the far-
thest object that needs to be rendered in the scene, and keep the detail of distant objects fairly low.

The Auto Render Clip Plane option automatically determines the position of the clipping
planes when rendering with Maya software (this setting does not affect animations rendered
with mental ray, Maya hardware, or vector renders). It’s always a good idea to turn off this
option and set the clipping plane values manually.

1. From the panel menu, choose Panels > Layouts > Two Panes Side By Side. Set the left
pane to the perspective view and the right pane to shotCaml.

2. Select shotCaml, and choose the Show Manipulator tool from the toolbox.

3. Zoom in on the shot cam in the perspective view, and click the blue manipulator switch
(located just below the camera when the Show Manipulator tool is active; see Figure 2.11)
twice to switch to the clipping plane display.

FIGURE 2.11
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The clipping plane manipulator consists of two blue rectangles connected by lines. The
near clipping plane is a small rectangle very close to the camera; the far clipping plane is
very large and far from the camera.

4. Zoom in close to shotCam1, and RMB or MMB-drag the clipping plane manipulator. You
can set the position of this clipping plane interactively. Note that as you move the plane
away from the camera, the geometry in the shotCam1 view is cut off. Any object between
the camera and the near clipping plane will not render or will only partially render.

5. Zoom out until you can see the far clipping plane manipulator.

6. MMB-drag this to bring it in closer to the camera. Objects beyond this clipping plane will
not be rendered by the camera or will appear cut off.

7. In the Attribute Editor for the shotCam1Shape node, set Near Clip Plane to .05 and Far
Clip Plane to 85 (the units for this scene are set to meters). This is a good starting place; if
the positions of the planes need to change later, they can be adjusted (see Figure 2.12).
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FIGURE 2.12
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8. Save the scene as chase_v02.ma.

To see a version of the scene to this point, open chase_v02.ma from the chapter2/scenes
directory on the DVD.

CLIPPING PLANE PROBLEMS

Sometimes you may find that everything disappears in a scene when you change the working units
in the Preferences dialog box or when you open a scene. This usually happens when the clipping
planes have been set incorrectly or have changed. Try opening the Attribute Editor for the current
viewing camera, and adjust the clipping plane values. This is true for the front, side, and top cameras
as well as the perspective camera.

Composing the Shot Using the Film Back Settings

In an actual camera, the film back refers to the plate where the negative is placed when it is
exposed to light. The size of the film determines the film back setting, so 35mm film uses a
35mm film back. The film gate is the gate that holds the film to the film back. Unless you are try-
ing to match actual footage in Maya, you shouldn’t need to edit these settings.

Ideally you want the Film Gate and Resolution Gate settings to be the same size. If you turn
on the display of both the Film Gate and the Resolution in the camera’s Display Options rollout
panel (toward the bottom of the Attribute Editor—you can’t turn on both the Film Gate and
Resolution Gate using the icons in the panel menu bar), you may see that the Film Gate appears
larger than the Resolution Gate in the viewport—the gates are displayed as boxes. You can fix
this by adjusting the Film Aspect Ratio setting. Simply divide the resolution width by the reso-
lution height (1280 + 720 = 1.777777), and put this value in the Film Aspect Ratio setting (see
Figure 2.13).

The Film Gate drop-down list has presets available that you can use to match footage if
necessary. The presets will adjust the camera aperture, film aspect ratio, and lens squeeze
ratio as needed. If you're not trying to match film, you can safely leave these settings at their
defaults and concern yourself only with the Image Size and Resolution attributes in the
Render Settings window.
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CREATING AND ANIMATING CAMERAS

The Film Fit Offset and Film Offset controls in the Film Back rollout can be very useful in
special circumstances when you need to change the center of the rendered area without altering
the position of the camera. The parallax caused by the perspective of the 3D scene in the frame
does not change even though the camera view has. Creating an offset in an animated camera

can create a strange but very stylistic look.

The Film Fit Offset value has no effect if Fit Resolution Gate is set to Fill or Overscan. If you
set Fit Resolution Gate to Horizontal or Vertical and then adjust the Film Fit Offset, the offset
will be either horizontal or vertical based on the Fit Resolution Gate setting. The Film Offset val-

ues accomplish the same thing; however, they don’t depend on the setting of Fit Resolution Gate.

1. Continue with the scene from the previous section, or open the chase_v02.ma scene from
the chapter2/scenes directory on the DVD. Set the current camera in the viewport to

shotCaml and the timeline to frame 61.

2. In the Display tab of the Layer Editor, turn on the choppers layer so that the helicopter is

visible in the shot.

3. Open the Attribute Editor for shotCam1, and switch to the shape node (shotCamShapel) tab.
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4. In the Film Back rollout panel, set Film Offset to 0.2 and -0.05. Notice how this change
alters the composition of the frame. Even a small change can affect the emotional impact
of a shot (see Figure 2.14).

FIGURE 2.14
Adjusting the

Film Offset set-
ting changes the
framing of the shot
without actually
moving the camera
or the perspective
of the image.

Creating a Camera Shake Effect

The Shake attribute is an easy way to add a shaky vibrating motion to a camera. The first field
is the Horizontal shake, and the second field is the Vertical shake. The values you enter in

the shake fields modify the current settings for Film Offset. When you are applying a shake,
you're essentially shaking the film back, which is useful because this does not change how
the camera itself is animated. You can apply expressions, keyframes, or animated textures to
one or both of these fields. The Shake Enabled option allows you to turn the shaking on or off
while working in Maya; it can’t be keyframed. However, you can easily animate the amount of
shaking over time.

In this example, you'll use an animated fractal texture to create the camera shaking effect.
You can use an animated fractal texture any time you need to generate random noise values for
an attribute. One advantage fractal textures have over mathematical expressions is that they are
easier to animate over time.

1. Turn on the Shake Enabled option.

2. Right-click the first field in the Shake option, and choose Create New Texture from the
context window (see Figure 2.15).

3. Under the Maya section in the node list on the left of the Create Render Node window,
choose Fractal from the 2D Textures section. The camera view will move when you add
the texture, and that’s okay.

4. The attributes for the fractal texture will appear in the Attribute Editor. Set Amplitude to 0.1.

5. Select the Animated check box to enable the animation of the texture, and rewind the
animation.
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7. Set the timeline to frame 200. Set the Time attribute to 100, and set another key.
8. Rewind and play the animation; you’'ll see the camera move back and forth.

9. Repeat steps 2 though 7 for the Vertical setting in Shake to add another animated fractal
texture to this attribute. You want to have a different texture for each setting so that the
horizontal and vertical shaking settings of the camera are not the same value; otherwise,
the camera will appear to shake diagonally.

10. In the Attribute Editor for the second fractal texture, expand its UV Coordinates rollout
panel, and click the arrow to the right of it to go to the fractal texture’s place2dTexture2
node.

11. Set the Rotate UV value to 45. This rotates the texture so that the output of this animated
texture is different from the other, ensuring a more random motion.

You may notice that the shaking is nice and strong but that you've lost the original com-
position of the frame. To bring it back to where it was, adjust the range of values created
by each texture. The Fractal Amplitude of both textures is set to 0.1, which means each
texture is adding a random value between 0 and 0.1 to the film offset. You need to equal-
ize these values by adjusting the Alpha Offset and Alpha Gain settings of the textures.

12. Open the Hypershade by choosing Window > Rendering Editors > Hypershade. Click
the Textures tab, and Shift+click the two fractal textures.

13. From the Hypershade menu, choose Graph » Input And Output Connections. In the
Work Area, you'll see the two textures connected to the camera.

14. Deselect the texture nodes in the Work Area. Hold the mouse over the line connecting
one of the textures to the shotCamShapel node. The pop-up label shows that the outAl-
pha attribute of the texture is connected to the vertical or horizontal shake of the camera.
This means you must adjust the outAlpha value to compensate for the change made to
the camera’s offset (see Figure 2.17).

If you look at what’s going on with the fractal texture, you'll see that when the Amplitude set-
ting of the texture is 0, the outAlpha value is 0.5 (you can see this by switching to the shotCam-
Shapel tab and looking at the Horizontal Shake field). The fractal texture itself is a flat gray color
(value = 0.5). As you increase the Amplitude setting, the variation in the texture is amplified. At
an Amplitude value of 1, the outAlpha attribute ranges from 0 to 1. You can see this in the values
generated for the Shake attribute in the camera node. This is a large offset and causes the shaking
of the camera to be extreme. You can set Amplitude to a low value, but this means the outAlpha
value generated will remain close to 0.5, so as the shake values are added to the film offset, the
composition of the frame is changed—the view shifts up to the right.

To fix this, you can adjust the Alpha Gain and Alpha Offset attributes found in the Color
Balance rollout of each fractal texture. Alpha Gain is a scaling factor. When Alpha Gain is set to
0.5, the outAlpha values are cut in half; when Alpha Gain is set to 0, outAlpha is also 0, and thus
the Shake values are set to 0, and the camera returns to its original position. So if you want to
shake the camera but keep it near its original position, it seems as though the best method is to
adjust the Alpha Gain value of the fractal texture.
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FIGURE 2.17 Hypershade
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However, there is still one problem with this method. You want the outAlpha value of the
fractal to produce both negative and positive values so that the camera shakes around its origi-
nal position in all directions. If you set Alpha Gain to a positive or negative number, the values
produced will be either positive or negative, which makes the view appear to shift in one direc-
tion or the other. To properly adjust the output of these values, you can use the Alpha Offset
attribute to create a shift.

Set Alpha Offset to negative one-half of Alpha Gain to get a range of values that are both
positive and negative; 0 will be in the middle of this range. Figure 2.18 shows how adjusting the
Amplitude, Alpha Gain, and Alpha Offset attributes affect the range of values produced by the
animated fractal texture.
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Using an Expression to Control Alpha Offset

You can reduce the number of controls needed to animate the camera shake by automating the
Alpha Offset setting on the fractal node. The best way to set this up is to create a simple expres-
sion where Alpha Offset is multiplied by negative one-half of the Alpha Gain setting. You can
use this technique any time you need to shift the range of the fractal texture’s outAlpha to give
both positive and negative values.

1.

Select the fractal node that has been connected to the camera, and open its attributes
in the Attribute Editor. Expand the Color Balance rollout panel, and set the Alpha Gain
value of fractall to 0.25.

In the field for Alpha Offset, type =-0.5*fractall.alphaGain;. Then hit the Enter key on
the numeric keypad to enter the expression (Figure 2.19). Note that the correct fractal
node must be explicitly stated in the expression or you will get an error. If the node itself
is named something other than “fractall,” make sure that this is named in the expression
accordingly. When in doubt, just look at the top of the Attribute Editor in the Fractal field.
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You can create the same setup for the fractal2 node. However, it might be a better idea to
create a direct connection between the attributes of fractall and fractal2, so you need only
adjust the Alpha Gain of fractall, and all other values will update accordingly.

FIGURE 2.19
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3. In the Hypershade, MMB-drag fractall on top of fractal2, and choose Other from the
pop-up menu to open the Connection Editor.

4. Use the Connection Editor to connect the Alpha Gain and Alpha Offset settings of frac-
tall to Alpha Gain and Alpha Offset of fractal2. On the left side of the Connection Editor,
select alphaGain from the list; on the right side, select alphaGain to connect these two
attributes. Select alphaOffset on the left side, and then select alphaOffset on the right side
to connect these two attributes.

5. Select Amplitude on the left, and then select Amplitude on the right to connect these two
attributes as well (see Figure 2.20).

6. Play the animation, and you'll see the camera shake. To tone down the movement, reduce
the Alpha Gain of fractall.

7. Set the timeline to frame 60, and set the Alpha Gain value of fractall to 0. Right-click the
Alpha Gain field, and choose Set Key.

8. Set the timeline to frame 65. Set the Alpha Gain value of fractall to 0.5, and set another key.
9. Set the timeline to frame 90. Set the Alpha Gain value of fractall to 0, and set a third key.

10. Play back the animation, and you'll see the camera shake as the car and helicopter fly by
(make sure the playback speed in the Time Slider preferences is set to Real-time [24 fps];
otherwise, the shake will not appear at the proper speed in the view window as you play
the animation).

11. Save the scene as chase_v03.ma.
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FIGURE 2.20
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To see a version of the scene to this point, open the chase_v03.ma file from the chapter2\
scenes directory.

The Shake Overscan attribute moves the film back and forth on the z-axis of the camera as
opposed to the Shake settings, which move the film back and forth horizontally and vertically.
Try animating the Shake Overscan setting using a fractal texture to create some dramatic
horror-movie effects.

SHAKING CAMERA ASSET

This camera arrangement is a good candidate for an asset. You can create an asset from nodes
that have already been connected and animated. In the Outliner, turn off DAG Objects Only in the
Display menu. From the list of nodes in the Outliner, select the camera’s shape node, expression,
and fractal textures, and create an asset. You can then use the Asset Editor to publish the Amplitude
and Alpha Gain attributes of fractal1 to the container as custom attributes (give the attributes
descriptive names, such as shakeAmplitude and shakeScale). When you need to make changes to
the animation of the shake, you can simply set keyframes on the published shakeScale attribute.
For more information on assets, consult Chapter 1, “Working in Maya.”

Creating Custom Camera Rigs

Maya'’s three camera types (Camera, Camera and Aim, Camera Aim and Up) work well for
many common animation situations. However, you'll find that sometimes a custom camera rig
gives you more creative control over a shot. This section shows you how to create a custom cam-
era rig for the car chase scene. Use this example as a springboard for ideas to design your own
custom camera rigs and controls.
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Swivel Camera Rig

This rig involves attaching a camera to a NURBS circle so that it can easily swivel around a sub-
ject in a perfect arc.

1.

Open the chase_v03.ma scene from the chapter2\scenes directory on the DVD, or
continue with the scene from the previous section. In the Display tab of the Layer Editor,
turn off both the choppers and buildings layers.

Switch to the persp camera in the viewport.

Create a NURBS circle by choosing Create » NURBS Primitives > Circle. Drag on the
grid to create the circle. Name the circle swivelCamRig.

Create a new camera (Create » Cameras » Camera), and name it swivelCam.

5. Open the Attribute Editor for swivelCam to the swivelCamShape tab. Set Controls to

Camera and Aim.

. Expand the new swivelCam_group node in the Outliner. Select the swivelCam, and press

the f hot key to focus on the camera in the viewport.

7. In the Outliner, select swivelCam, and Ctrl+click the swivelCamRig circle.

8. Switch to the Animation menu set, and choose Animate > Motion Paths > Attach To
Motion Path > Options.

9. In the Attach To Motion Path Options dialog box, set Time Range to Start and
uncheck Follow.

10. Click Attach to attach the camera to the circle (see Figure 2.21). You may get a warning
in the script editor when you attach a camera to a curve stating that the camera may not
evaluate as expected. You can safely ignore this warning,.

FIGURE 2.21 Duapiay Show  Pane ) 0 Attach 1o Motion Path Options
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To Motion Path

command.
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TURN OFF THE FOLLOW OPTION

The camera’s rotation channels are already controlled by the Aim locator. If you leave the Follow
option selected in the Attach To Motion Path Options dialog box, you’ll get an error message in the
Script Editor bar.

11.

12.

13.
14.

15.
16.

17.

FIGURE 2.22
The NURBS circle
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and the swivel-
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group.

18.
19.

The camera is now attached to the circle via the motion path; the camera will stay in a
fixed position on the circle curve. This is a fast and easy way to attach any object or other
type of transform node (such as a group) to a curve.

Make sure the visibility of the street and car display layers is on, and rewind the
animation.

Zoom out in the perspective viewport. In the Outliner, select swivelCamRig, and MMB-
drag it up in the Outliner into the vehicleAnim group.

Expand the vehicleAnim group, and select the swivelCamRig.

Open the Channel Box, and set the Translate and Rotate channels to 0. The circle will be
repositioned around the car.

Select the swivelCam_aim locator from within the swivelCam_group.

In the Outliner, MMB-drag this up into the vehicleAnim group as well. Set its Translate
and Rotate channels to 0. This will move to the pivot point of the vehicleAnim group.

Select the swivelCamRig, and in the Channel Box set Translate Y to 0.4. Set the Scale attri-
butes to 0.5 (see Figure 2.22).

Set the viewport to the swivelCam, and turn on the Resolution Gate display.

Select the swivelCam node, and set its Focal Length to 20. Play the animation. You'll see
the camera follow along with the car as it drives down the road.
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Swivel Camera Rig Asset

The camera follows the car, but things don't get interesting until you start to animate the attri-
butes of the rig. To cut down on the number of node attributes that you need to hunt through
to animate the rig, you'll create an asset for the camera and rig and publish attributes for easy

access

1.

2.
3.

4.

FIGURE 2.23

The Create

in the Channel Box. (For more information on assets, consult Chapter 1.)

In the Outliner, Ctrl+click the swivelCam node, swivelCamShape, the swivelCam_aim
locator, and the swivelCamRig node.

Choose Assets » Advanced Assets > Create > Options.

Set Operation to Create Asset, and set the name to swivelCamera. Turn off Include
Hierarchy so that only the nodes selected in the Outliner are included.

Click Apply And Close to create the asset (Figure 2.23).

Advanced Asset Create Asset Effect
Options dialog box Operation: ®

5.

6.

10.

Name

Include Options

e Conn

Publish Options

Selection Transform

Apply and Close

Choose Assets » Asset Editor. On the left side of the Asset Editor, select the swivelCam-
era asset, and click the pushpin icon to edit the asset.

Click the plus sign in the square to expand the swivelCamera asset, and then expand the
swivelCam rig node (click the plus sign in the circle next to swivelCamRig).

From the list of attributes, scroll down to find the Translate attributes. Expand the
Translate group by clicking the plus sign in the circle, and select the Translate Y attribute.

. Click the second icon from the top at the center of the Asset Editor. Set the published

name to rise.

Expand the Rotate group, select the Rotate Y attribute, and publish it using the name
swivel. Expand the Scale group, select Scale Z, and publish it using the name push.

On the left side of the editor, expand the swivelCam_aim node, and select its Translate
attribute.
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11. Publish it using the name aim (see Figure 2.24). The three attributes Aim X, Aim Y, and
Aim Z will be created at once. Maya will automatically capitalize these attributes in the
Channel box.

FIGURE 2.24 000 Asset Editor - swivelCamera
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12. Expand the swivelCam (click the plus sign in the square) and the swivelCamShape nodes
(click the plus sign in the circle).

13. Select the Focal Length attribute, and publish it using the name zoom.

14. Close the Asset Editor, and select the swivelCamera asset node in the Outliner. Try
changing the values of the published attributes and playing the animation.

LoCK UNUSED ROTATION CHANNELS

To cut down on rotation problems, you’ll want to lock the Rotate X and Rotate Z values of the swiv-
elCamRig. Select the nodes in the INPUTS section of the Channel Box, set the values to 0, right-click
these attributes, and choose Lock Selected. This keeps the rotation nice and simple.

INPUTS
swivelCameraRi
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15. Open the Preferences panel (Window > Settings/Preferences > Preferences), and select
Animation from the Settings category in the column on the left. Make sure Default In
Tangent and Default Out Tangent are set to Clamped.

16. Try setting the following keyframes to create a dramatic camera move using the rig (see

Figure 2.25):

FRAME
Frame1
Frame 41
Frame 92
Frame 145
Frame 160

Frame 200

RISE
3.227
0.06
0.06
0.13
0

0.093

SWIVEL
48.411
134.265
246.507
290.819
458.551
495.166

PUSH
6

0.3
0.3
0.8
0.4
0.4

AIM X

AIMY
0

0
0.091
0.167
0.132

0.132

AIM Z
0

0
0.046
-0.087
-0.15

-0.015

17. Make sure that the view in the perspective window is still set to swivelCam (Panels »
Perspective » swivelCam).

18. Turn on all the display layers, and play the animation (Figure 2.26). Save the scene as
chase_v04.ma.

To see a finished version of the animation, open the chase_v04.ma scene from the chapter2\

scenes directory on the DVD.

FIGURE 2.25
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FIGURE 2.26
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Applying Depth of Field and Motion Blur

Depth of field and motion blur are two effects meant to replicate real-world camera phenomena.
Both of these effects can increase the realism of a scene as well as the drama. However, they can
both increase render times significantly, so it’s important to learn how to efficiently apply them
when rendering a scene. In this section, you'll learn how to activate these effects and the basics
of how to work with them. Using both effects effectively is closely tied to render-quality issues.
Chapter 12, “Rendering for Compositing,” discusses render-quality issues more thoroughly.

Rendering Using Depth of Field

The depth of field (DOF) settings in Maya simulate the photographic phenomena where some
areas of an image are in focus and other areas are out of focus. Artistically this can greatly
increase the drama of the scene, because it forces the viewers to focus their attention on a spe-
cific element in the composition of a frame.

Depth of field is a ray-traced effect and can be created using both Maya software and mental
ray; however, the mental ray DOF feature is far superior to that of the Maya software. This sec-
tion describes how to render depth of field using mental ray.

There are two ways to apply the mental ray depth of field effect to a camera in a Maya scene:

¢ Activate the Depth Of Field option in the camera’s Attribute Editor.

¢ Add amental ray physical_lens_dof lens shader or the mia_lens_bokeh shader to the cam-
era (mental ray has special shaders for lights and cameras, as well as surface materials).

Both methods produce the same effect. In fact, when you turn on the DOF option in the
Camera Attributes settings, you're essentially applying the mental ray physical DOF lens shader
to the camera. The mia_lens_bokeh lens shader is a more advanced DOF lens shader that has a
few additional settings that can help improve the quality of the depth of field render. For more
on lens shaders, consult Chapter 10, “mental ray Shading Techniques.”
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DEPTH OF FIELD AND RENDER TIME

Depth of field adds a lot to render time, as you’ll see from the examples in this section. When work-
ing on a project that is under time constraints, you will need to factor DOF rendering into your
schedule. If a scene requires an animated depth of field, you’ll most likely find yourself re-rendering
the sequence a lot. As an alternative, you may want to create the DOF using compositing software
after the sequence has been rendered. It may not be as physically accurate as mental ray’s DOF, but
it will render much faster, and you can easily animate the effect and make changes in the composit-
ing stage. To do this, you can use the Camera Depth Render Pass preset (discussed in Chapter 12) to
create a separate depth pass of the scene and then use the grayscale values of the depth pass layer in
conjunction with a blur effect to create DOF in your compositing software. Not only will the render
take less time to create in Maya, but you’ll be able to fine-tune and animate the effect quickly and
efficiently in your compositing software.

The controls in the camera’s Attribute Editor are easier to use than the controls in the physi-
cal DOF shader, so this example will describe only this method of applying DOF.

1. Open the chase_v05.ma scene from the chapter2/scenes directory on the DVD.

2. In the viewport, switch to the DOF_cam camera. If you play the animation (which starts
at frame 100 in this scene), you'll see the camera move from street level upward as two
helicopters come into view.

3. In the panel menu bar, click the second icon from the left to open the DOF_cam’s
Attribute Editor.

4. Expand the Environment rollout, and click the Background Color swatch.
5. Use the Color Chooser to create a pale blue color for the background (Figure 2.27).

6. Open the Render Settings dialog box, and make sure the Render Using drop-down
list is set to mental ray. If mental ray does not appear in the list, you'll need to load the
Mayatomr.m11 plug-in (Mayatomr.bundle on the Mac) found in the Window > Settings/
Preferences > Plug-in Manager window.

7. Select the Quality tab in the Render Settings dialog box, and set the Quality Presets to
Preview: Final Gather.

8. Switch to the Rendering menu set. Choose Render > Test Resolution » 50% Settings
(640x360). This way, any test renders you create will be at half resolution, which will save
a lot of time but will not affect the size of the batch-rendered images.

9. Set the timeline to frame 136, click in the viewport to set the rendering view, and Choose
Render > Render Current Frame to create a test render (see Figure 2.27).

The Render View window will open and render a frame. Even though there are no lights
in the scene, even lighting is created when Final Gather is activated in the Render Settings
dialog box (it’s activated automatically when you choose the Preview: Final Gather Quality
preset). The pale blue background color in the current camera is used in the Final Gather
calculations. (Chapter 10 discusses more sophisticated environmental lighting.) This par-
ticular lighting arrangement is simple to set up and works fine for an animatic.
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As you can see from the test render, the composition of this frame is confusing to the eye
and does not read very well. There are many conflicting shapes in the background and
foreground. Using depth of field can help the eye separate background elements from
foreground elements and sort out the overall composition.

10. In the Attribute Editor for the DOF_cam, expand the Depth Of Field rollout panel, and
activate Depth Of Field.

11. Store the current image in the Render Preview window (from the Render Preview win-
dow menu, choose File > Keep Image In Render View). Click in the viewport to set the
render view and then create another test render using the default DOF settings.

12. Use the scroll bar at the bottom of the Render View window to compare the images.
There’s almost no discernable difference. This is because the DOF settings need to be
adjusted. There are only three settings:

Focus Distance This determines the area of the image that is in focus. Areas in front or
behind this area will be out of focus.

F Stop This describes the relationship between the diameter of the aperture and the
focal length of the lens. Essentially it is the amount of blurriness seen in the rendered
image. F Stop values used in Maya are based on real-world f-stop values. The lower the
value, the blurrier the areas beyond the focus distance will be. Changing the focal length
of the lens will affect the amount of blur as well. If you are happy with a camera’s DOF
settings but then change the focal length or angle of view, you'll probably need to reset
the F Stop setting. Typically values range from 2.8 to about 12.

Focus Region Scale You can use this value to adjust the area in the scene you want to
stay in focus. Lowering this value will also increase the blurriness. Use this option to
fine-tune the DOF effect once you have the Focus Distance and F Stop settings.
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13. Select the DOF_cam and set Focus Distance to 15, F Stop to 2.8, and Focus Region Scale to
0.1, and create another test render from the DOF_cam.

The blurriness in the scene is much more obvious, and the composition is a little easier to
understand. The blurring is very grainy. You can improve this by adjusting the Quality
settings in the Render Settings. Increasing the Max Sample Level and decreasing the
Anti-Aliasing Contrast will smooth the render, but it will take much more time to render
the image. For now you can leave the settings where they are as you adjust the DOF (see
Figure 2.28). Chapter 12 discusses render-quality issues.

14. Save the scene as chase_v06.ma.

To see a version of the scene so far, open chase_v06.ma from the chapter2\scenes directory
on the DVD.

FIGURE 2.28
Adding depth of
field can help sort
the elements of a
composition by
increasing the
sense of depth.

Creating a Rack Focus Rig

A rack focus refers to a depth of field that changes over time. It’s a common technique used in
cinematography as a storytelling aid. By changing the focus of the scene from elements in the
background to the foreground (or vice versa), you control what the viewer looks at in the frame.
In this section, you'll set up a camera rig that you can use to interactively change the focus dis-
tance of the camera.

1. Continue with the scene from the previous section, or open the chase_v06.ma file from
the Chapter2\scenes directory of the DVD.

2. Switch to the perspective view. Choose Create > Measure Tools > Distance Tool, and
click two different areas in the scene to create the tool. Two locators will appear with an
annotation that displays the distance between the two locators in scene units (meters for
this scene).

3. In the Outliner, rename locatorl to camPosition, and rename locator2 to distToCam (see
Figure 2.29).
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FIGURE 2.29

A measure tool,
consisting of two
locators, is created
on the grid.

4. In the Outliner, expand the DOF_cam_group. MMB-drag camPosition on top of the DOF
_cam node to parent the locator to the camera.

5. Open the Channel Box for the camPosition locator, and set all of its Translate and Rotate
channels to 0; this will snap camPosition to the center of the camera.

6. Citrl-select the fields for the camPosition’s Translate and Rotate channels in the Channel
Box, right-click the fields, and choose Lock Selected so that the locator can no longer be
moved.

7. In the Outliner, MMB-drag distToCam on top of the camPosition locator to parent
distToCam to camPosition.

8. Select distToCam; in the Channel Box, set its Translate X and Y channels to 0, and lock
these two channels (see Figure 2.30). You should be able to move distToCam only along
the z-axis.

9. Open the Connection Editor by choosing Window > General Editors » Connection
Editor.

10. In the Outliner, select the distanceDimensionl node, and expand it so you can select the
distanceDimensionShapel node (make sure the Display menu in the Outliner is set so
that shape nodes are visible).

FIGURE 2.30 Channels Edit Object
distToCam

The Translate X : arclin’®

and Y channels Transiate ¥

Channels

of the distToCam
node are locked so
that it can move
only along the
z-axis.
Unmute Selects
Unm
aph Editor Display
Sync Timeline Display
Cut
y Selected
elect
d

Duplicate Values

Free:
ions
nection
Lock Selected
Unlock Selected




APPLYING DEPTH OF FIELD AND MOTION BLUR| 87

11. Click the Reload Left button at the top of the Connection Editor to load this node.

12. Expand the DOF_cam node in the Outliner, and select DOF_camShape. Click Reload
Right in the Connection Editor.

13. From the bottom of the list on the left, select distance. On the right side, select focusDis-
tance (see Figure 2.31).

FIGURE 2.31
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14. Look in the perspective view at the distance measured in the scene, select the distToCam
locator, and move it so that the annotation reads about 5.5 units.

15. Select the DOF_camShape node, and look at its focusDistance attribute. If it says some-
thing like 550 units, then there is a conversion problem:

A. Select the distanceDimensionShapel node in the Outliner, and open the Attribute Editor.

B. From the menu in the Attribute Editor, click Focus, and select the node that reads
unitConversionl14. If you are having trouble finding the unit conversion node, turn off
DAG Objects Only in the Outliner’s Display menu, and turn on Show Auxiliary Nodes
in the Outliner’s Show menu. You should see the unitConversion nodes at the bottom
of the Outliner.

C. Select unitConversionl14 to switch to the unitConversion node in the Attribute Editor,
and set Conversion Factor to 1.
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Occasionally when you create this rig and the scene size is set to something other than
centimeters, Maya converts the units automatically, and you end up with an incorrect
number for the Focus Distance attribute of the camera. This node may not always be
necessary when setting up this rig. If the value of the Focus Distance attribute of the cam-
era matches the distance shown by the distanceDimension node, then you don’t need to
adjust the unitConversion’s Conversion Factor setting.

16. Set the timeline to frame 138. In the Perspective window, select the distToCam locator,
and move it along the z-axis until its position is near the position of the car (about -10.671
in the Channel Box).
17. In the Channel Box, right-click the Translate Z channel, and choose Key Selected (see
Figure 2.32).
18. Switch to the DOF_cam in the viewport, and create a test render. The helicopters should
be out of focus, and the area further up the street in the distance should be in focus.
19. Set the timeline to frame 160.
FIGURE 2.32
The distToCam

locator is moved
near the position
of the car on
frame 138 and
keyframed.

20.

21.
22.

Move the distToCam node so it is at about the same position as the closest helicopter
(around -1.026).

Set another keyframe on its Z translation.

Switch back to the DOF_cam and render another test frame.

The area around the helicopter is now in focus (see Figure 2.33).

If you render a sequence of this animation for the frame range between 120 and 180, you'll
see the focus change over time. To see a finished version of the camera rig, open chase_v07.ma
from the chapter2\scenes directory on the DVD.
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FIGURE 2.33

The focus distance
of the camera has
been animated
using the rig so
that at frame 160
the helicopter is in
focus and the back-
ground is blurry.
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Adding Motion Blur to an Animation
If an object changes position while the shutter on a camera is open, this movement shows up as
a blur. Maya cameras can simulate this effect using the Motion Blur settings found in the Render
Settings as well as in the camera’s Attribute Editor. Not only can motion blur help make an ani-
mation look more realistic, it can also help smooth the motion in the animation.

Like depth of field, motion blur is very expensive to render, meaning it can take a long time.
Also much like depth of field, there are techniques for adding motion blur in the composit-
ing stage after the scene has been rendered. You can render a motion vector pass using mental
ray’s passes (render passes are discussed in Chapter 12 ) and then adding the motion blur using
the motion vector pass in your compositing software. For jobs that are on a short timeline and
a strict budget, this is often the way to go. In this section, however, you'll learn how to create
motion blur in Maya using mental ray.

There are many quality issues closely tied to rendering with motion blur. In this chapter,
you'll learn the basics of how to apply the different types of motion blur. Chapter 12 discusses
issues related to improving the quality of the render.

MENTAL RAY MOTION BLUR

The mental ray Motion Blur setting supports all rendering features such as textures, shadows (ray
trace and depth map), reflections, refractions, and caustics.

You enable the Motion Blur setting in the Render Settings window, so unlike the Depth Of
Field setting, which is activated per-camera, all cameras in the scene will render with motion
blur once it has been turned on. Likewise, all objects in the scene have motion blur applied to
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them by default. You can, and should, turn off the Motion Blur setting for those objects that
appear in the distance or do not otherwise need motion blur. If your scene involves a close-up
of an asteroid whizzing by the camera while a planet looms in the distance surrounded by
other slower-moving asteroids, you should disable the Motion Blur setting for those distant and
slower-moving objects. Doing so will greatly reduce render time.

To disable the Motion Blur setting for a particular object, select the object, open its Attribute
Editor to its shape node tab, expand the Render Stats rollout panel, and deselect the Motion Blur
option. To disable the Motion Blur setting for a large number of objects at the same time, select
the objects, and open the Attribute Spread Sheet (Window > General Editors > Attribute Spread
Sheet). Switch to the Render tab, and select the Motion Blur header at the top of the column to
select all the values in the column. Enter 0 to turn off the Motion Blur setting for all the selected
objects (see Figure 2.34).

FIGURE 2.34

You can disable

the Motion Blur

setting for a single

object in the Ren-

der Stats SECtiOH r . structureShape on

of its Attribute / o s roofShape on

Editor or for alarge §E : spikeShapel on

number of selected : 7 ) spikeShape2 on

objects using the "E“:ez:a"e:zj :
eet.

pCubeShapel3s on
pCubeShapel ¥l an
pCubeShapel 72 an
pCubeShapel73 an
pCubeShapel 74 on
pCubeShapel 75 an
pCubeShapel e an
pCubeShapel 77 on
pCubeShapel 78 on
pCubeShapel 79 an
pCubeShapeldn an
pCubeShapeldl on
pCubeShapeld2 on
pCubeShapeld3 an

pCubeShapeld4 an

MOTION BLUR AND RENDER LAYERS

The Motion Blur setting can be active for an object on one render layer and disabled for the same
object on another render layer using render layer overrides. For more information on using render
layers, consult Chapter 12.
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There are two types of motion blurs in mental ray for Maya: No Deformation and Full. No
Deformation calculates only the blur created by an object’s transformation—meaning its transla-
tion, rotation, and scale. A car moving past a camera or a helicopter blade should be rendered
using No Deformation.

The Full setting calculates motion vectors for all of an object’s vertices as they move over
time. Full should be used when an object is being deformed, such as when a character’s arm
geometry is skinned to joints and animated moving past the camera. Using Full motion blur
will give more accurate results for both deforming and nondeforming objects, but it will take a
longer time to render than using No Deformation.

MOTION BLUR FOR MOVING CAMERAS

If a camera is moving by a stationary object, the object will be blurred just as if the object were
moving by a stationary camera.

The following procedure shows how to render with motion blur:
1. Open the scene chase_v08.ma from the chapter2\scenes directory of the DVD.

2. In the Display tab of the Layer Editor, right-click the buildings display layer, and choose
Select Objects. This will select all the objects in the layer.

3. Open the Attribute Spread Sheet (Window > General Editors > Attribute Spread Sheet),
and switch to the Render tab.

4. Select the Motion Blur header to select all the values in the Motion Blur column, and type
0 and press Enter to turn the settings to Off (shown in Figure 2.35). Do the same for the
objects in the street layer.

5. Switch to the Rendering menu set. Choose Render > Test Resolution > Render Settings
(1280x720). This will set the test render in the Render View window to 1280 by 720,
the same as in the Render Settings window. In the Render Settings window under the
Quality tab, set Quality Presets to Preview.

6. Switch to the shotCam1 camera in the viewport.

7. Set the timeline to frame 59, and open the Render View window (Window > Rendering
Editors » Render View).

8. Create a test render of the current view. From the Render View panel, choose Render >
Render > shotCaml. The scene will render. Setting Quality Presets to Preview disables
Final Gathering, so the scene will render with default lighting. This is okay for the pur-
pose of this demonstration.

9. In the Render View panel, LMB-drag a rectangle over the blue helicopter. To save time
while working with motion blur, you'll render just this small area.

10. Open the Render Settings window.
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11. Switch to the Quality tab. Expand the Motion Blur rollout panel, and set Motion Blur to
No Deformation. Leave the settings at their defaults.

12. In the Render View panel, click the Render Region icon (second icon from the left) to
render the selected region in the scene. When it’s finished, store the image in the ren-
der view. You can use the scroll bar at the bottom of the render view to compare stored
images (see Figure 2.35).

FIGURE 2.35
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In this case, the motion blur did not add a lot to the render time; however, consider that

this scene has no textures, simple geometry, and default lighting. Once you start adding
more complex models, textured objects, and realistic lighting, you'll find that the render
times will increase dramatically.

OPTIMIZING MOTION BLUR

Clearly, optimizing Motion Blur is extremely important, and you should always consider bal-
ancing the quality of the final render with the amount of time it takes to render the sequence.
Remember that if an object is moving quickly in the frame, some amount of graininess may actually
be unnoticeable to the viewer.

13. In the Render Settings window, switch to the Features tab, and set the Primary Renderer
to Rasterizer (Rapid Motion), as shown in Figure 2.36.

14. Click the Render Region button again to re-render the helicopter.
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15. Store the image in the render view, and compare it to the previous render. Using

16.

Rasterizer (Rapid Motion) will reduce render times in more complex scenes.

The Rapid Motion setting uses a different algorithm to render motion blur, which is not
quite as accurate but much faster. However, it does change the way mental ray renders
the entire scene.

The shading quality produced by the Rasterizer (Rapid Motion) option is different from
the Scanline option. The Rasterizer does not calculate motion blurring for ray-traced ele-
ments (such as reflections and shadows). You can solve some of the problem by using
detailed shadow maps instead of ray-traced shadows (discussed in Chapter 9, “Lighting
with mental ray”), but this won't solve the problem that reflections lack motion blur.

Switch back to the Quality tab, and take a look at the settings under Motion Blur:

Motion Blur By This setting is a multiplier for the motion blur effect. A setting of 1 pro-
duces a realistic motion blur. Higher settings create a more stylistic or exaggerated effect.

Shutter Open and Shutter Close These two settings establish the range within a frame
where the shutter is opened or closed. By increasing the Shutter Open setting, you're cre-
ating a delay for the start of the blur; by decreasing the Shutter Close setting, you're mov-
ing the end time of the blur closer to the start of the frame.
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17. Switch back to the Quality tab in the Render Settings window. Under Motion Blur, set
Shutter Open to 0.25, and render the region again.

18. Store the frame, and compare the two images. Try a Shutter Close setting of 0.75.
Figure 2.37 shows the results of different settings for Shutter Open and Shutter Close.

Setting Shutter Open and Shutter Close to the same value effectively disables motion
blur. You're basically saying that the shutter opens and closes instantaneously, and there-
fore there’s no time to calculate a blur.

y .

FIGURE 2.37
Different settings
for Shutter Open
and Shutter Close
affect how motion
bluris calculated.
From left to right,
the Shutter Open
and Shutter Close
settings for the
three images are
(0, 1), (0.25, 1), and
(0.25, 0.75). The
length of time the
shutter is open for
the last image is
half of the length
of time for the first
image.

USING THE SHUTTER ANGLE ATTRIBUTE

You can achieve results similar to the Shutter Open and Shutter Close settings by changing the
Shutter Angle attribute on the camera’s shape node. The default setting for Maya cameras is 144.
If you set this value to 72 and render, the resulting blur would be similar to setting Shutter Angle to
144, Shutter Open to 0.25, and Shutter Close to 0.75 (effectively halving the total time the shutteris
open). The Shutter Angle setting on the camera is meant to be used with Maya Software Rendering
to provide the same functionality as mental ray’s Shutter Open and Shutter Close settings. It’s a
good idea to stick to one method or the other—try not to mix the two techniques, or the math will
start to get a little fuzzy.

19. Return the Shutter settings to 0 for Shutter Open and 1 for Shutter Close.

20. In the Quality section below the Motion Blur settings, increase Motion Steps to 6, and
render the helicopter region again.



APPLYING DEPTH OF FIELD AND MOTION BLUR ‘ 95

21. Store the image, and compare it to the previous renders. Notice that the blur on the heli-
copter blade is more of an arc, whereas in previous renders, the blur at the end of the
blade is a straight line (Figure 2.38).

FIGURE 2.38 ok Renger View
Increasing Motion .. @ View Bender PR Optioms play  Resder Twger  Help
Steps increases the
number of times
the motion of the
objects is sampled,
producing more of
an accurate blur in
rotating objects.

In this figure the
picture is zoomed
in to make the dif-
ference clear.

The Motion Steps attribute increases the number of times the motion of the objects are sam-
pled between the opening and closing of the shutter. If Motion Steps is set to 1, the motion of the
object when the shutter opens is compared to the motion when the shutter is closed. The blur
is calculated as a linear line between the two points. When you increase the Motion Steps set-
ting, mental ray increases the number of times it looks at the motion of an object over the course
of time in which the shutter is open and creates a blur between these samples. This produces a
more accurate blur in rotating objects, such as wheels or helicopter blades.

The other settings in the Quality section include the following:

Displace Motion Factor This setting adjusts the quality of motion-blurred objects that have
been deformed by a displacement map. It effectively reduces geometry detail on those parts
of the model that are moving past the camera based on the amount of detail and the amount
of motion as compared to a nonmoving version of the same object. Slower-moving objects
should use higher values.

Motion Quality Factor This is used when the Primary Renderer is set to Rasterizer (Rapid
Motion). Increasing this setting lowers the sampling of fast-moving objects and can help
reduce render times. For most cases, a setting of 1 should work fine.

Time Samples This controls the quality of the motion blur. Raising this setting adds to
render time but increases quality. As mental ray renders a two-dimensional image from a
three-dimensional scene, it takes a number of spatial samples at any given point on the two-
dimensional image. The number of samples taken is determined by the anti-alias settings
(discussed further in Chapter 12). For each spatial sample, a number of time samples can also
be taken to determine the quality of the motion blur effect; this is determined by the Time
Samples setting.
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Time Contrast Like Anti-Aliasing contrast (discussed in Chapter 12), lower Time Contrast
values improve the quality of the motion blur but also increase render time. Note that the
Time Samples and Time Contrast settings are linked. Moving one automatically adjusts the
other in an inverse relationship.

Motion Offsets These controls are found in the Motion offsets rollout below the Quality
rollout. They enable you to set specific time steps where you want motion blur to be
calculated.

Using Orthographic and Stereo Cameras

Orthographic cameras are generally used for navigating a Maya scene and for modeling from
specific views. A stereoscopic or stereo camera is a special rig that can be used for rendering
stereoscopic 3D movies.

Orthographic Cameras

The front, top, and side cameras that are included in all Maya scenes are orthographic cameras.
An orthographic view is one that lacks perspective. Think of a blueprint drawing, and you get
the basic idea. There is no vanishing point in an orthographic view.

Any Maya camera can be turned into an orthographic camera. To do this, open the Attribute
Editor for the camera, and in the Orthographic Views rollout panel, turn on the Orthographic
option. Once a camera is in orthographic mode, it appears in the Orthographic section of the
viewport’s Panels menu. You can render animations using orthographic cameras; just add the
camera to the list of renderable cameras in the Render Settings window. The Orthographic
Width is changed when you dolly an orthographic camera in or out (see Figure 2.39).

FIGURE 2.39
The Orthographic
option for the
perspective
camera is
activated,
flattening the
image seenin the
perspective view.
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THE VIEWCUBE

You can use Maya’s ViewCube to view the objects in your scene from a variety of different angles.
This means you are not limited to just the Perpsective, Front, Side, and Top camera options. By
default, the ViewCube appears in the upper right corner of the viewport. To change the view, sim-
ply click on one of the faces of the ViewCube. When you have the cube set to an orthographic view,
such as the bottom, the other faces of the ViewCube will not be visible. In this case, arrows appear
outside of the ViewCube. You can click on these arrows to rotate the ViewCube and thus change
the viewing angle of the scene. Click on the center of the ViewCube to zoom in; click on an edge or
corner of the ViewCube to see the scene from an oblique view; or click on the house icon to return
to your strating view. You can choose more options for the ViewCube by clicking on the small arrow
at the lower right of the ViewCube icon.

INPUTS
swivelCameraRig

CERT
OBJECTIVE Stereo Cameras

You can use stereo cameras when rendering a movie that is meant to be seen using special 3D
glasses. Follow the steps in this example to learn how to work with stereo cameras:

1. Create a new scene in Maya. From the Create menu, choose Cameras » Stereo Camera.
You'll see three cameras appear on the grid.

2. Switch the panel layout to Panels > Saved Layouts > Four View.

3. Set the upper-left panel to the perspective view and the upper right to Panels > Stereo »
stereoCamera.

4. Use the panel menu in the viewport to set the lower-left viewport to StereoCameraLeft
and the lower-right viewport to StereoCameraRight.

5. Create a NURBS sphere (Create » NURBS Primitives » Sphere).

6. Position the sphere in front of the center camera of the rig, and set its Translate Z channel
to -10.
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7.

10.
11.
12.

FIGURE 2.40

A stereo camera
uses three cameras
to render an image
for 3D movies.

The Zero Parallax
Plane is positioned
at the point where
objects in front of
the center camera
appear in the same
position in the left
and right cameras.

In the perspective view, select the center camera, and open the Attribute Editor to
stereoCameraCenterCamShape.

In the Stereo rollout panel, you can choose which type of stereo setup you want; this

is dictated by how you plan to use the images in the compositing stage. The Interaxial
Separation adjusts the distance between the left and right cameras, and the Zero Parallax
defines the point on the z-axis (relative to the camera) at which an object directly in front
of the camera appears in the same position in the left and right cameras.

In the Attribute Editor, under the Stereo Display Controls rollout panel, set Display
Frustum to All In the perspective view you can see the overlapping angle of view for all
three cameras.

Turn on Zero Parallax Plane. A semitransparent plane appears at the point defined by the
Zero Parallax setting.

Set the Stereo setting in the Stereo rollout panel to Converged.
Set the Zero Parallax attribute to 10 (see Figure 2.40).

In the perspective view, switch to a top view, and make sure the NURBS sphere is
directly in front of the center camera and at the same position as the Zero Parallax Plane
(Translate Z = -10).

As you change the Zero Parallax value, the left and right cameras will rotate on their
y-axes to adjust, and the Zero Parallax Plane will move back and forth depending on the
setting.




USING THE CAMERA SEQUENCER

13. In the top view, move the sphere back and forth toward and away from the camera rig.
Notice how the sphere appears in the same position in the frame in the left and right
camera view when it is at the Zero Parallax Plane. However, when it is in front of or
behind the plane, it appears in different positions in the left and right views.

If you hold a finger up in front of your eyes and focus on the finger, the position of the finger
is at the Zero Parallax Point. Keep your eyes focused on that point, but move your finger
toward and away from your face. You see two fingers when it’s before or behind the Zero
Parallax Point (more obvious when it’s closer to your face). When a stereo camera rig is
rendered and composited, the same effect is achieved, and, with the help of 3D glasses, the
image on the two-dimensional screen appears in three dimensions.

14. Select the center stereo camera and turn on the Safe Viewing Volume option in the
Attribute Editor. This displays the area in 3D space where the views in all three cameras
overlap. Objects should remain within this volume in the animation so that they render
correctly as a stereo image.

15. Open the Render Settings to the Common tab.

16. Under Renderable Cameras, you can choose to render each camera of the stereo rig sepa-
rately, or you can select the Stereo Camera (Stereo Pair) option to add both the right and
left cameras at the same time. Selecting the stereoCamera option renders the scene using
the center camera in the stereo camera rig. This can be useful if you want to render a non-
stereoscopic version of the animation.

The cameras will render as separate sequences, which can then be composited together in
compositing software to create the final output for the stereo 3D movie.

You can preview the 3D effect in the Render View window by choosing Render > Stereo
Camera from the Render menu in the Render view. The Render View window will render the
scene and combine the two images. You can then choose one of the options in the Display menu
of the Render view by selecting Display » Stereo Display menu to preview the image. If you
have a pair of red/green 3D glasses handy, choose the Anaglyph option, put on the glasses, and
you'll be able to see how the image will look in 3D.

The upper-right viewport window has been set to StereoCamera, which enables a Stereo
menu in the panel menu bar. This menu has a number of viewing options you can choose from
when working in a stereo scene, including viewing through just the left or right camera. Set the
shading mode to Smooth Shade All and switch to Anaglyph mode to see the objects in the scene
shaded red or green to correspond with the left or right camera (this applies to objects that are
in front or behind the Zero Parallax Plane).

Using the Camera Sequencer

The Camera Sequencer is a nonlinear editing interface that allows you to stitch together multiple
camera views into a single sequence. The Camera Sequencer editing interface itself is similar

to editing interfaces found in video editing and compositing programs but instead of editing

a sequence of images, the Camera Sequencer edits the animation of cameras in an existing 3D
scene. This allows you to work out the timing of shots in a scene without having to render any
images.
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This exercise will demonstrate the basic functions of the Camera Sequencer:

1. Open the chase_v09.ma scene from the Chapter 2 folder on this book’s companion DVD.
2. In the perspective viewport, choose Panels > Saved Layouts > Persp/Camera Sequencer
(see Figure 2.41).
FIGURE 2.41
Choose the Persp/
Camera Sequencer
layout preset.
Saved Layouts
The Camera Sequencer interface appears at the bottom, below the persp view. Notice that
it has its own timeline. When you work with the Camera Sequencer, you do not need to
move the playhead on the main Time Slider; in fact, this can get a little confusing when
you first start using the sequencer, so it is not a bad idea to hide the Time Slider.
3. From the main menu bar choose Display » UI Elements. Uncheck both Time Slider and
Range Slider.
Now you can add a camera to the sequencer and start stitching together a sequence from
all three cameras.
4. From the menu bar in the Camera Sequencer, choose Create > Shot > Options. Make sure

shotl is listed in the Name field. Set the Shot Camera menu to shotCam1. Set Start Time to
50 and End Time to 90. Set New Shot Placement to Current Frame. Click the Create Shot
button (see Figure 2.42).

Hold the Alt key and drag to the right in the sequencer so that you can see more of the
timeline.



FIGURE 2.42

The options for
adding a shot to the
Camera Sequencer

FIGURE 2.43
shot1 has been
added to the
sequencer, indi-
cated by along

blue bar.

6.
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Current Frame

Image:

Create Shot

When you create the shot, a blue bar is added to the sequencer. This represents the range
of shotl. Notice that the shot is placed at the start of the Time Slider in the sequencer even
though the shot itself starts at frame 50 (see Figure 2.43).

Click the Playback Sequence button (the triangle pointed to the right) in the sequencer.
The animation shows the car and the helicopter whizzing past the shaking camera.

Stop the animation and rewind the playhead in the sequencer by clicking the double tri-
angle button on the far left of the sequencer controls.

Choose Create > Shot > Options to create a second shot. In the Create Shot Options dia-
log box, set the shot name to shot2, set Shot Camera to swivelCam, and set Start Time to
40 and End Time to 150. Leave New Shot Placement set to Current Frame. Click the Create
Shot button.

A second blue bar appears in the Camera Sequencer editing interface below the shotl bar
on a new track. This is because New Shot Placement was set to Current Frame. You can
add the shot to the same track as the original by choosing After Current Shot. We think
it’s easier to work with the shots if they are on separate tracks. As you'll see, you can eas-
ily move the tracks around in the Camera Sequencer Editing Interface.
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9. In the Camera Sequencer Editing Interface, click on the long blue bar in track 2, and drag
it to the right so that the left end of shot2 is below the right end of shotl (see Figure 2.44).

FIGURE 2.44
Move shot2 so that
it is aligned with
the end of shot1 | e iHhecam
in the Camera
Sequencer Editing
Interface.

The numbers at either end of the track correspond to the frame numbers in the anima-
tion. The upper number is the frame of the original sequence. The lower number is the
frame number in the Camera Sequencer Editing Interface. Look at the blue bar for shotl.
The number 41 indicates that you're on frame 41 in the sequencer. The number 90 indi-
cates that it is frame 90 of the actual animation. At the start of the bar for shot?2 (the left
end), the number 42 indicates that you're on frame 42 of the sequence and the number 40
indicates frame 40 of the actual animation.

10. Click the Playback Sequence button in the sequencer to play the animation. In spite of the
fact that technically the animation is jumping backward from the end of shotl to the start
of shot2, it looks seamless. In fact, you could even drag shotl so that it comes after shot2.

The shot at the top of the stack is what you'll see when the animation plays.

11. Stop the animation, rewind it, and use the Create menu to add a third shot. Name the
shot shot3, and set Shot Camera to DOF_camShape, Start Time to 100, and End Time to
150. Leave New Shot Placement set to Current Frame so that the new shot creates a new
track. Click the Create Shot button.

12. Drag the blue bar for shot3 to the right until the number in the lower-left corner of the bar
reads 90. You may need to Alt+MMB-drag to pan the view of the sequencer. Drag the bar
up and place it on the same track with shotl.

13. Play the sequence.

Now things are taking shape. With very little effort, you're already editing a film before a
single frame has been rendered!

14. Drag the double red vertical line (this is the playhead) until you're at frame 120 in the
sequence. Select the bar for shot2 so that it turns yellow.

15. On the menu bar for the Camera Sequencer Editing Interface, click the fourth icon from
the left—the icon that looks like a pair of scissors. Doing so splits the selected shot at the
playhead (see Figure 2.45).

FIGURE 2.45
Click the scissors
icon to split the
shot.
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16. Click on a blank part of the sequencer to deselect the shots and then click on the shorter
end of the shot2 bar in the Camera Sequencer Editing Interface. Drag it to the right so that
the left end is aligned with the right end of shot3.

17. Hold the mouse cursor over the frame number in the upper-right corner of shot2. The
cursor looks like a brush. Drag this corner to the right to extend the shot. Drag it all the
way until this number reads 200 (see Figure 2.46).

FIGURE 2.46
Arrange and
extend the shots
in the Camera
Sequencer Editing
Interface to create
a seamless anima-
tion sequence.

shotatnd lwtveicam)
100 | B3

Soundtrack

18. Play the sequence. Congratulations, you are on your way to becoming a virtual
filmmaker!

19. Save the scene as chase_v10.ma. To see a version of this scene, open the chase_v10.ma
scene from the Chapter 2 folder of the DVD.

The Camera Sequencer is a very powerful tool. In addition to rearranging camera sequences
in a nonlinear fashion, you can change the speed of the shots simply by dragging left or right
on the frame number in the lower-left or lower-right corners of the shot bar. When you do this,
you'll notice that the percentage value at the center of the bar updates. So if you extend the shot
to 200 percent of its original length, the camera moves, and the animation in the shot will be
slowed down to half speed. If you try this for shot3, you'll see the blades of the helicopters rotate
slower than in the original shot. However, the actual animation has not been changed. If you
leave the Camera Sequencer as is, the original animation in the scene will not be altered.

You can create an Ubercamera, which incorporates all the changes created in the Camera
Sequencer into a single camera. To do this, choose Create > Ubercam in the Camera Sequencer.
The main caveat is that you cannot alter the duration of the shots in the camera sequence.
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The Bottom Line

Determine the image size and film speed of the camera. You should determine the final
image size of your render at the earliest possible stage in a project. The size will affect every-
thing from texture resolution to render time. Maya has a number of presets that you can use
to set the image resolution.

Master It Set up an animation that will be rendered to be displayed on a high-definition
progressive-scan television.

Create and animate cameras. The settings in the Attribute Editor for a camera enable you
to replicate real-world cameras as well as add effects such as camera shaking.

Master It Create a camera setting where the film shakes back and forth in the camera.
Set up a system where the amount of shaking can be animated over time.

Create custom camera rigs. Dramatic camera moves are easier to create and animate when
you build a custom camera rig.

Master It Create a camera in the car chase scene that films from the point of view of
chopperAnim3 but tracks the car as it moves along the road.

Use depth of field and motion blur. Depth of field and motion blur replicate real-world
camera effects and can add a lot of drama to a scene. Both are very expensive to render and
therefore should be applied with care.

Master It Create a camera asset with a built-in focus distance control.

Create orthographic and stereoscopic cameras. Orthographic cameras are used primarily
for modeling because they lack a sense of depth or a vanishing point. A stereoscopic rig uses
three cameras and special parallax controls that enable you to render 3D movies from Maya.

Master It Create a 3D movie from the point of view of the driver in the chase scene.

Use the Camera Sequencer. The Camera Sequencer can be used to edit together multiple
camera shots within a single scene. This is very useful when blocking out an animatic for
review by a director or client.

Master It Add a fourth camera from the point of view of the car and edit it into the cam-
era sequence created in the section “Using the Camera Sequencer” in this chapter.



