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extrude, revolve, fillets, cuts, and holes, among others. You can put the parts together into

I n SolidWorks, you build 3D parts from a series of simple 2D sketches and features such as
assemblies. You can then create 2D drawings from the 3D parts and assemblies.

This chapter will familiarize you with some of the tools available to make the transition to
SolidWorks and with some of the basic facts and concepts that you need to know to get the most
out of the software.

VibEo

You can view videos for each chapter on the Wiley website, in addition to downloading sample files. View the Chapter 1
Introduction video to get started.

Installing SolidWorks for the First Time

Some of you will have SolidWorks installed for you by people in your company or by SolidWorks
reseller experts, and some of you will do the installation on your own. Regardless, it is best to
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make sure that your hardware and software are compatible with the SolidWorks system
requirements, available on the SolidWorks website at www.solidworks.com/sw/support/
SystemRequirements.html.

SolidWorks installs natively on both 32- and 64-bit operating systems. It is supported only
for Windows Vista and Windows 7. SolidWorks 2013 does not install on Windows XP.
The 64-bit operating system is recommended. In all cases, the professional-level OS is rec-
ommended. Although it is possible to install and run SolidWorks under Parallels and Boot
Camp on Apple hardware, that configuration is not supported or tested by SolidWorks
Corporation or its resellers.

You can find video card requirements at the above link for system requirements. The main
concern with a video card for SolidWorks is that it must be compatible with OpenGL, and
be SolidWorks certified. Hardware changes too rapidly for me to give specific recommen-
dations here, but generally nVidia brand boards in the Quadro line are acceptable, as are
AMD/ATI brand boards in the FirePro line. You should expect to pay $100 to $500 for a
serviceable low- to mid-range video card. Cards that are marketed as game cards, such as
the Radeon or GeForce, have known limitations and do not work well with SolidWorks.

In addition to installing the correct hardware, you also must have a compatible driver ver-
sion installed. Again, refer to the SolidWorks system requirements website.

Tip

Whether you are installing SolidWorks or someone is installing it for you, you should consider purchasing a copy of the

SolidWorks Administration Bible (Wiley, 2010), which contains all the information you need on installing, configuring,
and troubleshooting SolidWorks.

Alternatively, you might not want to get that involved at first. You can install the software
with all defaults just to get started, using it as a practice installation, especially if you
intend to learn as much as you can about it, and then come back and do a more thorough
job of implementing it later. If this is the case, just put the DVD in the drive (or use the
automatic download installers) and accept all the defaults.

You should count on the installation requiring about 6GB of space on your hard drive,
depending on the options you select to install. The locations of files on your computer
will vary by SolidWorks version, by your operating system, and by your own installation
choices, but the bulk of the files are placed into two separate folders: the Program Files
folder (C:\Program Files\SolidWorks Corp\SolidWorks) and the Toolbox Data
folder (C:\SolidWorks Data).

When installing any software, be sure to exit out of all other software first, turn off antivi-
rus software, make sure you have enough hard drive space and otherwise meet the system
requirements outlined on the SolidWorks System Requirements web page, and reboot
when the installation is complete.



Chapter 1: Introducing SolidWorks

You also can install without a DVD, using downloaded data instead. To do this, you need
a subscription account for the Customer Portal area of the SolidWorks website at www.
solidworks.com/sw/support/Subscription % 20Services.html.

Trial installations, network licenses, student versions, administrative images, and other
special cases may require that you contact your reseller for technical support.

Starting SolidWorks for the First Time

SolidWorks has many tools for beginning users that are available when the software is
installed. A default installation presents you with several options when the software is
started the first time. This section includes a description of these options and how you can
most benefit from them. If you plan to go to formal SolidWorks reseller-based training
classes, be sure to go through some of the tutorials mentioned in this section first, so you
are prepared to ask educated questions and have a leg up on the rest of the class. You will
get more out of the training with the instructor if you have seen the material once before.

New FEaTURE
While SolidWorks opens, it displays a splash screen, which features a Cancel button. SolidWorks 2013 enables you to
cancel out of the software opening before it actually opens. SolidWorks 2013 also starts some components when you

start your computer to make startup of the software faster. If you prefer to disable these components from loading when
you start your computer, go to the Windows Start menu=> All Programs => Startup, right-click SolidWorks Fast Start, and
select Delete.

Examining the SolidWorks license agreement

Becoming familiar with what the license agreement says can be useful, but the agreement
does not have any bearing on learning how to use the software other than the fact that it
allows for a Home Use License. Many users find this part of the license agreement helpful.
The primary user of the license at work is also allowed to use the license at home or on a
portable computer. This is often a good option for learning techniques, doing additional
practice, or completing the design of that deck or soapbox derby car. If your employer
uses floating licenses or you are outside of North America, the rules are somewhat differ-
ent. Contact your reseller for details.

Viewing the Welcome to SolidWorks screen

The Welcome to SolidWorks screen, shown in Figure 1.1, is the next thing to greet you.
This helps you establish what type of tools you would like to see in the interface and gives
you some help options. You may not get the chance to see this dialog box if someone else,
such as an IT person, has installed and done an initial test on your software for you.
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FIGURE 1.1

The Welcome to SolidWorks screen

Welcome to SolidWorks (=]

Welcome bo SalidWaorks, This is the first ime you have run SalidWorks on this machine, We
wiould like Eo give you an opparbunity ko customize your SolidWarks installation,

Help customization
@) 1 am & new user, Show Quick Tips to help me get started,
“) T am new to this version of Solidvorks, Show me Interactie \What's New help.

_) Do nok show me any dynamic help.

“Work Flowe customization

You can customize default visibilty of toolbars and menus by vour ares of expertise. Select
any, all, or none of the Folowing categories.

[T Consumer product design
[ Machine design
[ Mold design

| Mote: You can change these ogtions at any time in the Soidworks application.

If you make a choice that you would like to change later, the options presented in this dia-
log box also are available elsewhere. Although you will not see this dialog box again, the
interface is highly customizable and options exist for most things you might want to
change. Chapter 2 covers interface customization in more detail.

Using Quick Tips
Quick Tips become available only when a document window is active. The Quick Tips set-
ting enables balloons with tips to help you get started with several tasks.

You can turn Quick Tips on or off by clicking the small square on the status bar near the
lower-right corner, as shown in Figure 1.2. You can turn the status bar on or off in the
View menu; however, the status bar serves many useful purposes for all users, so I recom-
mend you leave it active. You also can turn Quick Tips off in the Help menu by deselect-
ing Quick Tips. The on/off setting is document-type sensitive, so if you deselected Quick
Tips off in part mode, you need to do it again for assemblies and drawings as well. Quick
Tips are a great way to get going or to get a little refresher if it has been a while since you
last saw the software.

Using Interactive What's New

Interactive What’s New help is another option that you can change later from the Help
menu (Help=> What’s New > Interactive). This adds a question mark with an asterisk sym-
bol next to menu items that are new and have special Help file entries.

Customizing Workflow

The Workflow Customization options in the Welcome to SolidWorks dialog box activate
certain toolbars in the interface by default. It does not customize the toolbars at all. All
these options can be changed later in a more complete interface customization.
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FIGURE 1.2

Turning Quick Tips on or off

What would you like to do?

O  Create a solid part.
\G)D Create a 2D sketch.
2l Creale a sheet metal part.

[ Quick Tips Help

Editing Part IP5 =«

Creating a new document

To start a new SolidWorks document, click the New icon in the title bar of the SolidWorks
application. With standard functions such as creating a new document, SolidWorks works
just like a Microsoft Office application, and the icons even look the same.

The first time you create a document, SolidWorks prompts you to select units for your
default templates, as shown in Figure 1.3. This is an important step, although you can
make changes later if needed. SolidWorks stores most of the document-specific settings in
document templates for each type of document—parts, assemblies, and drawings. More
information on part and assembly templates can be found later in this chapter.

FIGURE 1.3

The default template units selection

Units and Dimension Standard (=]
Select the initial settings For the default templates:
Uniks:
[IPS {inch, pound, second) ']

Dimension standard:

= -

NOTE: These settings can be changed For individual
templates or documents in Tools, Options, Document
Properties.

[ e ][ concel " Help
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One of the most common questions new users ask is how they can change the default so
new documents come up with a certain type of units every time. Units in new documents
are set within the templates as a part of the drafting standards. To create a part with inch
units, use a template with inch units. You can have as many templates as you want, with
a different template for each type of units you might use.

ISO (International Organization for Standardization) and ANSI (American National
Standards Institute) drafting standards use different methods of displaying dimensions,
tolerances, drawing views, symbols, and projecting views, and these standards are con-
trolled by templates. ISO is typically a European standard and uses first angle projection,
while ANSI is an American standard and uses third angle projection. The standard used
throughout this book is ANSI, except where noted.

The difference between third and first angle projections can cause parts to be manufac-
tured incorrectly. Figure 1.4 demonstrates the difference between the two projection types.

Third angle projections are created as if the observer moves to the named side of the part,
and the named view is placed in the named orientation with respect to the Front view. So
the Right view is created by looking at the part from the right side, and then placing the
Right view to the right of the Front view.

First angle projections are the same as third angle except that the Right view is placed on
the left of the Front view; the Top view is placed on the bottom. The effect is that if you
are reading a first angle drawing but expecting a third angle drawing, the views appear to
be incorrect.

FIGURE 1.4
Differences between first (left) and third (right) angle projections
"%, Projections.SLOPAT EEE] % PujecionsSLIPHT SE=]
L Lfs °l ®
= - I
Er—

S

First angle projection Third angle projection
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For more information on first and third angle projections, refer to this Wikipedia article:
http://en.wikipedia.org/wiki/Multiview_orthographic_projection.

Be sure to get the option correct. If someone else, such as a computer specialist who is not
familiar with mechanical drafting standards, initially sets up SolidWorks on your com-
puter, verify that the default templates use the correct standards, units, and projection
method.

Another setting affecting projections that you will want to check can be accessed by
choosing Tools= Options = Display/Selection=>Projection type for four-view viewport.
This does not follow the drafting standard selected for the default templates or the country
in which the software is installed.

Exploring SolidWorks documentation

Several types of documentation are available to SolidWorks users. A great place to start is
the SolidWorks Resources tab in the Task Pane (on the right side of the screen). This is
the tab with the Home icon. The Getting Started option in the SolidWorks Resources tab is
shown in Figure 1.5.

FIGURE 1.5
The Getting Started panel on the SolidWorks Resources tab of the Task Manager

< Solid¥orks Resources
Getting Started ®|
[ Mew Document [
| Open a Document
B Making My First Part
B Making My First Drawing
= Tutorials
@ Introducing SolidWorks:
1) General Information

SolidWorks has two separate Help files. One is stored on the web (and is unavailable
during beta testing, when this book is being written), and the other is installed on your
computer. The reason for this, according to SolidWorks, is that it is easier to update the
files on the web. The option to select which you want to use is at Help= Use SolidWorks
Web Help.

Accessing tutorials

You can access several tutorials by selecting the SolidWorks Tutorials option from the
Help menu or from the SolidWorks Resources tab in the Task Manager. There, you will
find a list of tutorials on subjects from sheet metal to macros in parts, assemblies, and
drawings. These tutorials are certainly worth your time and will build your skills and
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knowledge of basic functionality. This SolidWorks Bible distinguishes itself from the man-
ufacturer’s tutorials by going into far more detail and depth about each function, adding
information such as best practices, performance considerations, and cautionary data,
acting as a thorough desk reference. The purpose of this book is not to duplicate all the
resources for beginners, but to take the information into far more depth and detail and
answer the “why” questions instead of just the “how” questions.

Keeping up with what's new

With every release, SolidWorks publishes a What’s New document to help you keep up to
speed with the changes. This is typically a PDF file with accompanying example files. If
you have missed a version or two, reading through the What’s New files can help get you
back on track. (You can find every What’s New document on Ricky Jordan’s blog at
http://rickyjordan.com.)

Moving from 2D to 3D

The Help menu contains a selection called Moving from 2D to 3D. It is intended to help
transitioning users acclimate to their new surroundings. Terminology is a big part of the
switch and figures prominently in the Moving from 2D to 3D help file. Likely, the most
helpful sections in Moving from 2D to 3D are “Approach to Modeling” and “Imported
AutoCAD Data.”

Checking out the Tip of the Day
The SolidWorks Tip of the Day, when activated, is displayed at the bottom of the

SolidWorks Resources tab in the Task Pane. Cycling through a few of the tips or using
them to quiz coworkers can be a useful skills-building exercise.

Identifying SolidWorks Documents

SolidWorks has three main data type files: parts, assemblies, and drawings; however,
there are additional supporting types that you may want to be familiar with if you are con-
cerned with customization and creating implementation standards. Table 1.1 outlines the
document types.

TABLE 1.1 Document Types

Design Documents Description

.sldasm SolidWorks assembly file type
slddrw SolidWorks drawing file type
sldprt SolidWorks part file type
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Templates and Formats Description

.asmdot Assembly template

.asmprp Assembly custom properties tab template
.drwdot Drawing template

.drwprp Drawing custom properties tab template
journal.doc Design journal template

.prtdot Part template

prtprp Part custom properties tab template
sldbombt BOM template (table-based)

sldtbt General table template

.slddrt Drawing sheet format

sldholtbt Hole table template

.sldrevtbt Revision table template

.sldwldtbt Weldment cutlist template

xls BOM template (Excel-based)

Library Files Description

.sldblk Blocks

sldifp Library part file

Styles Description

.sldgtolfvt Geometric tolerance style

.sldsffvt Surface finish style

.sldweldfvt Weld style

Symbol Files Description

gtol.sym A symbol file that enables you to create custom symbols
swlines.lin A line style definition file that enables you to create new line styles
Others Description

bt Sheet metal bend table

calloutformat.txt Hole callout format file

sldclr Color palette file

sldreg SolidWorks settings file

.sldmat Material database

.sldstd Drafting standard

.swhb, swp Macros, macro features

ixt Custom property file, sheet metal bend line note file
xls Sheet metal gauge table

11
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Saving your setup

If you need to reinstall SolidWorks, move to another computer, or duplicate the setup for
another user, you need to copy out the files you have used or customized. By default, all
these files are located in different folders within the SolidWorks installation directory.
Chapter 2 deals with interface settings and creating a registry settings file to copy to other
computers or use as a backup.

Best PracTiCE
It is especially important to have copies of any customized template or library files in a location other than the default

installation folder when you are doing complex implementations that include templates of various types of tables or cus-
tomized symbol files. Uninstalling SolidWorks or installing a new version will wipe out all your hard work. Choose
Tools=> Options=> File Location to establish separate library folders on the local hard drive or on a network location.

Using templates

I have included some of my part and assembly templates with the download materials for
this book. After you have downloaded the Zip files for each chapter, extract and copy
them to the folder specified at Tools= Options= File Locations= Document Templates.

ON THE WEBSITE
Wiley has established a website for the material in this book. You can download files for each chapter from www.wiley.
com/go/solidworks2013.

When you begin to create a new document, and the New SolidWorks Document dialog
box gives you the option to select one of several files to start from, those files are tem-
plates. Think of templates as “start parts” that contain all the document-specific settings
for a part (Tools=> Options= Document Properties). The same concept applies to assem-
blies and drawings. Templates generally do not have any geometry in them (although it
is possible).

Tip

The Novice interface for the New SolidWorks Document dialog box (File=> New SolidWorks Document) enables you to
select default templates only. The Advanced interface enables you to select any available template.

As shown in Figure 1.6, several tabs can be displayed on the Advanced interface. Each

of these tabs results from creating a folder in the template directory specified in the
Options dialog box (Tool=> Options). To switch from the Novice interface to the Advanced
interface, click the Advanced button. To switch from Advanced to Novice, click the
Novice button.

12
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FIGURE 1.6

The Novice and Advanced interfaces for the New SolidWorks Document dialog box

New SolidWorks Document (=]
% 3 30 represertation of 2 single design component
Part
@ 23D arrangement of parts andfor other assembles
Aszembly
E% 4 20 engineering drawing, typically of a part or assembly
Cravwing
Advanced O Cancel Help ]
New SolidWorks Document (=]
Templakes | Tutorial
e I =
P
fizsembly Drawing

Preview

Preview is not available.

Novice: O Cancel Help

Having multiple document templates available
Having multiple templates available gives you many options when starting a new docu-

ment. This offers an advantage in many situations, including the following:
e Standardization for a large number of users
e Working in various units
e DPreset materials
e DPreset custom properties
e Parts with special requirements, such as sheet metal or weldments
e Parts and assemblies with standardized background colors

13
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e Drawings of various sizes with formats (borders) already applied

e Drawings with special notes already on the sheet

|| |]|:||::> Drawing templates and formats are complex enough that | devote a chapter to them. Chapter 24 dis-

14

cusses the differences between drawing templates and formats and how to use them to your advantage.
This chapter addresses part and assembly templates.

Depending on your needs, it might be reasonable to have templates for metric parts and
assemblies and Imperial parts and assemblies, templates for steel and aluminum, and tem-
plates for sheet metal parts and weldments, if you design these types of parts. If your firm
has different customers with different requirements, you might consider using separate
templates for each customer. Over time, you will discover the types of templates you
need, because you will find yourself making the same changes repeatedly.

To create a template, open a document of the appropriate type (part, assembly, or draw-
ing), and make the settings you want the template to have; for example, units are one of
the most common reasons to make a separate template, although any Document Property
setting is fair game, from the dimensioning standard used to the image quality settings.
You can find these settings through the menus at Tools= Options=> Document Properties.

Some document-specific settings do not appear in the Document Properties dialog box,
such as the names of standard planes or the use of axes as reference geometry. Still, these
settings are saved with the template. Settings that fall into this category are the View
menu entity type visibility option and the Tools=> Sketch Settings menu options.

Custom Properties are another piece of the template puzzle. If you use or plan to use
BOMs (Bills of Materials), PDM (Product Data Management), or linked notes on drawings,
you need to take advantage of the automation options available with custom properties.

Locating templates

You can set the location of the templates folder at Tools= Options©> File Locations=>
Document Templates. The folder location may be a local folder or a shared network
folder. Multiple folders may be specified in the list box, each corresponding to a tab in the
New Document’s Advanced interface.

After all the Document Properties, custom properties, and other settings are set to your lik-
ing and you are ready to save the file as a template, choose Filew>Save As and select Part
Templates in Files of Type. SolidWorks prompts you to save the template in the first folder
listed in the File Locations list. You can create assembly templates the same way, except
that you change the settings for an assembly document.

You also can create additional tabs on the New SolidWorks Document dialog box by mak-
ing subfolders in the main folder in the File Locations area, as shown in Figure 1.7.

Adding subfolders to either of the locations listed in File Locations results in additional
tabs in the New SolidWorks Document dialog box.
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FIGURE 1.7
The Tools= Options @ File Locations list
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Using default templates

Default templates are established at Tools=> Options= Default Templates. The default tem-
plates must be in one of the paths specified in File Locations. Figure 1.8 shows the Default
Templates settings.

FIGURE 1.8

The Tools= Options= Default Templates settings

System Options | Document Properties,
General These templates wil be used for operations (such as File Tmport and Mirror
Drawings Part) where Sclidworks doss not prompt For a template,

- Display Style

- Mrea Hatch/Fill Parts:
Colors CriProgrambatalSolidwionks| Solidworks 201 3\templatesiPart. prodol :]
sketch

- Relations/Snaps Asserbies:
Display/Selection CiiProgramDatalSolidwarkslSalidwiorks 2013 bemplates)Assembly -
Ferfarmance

. Dirawaings:
Assemblies - - - -
External References i ProgramDatalSalidwarks) Solidworks 2013 kemplakes\Dr awing.dr =
Default Templates
File Locations @) Abaays Lse these default document templates
Fe .ature Manager () Prompt user to select dacument bemplake
| | Spin Box Increments

Two Default Template options are available: Always use these default document templates
and Prompt user to select document template. The Default Template options apply to situa-
tions when a template is required by an automatic feature in the software, such as an
imported part or a mirrored part. In this situation, depending on the option selected, the
system automatically uses the default template or the user is prompted to select a template.

PERFORMANCE
Allowing the software to apply the default template automatically can have a great impact on speed. This is especially

true in the case of imported assemblies, which would require you to select templates manually for each imported part in
the assembly if the Prompt user to select document template option is selected.

15
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Sharing templates

If you are administering an installation of a large number of users, or even if just a couple
of users are working on similar designs, shared templates are necessary. If every user does
what she thinks is best, you may get an adverse combination of conflicting ideas, and the
consistency of the company’s documentation may suffer. Standardized templates cannot
make users model, assemble, and detail in exactly the same way, but they do help users
start on the same foot.

To share templates among several users, create a folder for templates on a commonly
accessible network location, preferably with read-only access for users and read-write
permissions for administrators. Then point each user’s File Locations and Default tem-
plates to that location. Access problems due to multiple users accessing the same files do
not arise in this situation because users copy templates to create new documents and do
not use them directly.

CaurtioN

One of the downfalls of this arrangement is that if the network goes down, users no longer have access to their tem-

plates. This can be averted by also putting copies of the templates on the local computers; however, this has the ten-
dency to undermine the goal of consistent documentation. Users may tend to use and customize the local templates
rather than use the standardized network copies.

CAD administration and organizing any group of people on some level always comes down to training and then trusting
employees to do the right thing. There is no way to completely secure any system.
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Understanding Feature-Based Modeling

You need to be familiar with some terminology before diving into building models with
SolidWorks. Notice that I talk about “modeling” rather than “drawing” or even “design.”
This is because SolidWorks is virtual prototyping software. Whether you are building an
assembly line for automotive parts or designing decorative perfume bottles, SolidWorks
can help you visualize your geometrical production data in the most realistic way possible
without actually having it in your hand. This is more akin to making a physical model in
the shop than drawing on paper.

“Feature-based” modeling means that you build the model by creating 2D sketches and
applying processes (features) to create the 3D shape. For example, you can create a simple
box by using the Extrude process, and you can create a sphere using the Revolve process.
However, you can make a cylinder using either process, by revolving a rectangle or
extruding a circle. You start by visualizing the 3D shape, and then you apply a 3D process
to a 2D sketch to create that shape. This concept on its own is half of what you need to
know to create models with SolidWorks.

Figure 1.9 shows images of simple feature types along with the 2D sketches from which
they were created.
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FIGURE 1.9

Simple extruded and revolved features

Many different feature types in SolidWorks enable you to create everything from the
simplest geometry shown in Figure 1.10 to more complex shapes. In general, when I talk
about modeling in this book, I am talking about solid modeling, although SolidWorks also
has a complete complement of surfacing tools. I discuss the distinction between solid and
surface modeling in Chapter 33.

Table 1.2 lists some of the most common features in SolidWorks and classifies them
according to whether they always require a sketch, a sketch is optional, or they never
require a sketch. As an example of a sketch optional feature, a sweep can use a model
edge as a sweep path.

TABLE 1.2 Feature Types

Sketch Required Sketch Optional No Sketch (Applied Features)
Extrude Loft Fillet

Revolve Sweep Chamfer

Rib Dome Draft

Hole Wizard Boundary Shell

Wrap Deform Flex

In addition to these features, other types of features create reference geometry, such as
curves, planes, axes, and surface features (Chapter 32); specialty features for techniques
like sheet metal (Chapter 34); and plastics/mold tools (Chapters 38 and 39).

17
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Understanding History-Based Modeling

In addition to being feature-based, SolidWorks is also history-based. The process history is
shown in a panel to the left side of the SolidWorks window called the FeatureManager.
The FeatureManager keeps a list of the features in the order in which you have added
them. It also enables you to reorder items in the tree (in effect, to change history).
Because of this, the order in which you perform operations is important. For example,
consider Figure 1.10. This model was created by the following process, left to right start-
ing with the top row:

Create a sketch.

Extrude the sketch.

Create a second sketch.
Extrude the second sketch.
Create a third sketch.
Extrude Cut the third sketch.
Apply fillets.

Shell the model.

® N o g K~ W DD e

FIGURE 1.10

Features used to create a simple part
P
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If the order of operations used in the previous part were slightly reordered (by putting the
shell and fillet features before Step 6), the resulting part would look slightly different, as
shown in Figure 1.11. You can find this part in the download materials for this chapter.

FIGURE 1.11

Using a different order of features for the same part

Figure 1.12 shows a comparison of the FeatureManager design trees for the two different
feature orders. You can reorder features by dragging them up or down the tree. Relationships
between features can prevent reordering; for example, the fillets are dependent on the sec-
ond extruded feature and cannot be reordered before it. This is referred to as a Parent/
Child relationship.

|] [||:||:> Reordering and Parent/Child relationships are discussed in more detail in Chapter 12.

FIGURE 1.12

Compare the FeatureManager design trees for the parts shown in Figure 1.10 and Figure 1.11.
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Note

The order of operations, or history, is important to the final state of the part. For example,
if you change the order so that the shell comes before the extruded cut, the geometry of
the model changes, removing the sleeve inside instead of the hole on top. You can try this
for yourself by opening the part indicated previously, dragging the Shelll feature in the
FeatureManager and dropping it just above the Cut-Extrudel feature.

You can drag only one item at a time in the FeatureManager. Therefore, you may drag the shell and then drag each of

two fillets, or you could just drag the cut feature down the tree. Alternatively, you can put the shell and fillets in a folder
and drag the folder to a new location. Reordering is limited by parent/child relationships between dependent features.

|[||:||:> You can read more about reordering folders in Chapter 12.
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In some cases, reordering the features in the FeatureManager may result in geometry that
might not make any sense; for example, if the fillets are applied after the shell, they might
break through to the inside of the part. In these cases, SolidWorks gives an error that
helps you to fix the problem.

In 2D CAD programs where you are just drawing lines, the order in which you draw the
lines does not matter. This is one of the fundamental differences between history-based
modeling and drawing.

Features are really just like steps in building a part; the steps can either add material or
remove it. However, when you make a part on a mill or lathe, you are only removing
material. Some people choose to model following manufacturing methods, so they start
from a piece of stock and apply features that remove material. This approach works best
for machining, but doesn’t work well for molding, casting, sheet metal, or progressive
dies. The FeatureManager is like an instruction sheet to build the part. When you reorder
and revise history, you change the order of operations and thus the final result. Some peo-
ple look at the FeatureManager as a recipe for cooking a dish.

Sketching with Parametrics

Sketching is the foundation that underlies the most common feature types. You will find
that sketching in parametric software is vastly different from drawing lines in 2D CAD.

Dictionary.com defines the word parameter as “one of a set of measurable factors . . .
that define a system and determine its behavior and [that] are varied in an experiment.”
SolidWorks sketches are parametric. What this means is that you can create sketches that
change according to certain rules and maintain relationships through those changes. This
is the basis of parametric design. It extends beyond sketching to all the types of geometry
that you can create in SolidWorks. Creating sketches and features with intelligence is the
basis of the concept of Design Intent, which I cover in more detail later in this chapter.
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In addition to 2D sketching, SolidWorks also makes 3D sketching possible. Of the two
methods, 2D sketches are by far more widely used. You create 2D sketches on a selected
plane or planar face and then use them to establish shapes for features such as Extrude,
Revolve, and others. Relations in 2D sketches often are created between sketch entities and
other model edges that may or may not be in the sketch plane. In situations where other
entities are not in the sketch plane, the out-of-plane entity is projected into the sketch plane
in a direction that is normal to the sketch plane. This does not happen for 3D sketches.

You can use 3D sketches for the Hole Wizard, routing, weldments, and complex shape
creation, among other applications.

|] [||:||:> For more information on 3D sketching, refer to Chapter 6.

For a simple example of working with sketch relations in a 2D sketch, consider the sketch
shown in Figure 1.13a. The only relationships among the four lines are that they form a
closed loop that is touching end to end and one of the corners is coincident to the part ori-
gin. The small square icon near the origin shows the symbol for a coincident sketch rela-
tion. These sketch relations are persistent through changes and enable you to dynamically
move sketch elements with the cursor on the screen. The setting to enable or disable dis-
playing the sketch relation symbols is found at View=> Sketch Relations.

FIGURE 1.13

A sketch of four lines

£l

If you drag any of the unconstrained corners (except for the corner that is coincident to
the origin), the two neighboring lines follow the dragged endpoint, as shown in Figure
1.13b. Notice the ghosted image left by the original position of the sketch. This is helpful
when experimenting with changes to the sketch because you can see both the new and
the old states of the sketch. The setting to enable or disable this ghosted position is found
at Tools=> Options=> Sketch=>Ghost Image on Drag.
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If you add a parallel relation between opposing lines, they now act differently, as shown

in Figure 1.13c. You add a parallel relation by selecting the two lines to make parallel and
selecting Parallel from the PropertyManager panel. You also can select the Parallel relation
from the context bar that pops up in the graphics window when you have both lines selected.

|| [||:||::> You can read more about the PropertyManager in Chapter 2.
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Next, add a second parallel and a horizontal relation, as shown in Figure 1.13d. If you are
following along by re-creating the sketch on your computer, you will notice that one line
has turned from blue to black.

The line colors represent sketch states. It may be impossible to see this in the black and white
printing of this book, but if you are following along on your own computer, you can now see
one black line and three blue lines. Sketch states include Underdefined, Overdefined, Fully
Defined, Unsolvable, Zero Length, and Dangling, and are described as follows:

e Blue: Underdefined. The sketch entity is not completely defined. You can drag a
portion of it to change size, position, or orientation.

e Black: Fully Defined. The sketch entity is fully defined by a combination of
sketch relations and dimensions. A sketch cannot be fully defined without being
connected in some way to something external to the sketch, such as the part ori-
gin or an edge. (The exception to this rule is the use of the Fix constraint, which,
although effective, is not a recommended practice.)

e Red: Overdefined—Not Solved. When a sketch entity has two or more relations
and one of them cannot be satisfied, the unsatisfied relation will be red. For exam-
ple, if a line has both Horizontal and Vertical relations, and the line is actually ver-
tical, the Vertical relation will be yellow (because it is conflicting but satisfied),
and the Horizontal will be red (because it is conflicting and not satisfied).

e Yellow: Overdefined—Conflicts. Solving the sketch relations would result in a
zero-length entity; for example, this can occur where an arc is tangent to a line,
and the centerpoint of the arc is also coincident to the line.

e Brown: Dangling. The relation has lost track of the entity to which it was
connected.

Entities with different states can exist within a single sketch. In addition, endpoints of
lines can have a different state than the rest of the sketched entity. For example, a line
that is sketched horizontally from the origin has a coincident at one endpoint to the origin,
and the line itself is horizontal. As a result, the line and first endpoint are black, but the
other endpoint is underdefined because the length of the line is not defined. Sketch states
are indicated in the lower-right corner of the graphics window and in the status bar. You
can see that dragging one corner allows only the lines to move in certain ways, as shown
in Figure 1.13e.

In addition to sketch relations, dimensions applied using the Smart Dimension tool are
also part of the parametric scheme. If you apply an angle dimension (by clicking the two
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angled lines with the Smart Dimension tool) about the origin and try dragging again, as
shown in Figure 1.13f, you see that the only aspect that is not locked down is the length
of the sides. Notice also that when the angle dimension is added, another line turns black.

Finally, adding length dimensions for the unequal sides completes the definition of the
sketch, as shown in Figure 1.13g. At this point, all lines have turned black. This state is
called “fully defined.” Between the dimensions and sketch relations, there is enough infor-
mation to re-create this sketch exactly.

Best PracTICE
A best practice is to fully define all sketches. However, sometimes this is not practical. When you create freeform

shapes, generally by using splines, these shapes cannot easily be fully defined, and even if they are fully defined, the
extra dimensions are usually meaningless, because it is impractical to dimension splines on manufacturing drawings.

Parametric relations within a sketch control how the sketch reacts to changes from dimen-
sions or relations within the sketch or by some other factor from outside the sketch. Other
factors can drive the sketch as well, such as equations, other model geometry that is exter-
nal to the sketch, and even geometry from another part in an assembly, as you’ll see later.

Understanding Design Intent

Design intent is a phrase that you will hear often among SolidWorks users. I like to think
of it as “design for change.” Design intent means that when you put the parametric sketch
relations together with the feature intelligence, you can build models that react to change
in predictable ways. This gives you a great deal of control over changes.

An example of design intent could be a statement that describes general aspects that help
define the design of a part, such as “This part is symmetrical, with holes that line up with
Part A and thick enough to be flush with Part B.” From this description, and the surround-
ing parts, it is possible to re-create the part in such a way that if Part A or Part B changes,
the part being described updates to match.

Some types of changes can cause features to fail or sketch relations to conflict. In most sit-
uations, SolidWorks has ample tools for troubleshooting and editing that you can use to
repair or change the model. In these situations, it is often the design intent itself that is
changing.

Best PrACTICE

When editing or repairing relations, a best practice is to edit rather than delete. Deleting often causes additional prob-
lems farther down the tree. Many users find it tempting to delete anything that has an error on it.
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Editing Design Intent

One of the most prominent aspects of design in general is change. I have often heard it said
that you may design something once, but you will change it a dozen times. This concept
carries over into solid modeling work. Design intent is sometimes thought of as a static
concept that controls changing geometry. However, design intent itself often changes, thus
requiring the way in which the model reacts to geometric changes to also change.
Fortunately, SolidWorks has many tools to help you deal with changing requirements.

Choosing sketch relations

Seeing the sketch relation symbols is the best tool for visualizing design intent. You can
show or hide icons that represent the relations by choosing View => Sketch Relations.
When shown, these relations appear as an icon in a small colored box in the graphics area
next to the sketch entity. Clicking the icon highlights the sketch elements involved in that
relation. Refer to Figure 1.14 for examples of these relations.

Tip

The View Sketch Relations option is an excellent candidate for use with a hotkey, thus enabling you to easily toggle it on
and off.

II [||:||:> For more information on creating and managing hotkeys, see Chapter 2.

You can use the sketch relation icons on the screen to delete relations by selecting the
icon in the graphics area and pressing Delete on the keyboard. You also can use them to
quickly determine the status of sketch relations by referring to the colors defined earlier.

Selecting display/delete relations
ﬁk The Display/Delete Relations tool enables you to list, sort, delete, and repair sketch rela-

tions. You can find the Display/Delete Relations tool on the Sketch toolbar. The sketch
status colors defined earlier also apply here, with the relations appearing in the appropri-
ate color. (Relations are not shown in blue or black, only the colors that show errors,
such as red, yellow, and brown.) This tool also enables you to group relations by several
categories:

e All in This Sketch

e Dangling

e Overdefining/Not Solved

e External

e Defined in Context

e Locked
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e Broken
e Selected Entities

In the lower Entities panel of the Display/Delete Relations PropertyManager, shown in
Figure 1.14, you can replace one entity with another or repair dangling relations.

FIGURE 1.14
The Display/Delete Relations PropertyManager enables you to repair broken relations.
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|] [||:||::> You can read more about repairing dangling entities in Chapter 6.

Using suppressed sketch relations

Suppressing a sketch relation means that the relation is turned off and not used to compute
the position of sketch entities. Suppressed relations generally are used in conjunction with
configurations.

|] [":":> Configurations are discussed in detail in Chapter 11.

25



Part I: Introducing SolidWorks Basics

Working with Associativity

In SolidWorks, associativity refers to links between documents, such as a part that

has an associative link to a drawing. If the part changes, the drawing updates as well.
Bidirectional associativity means that the part can be changed from the part or the draw-
ing document window. One of the implications of this is that you do not edit a SolidWorks
drawing by simply moving lines on the drawing; you must change the model, which
causes all drawing views of the part or assembly to update correctly.

Other associative links include using inserted parts (also called base or derived parts),
where one part is inserted as the first feature in another part. This might be the case when
you build a casting. If the part is designed in its “as cast” state, it is then inserted into
another part where machining operations are performed by cut features and the part is
transformed into its “as machined” state. This technique also is used for plastic parts
where a single shape spans multiple plastic pieces. A “master part” is created and split
into multiple parts. An example would be a mouse cover and buttons.

One of the most important aspects of associativity is file management. Associated files stay
connected by filenames. If a document name is changed and one of the associated files is
not updated appropriately, the association between the files can become broken. For this
reason, you should use either SolidWorks or SolidWorks Explorer to change names of
associated files. Other techniques will work, but you should avoid some techniques.

Best PracTiCE
A poor practice is to change filenames, locations, or the name of a folder in the path of documents that are referenced

by other documents with Windows Explorer. Links between parts, assemblies, and drawings can be broken in this way.
Using SolidWorks Explorer or a PDM application is the preferred method for changing filenames.
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Summary

While product development is about design, it is even more about change. You design
something once, but you may modify it endlessly (or it may seem that way sometimes).
Similarly, SolidWorks is about design, but it really enables change. Think of SolidWorks
as virtual prototyping software that enables you to change your prototype rather than hav-
ing to make a new one. Virtual prototypes will never completely replace physical models,
but they may reduce your dependence on them to some extent.

SolidWorks is also about reusing data. Associativity enables you to model a part once and
use it for Finite Element Analysis (FEA), creating 2D drawings, building assemblies, creating
photorealistic renderings, and so on. When you make changes to the model, your drawing is
automatically updated, and you don’t have to reapply FEA materials and conditions or redo
the rendering setup. Associativity saves you time by reusing your data. Associativity and
change driven by feature-based and history-based modeling can take some getting used to if
you have had limited exposure to it, but with some practice it becomes intuitive, and you
will see the many benefits for enabling change. Parametric sketching and feature creation
help you to maintain Design Intent and to adjust it as necessary.



