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Objective 1.1 – Deploy and manage server images. This objective may include but is not limited to: install the Windows 
Deployment Services (WDS) role; configure and manage boot, install, and discover images; update images with patches, 
hotfixes, and drivers; install features for offline images.
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2 | Lesson 1

Windows Deployment Services (WDS) is a software platform and technology that allows 
you to perform automated network-based installations based on network-based boot and 
installation media. In other words, you can perform an installation over a network with no 
operating system or local boot device on it. The WDS server will store the installation files 
and help you manage the boot and operating system image files used in the network installa-
tions. Although WDS is included with later versions of Windows Server, including Windows 
Server 2012, it can be used to deploy Windows XP, Windows Vista, Windows 7, Windows 8, 
Windows Server 2003, Windows Server 2008, and Windows Server 2012.

An image file is basically a snapshot of a computer’s hard drive taken at a particular moment 
in time. The image file is sometimes referred to as an install image and is used to install an 
operating system. It contains the following:

• All of the operating system files on the computer

• Any updates and drives that have been applied

• Any applications that have been installed

• Any configuration changes that have been made

For client computers to communicate with a WDS server without an operating system, the 
client computer must have support preboot execution environment (PXE), pronounced 
“pixie.” PXE is a technology that boots computers using the network interface without a 
data storage device, such as a hard drive or an installed operating system. For a computer 
to perform a PXE boot, you must configure the BIOS setup program to perform a network 
boot. Depending on your system, you must enable the PXE boot and/or change the boot 
order so that the PXE boot occurs before the system tries other boot devices to boot from.

When PXE is used with WDS, the client computer downloads a boot image that loads Windows 
Preinstallation Environment (Windows PE). Windows PE is a minimal Windows operating 
system with limited services. Windows PE is then used to install the operating system using an 
operating system image file. Windows PE 4.0 is based on the Windows 8 operating system.

■ Using Windows Deployment Services 

THE BOTTOM LINE

In the 70-410 course, you learned how to install Windows from a Windows installation 
disk. It is not difficult to figure out that installing 100 computers using an installation disk 
is a daunting task. In these situations, rather than do a manual install on each computer, 
you can use Windows Deployment Services to automatically deploy Windows to multiple 
computers. While Windows Deployment Services takes a little bit of work up front, it can 
save you a lot of work later. 

Before beginning this course, you should have some experience installing Windows, 
including installing Windows Server 2012. In an enterprise environment, many adminis-
trators will need to install Windows numerous times. In addition, administrators in many 
enterprise environments will have a need to deploy servers to remote site. Therefore, as a 
server administrator, you must be familiar with the various methods to install and deploy 
Windows. 

TAKE NOTE*

Installing the Windows Deployment Services Role

WDS is a server role that is included with Windows Server 2012. Therefore, before you 
can use WDS, you must install the WDS role and configure the services. Then you need 
to create and add the images that you want to deploy.
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WDS is a standard server role that can be installed using the Server Manager console and 
includes the following two role services:

• Deployment Server: Provides full functionality of WDS. It includes an image repository 
(including boot images, install images, and other files necessary for remote installation 
over a network), PXE server for remote computers to boot, and a Trivial File Transfer 
Protocol (TFTP) server to transfer files over the network. TFTP is similar to FTP, but 
uses User Datagram Protocol (UDP) instead of Transmission Control Protocol (TCP) 
for less overhead (simpler packets that can be processed faster than TCP packets because 
UDP does not require the use of acknowledgments). In addition, the Deployment Server 
includes tools to create and customize images. 

• Transport Server: While required by the Deployment Server, the Transport Server 
role is a subset of WDS functionality, but can also be used for custom solutions. The 
Transport Server can also use multicasting, which allows one set of packets to be sent to 
multiple computers simultaneously.

DEPLOY WDS

GET READY. To deploy WDS on Windows Server 2012, perform the following steps:

 1. Open Server Manager by clicking the Server Manager button on the task bar. The 
Server Manager opens.

 2. At the top of Server Manager, click Manage and then click Add Roles and Features. 
The Add Roles and Feature Wizard opens.

 3. On the Before you begin page, click Next.

 4. Select Role-based or feature-based installation, and then click Next.

 5. Click Select a server from the server pool, click the name of the server to install 
WDS to, and then click Next. 

 6. Scroll down and select Windows Deployment Services (see Figure 1-1).

CERTIFICATION READY
Install the Windows 
Deployment Services 
(WDS) role.
Objective 1.1

Figure 1-1

Selecting Windows Deployment 
Services
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Figure 1-2

Adding Required Features 
for WDS

Figure 1-3

Selecting the WDS Role 
Services

 7. When the Add Roles and Features Wizard dialog box opens, click Add Features 
(see Figure 1-2). 

 8. Click Next.

 9. Back on the Select server roles page, click Next.

 10. On the Select features page, click Next.

 11. On the WDS page, click Next.

 12. On the Select role services page, make sure that the Deployment Server option and 
the Transport Server option are selected (see Figure 1-3), and then click Next.
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WDS is inactive until you perform the initial configuration of the service and add images to 
the server. To use WDS, your system must meet the following requirements:

• The server is a member of an Active Directory Domain Services (AD DS) domain, or a 
domain controller for an AD DS domain.

• There is an active DHCP server on the network.

• There is an active DNS server on your network.

• The WDS server has an NTFS file system partition to store images.

PERFORMING THE INITIAL CONFIGURATION OF WDS
Before you can use WDS, you must configure WDS by determining if the server will be 
part of Active Directory, determining where the boot and install images will be stored, and 
configuring the DHCP server so that clients can boot to the WDS server. To perform the 
initial configuration using the Windows Deployment Services Configuration Wizard, open 
the Windows Deployment Services console, right-click the WDS server, and then select 
Configure Server. 

PERFORM THE INITIAL CONFIGURATION OF WDS

GET READY. To perform the initial configuration of WDS on Windows Server 2012, perform 
the following steps:

 1. Open Server Manager by clicking the Server Manager button on the task bar. The 
Server Manager opens.

 2. At the top of Server Manager, click Tools > Windows Deployment Services (see 
Figure 1-4). The Windows Deployment Services console opens.

 3. Expand Servers, right-click the WDS server, and then select Confi gure Server (see 
Figure 1-5).

Configuring the WDS Server

Before you can use WDS, you must configure the WDS server, including performing the 
initial server configuration, adding a default startup and install images, and configuring a 
boot menu.

 13. On the Confi rm installation selections page, click Install.

 14. When the installation fi nishes, click Close.

c01DeployingAndManagingServerImages.indd Page 5  1/22/13  5:40 PM f-481 c01DeployingAndManagingServerImages.indd Page 5  1/22/13  5:40 PM f-481 /208/WB00898/XXXXXXXXXXXX/ch02/text_s/208/WB00898/XXXXXXXXXXXX/ch02/text_s



6 | Lesson 1

Figure 1-4

Opening the Windows 
Deployment Services console

Figure 1-5

Starting the Initial 
Configuration Wizard for WDS
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 4. When the Before You Begin page appears, click Next.

 5. On the Install Options page, select the Integrated with Active Directory option 
(see Figure 1-6), and then click Next.

Figure 1-6

Selecting the Integrated with 
Active Directory option

 6. On the Remote Installation Folder Location page, specify the location of the 
remote installation folder (see Figure 1-7) and then click Next.

Figure 1-7

Specifying the location of the 
remote installation folder
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  By default, when a DHCP client is looking for a DHCP server, it will perform 
a broadcast using UDP port 67. If the WDS server is also the DHCP server, 
you must tell WDS not to listen on port 67 so that DHCP can function 
properly. To do this, select the Do not listen on DHCP and DHCPv6 ports 
check box. 

  If the local DHCP server is a Microsoft DHCP server, you should select the 
Confi gure DHCP options for Proxy DHCP check box so that the DHCP server 
is automatically confi gured to forward the PXE requests to the WDS server. 
If the local DHCP server is not a Microsoft DHCP server, you will have 
to manually confi gure the DHCP server to forward the request to the 
WDS server. 

 9. Click Next.

 7. If you use the C drive, you will be warned that you have selected the 
Windows system volume and that you should use a separate volume. To 
continue, click Yes. Of course, in a production environment, for performance 
and system reliability, you should create a separate volume to store the 
WDS images.

 8. If your WDS server is also a DHCP server, another page appears (see Figure 1-8), 
enabling you to confi gure the server so that there is not a port confl ict. 

Figure 1-8

Specifying the DHCP Server 
options

c01DeployingAndManagingServerImages.indd Page 8  1/22/13  5:40 PM f-481 c01DeployingAndManagingServerImages.indd Page 8  1/22/13  5:40 PM f-481 /208/WB00898/XXXXXXXXXXXX/ch02/text_s/208/WB00898/XXXXXXXXXXXX/ch02/text_s



Deploying and Managing Server Images | 9

Figure 1-9

Specifying how WDS/PXE 
Server responds to clients

 10. On the PXE Server Initial Settings page (see Figure 1-9), select the appropriate 
options:

• Do not respond to any client computers: By selecting this option, WDS cannot 
perform installations. You would typically use this option to keep WDS disabled 
until you are ready to use it.

• Respond only to known client computers: A known client computer is a computer 
that has a computer account pre-staged or created in Active Directory before you 
perform the installation. By selecting this option, WDS responds to computers that 
you have prestaged; it does not respond to unstaged or rogue systems. This option 
is selected by default.

• Respond to all client computers (known and unknown): By selecting this 
option, WDS responds to any client system that makes an installation request. 
Because it responds to any computer that attempts a PXE boot, it is the least 
secure option.

 11. Click Next.

 12. When the task is completed, click Finish.

CONFIGURING THE WDS PROPERTIES
After you perform the initial configuration, you must reconfigure the WDS server 
by accessing the WDS Properties (right-click the server in the Windows Deployment 
Services console and then select Properties). The WDS properties include the following 
tabs:

• General: Displays server name, mode, and location of the remote installation folder 
where images are stored. (See Figure 1-10.)
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• PXE Response: Enables you to specify which types of computers (known or unknown) 
can download and install images from the server. In addition, you can determine the 
PXE boot delay in seconds (zero by default). (See Figure 1-11.)

Figure 1-10

Viewing the General tab

Figure 1-11

Viewing the PXE Response tab
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Figure 1-12

Viewing the AD DS tab

• AD DS: Allows you to determine the automatic naming format for WDS clients in AD 
DS that are not prestaged, and it allows you to specify where the computer account will 
be created in Active Directory. (See Figure 1-12.)

Figure 1-13

Viewing the Boot tab

• Boot: Allows you to specify the default network boot image for each architecture type (x86, 
x64, and ia64) and the PXE Boot Policy settings for known and unknown clients. It also 
allows you to specify if a user must press F12 to continue the PXE boot. (See Figure 1-13.)
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• Client: Allows you to enable and configure unattended installations of the WDS clients. 
In addition, if you do not want to add a computer to the domain, you can select the Do 
not join the client to a domain after an installation option. (See Figure 1-14.)

Figure 1-14

Viewing the Client tab

Figure 1-15

Viewing the DHCP tab

• DHCP: Allows you to enable or disable if a server listens on the DHCP ports (port 67) 
and to automatically configure DHCP option 60 on a DHCP server. (See Figure 1-15.)
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• Multicast: Allows you to use one set of packets to install operating systems on multiple 
computers simultaneously. As a result, you minimize network traffic. The Multicast tab 
also allows you to configure Transfer Settings. (See Figure 1-16.)

Figure 1-16

Viewing the Multicast tab

• Advanced: Allows you to authorize your WDS server in DHCP. It also allows you to 
specify a domain controller and global catalog or to allow WDS to discover them on its 
own. (See Figure 1-17.)

Figure 1-17

Viewing the Advanced tab
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• Network: Allows you to specify the UDP port ranges WDS uses. Typically, you would 
leave the default setting (Obtain dynamic ports from Winsock) selected. You should note 
that the Network profile option is grayed out in Windows Server 2012, which would 
allow you to specify the bandwidth of your network. Instead, the bandwidth is deter-
mined automatically. (See Figure 1-18.)

Figure 1-18

Viewing the Network tab

Figure 1-19

Viewing the TFTP tab

• TFTP: Allows you to configure the maximum block size used for FTP transfers. The 
TFTP option is new to Windows Server 2012. (See Figure 1-19.)
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STARTING WDS
After you perform the initial configuration, you reconfigure the WDS server by accessing 
the WDS Properties. To access the WDS Properties, right-click the server in the Windows 
Deployment Services console, choose All Tasks, and then choose Start (see Figure 1-20). 
Then you will need to add the images that you want to deploy, which is discussed in the 
next section.

Figure 1-20

Starting WDS

CONFIGURING THE CUSTOM DHCP OPTION
As previously mentioned, if you have a separate server that is running the DHCP server, you 
must configure it manually to include the custom option that provides the WDS clients with 
the name of the WDS Server via DHCP. If this option is not performed, the WDS clients 
will not be able to find the WDS server to boot from.

CONFIGURE THE CUSTOM DHCP OPTION

GET READY. To configure the custom DHCP Option on the DHCP server, perform the 
following steps:

 1. Open the Server Manager by clicking the Server Manager button on the task bar. 
The Server Manager opens.

 2. Click Tools > DHCP. The DHCP console opens.

 3. Expand the server node.

 4. Right-click IPv4 and then select Set Predefi ned Options (see Figure 1-21). The 
Predefi ned Options and Values dialog box appears.
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 5. Click Add. The Option Type dialog box opens (see Figure 1-22).

Figure 1-21

Selecting Set Predefined 
Options 

Figure 1-22

Setting option types 

 6. In the Name text box, type PXEClient.

 7. For the Data type, select String.

 8. In the Code text box, type 060 (see Figure 1-23).

Figure 1-23

Specifying the PXE Client 
Option 060
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 9. Click OK to accept your settings.

 10. Click OK to close the Predefi ned Options and Values dialog box.

 11. Expand the IPv4 node, and then click Server Options. 

 12. Find and then click the 060 PXEClient option. 

 13. In the String value text box, type the name or IP address of your WDS server (see 
Figure 1-24).

Figure 1-24

Typing the name of your 
WDS server

 14. Click OK to accept your settings and to close the Server Options dialog box.

There are two types of image formats:

• Sector-based image formats, whereby each sector is stored within the file and each 
sector is the smallest unit of information. One common example of a disk image is the 
.ISO file used for a CD image and a DVD image.

• File-based image formats, whereby each file is the smallest unit. The advantage of 
using a file-based image is that it is hardware-independent and a file can be referenced 
multiple times within the file system tree. A common example is a WIM image used 
with WDS.

The boot images and the install images use the Windows Imaging Format (WIM), a file 
format that allows a file structure (folders and files) to be stored inside a single WIM database. 
By using a database, the system does not have to open and close several individual files during 
the data transfer. 

Configuring and Managing Boot, Install, and Discover Images

To deploy Windows, you must create two types of images: a boot image and an install 
image. Just as the name implies, the boot image boots the computer. In addition, the boot 
image starts the operating system installation. The install image contains the operating 
system that WDS installs.

CERTIFICATION READY
Configure and manage 
boot, install, and discover 
images.
Objective 1.1
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ADDING BOOT IMAGES
The Windows Server 2012 installation DVD includes a boot image file named boot.wim, 
located in the \sources folder (see Figure 1-25), which loads Windows PE 4.0 on the 
client computer. Since it is used to boot the computer and start the installation of an 
operating system, it can be used for virtually any operating system deployment without 
modification.

ADD A BOOT IMAGE 

GET READY. To add a boot image file to WDS, perform the following steps:

 1. Open Server Manager.

 2. Click Tools > Windows Deployment Services. The Windows Deployment Services 
console opens.

 3. Expand Servers and then expand the server so that you can see the Install Images 
folder and the Boot Images folder (see Figure 1-26).

Figure 1-25

Viewing the sources folder

Figure 1-26

Viewing the Install Images 
folder and the Boot Images 
folder
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 4. To add a boot image, right-click the Boot Images folder and choose Add Boot 
Image. The Add Image Wizard opens.

 5. Browse to the location of the image fi le (such as the Sources folder located on the 
installation DVD), click the boot.wim fi le (see Figure 1-27), and then click Open. 

 6. On the Image File page, click Next.

 7. On the Image Metadata page, type a name and description of the image and 
then click Next. Most of the time, you can use the default values shown in 
Figure 1-28.

Figure 1-27

Opening the Boot.wim file

Figure 1-28

Specifying the image name 
and description

 8. On the Summary page, click Next. 

 9. When the image is added to the server, click Finish.
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ADDING IMAGE FILES
As previously mentioned, the image file contains the operating system that WDS will install 
on the client computer. Included in the Sources folder on the Windows Server 2012 installa-
tion disk is an install.wim file for Windows Server 2012 that allows you to perform a standard 
Windows Server 2012 installation similar to performing a manual installation from disk.

When you create image files, you place the image file in an image group. An image group is a 
folder within the image repository of WDS that shares security options and file resources. The 
image group consists of the following two components:

• The resource .wim file (Res.rwm). This contains the file resources for all of the images 
in an image group. Although the file name seems to indicate otherwise, the .rwm file is 
actually a .wim file. 

• The <imagename>.wim files. Each .wim image file contains the metadata that describes 
the image, but the actual file resources for the image reside in Res.rwm.

 Any permission assigned to an image group is inherited by all of the images in the 
group. By default, authenticated users are granted read access to image groups and 
images while administrators have full control. You can control who can receive specific 
images by modifying the permissions of the images or by placing the images in image 
groups and modifying the permissions of the groups. 

ADD AN INSTALL IMAGE FILE

GET READY. To add an install image file to WDS, perform the following steps:

 1. Open Server Manager.

 2. Click Tools > Windows Deployment Services. The Windows Deployment Services 
console opens.

 3. Expand Servers and then expand the server so that you can see the Install Images 
folder and the Boot Images folder (see Figure 1-26).

 4. Right-click the Install Images folder and select Add Install Image. The Add Image 
Wizard page opens (see Figure 1-29).

Figure 1-29

Creating an Image Group

 5. On the Image Group page, the Create an image group named option is selected. If 
desired, type a different name of the image group and then click Next.
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 6. Browse to the location of the image fi le (such as the Sources folder located on 
the installation DVD), select the install.wim fi le, and then click Open. 

 7. On the Image File page, click Next.

 8. On the Available Images page, select the images you want to include (see Figure 
1-30), and then click Next. 

 9. On the Summary page, click Next. 

10. When the images are added to the server, click Finish.

CREATING AN IMAGE FILE WITH WDS
The install images that are included on a Windows installation disk are images of a basic 
Windows installation, with no patches, updates, or additional drivers. If you would like to cre-
ate your own image files, you must first set up a master computer with all of the patches, driv-
ers, applications, and configurations applied. Then use WDS to create your own image file by 
modifying an existing boot image, booting the master computer with the modified boot image, 
and running the Windows Deployment Services Capture Utility. The Windows Deployment 
Services Capture Utility will create an image file and write it to the computer’s drive, which will 
eventually be copied to the WDS server. You can then use it to be deployed to other computers.

CREATE AN IMAGE FILE

GET READY. To create an image file, perform the following steps:

 1. Open Server Manager.

 2. Click Tools > Windows Deployment Services. The Windows Deployment Services con-
sole opens.

 3. Expand Servers and then expand the server so that you can see the Install Images 
folder and the Boot Images folder.

 4. If you have not done so already, add the Windows Server 2012 boot.wim image to the 
Boot Images store by following the steps provided in the Add a Boot Image exercise.

Figure 1-30

Specifying the images you 
want to include
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 5. Right-click the boot image and choose Create Capture Image (see Figure 1-31). 
The Create Capture Image Wizard opens.Figure 1-31

Starting the Create Capture 
Image Wizard

Figure 1-32

Specifying the location and file 
name

 6. Specify a name and description for the new image. Then specify the Location and 
fi le name for the new image fi le (see Figure 1-32). Click Next.

 7. When the task is complete, you can select Add image to the Windows Deployment 
Server now (if desired). Then click Finish.
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Before capturing a computer with WDS, you must prepare a master or reference computer 
with the Sysprep.exe utility and reboot the computer using the capture image. Microsoft’s 
System Preparation Utility (Sysprep.exe) prepares a Windows computer for cloning by 
removing specific computer information such as the computer name and Security Identifier 
(SID). On Windows Server 2012, the Sysprep.exe is located in the C:\Windows\System32\
Sysprep folder. When you reboot the computer with the capture image, a Wizard guides 
you through the process of capturing an image of the computer and uploading it to the 
WDS server.

When running sysprep on the master computer, use the following syntax:

 sysprep /generalize /oobe

The /generalize parameter removes the unique values, such as the computer name 
and the SID, so that they are not captured in the image file and replicated to the 
target workstations. The /oobe parameter configures Windows to present the Windows 
Welcome Wizard the next time the computer starts. The Windows Welcome Wizard 
allows you to name the computer and generate a SID and any other required unique 
information.

CREATING A DISCOVER IMAGE
If you have a computer that does not support a PXE boot, you can boot the computer 
from disk using a discover image. A discover image is an image file that you can burn to a 
CD-ROM or other boot medium. When you boot the client computer using the discover 
image disk, the computer loads Windows PE, connects to a specified WDS server, and 
proceeds with the operating system installation process. 

CREATE A DISCOVER IMAGE

GET READY. To create a discover image file, perform the following steps:

 1. Open Server Manager.

 2. Click Tools > Windows Deployment Services. The Windows Deployment Services 
console appears.

 3. Expand Servers and then expand the server so that you can see the Install Images 
folder and the Boot Images folder.

 4. To create a discover boot image, right-click a boot image in the Windows Deploy-
ment Services console and choose Create Discover Image (see Figure 1-33). Click 
Next.
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 5. On the Metadata and Location page, leave the default Image name and Image 
description as-is. Then specify where you want to store the discover image fi le. In 
addition, you can Enter the name of the Windows Deployment Services server... (see 
Figure 1-34). Click Next.

Figure 1-33

Creating a discover image

Figure 1-34

Specifying the image name, the 
image description, and where 
to store the discover image file
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 6. On the Summary page, click Next. 

 7. When the images are added to the server, click Finish.

To convert the discover image to a bootable .ISO image, you first must download and install 
the Windows Assessment and Deployment Kit (ADK) for Windows 8. ADK is a set of tools 
provided by Microsoft to customize, assess, and deploy a Windows operating system to new 
computers. It is located at Microsoft’s Download Center. Then use the oscdimg.exe command 
to create the .ISO image.

INSTALL THE WINDOWS ASSESSMENT AND DEPLOYMENT KIT (ADK)

GET READY. To install the ADK, perform the following steps:

 1. Start the Windows Assessment and Deployment Kit by double-clicking adksetup.exe.

 2. On the Specify Location page, leave the default settings, and then click Next.

 3. When you are prompted to join the Customer Experience Improvement Program 
(CEIP), click Next.

 4. On the License Agreement page, click Accept.

 5. With the Deployment Tools and Windows Preinstallation Environment (Windows PE) 
already selected, click Install.

 6. When the installation is complete, click Close.

CREATE A BOOTABLE ISO IMAGE

GET READY. After you have installed the ADK for Windows 8, perform the following steps to 
create a bootable ISO Image:

 1. Create a folder named C:\WinPE_x64\ISO.

 2. Copy the contents of the C:\Program Files (x86)\Windows Kits\8.0\Assessment 
and Deployment Kit\Windows Preinstallation Environment\amd64\Media folder to 
C:\WinPE_x64\ISO.

 3. Create the C:\WinPE_x64\ISO\Sources folder. 

 4. Copy the discover image to the C:\WinPE_x64\ISO\Sources folder.

 5. Rename the discover.wim fi le in the C:\WinPE_x64\ISO\Sources folder to boot.wim.

 6. Copy the etfsboot.com fi le from the C:\Program Files (x86)\Windows Kits\8.0\
Assessment and Deployment Kit\Deployment and Imaging Tools\amd64\Oscdimg 
folder to the C:\WinPE_x64 folder.

 7. Create the bootable ISO by running the following command:

  oscdimg -b"c:\WinPE_X64\etfsboot.com" -n C:\WinPE_X64\ISO C:\
WinPE_X64\WinPE_X64.iso

USING WDSUTIL
Different from most of the components that are included with Windows, you cannot install 
and configure Windows Deployment Services by using Windows PowerShell. Instead, the 
wdsutil command is used for managing the Windows Deployment Services server. To use the 
wdsutil command line, you will need to open a Command Prompt as an administrator.

The wdsutil commands include:

• /add – Adds prestaged computers, images, or image groups.

• /approve-AutoAddDevices – Approves computers that are pending administrator 
approval.
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• /convert-RiprepImage – Converts an existing Remote Installation Preparation (RIPrep) 
image to a Windows Image (.wim) file.

• /copy – Copies an image or a driver group.

• /delete-AutoAddDevices – Deletes computers that are in the Auto-Add database (which 
stores information about the computers on the server).

• /disable – Disables all services for Windows Deployment Services.

• /disconnect-Client – Disconnects a client from a multicast transmission or namespace.

• /enable – Enables all services for Windows Deployment Services.

• /export-Image – Exports an image from the image store to a .wim file.

• /get – Retrieves properties and attributes about the specified object.

• /initialize-Server – Configures a Windows Deployment Services server for initial use.

• /new – Creates new capture and discover images, multicast transmissions, and namespaces.

• /progress – Displays the progress status while a command is being executed.

• /reject-AutoAddDevices – Rejects computers that are pending administrator approval.

• /remove – Removes objects.

• /replace-Image – Replaces a boot or installation image with a new version of that 
image.

• /set – Sets properties and attributes on the specified object.

• /start – Starts all services on the Windows Deployment Services server, including multi-
cast transmissions, namespaces, and the Transport Server.

• /stop – Stops all services on the Windows Deployment Services server.

• /uninitialize-Server – Reverts changes made during server initialization.

• /update-ServerFiles – Updates server files on the RemoteInstall share. 

• /verbose – Displays verbose output for the specified command.

For example, to show the WDS configuration, you can use one of the following commands:

wdsutil /get-server /show configure
wdsutil /get-server /show:all /detailed

To show the WDS configuration, you can use one of the following commands:

wdsutil /get-server /show configure
wdsutil /get-server /show:all /detailed

To stop or start the WDS server, use the following commands:

wdsutil /stop-server
wdsutil /start-server

To show the WDS configuration, you can use one of the following commands:

wdsutil /get-server /show configure
wdsutil /get-server /show:all /detailed

To show the WDS configuration, you can use one of the following commands:

wdsutil /get-server /show configure
wdsutil /get-server /show:all /detailed

To add a computer by using a MAC address, you would use the following command:

wdsutil /Add-Device /Device:PC1 /ID:00-C1-46-8A-1F-EB

To add a boot image, use the following command:

wdsutil /Add-Image /ImageFile:"C:\Data\Boot.wim" /ImageType:Boot
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To add an install image, use the following command:

Wdsutil /Add-Image /ImageFile:"C:\Data\Install.wim" /ImageType:Install

PERFORMING AN UNATTENDED INSTALLATION
So far, we’ve discussed deploying Windows over the network. However, the installations cov-
ered thus far have been a manual process whereby you have to step through the installation 
Wizard. To streamline the installation process, you need to automate the Windows instal-
lation by using answer files, which provide responses to the prompts that would normally 
appear during the Windows installation. Besides clicking the standard Next button used on 
most screens, the answer file can also be used to partition and format disk, install additional 
device drivers, and specify what Windows features to install. 

You can create an answer file with a text editor or XML editor, but Microsoft recommends 
that you use the System Image Manager (SIM), a tool used to create and manage unat-
tended Windows setup answer files using a graphical interface. SIM can also be used to check 
answer files. SIM is also part of the Windows Assessment and Deployment Kit.

CREATE AN ANSWER FILE

GET READY. To create an answer file, log on to the computer where you installed the ADK and 
then perform the following steps:

 1. Click Start > All Ap ps > Windows System Image Manager. The Windows System 
Image Manager console opens (see Figure 1-35).Figure 1-35

Viewing the Windows System 
Image Manager console
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 2. Click Tools > Create Distribution Share. The Create Distribution Share dialog box 
opens.

 3. Browse to the folder where you want to create the distribution share and then 
click Open. The distribution share subfolders appear in the Distribution Share pane 
(see Figure 1-36).

 4. Insert a Windows 2012 installation disk into the computer’s DVD drive.

 5. Click File > Select Windows Image. The Select a Windows Image dialog box opens.

 6. Browse to the folder where you are storing an install.wim fi le, select the install
.wim image fi le, and then click Open. The Select an Image dialog box opens (see 
Figure 1-37).

Figure 1-36

Viewing the distribution share 
subfolders in the Distribution 
Share pane 

Figure 1-37

Selecting an Image
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 7. Select the image that you want to use, and then click OK.

 8. If you are prompted to create a catalog fi le, click Yes.

 9. Click File > New Answer File. The answer fi le elements appear in the Answer File pane 
(see Figure 1-38).

Figure 1-38

Viewing elements in the 
Answer File pane

After you create the answer file, you are ready to start configuring the elements or settings 
that you want to include in the answer file. As Windows is installed, the installation is 
divided into seven configuration passes. Each pass specifies what actions can occur during 
the installation process. For example, if you need to partition and format your disk, you 
must do that at the very beginning of the installation process, which happens to be the 
Windows PE pass.

The seven configuration passes in an answer file are as follows:

• windowsPE: Configures Windows PE options and basic Windows Setup, including the 
initial boot options. Options can include specifying the product key and configuring a 
disk (partitioning and formatting).

• offlineServicing: Applies updates to a Windows image using DISM.exe, including 
software fixes, language packs, and other security updates.

• generalize: If you used the sysprep /generalize command, generalize 
removes system-specific information, such as computer name and security ID. 
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• specialize: Creates and applies system-specific information, such as network settings, 
international settings, and domain information (including joining a computer to the 
domain).

• auditSystem: Applies settings to the system if the computer is started in audit mode as 
specified with the sysprep command.

• auditUser: Applies settings to the user if the computer is started in audit mode as 
specified with the sysprep command.

• oobeSystem: Applies settings to Windows before the Windows Welcome starts.

To add a configuration setting to the answer file, browse through the available settings in the 
Windows Image pane, right-click the setting you want to add, and then select the configuration 
pass specifying when you want the setup program to configure the setting (see Figure 1-39).

Figure 1-39

Selecting a configuration pass

The setting then appears in the Answer File pane and the properties specific to that setting 
appear in the adjacent Properties pane (see Figure 1-40). After the setting has been added, 
you modify the values in the properties. If you need clarification on a setting, press F1 while 
a property or setting is highlighted to open the Unattended Windows Setup Reference Guide 
(see Figure 1-41).
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Figure 1-40

Configuring setting properties

Figure 1-41

Opening the Unattended 
Windows Setup Reference 
Guide
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After you configure the answer files, you can validate the answer file by clicking Tools > 
Validate Answer file. If SIM finds any discrepancies (such as incorrect values or omitted 
values), you are notified in the Messages pane (see Figure 1-42).

Figure 1-42

Validating an answer file

To create a configuration set from the answer file, click Tools > Create Configuration Set. This 
action copies the files to a distribution share, including the answer file (Autounattend.xml). 
These files are then used to perform an unattended installation. Figure 1-43 shows the Create 
Configuration Set dialog box.

Figure 1-43

Creating a configuration set

TAKE NOTE*
Microsoft recommends 
using SIM to create and 
validate answer files.
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The configuration set could be copied to a removable medium, such as a CD-ROM, a DVD-
ROM, or a USB flash drive. To perform an unattended installation, boot the computer from 
a Windows installation disk. Once the system has begun to boot from the disk, insert the 
removable medium containing the configuration set. The Windows Setup program auto-
matically scans all of the removable drives on the computer for an answer file. If it finds the 
answer file, it will use the answer file to perform the installation. If you are performing a net-
work installation using the Windows PE command prompt, you can specify the location of 
the answer file at the command prompt:

 setup.exe /unattend:\\server\share\configset

By using the standard Windows image files and boot files, you will only be perform-
ing a standard operating system installation over the network through the WDS server. 
Unfortunately, this installation is still a manual installation whereby you have to go 
through the installation wizard. If you have hundreds of installations, the easiest and 
quickest way to install all of the computers the same way is to perform an unattended 
installation, whereby you boot the computer and it automatically starts and completes the 
installation.

To install an operating system on a client using WDS with no interactivity, you must have the 
following two unattend files:

• WDS client unattend file: This unattend file automates the WDS client procedure that 
begins when the client computer loads the boot image file.

• Operating system unattend file: This is an unattend file for a standard operating system 
installation, containing responses to all of the prompts that display after the client com-
puter loads the install image file.

DEPLOY A SERVER USING AN UNATTEND FILE

GET READY. To deploy a server using an unattended installation, perform the following steps:

 1. Open Server Manager.

 2. Click Tools > Windows Deployment Services. The Windows Deployment Services con-
sole opens.

 3. Expand the Servers node. 

 4. Right-click the node for your server and choose Properties. The server’s Properties 
dialog box opens.

 5. Click the Client tab.

 6. Select the Enable unattended installation checkbox.

 7. Click the Browse button corresponding to the processor architecture of the client 
computer, and then browse to your unattend fi le. Click Open.

 8. Click OK to close the server’s Properties sheet.

 9. Expand the Install Images node.

 10. Right-click the image for which you want to perform an unattended installa-
tion and then choose Properties. The Image Properties dialog box opens (see 
Figure 1-44).
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 11. Select the Allow image to install in unattended mode checkbox.

 12. Click Select File. The Select Unattend File dialog box opens.

 13. Browse to the unattend fi le you want to use, and then click OK. 

 14. Click OK to accept your settings and to close the Image Properties dialog box.

Figure 1-44

Viewing the Image Properties 
dialog box

Updating Images with Patches, Hotfixes, and Drivers

When you create an image file, you install Windows on a master computer, update and 
configure the computer, and then install any applications – all of which can take many 
hours to get everything just right. When Microsoft releases updates that you want to 
include in the new image, instead of going through the entire process of creating and set-
ting up a new master computer, you can update the image file using Deployment Image 
Servicing and Management (Dism.exe).

Deployment Image Servicing and Management (Dism.exe) is a command-line tool that can 
be used to service a Windows image or to prepare a Windows PE image. With Dism, you can 
mount an image offline and then add, remove, update, or list the features, packages, drivers, 
or international settings stored on that image. Dism.exe is not included with Windows. 

To make changes to an image, you must mount the Windows image in the Windows file 
structure using the Mount-Wim option. To mount the D:\RemoteInstall\install.wim file to the 
C:\Offline folder, use the following command:

Dism /Mount-Wim /WimFile: D:\RemoteInstall\install.wim /index:1 /
MountDir:C:\Offline

CERTIFICATION READY
Update images with 
patches, hotfixes, and 
drivers.
Objective 1.1
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After you make changes to the image, you need to commit the changes by using the /
Commit-Wim option:

Dism /Commit-Wim /MountDir:C:\Offline

To unmount the image, use the /Unmount-Wim option. If you want to commit the changes 
while you unmount the image, add the /Commit option. To discard the changes, use the /
Discard option. For example, to unmount the image mounted to the C:\Offline folder while 
saving the changes, execute the following command:

Dism /Unmount-Wim /MountDir:C:\offline /commit 

To get information about an image or WIM file, use the /Get-WimInfo option. For example, 
in the previous WIM file, execute the following command:

Dism /Get-WimInfo /WimFile:C:\offline\install.wim /index:1

Packages are used by Microsoft to distribute software patches, hotfixes, service packs, language pack-
ages, and Windows features. If a Windows package is provided as a cabinet (.cab) file or as a Windows 
Update Stand-alone Installer (.msu) file, you can add the package using the /Add-Package com-
mand. For example, to add the C:\Update\Update.cab file, execute the following command:

Dism /image:C:\offline /Add-Package /Packagepath:C:\Update\Update.cab

To remove a package, use the /Remove-Package option. For example, to remove the update.
cab file, execute the following command:

Dism /image:C:\offline /Remove-Package /PackagePath:C:\Update\Update.cab

You can use the /Add-Driver option to add third-party driver packages that include a valid 
INF file. For example, to add mydriver to the Windows image, execute the following command:

Dism /image:C:\offline /Add-Driver /driver:C:\Drivers\mydriver.INF

If you point to a path and use /Recurse, all subfolders will be checked for valid drivers. For 
example, to add drivers from the C:\Drivers folder, execute the following command:

Dism /image:C:\offline /Add-Driver /driver:C:\drivers /recurse

To remove a third-party device driver, use the /Remove-Driver option to specify the name of 
a device driver (such as oem0.inf, oem1.inf, and so on). For example, to remove the second third-
party driver (oem1.inf) that has been added to the system, execute the following command:

Dism /image:C:\offline /Remove-Driver /driver:oem1.inf

Similar to adding or removing packages, you can use Dism.exe to mount an image offline and 
then use Dism.exe to add, remove, update, or list the Windows feature. For example, to list 
the features, execute the following command:

Dism /image:C:\offline /Get-Features

To enable a feature, use the /Enable-Feature option. For example, to install the Hearts 
game, execute the following command:

Installing Features for Offline Images

Features are a set of Windows programs that can be enabled or disabled by an admin-
istrator and are included with Windows. Examples of features include FreeCell, Hearts, 
Solitaire, FTP Server, World Wide Web Service, and Microsoft .NET Framework 3.5. To 
add or remove features in Windows Server 2012, you would use Server Manager. To add 
or remove features in Windows 8, you would use Control Panel > Programs and Features. 
Similarly, you can use Dism.exe to add to or remove features from of offline image.

CERTIFICATION READY
Install features for offline 
images.
Objective 1.1
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Dism /image:C:\offline /Enable-Feature /FeatureName:Hearts

To remove the Hearts game, use the /Disable-Features option. For example, to remove 
the Hearts game, execute the following command:

Dism /Image:C:\offline /Disable-Feature /FeatureName:Hearts

Of course, after you add or remove features, remember to commit the 
changes with the Dism /Commit-Wim command that was discussed previously.

Using dynamic driver provisioning requires the following:

• The boot image from either Windows 7, Windows 8, Windows Server 2008 R2, or 
Windows Server 2012 (from \Sources\Boot.wim on the DVD).

• The install images for Windows Vista SP1, Windows 7, Windows 8, Windows Server 
2008, Windows 7, Windows Server 2008 R2, or Windows Server 2012. 

To deploy drivers based on the plug-and-play hardware of the client, you must extract the 
drives; they cannot be an .msi file or an .exe file.

CREATE A BOOTABLE ISO IMAGE

GET READY. To add drivers to an image, perform the following steps:

 1. Open Server Manager.

 2. Click Tools > Windows Deployment Services. The Windows Deployment Services console 
opens.

 3. Expand the server node.

 4. Right-click the Drivers node and then choose Add Driver Package (see Figure 1-45).

Deploying Driver Packages with an Image

Starting with Windows Server 2008 R2, WDS includes dynamic driver provisioning, which 
allows you to add driver packages to WDS and then deploy them when you deploy an image. 

Figure 1-45

Selecting the Add Driver 
Package option

 5. On the Driver Package Location page, select either the Select driver packages from 
an .inf fi le option or the Select all driver packages from a folder option. Specify 
the location of the .inf fi le or folder, and then click Next.

c01DeployingAndManagingServerImages.indd Page 36  1/22/13  5:41 PM f-481 c01DeployingAndManagingServerImages.indd Page 36  1/22/13  5:41 PM f-481 /208/WB00898/XXXXXXXXXXXX/ch02/text_s/208/WB00898/XXXXXXXXXXXX/ch02/text_s



Deploying and Managing Server Images | 37

 6. On the Available Driver Packages page, select the drivers that you want to include 
(see Figure 1-46), and then click Next.

 7. On the Summary page, click Next.

 8. When the tasks are completed, click Next.

 9. Select a current driver group or create a new driver group (see Figure 1-47), and 
then click Next. 

Figure 1-46

Selecting driver packages

Figure 1-47

Selecting a driver group

 10. On the Tasks Complete page, click Finish.
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S K I L L  S U M M A R Y

IN THIS LESSON, YOU LEARNED:

• Windows Deployment Services (WDS) is a software platform and technology that allows 
administrators to perform automated network-based installations based on network-based 
boot and installation media.

• For client computers to communicate with a WDS server without an operating system, the 
client computer must support the preboot execution environment (PXE). 

• PXE (pronounced “pixie”) is a technology that boots computers using the network interface 
without a data storage device, such as a hard drive or an installed operating system.

• Windows Preinstallation Environment (Windows PE) is a minimal Windows operating 
system with limited services.

• Before you can use WDS, you must configure WDS server, including performing the initial 
server configuration, adding a default startup and install images, and configuring a boot 
menu.

• To deploy Windows, you must create two types of images: a boot image and an install 
image. Just as its name implies, the boot image boots the computer. In addition, the boot 
image starts the operating system installation. The install image contains the operating 
system that WDS will install.

• The boot images and install images use the Windows Imaging Format (WIM). While the 
architecture is file-based, the files are actually stored inside a single WIM database.

• The Microsoft’s System Preparation Utility (Sysprep.exe) prepares a Windows computer for 
cloning by removing specific computer information such as the computer name and 
Security Identifier (SID). 

• If you have a computer that does not support a PXE boot, you can boot the computer 
from a disk using a discover image. A discover image is an image file that you can burn to 
a CD-ROM or other boot medium.

• To streamline the installation process, you must automate the Windows installation by 
using answer files, which provide responses to the prompts that would normally display 
during the Windows installation.

• Although you can create an answer file with a text editor or XML editor, Microsoft 
recommends that you use the System Image Manager (SIM) to generate the answer file.

• Deployment Image Servicing and Management (Dism.exe) is a command-line tool that can 
be used to service a Windows image or to prepare a Windows PE image.

• Starting with Windows Server 2008 R2, WDS includes dynamic driver provisioning, which 
allows you to add driver packages to WDS and deploy them when you deploy an image.

■ Knowledge Assessment

Multiple Choice

Select the correct answer for each of the following questions.

 1. Which of the following is used to boot a computer over the network?
 a. Multicast Transmitter
 b. System Preparation Utility
 c. PXE
 d. Answer File
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 2. Which of the following is used to load a minimum version of Windows to troubleshoot-
ing and installation?

 a. PXE
 b. Windows PE
 c. System Preparation Utility
 d. WDS Server

 3. Which two roles are available in WDS? (Choose two answers.)
 a. Deployment server
 b. Boot Server
 c. File Archive Server
 d. Transport Server

 4. Which of the following are necessary for deploying WDS? (Choose all that apply.)
 a. AD DS
 b. FAT32 or NTFS 
 c. DHCP
 d. DNS

 5. The answer file is made as a(n) _____ file.
 a. XLS
 b. SIM
 c. XML
 d. RTF

 6. Which of the following allows you to package drivers together and deploy them with 
images?

 a. DISM
 b. SIM
 c. PXE
 d. Dynamic Driver Provisioning

 7. Which command allows you to modify an offline image?
 a. DISM
 b. SIM
 c. PXE
 d. Dynamic Driver Provisioning

 8. Which program is used to remove the computer name and SID from a computer?
 a. PXE
 b. Windows PE
 c. System Preparation Utility
 d. WDS Server

 9. Which of the following is the filename extension for install images and boot images?
 a. WIM
 b. FTP
 c. TIP
 d. XML

 10. Which of the following is used to convert a master computer to an image file?
 a. Deployment Image Servicing and Managing utility
 b. Discover Utility
 c. System Preparation utility
 d. Windows Deployment Service Capture utility
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Best Answer

Choose the letter that corresponds to the best answer. More than one answer choice may achieve the 
goal. Select the BEST answer.

 1. You are an administrator of several regional offices. You install WDS on Server1 and 
create three images for each regional office. You want to deploy the images using WDS, 
but you want to ensure that the administrator for each regional office can view only the 
images for his or her regional office. Which of the following actions should you perform?

 a.  Grant each administrator administrative permissions to the images assigned to the 
regional office.

 b.  Create an OU for each regional office and place the computers in the appropriate 
regional OU.

 c.  Place the images for each regional office into a separate image group on the WDS server. 
Then grant each administrator permission to his or her regional office’s image group.

 d.  Add all images to an image group and assign administrator permissions to the image 
group.

 2. Which of the following is used to convert a discover image to an ISO file?
 a. oscdimg.exe
 b. sim.exe
 c. oobe.exe
 d. sysprep.exe

 3. Which term best describes computers that have computer accounts created in Active 
Directory before the installation is completed with WDS?

 a. dynamic computers
 b. sysprep computers
 c. MAC-defined computers
 d. prestaged computers

 4. You are preparing 30 computers for classroom instruction. Which of the following is the 
quickest way to redeploy all 30 computers?

 a. Use WDS to deploy each computer at a time.
 b. Use WDS to deploy all of the computers at once while using unicast transmissions.
 c. Use WDS to deploy all of the computers while using multicasting.
 d. Use TFTP to copy the image to each computer manually.

 5. You are administering a computer that does not support PXE boot. Which action should 
be taken to start the computer and install an image using WDS?

 a. Use a boot image.
 b. Use an install image.
 c. Use a discover image.
 d. Boot with a DOS floppy disk.

 6. Which of the following ports is used by a DHCP client to contact a DHCP server?
 a. 23
 b. 67
 c. 341
 d. 387
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Matching and Identification

 1. Match the configuration pass with its respective function when creating an answer file 
with Windows SIM.

 _______ a) Specialize
 _______ b) Windows PE
 _______ c) Generalize
 _______ d) OobeSystem
 _______ e) OfflineServicing

 1.  Includes initial boot options including specifying the product and key and configuring 
a disk

 2. Applies updates using DISM.exe
 3. Applies settings to Windows before the Windows Welcome starts
 4. Configures network settings and join a computer to a domain
 5. Removes the system-specific information, such as computer name and security ID

 2. Write the DISM command that is used to perform each respective function.
 _________ a) Remove a package.
 _________ b) Mount a WIM image.
 _________ c) Add a driver.
 _________ d) Commit the changes to the image.
 _________ e) Unmounts a WIM image.

Build a List

 1. Specify the correct order in which to prepare a WDS server to deploy Windows to 
multiple computers. (Not all steps will be used.)

 _____ Install an image to a DVD image.
 _____ Add an image file.
 _____ Create an WDS Client unattend file.
 _____ Run DISM to deploy the image.
 _____ Add a boot image.
 _____ Create a system unattend file.
 _____ Boot the computer using a PXE boot.

 2. Specify the correct order in which to create an image file.
 _____ Run the sysprep command.
 _____ Boot the master computer with the modified boot image.
 _____ Use the WDS Capture Utility.
 _____ Install all Windows patches, applications, and drivers.
 _____ Install Windows.
 _____ Modify a boot image.

■ Business Case Scenarios
Scenario 1-1: Deploying Servers Using WDS

Your organization decides to build a second data center to be used as a backup site. You need 
to deploy roughly 150 servers. What steps will you need to take to deploy 150 servers at the 
new data center?

Scenario 1-2: Adding a Service Pack to WDS Install Image

Several months ago, you deployed a WDS server to deploy computers running Windows 2012. 
Service Pack 2 was just released and you need to add Service Pack 2 to your image so that future instal-
lations will automatically have the service pack. What steps will you need to take to make this happen?
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